Merge remote-tracking branch 'up/master' into master-riscv64
Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
commit
8c11451ed6
@ -1,113 +0,0 @@
|
||||
From patchwork Wed Mar 27 08:54:24 2019
|
||||
Date: Wed, 27 Mar 2019 08:54:24 +0000
|
||||
From: Mel Gorman <mgorman@techsingularity.net>
|
||||
To: Andrew Morton <akpm@linux-foundation.org>
|
||||
Cc: Mikhail Gavrilov <mikhail.v.gavrilov@gmail.com>,
|
||||
Daniel Jordan <daniel.m.jordan@oracle.com>, Qian Cai <cai@lca.pw>,
|
||||
linux-mm@kvack.org, vbabka@suse.cz, linux-kernel@vger.kernel.org
|
||||
Subject: [PATCH] Correct zone boundary handling when resetting pageblock skip
|
||||
hints
|
||||
|
||||
Mikhail Gavrilo reported the following bug being triggered in a Fedora
|
||||
kernel based on 5.1-rc1 but it is relevant to a vanilla kernel.
|
||||
|
||||
kernel: page dumped because: VM_BUG_ON_PAGE(PagePoisoned(p))
|
||||
kernel: ------------[ cut here ]------------
|
||||
kernel: kernel BUG at include/linux/mm.h:1021!
|
||||
kernel: invalid opcode: 0000 [#1] SMP NOPTI
|
||||
kernel: CPU: 6 PID: 116 Comm: kswapd0 Tainted: G C 5.1.0-0.rc1.git1.3.fc31.x86_64 #1
|
||||
kernel: Hardware name: System manufacturer System Product Name/ROG STRIX X470-I GAMING, BIOS 1201 12/07/2018
|
||||
kernel: RIP: 0010:__reset_isolation_pfn+0x244/0x2b0
|
||||
kernel: Code: fe 06 e8 0f 8e fc ff 44 0f b6 4c 24 04 48 85 c0 0f 85 dc fe ff ff e9 68 fe ff ff 48 c7 c6 58 b7 2e 8c 4c 89 ff e8 0c 75 00 00 <0f> 0b 48 c7 c6 58 b7 2e 8c e8 fe 74 00 00 0f 0b 48 89 fa 41 b8 01
|
||||
kernel: RSP: 0018:ffff9e2d03f0fde8 EFLAGS: 00010246
|
||||
kernel: RAX: 0000000000000034 RBX: 000000000081f380 RCX: ffff8cffbddd6c20
|
||||
kernel: RDX: 0000000000000000 RSI: 0000000000000006 RDI: ffff8cffbddd6c20
|
||||
kernel: RBP: 0000000000000001 R08: 0000009898b94613 R09: 0000000000000000
|
||||
kernel: R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000100000
|
||||
kernel: R13: 0000000000100000 R14: 0000000000000001 R15: ffffca7de07ce000
|
||||
kernel: FS: 0000000000000000(0000) GS:ffff8cffbdc00000(0000) knlGS:0000000000000000
|
||||
kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
|
||||
kernel: CR2: 00007fc1670e9000 CR3: 00000007f5276000 CR4: 00000000003406e0
|
||||
kernel: Call Trace:
|
||||
kernel: __reset_isolation_suitable+0x62/0x120
|
||||
kernel: reset_isolation_suitable+0x3b/0x40
|
||||
kernel: kswapd+0x147/0x540
|
||||
kernel: ? finish_wait+0x90/0x90
|
||||
kernel: kthread+0x108/0x140
|
||||
kernel: ? balance_pgdat+0x560/0x560
|
||||
kernel: ? kthread_park+0x90/0x90
|
||||
kernel: ret_from_fork+0x27/0x50
|
||||
|
||||
He bisected it down to commit e332f741a8dd ("mm, compaction: be selective
|
||||
about what pageblocks to clear skip hints"). The problem is that the patch
|
||||
in question was sloppy with respect to the handling of zone boundaries. In
|
||||
some instances, it was possible for PFNs outside of a zone to be examined
|
||||
and if those were not properly initialised or poisoned then it would
|
||||
trigger the VM_BUG_ON. This patch corrects the zone boundary issues when
|
||||
resetting pageblock skip hints and Mikhail reported that the bug did not
|
||||
trigger after 30 hours of testing.
|
||||
|
||||
Fixes: e332f741a8dd ("mm, compaction: be selective about what pageblocks to clear skip hints")
|
||||
Reported-and-tested-by: Mikhail Gavrilov <mikhail.v.gavrilov@gmail.com>
|
||||
Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
|
||||
---
|
||||
mm/compaction.c | 27 +++++++++++++++++----------
|
||||
1 file changed, 17 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/mm/compaction.c b/mm/compaction.c
|
||||
index f171a83707ce..b4930bf93c8a 100644
|
||||
--- a/mm/compaction.c
|
||||
+++ b/mm/compaction.c
|
||||
@@ -242,6 +242,7 @@ __reset_isolation_pfn(struct zone *zone, unsigned long pfn, bool check_source,
|
||||
bool check_target)
|
||||
{
|
||||
struct page *page = pfn_to_online_page(pfn);
|
||||
+ struct page *block_page;
|
||||
struct page *end_page;
|
||||
unsigned long block_pfn;
|
||||
|
||||
@@ -267,20 +268,26 @@ __reset_isolation_pfn(struct zone *zone, unsigned long pfn, bool check_source,
|
||||
get_pageblock_migratetype(page) != MIGRATE_MOVABLE)
|
||||
return false;
|
||||
|
||||
+ /* Ensure the start of the pageblock or zone is online and valid */
|
||||
+ block_pfn = pageblock_start_pfn(pfn);
|
||||
+ block_page = pfn_to_online_page(max(block_pfn, zone->zone_start_pfn));
|
||||
+ if (block_page) {
|
||||
+ page = block_page;
|
||||
+ pfn = block_pfn;
|
||||
+ }
|
||||
+
|
||||
+ /* Ensure the end of the pageblock or zone is online and valid */
|
||||
+ block_pfn += pageblock_nr_pages;
|
||||
+ block_pfn = min(block_pfn, zone_end_pfn(zone) - 1);
|
||||
+ end_page = pfn_to_online_page(block_pfn);
|
||||
+ if (!end_page)
|
||||
+ return false;
|
||||
+
|
||||
/*
|
||||
* Only clear the hint if a sample indicates there is either a
|
||||
* free page or an LRU page in the block. One or other condition
|
||||
* is necessary for the block to be a migration source/target.
|
||||
*/
|
||||
- block_pfn = pageblock_start_pfn(pfn);
|
||||
- pfn = max(block_pfn, zone->zone_start_pfn);
|
||||
- page = pfn_to_page(pfn);
|
||||
- if (zone != page_zone(page))
|
||||
- return false;
|
||||
- pfn = block_pfn + pageblock_nr_pages;
|
||||
- pfn = min(pfn, zone_end_pfn(zone));
|
||||
- end_page = pfn_to_page(pfn);
|
||||
-
|
||||
do {
|
||||
if (pfn_valid_within(pfn)) {
|
||||
if (check_source && PageLRU(page)) {
|
||||
@@ -309,7 +316,7 @@ __reset_isolation_pfn(struct zone *zone, unsigned long pfn, bool check_source,
|
||||
static void __reset_isolation_suitable(struct zone *zone)
|
||||
{
|
||||
unsigned long migrate_pfn = zone->zone_start_pfn;
|
||||
- unsigned long free_pfn = zone_end_pfn(zone);
|
||||
+ unsigned long free_pfn = zone_end_pfn(zone) - 1;
|
||||
unsigned long reset_migrate = free_pfn;
|
||||
unsigned long reset_free = migrate_pfn;
|
||||
bool source_set = false;
|
@ -1 +1 @@
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
|
@ -1 +1 @@
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
8ed86627f715eacbd6db6862f9499d6d96ea4ad6
|
||||
771acc7e4a6e5dba779cb1a7fd851a164bc81033
|
||||
|
@ -2572,7 +2572,7 @@ CONFIG_LIBERTAS_USB=m
|
||||
CONFIG_LIBFC=m
|
||||
CONFIG_LIBFCOE=m
|
||||
# CONFIG_LIBIPW_DEBUG is not set
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
# CONFIG_LIDAR_LITE_V2 is not set
|
||||
CONFIG_LIQUIDIO_VF=m
|
||||
CONFIG_LIRC=y
|
||||
|
@ -2553,7 +2553,7 @@ CONFIG_LIBERTAS_USB=m
|
||||
CONFIG_LIBFC=m
|
||||
CONFIG_LIBFCOE=m
|
||||
# CONFIG_LIBIPW_DEBUG is not set
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
# CONFIG_LIDAR_LITE_V2 is not set
|
||||
CONFIG_LIQUIDIO_VF=m
|
||||
CONFIG_LIRC=y
|
||||
|
@ -2872,7 +2872,7 @@ CONFIG_LIBERTAS_USB=m
|
||||
CONFIG_LIBFC=m
|
||||
CONFIG_LIBFCOE=m
|
||||
# CONFIG_LIBIPW_DEBUG is not set
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
# CONFIG_LIDAR_LITE_V2 is not set
|
||||
CONFIG_LIQUIDIO_VF=m
|
||||
CONFIG_LIRC=y
|
||||
|
@ -2853,7 +2853,7 @@ CONFIG_LIBERTAS_USB=m
|
||||
CONFIG_LIBFC=m
|
||||
CONFIG_LIBFCOE=m
|
||||
# CONFIG_LIBIPW_DEBUG is not set
|
||||
CONFIG_LIBNVDIMM=y
|
||||
CONFIG_LIBNVDIMM=m
|
||||
# CONFIG_LIDAR_LITE_V2 is not set
|
||||
CONFIG_LIQUIDIO_VF=m
|
||||
CONFIG_LIRC=y
|
||||
|
26
kernel.spec
26
kernel.spec
@ -67,7 +67,7 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 3
|
||||
%global rcrev 4
|
||||
# The git snapshot level
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
@ -597,12 +597,6 @@ Patch501: input-rmi4-remove-the-need-for-artifical-IRQ.patch
|
||||
Patch506: 0001-s390-jump_label-Correct-asm-contraint.patch
|
||||
Patch507: 0001-Drop-that-for-now.patch
|
||||
|
||||
# rhbz 1688283
|
||||
Patch512: v3-tpm-fix-an-invalid-condition-in-tpm_common_poll.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10872997/
|
||||
Patch513: Correct-zone-boundary-handling-when-resetting-pageblock-skip-hints.patch
|
||||
|
||||
Patch550: riscv-arm-fix.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
@ -1878,6 +1872,24 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Apr 10 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc4.git2.1
|
||||
- Linux v5.1-rc4-43-g771acc7e4a6e
|
||||
|
||||
* Tue Apr 09 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc4.git1.1
|
||||
- Linux v5.1-rc4-34-g869e3305f23d
|
||||
|
||||
* Tue Apr 09 2019 Jeremy Cline <jcline@redhat.com>
|
||||
- Reenable debugging options.
|
||||
|
||||
* Mon Apr 08 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc4.git0.1
|
||||
- Linux v5.1-rc4
|
||||
|
||||
* Mon Apr 08 2019 Jeremy Cline <jcline@redhat.com>
|
||||
- Disable debugging options.
|
||||
|
||||
* Fri Apr 05 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc3.git3.1
|
||||
- Linux v5.1-rc3-206-gea2cec24c8d4
|
||||
|
||||
* Wed Apr 03 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc3.git2.1
|
||||
- Linux v5.1-rc3-35-g8ed86627f715
|
||||
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.0.tar.xz) = 3fbab70c7b03b1a10e9fa14d1e2e1f550faba4f5792b7699ca006951da74ab86e7d7f19c6a67849ab99343186e7d6f2752cd910d76222213b93c1eab90abf1b0
|
||||
SHA512 (patch-5.1-rc3.xz) = 611cd9107732ddc6bc9d37568aa2021b0427a3ece506119a11b6e857a27e33be366a692dba7d6e91b885cf1f09236c5dd592fb7f74f0155b76c5c7dc44b9aade
|
||||
SHA512 (patch-5.1-rc3-git2.xz) = 3e0a0efb709597b781ea66c5d1bbb0b897f287c496165f0e4c5cc8111438454e6e941eb8a3b0bcde6e812aa058c3616c909aec23adca85ea98ad92ef6dc3e3ad
|
||||
SHA512 (patch-5.1-rc4.xz) = 1feffe95816601137c4b2a09a5d14d8b023d05d7a3bb259ea42a05fc52ca48c8176a4477f88bfe4bcd8220f3e174793ddbefe7896807fdafaf5153934222eac2
|
||||
SHA512 (patch-5.1-rc4-git2.xz) = 81103e3340bc362c523c0c053157d9fe6946fffe03782302154b3be50eec7d7328b95cc50e0269405e8b610265c160ab5ca1df8de348cc0e5630d1edcebd56e8
|
||||
|
@ -1,103 +0,0 @@
|
||||
From patchwork Thu Mar 21 23:02:12 2019
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 8bit
|
||||
X-Patchwork-Submitter: Tadeusz Struk <tadeusz.struk@intel.com>
|
||||
X-Patchwork-Id: 10864497
|
||||
Return-Path: <linux-integrity-owner@kernel.org>
|
||||
Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org
|
||||
[172.30.200.125])
|
||||
by pdx-korg-patchwork-2.web.codeaurora.org (Postfix) with ESMTP id 711816C2
|
||||
for <patchwork-linux-integrity@patchwork.kernel.org>;
|
||||
Thu, 21 Mar 2019 23:02:15 +0000 (UTC)
|
||||
Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1])
|
||||
by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 57B312A4A8
|
||||
for <patchwork-linux-integrity@patchwork.kernel.org>;
|
||||
Thu, 21 Mar 2019 23:02:15 +0000 (UTC)
|
||||
Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486)
|
||||
id 4AA482A539; Thu, 21 Mar 2019 23:02:15 +0000 (UTC)
|
||||
X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on
|
||||
pdx-wl-mail.web.codeaurora.org
|
||||
X-Spam-Level:
|
||||
X-Spam-Status: No, score=-7.9 required=2.0 tests=BAYES_00,MAILING_LIST_MULTI,
|
||||
RCVD_IN_DNSWL_HI autolearn=ham version=3.3.1
|
||||
Received: from vger.kernel.org (vger.kernel.org [209.132.180.67])
|
||||
by mail.wl.linuxfoundation.org (Postfix) with ESMTP id C399A2A4A8
|
||||
for <patchwork-linux-integrity@patchwork.kernel.org>;
|
||||
Thu, 21 Mar 2019 23:02:14 +0000 (UTC)
|
||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1727157AbfCUXCO (ORCPT
|
||||
<rfc822;patchwork-linux-integrity@patchwork.kernel.org>);
|
||||
Thu, 21 Mar 2019 19:02:14 -0400
|
||||
Received: from mga04.intel.com ([192.55.52.120]:7149 "EHLO mga04.intel.com"
|
||||
rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP
|
||||
id S1727086AbfCUXCO (ORCPT <rfc822;linux-integrity@vger.kernel.org>);
|
||||
Thu, 21 Mar 2019 19:02:14 -0400
|
||||
X-Amp-Result: SKIPPED(no attachment in message)
|
||||
X-Amp-File-Uploaded: False
|
||||
Received: from orsmga004.jf.intel.com ([10.7.209.38])
|
||||
by fmsmga104.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384;
|
||||
21 Mar 2019 16:02:13 -0700
|
||||
X-ExtLoop1: 1
|
||||
X-IronPort-AV: E=Sophos;i="5.60,254,1549958400";
|
||||
d="scan'208";a="284777192"
|
||||
Received: from jdemuth-mobl.amr.corp.intel.com (HELO
|
||||
tstruk-mobl1.jf.intel.com) ([10.251.150.110])
|
||||
by orsmga004.jf.intel.com with ESMTP; 21 Mar 2019 16:02:13 -0700
|
||||
Subject: [PATCH v3] tpm: fix an invalid condition in tpm_common_poll
|
||||
From: Tadeusz Struk <tadeusz.struk@intel.com>
|
||||
To: jarkko.sakkinen@linux.intel.com
|
||||
Cc: grawity@gmail.com, James.Bottomley@HansenPartnership.com,
|
||||
linux-integrity@vger.kernel.org, linux-kernel@vger.kernel.org,
|
||||
stable@vger.kernel.org, tadeusz.struk@intel.com
|
||||
Date: Thu, 21 Mar 2019 16:02:12 -0700
|
||||
Message-ID:
|
||||
<155320933278.5015.1752135965699928631.stgit@tstruk-mobl1.jf.intel.com>
|
||||
User-Agent: StGit/unknown-version
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
Sender: linux-integrity-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-integrity.vger.kernel.org>
|
||||
X-Mailing-List: linux-integrity@vger.kernel.org
|
||||
X-Virus-Scanned: ClamAV using ClamSMTP
|
||||
|
||||
The poll condition should only check response_length,
|
||||
because reads should only be issued if there is data to read.
|
||||
The response_read flag only prevents double writes.
|
||||
The problem was that the write set the response_read to false,
|
||||
enqued a tpm job, and returned. Then application called poll
|
||||
which checked the response_read flag and returned EPOLLIN.
|
||||
Then the application called read, but got nothing.
|
||||
After all that the async_work kicked in.
|
||||
Added also mutex_lock around the poll check to prevent
|
||||
other possible race conditions.
|
||||
|
||||
Fixes: 9488585b21bef0df12 ("tpm: add support for partial reads")
|
||||
Reported-by: Mantas Mikulėnas <grawity@gmail.com>
|
||||
Tested-by: Mantas Mikulėnas <grawity@gmail.com>
|
||||
Signed-off-by: Tadeusz Struk <tadeusz.struk@intel.com>
|
||||
---
|
||||
drivers/char/tpm/tpm-dev-common.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/char/tpm/tpm-dev-common.c b/drivers/char/tpm/tpm-dev-common.c
|
||||
index 5eecad233ea1..7312d3214381 100644
|
||||
--- a/drivers/char/tpm/tpm-dev-common.c
|
||||
+++ b/drivers/char/tpm/tpm-dev-common.c
|
||||
@@ -203,12 +203,14 @@ __poll_t tpm_common_poll(struct file *file, poll_table *wait)
|
||||
__poll_t mask = 0;
|
||||
|
||||
poll_wait(file, &priv->async_wait, wait);
|
||||
+ mutex_lock(&priv->buffer_mutex);
|
||||
|
||||
- if (!priv->response_read || priv->response_length)
|
||||
+ if (priv->response_length)
|
||||
mask = EPOLLIN | EPOLLRDNORM;
|
||||
else
|
||||
mask = EPOLLOUT | EPOLLWRNORM;
|
||||
|
||||
+ mutex_unlock(&priv->buffer_mutex);
|
||||
return mask;
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user