Merge remote-tracking branch 'up/f38' into f38-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2023-05-11 22:51:51 +03:00
commit 8bf8e65627
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
6 changed files with 57 additions and 15 deletions

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/031984ff6b9b3a71724ccaf58e6bd26cd1997a5f
031984ff6b9b3a71724ccaf58e6bd26cd1997a5f xfs: verify buffer contents when we skip log replay
"https://gitlab.com/cki-project/kernel-ark/-/commit"/efa74f28ec858cb955be08faf1086f05c3f7510a
efa74f28ec858cb955be08faf1086f05c3f7510a arm64: dts: rk3399-pinephone-pro: Add touchscreen support

View File

@ -7897,7 +7897,7 @@ CONFIG_VIDEO_OV2640=m
CONFIG_VIDEO_OV2659=m
CONFIG_VIDEO_OV2680=m
CONFIG_VIDEO_OV2685=m
CONFIG_VIDEO_OV2740=m
# CONFIG_VIDEO_OV2740 is not set
CONFIG_VIDEO_OV4689=m
CONFIG_VIDEO_OV5640=m
CONFIG_VIDEO_OV5645=m

View File

@ -7875,7 +7875,7 @@ CONFIG_VIDEO_OV2640=m
CONFIG_VIDEO_OV2659=m
CONFIG_VIDEO_OV2680=m
CONFIG_VIDEO_OV2685=m
CONFIG_VIDEO_OV2740=m
# CONFIG_VIDEO_OV2740 is not set
CONFIG_VIDEO_OV4689=m
CONFIG_VIDEO_OV5640=m
CONFIG_VIDEO_OV5645=m

View File

@ -148,17 +148,17 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specversion 6.2.11
%define specversion 6.2.15
%define patchversion 6.2
%define pkgrelease 300
%define kversion 6
%define tarfile_release 6.2.11
%define tarfile_release 6.2.15
# This is needed to do merge window version magic
%define patchlevel 2
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}.0.riscv64%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.2.11
%define kabiversion 6.2.15
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3359,9 +3359,26 @@ fi
#
#
%changelog
* Thu Apr 20 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.2.11-0.0.riscv64]
* Thu May 11 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.2.15-0.0.riscv64]
- Add support for riscv64
* Thu May 11 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.2.15-0]
- redhat: configs: generic: x86: Disable CONFIG_VIDEO_OV2740 for x86 platform (Kate Hsuan)
- Add Bugs to be fixed in 6.2.15 (Justin M. Forbes)
- xfs: verify buffer contents when we skip log replay (Darrick J. Wong)
- Linux v6.2.15
* Sun Apr 30 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.2.14-0]
- Linux v6.2.14
* Wed Apr 26 2023 Augusto Caringi <acaringi@redhat.com> [6.2.13-0]
- Linux v6.2.13
* Thu Apr 20 2023 Augusto Caringi <acaringi@redhat.com> [6.2.12-0]
- Add bugs fixed by 6.2.12 (Justin M. Forbes)
- Use RHJOBS for create-tarball (Don Zickus)
- Linux v6.2.12
* Thu Apr 13 2023 Augusto Caringi <acaringi@redhat.com> [6.2.11-0]
- Linux v6.2.11

View File

@ -26,6 +26,7 @@
drivers/iommu/iommu.c | 22 +
drivers/pci/quirks.c | 24 +
drivers/usb/core/hub.c | 7 +
fs/xfs/xfs_buf_item_recover.c | 10 +
include/linux/efi.h | 22 +-
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -38,7 +39,7 @@
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
40 files changed, 1634 insertions(+), 177 deletions(-)
41 files changed, 1644 insertions(+), 177 deletions(-)
diff --git a/Documentation/devicetree/bindings/display/panel/himax,hx8394.yaml b/Documentation/devicetree/bindings/display/panel/himax,hx8394.yaml
new file mode 100644
@ -123,7 +124,7 @@ index 000000000000..1b2a1baa26f9
+
+...
diff --git a/Makefile b/Makefile
index 416490daa76a..f65904d89130 100644
index 9f535df81b03..3f92ef879b76 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1679,7 +1680,7 @@ index 258d5fe3d395..f7298e3dc8f3 100644
if (data->f01_container->dev.driver) {
/* Driver already bound, so enable ATTN now. */
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index f8100067502f..e0823c45e2fa 100644
index e6f2a0bc9f0b..537fc8197a21 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -8,6 +8,7 @@
@ -1690,7 +1691,7 @@ index f8100067502f..e0823c45e2fa 100644
#include <linux/kernel.h>
#include <linux/bits.h>
#include <linux/bug.h>
@@ -2813,6 +2814,27 @@ int iommu_dev_disable_feature(struct device *dev, enum iommu_dev_features feat)
@@ -2818,6 +2819,27 @@ int iommu_dev_disable_feature(struct device *dev, enum iommu_dev_features feat)
}
EXPORT_SYMBOL_GPL(iommu_dev_disable_feature);
@ -1719,10 +1720,10 @@ index f8100067502f..e0823c45e2fa 100644
* Changes the default domain of an iommu group that has *only* one device
*
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
index 494fa46f5767..27bc8dd45ad8 100644
index 8d32a3834688..4957f0a42315 100644
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
@@ -4296,6 +4296,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
@@ -4309,6 +4309,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9084,
quirk_bridge_cavm_thrx2_pcie_root);
@ -1771,6 +1772,27 @@ index 97a0f8faea6e..d837548d2024 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/fs/xfs/xfs_buf_item_recover.c b/fs/xfs/xfs_buf_item_recover.c
index ffa94102094d..43167f543afc 100644
--- a/fs/xfs/xfs_buf_item_recover.c
+++ b/fs/xfs/xfs_buf_item_recover.c
@@ -943,6 +943,16 @@ xlog_recover_buf_commit_pass2(
if (lsn && lsn != -1 && XFS_LSN_CMP(lsn, current_lsn) >= 0) {
trace_xfs_log_recover_buf_skip(log, buf_f);
xlog_recover_validate_buf_type(mp, bp, buf_f, NULLCOMMITLSN);
+
+ /*
+ * We're skipping replay of this buffer log item due to the log
+ * item LSN being behind the ondisk buffer. Verify the buffer
+ * contents since we aren't going to run the write verifier.
+ */
+ if (bp->b_ops) {
+ bp->b_ops->verify_read(bp);
+ error = bp->b_error;
+ }
goto out_release;
}
diff --git a/include/linux/efi.h b/include/linux/efi.h
index ac22f7ca195a..e680835ad387 100644
--- a/include/linux/efi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.2.11.tar.xz) = 282307954ae9555d9beb2f8d5d5abad5813064725311290e82082520998766cff7f993113c4f02fa34f5aafa9edc7985186a548bc1de24e54209989ce842af81
SHA512 (kernel-abi-stablelists-6.2.11.tar.bz2) = 19687f8a545865e906c1ef2a10636dc6d74db893ba47e9265cbcdf122540c691adc5f556d3d2299ce2f5fe48d0e7f710fe3d7535c87cb24282d1a6793dcf5663
SHA512 (kernel-kabi-dw-6.2.11.tar.bz2) = 7ffe7a54956c8723b997478027c55352592fb5ec3ccbba016d7b88e82583d29dfd2020936fe09e9809aa6a068cf2b898f77b5cc97e50471aa2a06a5972f30c89
SHA512 (linux-6.2.15.tar.xz) = c80d5c05a6bf06dcc758629644806ef5d5e59aabea8ccb6c4baf0a6b292d386341f49cf0312f05fd3ed3551af70bfc2ec2c192ab8fce874340f46353d967dc86
SHA512 (kernel-abi-stablelists-6.2.15.tar.bz2) = 47b0a74f77a1427f4386d0ae0bab8fb7aefa645792aea3a67ab56433de2339065f23328779bf8c3055f765b6a0e10f5908f876b8c655773823bda2cf72dd8b76
SHA512 (kernel-kabi-dw-6.2.15.tar.bz2) = 7787ef9bbe0fe892cedf650e855ef164ef4f446bc305b998585ca1b237ec101a8395d896939c93d3cbff3e901591fe82ca4769c4fb4350418b361848071663c4