Linux v4.9-rc1
This commit is contained in:
parent
4eea1586d9
commit
8bf2afaffd
@ -3312,6 +3312,7 @@ CONFIG_RTC_DRV_CMOS=y
|
|||||||
CONFIG_RTC_DRV_ABX80X=m
|
CONFIG_RTC_DRV_ABX80X=m
|
||||||
CONFIG_RTC_DRV_DS1307=m
|
CONFIG_RTC_DRV_DS1307=m
|
||||||
CONFIG_RTC_DRV_DS1307_HWMON=y
|
CONFIG_RTC_DRV_DS1307_HWMON=y
|
||||||
|
CONFIG_RTC_DRV_DS1307_CENTURY=y
|
||||||
CONFIG_RTC_DRV_DS1511=m
|
CONFIG_RTC_DRV_DS1511=m
|
||||||
CONFIG_RTC_DRV_DS1553=m
|
CONFIG_RTC_DRV_DS1553=m
|
||||||
CONFIG_RTC_DRV_DS1685_FAMILY=m
|
CONFIG_RTC_DRV_DS1685_FAMILY=m
|
||||||
@ -5595,6 +5596,7 @@ CONFIG_KS0108_PORT=0x378
|
|||||||
CONFIG_KS0108_DELAY=2
|
CONFIG_KS0108_DELAY=2
|
||||||
CONFIG_CFAG12864B=y
|
CONFIG_CFAG12864B=y
|
||||||
CONFIG_CFAG12864B_RATE=20
|
CONFIG_CFAG12864B_RATE=20
|
||||||
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
|
||||||
# CONFIG_PHANTOM is not set
|
# CONFIG_PHANTOM is not set
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 3fbd61fbbbfa7ae15cd3f3e2ff7a97e106be2b43 Mon Sep 17 00:00:00 2001
|
From 973e23bf27b0b2e5021321357fc570cccea3104c Mon Sep 17 00:00:00 2001
|
||||||
From: Dave Anderson <anderson@redhat.com>
|
From: Dave Anderson <anderson@redhat.com>
|
||||||
Date: Tue, 26 Nov 2013 12:42:46 -0500
|
Date: Tue, 26 Nov 2013 12:42:46 -0500
|
||||||
Subject: [PATCH] crash-driver
|
Subject: [PATCH] crash-driver
|
||||||
@ -149,19 +149,16 @@ index 0000000..404bcb9
|
|||||||
+
|
+
|
||||||
+#endif /* _ASM_IA64_CRASH_H */
|
+#endif /* _ASM_IA64_CRASH_H */
|
||||||
diff --git a/arch/ia64/kernel/ia64_ksyms.c b/arch/ia64/kernel/ia64_ksyms.c
|
diff --git a/arch/ia64/kernel/ia64_ksyms.c b/arch/ia64/kernel/ia64_ksyms.c
|
||||||
index 0967310..e888878 100644
|
index d111248..b14b4c6 100644
|
||||||
--- a/arch/ia64/kernel/ia64_ksyms.c
|
--- a/arch/ia64/kernel/ia64_ksyms.c
|
||||||
+++ b/arch/ia64/kernel/ia64_ksyms.c
|
+++ b/arch/ia64/kernel/ia64_ksyms.c
|
||||||
@@ -84,6 +84,9 @@ EXPORT_SYMBOL(ia64_save_scratch_fpregs);
|
@@ -9,3 +9,6 @@
|
||||||
#include <asm/unwind.h>
|
EXPORT_SYMBOL(min_low_pfn); /* defined by bootmem.c, but not exported by generic code */
|
||||||
EXPORT_SYMBOL(unw_init_running);
|
EXPORT_SYMBOL(max_low_pfn); /* defined by bootmem.c, but not exported by generic code */
|
||||||
|
#endif
|
||||||
|
+
|
||||||
+#include <linux/efi.h>
|
+#include <linux/efi.h>
|
||||||
+EXPORT_SYMBOL_GPL(efi_mem_type);
|
+EXPORT_SYMBOL_GPL(efi_mem_type);
|
||||||
+
|
|
||||||
#if defined(CONFIG_IA64_ESI) || defined(CONFIG_IA64_ESI_MODULE)
|
|
||||||
extern void esi_call_phys (void);
|
|
||||||
EXPORT_SYMBOL_GPL(esi_call_phys);
|
|
||||||
diff --git a/arch/powerpc/include/asm/crash-driver.h b/arch/powerpc/include/asm/crash-driver.h
|
diff --git a/arch/powerpc/include/asm/crash-driver.h b/arch/powerpc/include/asm/crash-driver.h
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..50092d9
|
index 0000000..50092d9
|
||||||
@ -270,7 +267,7 @@ index 0000000..fd4736e
|
|||||||
+
|
+
|
||||||
+#endif /* _X86_CRASH_H */
|
+#endif /* _X86_CRASH_H */
|
||||||
diff --git a/drivers/char/Kconfig b/drivers/char/Kconfig
|
diff --git a/drivers/char/Kconfig b/drivers/char/Kconfig
|
||||||
index fdb8f3e..7dd3a49 100644
|
index dcc0973..99b99d5 100644
|
||||||
--- a/drivers/char/Kconfig
|
--- a/drivers/char/Kconfig
|
||||||
+++ b/drivers/char/Kconfig
|
+++ b/drivers/char/Kconfig
|
||||||
@@ -4,6 +4,9 @@
|
@@ -4,6 +4,9 @@
|
||||||
@ -284,10 +281,10 @@ index fdb8f3e..7dd3a49 100644
|
|||||||
|
|
||||||
config DEVMEM
|
config DEVMEM
|
||||||
diff --git a/drivers/char/Makefile b/drivers/char/Makefile
|
diff --git a/drivers/char/Makefile b/drivers/char/Makefile
|
||||||
index 55d16bf..a40ace9 100644
|
index 6e6c244..29cc9c8 100644
|
||||||
--- a/drivers/char/Makefile
|
--- a/drivers/char/Makefile
|
||||||
+++ b/drivers/char/Makefile
|
+++ b/drivers/char/Makefile
|
||||||
@@ -61,3 +61,5 @@ js-rtc-y = rtc.o
|
@@ -60,3 +60,5 @@ js-rtc-y = rtc.o
|
||||||
obj-$(CONFIG_TILE_SROM) += tile-srom.o
|
obj-$(CONFIG_TILE_SROM) += tile-srom.o
|
||||||
obj-$(CONFIG_XILLYBUS) += xillybus/
|
obj-$(CONFIG_XILLYBUS) += xillybus/
|
||||||
obj-$(CONFIG_POWERNV_OP_PANEL) += powernv-op-panel.o
|
obj-$(CONFIG_POWERNV_OP_PANEL) += powernv-op-panel.o
|
||||||
@ -506,9 +503,9 @@ index 0000000..25ab986
|
|||||||
+
|
+
|
||||||
+#endif /* __CRASH_H__ */
|
+#endif /* __CRASH_H__ */
|
||||||
--
|
--
|
||||||
2.9.2
|
2.7.4
|
||||||
|
|
||||||
From 7523c19e1d22fbabeaeae9520c16a78202c0eefe Mon Sep 17 00:00:00 2001
|
From 23d8bd48303acda2d3a95a3e1a662784a4fa9fcd Mon Sep 17 00:00:00 2001
|
||||||
From: Fedora Kernel Team <kernel-team@fedoraproject.org>
|
From: Fedora Kernel Team <kernel-team@fedoraproject.org>
|
||||||
Date: Tue, 20 Sep 2016 19:39:46 +0200
|
Date: Tue, 20 Sep 2016 19:39:46 +0200
|
||||||
Subject: [PATCH] Update of crash driver to handle CONFIG_HARDENED_USERCOPY and
|
Subject: [PATCH] Update of crash driver to handle CONFIG_HARDENED_USERCOPY and
|
||||||
@ -601,5 +598,5 @@ index 085378a..0258bf8 100644
|
|||||||
|
|
||||||
static struct miscdevice crash_dev = {
|
static struct miscdevice crash_dev = {
|
||||||
--
|
--
|
||||||
2.9.3
|
2.7.4
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 22e118d8d8dd13cda14973e28e198ec76c6a9a3b Mon Sep 17 00:00:00 2001
|
From 649d991ca7737dd227f2a1ca4f30247daf6a7b4b Mon Sep 17 00:00:00 2001
|
||||||
From: Roland McGrath <roland@redhat.com>
|
From: Roland McGrath <roland@redhat.com>
|
||||||
Date: Mon, 6 Oct 2008 23:03:03 -0700
|
Date: Mon, 6 Oct 2008 23:03:03 -0700
|
||||||
Subject: [PATCH] kbuild: AFTER_LINK
|
Subject: [PATCH] kbuild: AFTER_LINK
|
||||||
@ -107,11 +107,11 @@ index d540966..eeb47b6 100644
|
|||||||
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=both) \
|
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=both) \
|
||||||
$(call cc-ldoption, -Wl$(comma)--build-id) -Wl,-Bsymbolic $(LTO_CFLAGS)
|
$(call cc-ldoption, -Wl$(comma)--build-id) -Wl,-Bsymbolic $(LTO_CFLAGS)
|
||||||
diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
|
diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
|
||||||
index 4f727eb..7f73bee 100755
|
index f742c65..526eee4 100755
|
||||||
--- a/scripts/link-vmlinux.sh
|
--- a/scripts/link-vmlinux.sh
|
||||||
+++ b/scripts/link-vmlinux.sh
|
+++ b/scripts/link-vmlinux.sh
|
||||||
@@ -65,6 +65,10 @@ vmlinux_link()
|
@@ -111,6 +111,10 @@ vmlinux_link()
|
||||||
-lutil -lrt -lpthread ${1}
|
-lutil -lrt -lpthread
|
||||||
rm -f linux
|
rm -f linux
|
||||||
fi
|
fi
|
||||||
+ if [ -n "${AFTER_LINK}" ]; then
|
+ if [ -n "${AFTER_LINK}" ]; then
|
||||||
|
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%global rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 9
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -2142,6 +2142,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 17 2016 Laura Abbott <labbott@redhat.com> - 4.9.0-0.rc1.git0.1
|
||||||
|
- Linux v4.8-rc1
|
||||||
|
|
||||||
* Mon Oct 17 2016 Laura Abbott <labbott@redhat.com>
|
* Mon Oct 17 2016 Laura Abbott <labbott@redhat.com>
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
c1af0afbd3df35c1ccdc7a5118cd2d07 linux-4.8.tar.xz
|
c1af0afbd3df35c1ccdc7a5118cd2d07 linux-4.8.tar.xz
|
||||||
0dad03f586e835d538d3e0d2cbdb9a28 perf-man-4.8.tar.gz
|
0dad03f586e835d538d3e0d2cbdb9a28 perf-man-4.8.tar.gz
|
||||||
e1029b94d3c299991f7103373ee1f090 patch-4.8-git9.xz
|
57c8efbc183617e94a8367d03f752b4d patch-4.9-rc1.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user