kernel-5.7.0-0.rc6.1

* Mon May 18 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.1]
- v5.7-rc6 rebase
- Updated changelog for the release based on 3d1c1e5931ce ("CKI@GitLab")
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-05-18 12:42:20 -05:00
parent 47fa8e4cc7
commit 8bcec8d902
11 changed files with 36 additions and 24 deletions

View File

@ -10,10 +10,10 @@ Patch for disconnect issues with storage attached to a
1 file changed, 7 insertions(+)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index 2b6565c06c23..2bbf3e341b47 100644
index fc748c731832..7d35e12de70f 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5516,6 +5516,13 @@ static void hub_event(struct work_struct *work)
@@ -5517,6 +5517,13 @@ static void hub_event(struct work_struct *work)
(u16) hub->change_bits[0],
(u16) hub->event_bits[0]);

View File

@ -16,10 +16,10 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
1 file changed, 1 insertion(+)
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index 9e87f5847c92..f57bee916600 100644
index 7f37a6d0658a..c88ee0e8ce6e 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -1125,6 +1125,7 @@ config XEN
@@ -1126,6 +1126,7 @@ config XEN
config FORCE_MAX_ZONEORDER
int
default "14" if (ARM64_64K_PAGES && TRANSPARENT_HUGEPAGE)

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 4a9877c61db5..015baafbaf9b 100644
index 266cc438f200..2f4fdf51c7e2 100644
--- a/Makefile
+++ b/Makefile
@@ -479,7 +479,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE

View File

@ -21,10 +21,10 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index 40fb05d96c60..9e87f5847c92 100644
index 5d513f461957..7f37a6d0658a 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -857,7 +857,7 @@ endchoice
@@ -858,7 +858,7 @@ endchoice
config ARM64_FORCE_52BIT
bool "Force 52-bit virtual addresses for userspace"

View File

@ -11,10 +11,10 @@ Signed-off-by: Jon Masters <jcm@redhat.com>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
index 66a04f6f4775..7b63103f088c 100644
index c77c93c485a0..f808c4e0727f 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -1542,9 +1542,9 @@ config HIGHMEM
@@ -1543,9 +1543,9 @@ config HIGHMEM
If unsure, say n.
config HIGHPTE

View File

@ -27,10 +27,10 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
1 file changed, 6 insertions(+)
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
index 082d4d5f24fd..49b267c5a6af 100644
index 0ef4f2f203fd..b8f8bf3aca50 100644
--- a/kernel/bpf/syscall.c
+++ b/kernel/bpf/syscall.c
@@ -3685,11 +3685,17 @@ static int link_update(union bpf_attr *attr)
@@ -3687,11 +3687,17 @@ static int link_update(union bpf_attr *attr)
SYSCALL_DEFINE3(bpf, int, cmd, union bpf_attr __user *, uattr, unsigned int, size)
{
union bpf_attr attr;

View File

@ -66,7 +66,7 @@ index c041d4e950f4..8588bb62e74c 100644
#define TAINT_FLAGS_COUNT 32
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
index 7626b8024471..082d4d5f24fd 100644
index 2843bbba9ca1..0ef4f2f203fd 100644
--- a/kernel/bpf/syscall.c
+++ b/kernel/bpf/syscall.c
@@ -24,6 +24,7 @@

View File

@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 11fe9b1535de..4a9877c61db5 100644
index 04f5662ae61a..266cc438f200 100644
--- a/Makefile
+++ b/Makefile
@@ -1190,7 +1190,13 @@ endef

View File

@ -17,7 +17,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
5 files changed, 20 insertions(+)
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
index 1bdd027766d4..5c1d47c41aa0 100644
index 5616b2567aa7..bc5caab1413b 100644
--- a/include/linux/lsm_hook_defs.h
+++ b/include/linux/lsm_hook_defs.h
@@ -371,6 +371,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc5.20200515git1ae7efb38854.1
%global distro_build 0.rc6.1
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,10 +69,10 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.7.0
%define pkgrelease 0.rc5.20200515git1ae7efb38854.1
%define pkgrelease 0.rc6.1
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc5.20200515git1ae7efb38854.1%{?buildid}%{?dist}
%define specrelease 0.rc6.1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -163,7 +163,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# The kernel tarball/base version
%define kversion 5.7
@ -564,7 +564,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-20200515git1ae7efb38854.tar.xz
Source0: linux-5.7-rc6.tar.xz
Source1: Makefile.rhelver
@ -1273,8 +1273,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-20200515git1ae7efb38854 -c
mv linux-20200515git1ae7efb38854 linux-%{KVERREL}
%setup -q -n kernel-5.7-rc6 -c
mv linux-5.7-rc6 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2764,6 +2764,18 @@ fi
#
#
%changelog
* Mon May 18 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.1]
- v5.7-rc6 rebase
- Updated changelog for the release based on 3d1c1e5931ce ("CKI@GitLab")
* Sun May 17 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc5.20200517git3d1c1e5931ce.1]
- 3d1c1e5931ce rebase
- Updated changelog for the release based on 12bf0b632ed0 ("CKI@GitLab")
* Sat May 16 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc5.20200516git12bf0b632ed0.1]
- 12bf0b632ed0 rebase
- Updated changelog for the release based on 1ae7efb38854 ("CKI@GitLab")
* Fri May 15 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc5.20200515git1ae7efb38854.1]
- 1ae7efb38854 rebase
- Updated changelog for the release based on 24085f70a6e1 ("CKI@GitLab")

View File

@ -1,3 +1,3 @@
SHA512 (linux-20200515git1ae7efb38854.tar.xz) = d822f1e88494b36e4d57483479a4d0a23db8035a825ec2e223a88868d32e20fdf94f0578dc266f707ae8e1533e031f4a80d406726597cee085344aa7c4937c5b
SHA512 (kernel-abi-whitelists-5.7.0-0.rc5.20200515git1ae7efb38854.1.tar.bz2) = cf003717d2bf9e60c07f9e3599f048053d74f499734c0916a6e4ad0d5fec2314c5fc62824df9a95cf295f93ef6153a281567253d00da2d1852d2d2a253390285
SHA512 (kernel-kabi-dw-5.7.0-0.rc5.20200515git1ae7efb38854.1.tar.bz2) = 2ef2c65a8a7fd7251c09f96fac0d15dcf67e9833e546a669e02c57656dec9ad0c9077784229ffdda39c4883f858bec8aa9a9c9b99b6a049e2f45c6026f0216a2
SHA512 (linux-5.7-rc6.tar.xz) = d21840e703ddbabd3ceda552c04808fc0239a850135b18400e1c5f46d1d92109028ce191df9927f21cb660e97ee5c7026cc6b3813d793eb856a81738b9376af7
SHA512 (kernel-abi-whitelists-5.7.0-0.rc6.1.tar.bz2) = 7ca35d40b774ebb45b297085c8ddf00651ee6d02b08e32ac3e159562fc8fdb1e04b600e1743f7a6f976d7f739f223b8c4a48f3850e4e2ea8260cb77a0da37dac
SHA512 (kernel-kabi-dw-5.7.0-0.rc6.1.tar.bz2) = 1ba26e33a7cee13ba8cd5967fcce2aea07da0cc213d587ddba10c558fcc6a7de4972efe6f32e3d2b3e3a949db8b425eb7aad0ba4d5db32da965d79b0029ed528