Merge branch 'f12/master' into f12/user/myoung/xendom0

Conflicts:
	kernel.spec
This commit is contained in:
Michael Young 2010-11-23 12:34:13 +00:00
commit 8a792d0342
4 changed files with 12 additions and 57 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ patch-*.bz2
clog
*.rpm
kernel-2.6.*/
/patch-2.6.32.26.bz2

View File

@ -48,7 +48,7 @@ Summary: The Linux kernel
# reset this by hand to 1 (or to 0 and then use rpmdev-bumpspec).
# scripts/rebase.sh should be made to do that for you, actually.
#
%global baserelease 172
%global baserelease 174
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@ -60,7 +60,7 @@ Summary: The Linux kernel
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
%define stable_update 25
%define stable_update 26
# Is it a -stable RC?
%define stable_rc 0
# Set rpm version accordingly
@ -832,9 +832,6 @@ Patch13030: l2tp-fix-oops-in-pppol2tp_xmit.patch
Patch14050: crypto-add-async-hash-testing.patch
# Red Hat Bugzilla #610911
Patch14130: kvm-mmu-fix-conflict-access-permissions-in-direct-sp.patch
Patch14200: net-do-not-check-capable-if-kernel.patch
# rhbz#596475
@ -1540,8 +1537,6 @@ ApplyPatch l2tp-fix-oops-in-pppol2tp_xmit.patch
# add tests for crypto async hashing (#571577)
ApplyPatch crypto-add-async-hash-testing.patch
ApplyPatch kvm-mmu-fix-conflict-access-permissions-in-direct-sp.patch
# rhbz #598796
ApplyPatch net-do-not-check-capable-if-kernel.patch
@ -2204,6 +2199,14 @@ fi
%kernel_variant_files -k vmlinux %{with_kdump} kdump
%changelog
* Mon Nov 22 2010 Kyle McMartin <kyle@redhat.com> 2.6.32.26-174
- Linux 2.6.32.26
* Sat Nov 20 2010 Chuck Ebbert <cebbert@redhat.com> 2.6.32.26-173.rc1
- Linux 2.6.32.26-rc1
- Comment out upstreamed patches:
kvm-mmu-fix-conflict-access-permissions-in-direct-sp.patch
* Sat Nov 06 2010 Michael Young <m.a.young@durham.ac.uk>
- update pvops to 2.6.32.25

View File

@ -1,49 +0,0 @@
From: Xiao Guangrong <xiaoguangrong@cn.fujitsu.com>
Date: Wed, 30 Jun 2010 08:02:45 +0000 (+0800)
Subject: KVM: MMU: fix conflict access permissions in direct sp
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=6aa0b9dec5d6dde26ea17b0b5be8fccfe19df3c9
KVM: MMU: fix conflict access permissions in direct sp
In no-direct mapping, we mark sp is 'direct' when we mapping the
guest's larger page, but its access is encoded form upper page-struct
entire not include the last mapping, it will cause access conflict.
For example, have this mapping:
[W]
/ PDE1 -> |---|
P[W] | | LPA
\ PDE2 -> |---|
[R]
P have two children, PDE1 and PDE2, both PDE1 and PDE2 mapping the
same lage page(LPA). The P's access is WR, PDE1's access is WR,
PDE2's access is RO(just consider read-write permissions here)
When guest access PDE1, we will create a direct sp for LPA, the sp's
access is from P, is W, then we will mark the ptes is W in this sp.
Then, guest access PDE2, we will find LPA's shadow page, is the same as
PDE's, and mark the ptes is RO.
So, if guest access PDE1, the incorrect #PF is occured.
Fixed by encode the last mapping access into direct shadow page
Signed-off-by: Xiao Guangrong <xiaoguangrong@cn.fujitsu.com>
Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
Signed-off-by: Avi Kivity <avi@redhat.com>
---
diff --git a/arch/x86/kvm/paging_tmpl.h b/arch/x86/kvm/paging_tmpl.h
index 89d66ca..2331bdc 100644
--- a/arch/x86/kvm/paging_tmpl.h
+++ b/arch/x86/kvm/paging_tmpl.h
@@ -342,6 +342,7 @@ static u64 *FNAME(fetch)(struct kvm_vcpu *vcpu, gva_t addr,
/* advance table_gfn when emulating 1gb pages with 4k */
if (delta == 0)
table_gfn += PT_INDEX(addr, level);
+ access &= gw->pte_access;
} else {
direct = 0;
table_gfn = gw->table_gfn[level - 2];

View File

@ -1,2 +1,2 @@
260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
d8fff54efff6c5f7b07e5370a5e9f119 patch-2.6.32.25.bz2
98071c23205c84912386e10b86c561c8 patch-2.6.32.26.bz2