kernel-6.3.10-200

* Wed Jun 28 2023 Augusto Caringi <acaringi@redhat.com> [6.3.10-0]
- Linux v6.3.10
Resolves:

Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
Augusto Caringi 2023-06-28 15:41:45 -03:00
parent acfa19b1a4
commit 89c90be095
3 changed files with 20 additions and 17 deletions

View File

@ -142,18 +142,18 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specrpmversion 6.3.9
%define specversion 6.3.9
%define specrpmversion 6.3.10
%define specversion 6.3.10
%define patchversion 6.3
%define pkgrelease 200
%define kversion 6
%define tarfile_release 6.3.9
%define tarfile_release 6.3.10
# This is needed to do merge window version magic
%define patchlevel 3
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 200%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.3.9
%define kabiversion 6.3.10
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3406,6 +3406,9 @@ fi
#
#
%changelog
* Wed Jun 28 2023 Augusto Caringi <acaringi@redhat.com> [6.3.10-0]
- Linux v6.3.10
* Wed Jun 21 2023 Augusto Caringi <acaringi@redhat.com> [6.3.9-0]
- Turn on CONFIG_RMNET for Fedora (Justin M. Forbes)
- redhat/config: common: Enable CONFIG_GPIO_SIM for software development (Kate Hsuan)

View File

@ -40,7 +40,7 @@
39 files changed, 512 insertions(+), 187 deletions(-)
diff --git a/Makefile b/Makefile
index f8ee72375885..8f848f64ad80 100644
index 47253ac6c85c..15a31ab19ace 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -384,7 +384,7 @@ index b51f2a4c821e..be31d32aba53 100644
obj-$(CONFIG_EFI_RCI2_TABLE) += rci2-table.o
obj-$(CONFIG_EFI_EMBEDDED_FIRMWARE) += embedded-firmware.o
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
index abeff7dc0b58..6384796e76dd 100644
index 34b9e7876538..97bc2138bf74 100644
--- a/drivers/firmware/efi/efi.c
+++ b/drivers/firmware/efi/efi.c
@@ -32,6 +32,7 @@
@ -395,7 +395,7 @@ index abeff7dc0b58..6384796e76dd 100644
#include <asm/early_ioremap.h>
@@ -947,40 +948,101 @@ int efi_mem_type(unsigned long phys_addr)
@@ -926,40 +927,101 @@ int efi_mem_type(unsigned long phys_addr)
}
#endif
@ -994,7 +994,7 @@ index 256a38371120..a77075a6abb5 100644
* Changes the default domain of an iommu group that has *only* one device
*
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index c015393beeee..d97dac7ae5a7 100644
index 8a632bf7f5a8..4c346f979f1e 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -251,6 +251,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
@ -1050,7 +1050,7 @@ index c015393beeee..d97dac7ae5a7 100644
void nvme_complete_rq(struct request *req)
{
struct nvme_ctrl *ctrl = nvme_req(req)->ctrl;
@@ -410,6 +423,9 @@ void nvme_complete_rq(struct request *req)
@@ -419,6 +432,9 @@ void nvme_complete_rq(struct request *req)
case FAILOVER:
nvme_failover_req(req);
return;
@ -1108,10 +1108,10 @@ index 2bc159a318ff..d5562a97f232 100644
if (!ctrl->max_namespaces ||
diff --git a/drivers/nvme/host/nvme.h b/drivers/nvme/host/nvme.h
index a2d4f59e0535..1c5092b995e9 100644
index 8657811f8b88..feee7e1e6c8d 100644
--- a/drivers/nvme/host/nvme.h
+++ b/drivers/nvme/host/nvme.h
@@ -878,6 +878,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
@@ -879,6 +879,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_start_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_default_iopolicy(struct nvme_subsystem *subsys);
void nvme_failover_req(struct request *req);
@ -1119,7 +1119,7 @@ index a2d4f59e0535..1c5092b995e9 100644
void nvme_kick_requeue_lists(struct nvme_ctrl *ctrl);
int nvme_mpath_alloc_disk(struct nvme_ctrl *ctrl,struct nvme_ns_head *head);
void nvme_mpath_add_disk(struct nvme_ns *ns, __le32 anagrpid);
@@ -916,6 +917,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
@@ -917,6 +918,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
static inline void nvme_failover_req(struct request *req)
{
}
@ -1429,10 +1429,10 @@ index cf6cc576736f..3653a4f35265 100644
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 920e44ba998a..921398590e3f 100644
index eb049014f87a..3fc66c4f9540 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -9733,6 +9733,8 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
@@ -9734,6 +9734,8 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
SND_PCI_QUIRK(0x17aa, 0x2318, "Thinkpad Z13 Gen2", ALC287_FIXUP_CS35L41_I2C_2),
SND_PCI_QUIRK(0x17aa, 0x2319, "Thinkpad Z16 Gen2", ALC287_FIXUP_CS35L41_I2C_2),
SND_PCI_QUIRK(0x17aa, 0x231a, "Thinkpad Z16 Gen2", ALC287_FIXUP_CS35L41_I2C_2),

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.3.9.tar.xz) = 5a121b928a0f730afc0560bc279841cf854b77bc93dd86066b6a2ec2fff934f5d4d2cb167af0e1a079d9228e086de7ac85796454429356946ae0bc98b646ecfe
SHA512 (kernel-abi-stablelists-6.3.9.tar.bz2) = 856b626aa04c96f94339b8721511b224648a17a37b943820374366ecf4a07567f0decec87ec99d77657c5f4354a3b23776d875921a5382b35f1483f8064eaee0
SHA512 (kernel-kabi-dw-6.3.9.tar.bz2) = 8de52912f14198ab1887ca62b2809faf116e708edde7a465024bebb7bbd688bdd99f528bb8af659fa33a9444d2660e64c86a2574ef077a1de1ed0f6215de969a
SHA512 (linux-6.3.10.tar.xz) = e1bee6ab13c2447d795c97daae52bc68b7dcd17f5055976e89ae733c58acc5de28cd51393942010f64957102f84870032e63392b24322a25798375fa96d8b25f
SHA512 (kernel-abi-stablelists-6.3.10.tar.bz2) = cb036e3facdb78170a0b0047139398ca5b5425f482f3a63072ae9c141a7d126a218f0bdec56c823b9bd0e972ce9061db2af250ffce16231906c0e81337ec8331
SHA512 (kernel-kabi-dw-6.3.10.tar.bz2) = 20ef9d7eca2ea19f1ef28d9f50becd8cfc583f2225c744f22dffa1de6dadc6811f4aef1b2a4314fa8108f931166f8850236e575169ba0d78260670932ebe3585