Update compat-wireless snapshot to version 3.3-rc1-2

This commit is contained in:
John W. Linville 2012-01-24 15:27:32 -05:00
parent bb1165406c
commit 8879a2cf41
6 changed files with 80 additions and 115 deletions

View File

@ -0,0 +1,47 @@
From 4f3d09de38d234ce7ffba5ec5a7e6704f983d375 Mon Sep 17 00:00:00 2001
From: John W. Linville <linville@tuxdriver.com>
Date: Wed, 11 Jan 2012 15:50:15 -0500
Subject: [PATCH] b43: add option to avoid duplicating device support with
brcmsmac
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/b43/Kconfig | 6 ++++++
drivers/net/wireless/b43/main.c | 2 ++
2 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/drivers/net/wireless/b43/Kconfig b/drivers/net/wireless/b43/Kconfig
index b97a40e..3876c7e 100644
--- a/drivers/net/wireless/b43/Kconfig
+++ b/drivers/net/wireless/b43/Kconfig
@@ -31,6 +31,12 @@ config B43_BCMA
depends on B43 && BCMA
default y
+config B43_BCMA_EXTRA
+ bool "Hardware support that overlaps with the brcmsmac driver"
+ depends on B43_BCMA
+ default n if BRCMSMAC || BRCMSMAC_MODULE
+ default y
+
config B43_SSB
bool
depends on B43 && SSB
diff --git a/drivers/net/wireless/b43/main.c b/drivers/net/wireless/b43/main.c
index b91f28e..23ffb1b 100644
--- a/drivers/net/wireless/b43/main.c
+++ b/drivers/net/wireless/b43/main.c
@@ -116,8 +116,10 @@ MODULE_PARM_DESC(pio, "Use PIO accesses by default: 0=DMA, 1=PIO");
#ifdef CONFIG_B43_BCMA
static const struct bcma_device_id b43_bcma_tbl[] = {
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_80211, 0x11, BCMA_ANY_CLASS),
+#ifdef CONFIG_B43_BCMA_EXTRA
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_80211, 0x17, BCMA_ANY_CLASS),
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_80211, 0x18, BCMA_ANY_CLASS),
+#endif
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_80211, 0x1D, BCMA_ANY_CLASS),
BCMA_CORETABLE_END
};
--
1.7.4.4

View File

@ -1,35 +0,0 @@
Simple patch to remove the overlap between the bcma (i.e. b43) driver
and the brcmsmac driver. David Woodhouse <dwmw2@infradead.org>
confirmed that this patch restores functionality of bcm4331 devices.
-- John W. Linville <linville@redhat.com>
diff -up linux-3.1.x86_64/drivers/bcma/host_pci.c.orig linux-3.1.x86_64/drivers/bcma/host_pci.c
--- linux-3.1.x86_64/drivers/bcma/host_pci.c.orig 2011-11-10 11:41:26.829742757 -0500
+++ linux-3.1.x86_64/drivers/bcma/host_pci.c 2011-11-10 11:41:22.884792078 -0500
@@ -225,11 +225,13 @@ static void bcma_host_pci_remove(struct
}
static DEFINE_PCI_DEVICE_TABLE(bcma_pci_bridge_tbl) = {
- { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x0576) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4331) },
+#if 0 /* Not in Fedora... */
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x0576) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4353) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4357) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4727) },
+#endif
{ 0, },
};
MODULE_DEVICE_TABLE(pci, bcma_pci_bridge_tbl);
diff -up linux-3.1.x86_64/drivers/net/wireless/brcm80211/Kconfig.orig linux-3.1.x86_64/drivers/net/wireless/brcm80211/Kconfig
--- linux-3.1.x86_64/drivers/net/wireless/brcm80211/Kconfig.orig 2011-11-10 11:42:31.764930961 -0500
+++ linux-3.1.x86_64/drivers/net/wireless/brcm80211/Kconfig 2011-11-10 11:42:33.613907846 -0500
@@ -5,7 +5,6 @@ config BRCMSMAC
tristate "Broadcom IEEE802.11n PCIe SoftMAC WLAN driver"
depends on PCI
depends on MAC80211
- depends on BCMA=n
select BRCMUTIL
select FW_LOADER
select CRC_CCITT

View File

@ -1,29 +0,0 @@
From c5cfdf2d138ba20a648990d9615c44942eef5fd3 Mon Sep 17 00:00:00 2001
From: John W. Linville <linville@tuxdriver.com>
Date: Fri, 18 Nov 2011 13:46:18 -0500
Subject: [PATCH] compat-wireless: change CONFIG_IWLAGN -> CONFIG_IWLWIFI
This Kconfig option changed in the 2.6.32 timeframe.
Signed-off-by: John W. Linville <linville@tuxdriver.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
---
config.mk | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/config.mk b/config.mk
index 0e964a5..05edb79 100644
--- a/config.mk
+++ b/config.mk
@@ -285,7 +285,7 @@ ifdef CONFIG_PCI
CONFIG_ATH5K_PCI=y
CONFIG_ATH9K_PCI=y
-CONFIG_IWLAGN=m
+CONFIG_IWLWIFI=m
# CONFIG_IWLWIFI_DEBUG=y
# CONFIG_IWLWIFI_DEBUGFS=y
# CONFIG_IWLWIFI_DEVICE_TRACING=y
--
1.7.4.4

View File

@ -1,6 +1,6 @@
diff -up compat-wireless-2011-12-18/config.mk.orig compat-wireless-2011-12-18/config.mk
--- compat-wireless-2011-12-18/config.mk.orig 2012-01-05 13:54:21.214595837 -0500
+++ compat-wireless-2011-12-18/config.mk 2012-01-05 13:54:35.668415136 -0500
diff -up compat-wireless-3.3-rc1-2/config.mk.orig compat-wireless-3.3-rc1-2/config.mk
--- compat-wireless-3.3-rc1-2/config.mk.orig 2012-01-21 02:00:21.000000000 -0500
+++ compat-wireless-3.3-rc1-2/config.mk 2012-01-24 15:16:38.204409844 -0500
@@ -14,6 +14,9 @@ else
include $(KLIB_BUILD)/.config
endif
@ -11,33 +11,15 @@ diff -up compat-wireless-2011-12-18/config.mk.orig compat-wireless-2011-12-18/co
ifneq ($(wildcard $(KLIB_BUILD)/Makefile),)
COMPAT_LATEST_VERSION = 3
@@ -395,7 +398,7 @@ ifdef CONFIG_CRC_CCITT
CONFIG_RT2800PCI=m
CONFIG_RT2800PCI_RT33XX=y
CONFIG_RT2800PCI_RT35XX=y
-# CONFIG_RT2800PCI_RT53XX=y
+CONFIG_RT2800PCI_RT53XX=y
endif #CONFIG_CRC_CCITT
NEED_RT2X00=y
@@ -525,7 +528,7 @@ ifdef CONFIG_CRC_CCITT
CONFIG_RT2800USB=m
CONFIG_RT2800USB_RT33XX=y
CONFIG_RT2800USB_RT35XX=y
-# CONFIG_RT2800USB_RT53XX=y
+CONFIG_RT2800USB_RT53XX=y
CONFIG_RT2800USB_UNKNOWN=y
endif #CONFIG_CRC_CCITT
CONFIG_RT2X00_LIB_USB=m
diff -up compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile.orig compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile
--- compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile.orig 2012-01-05 13:54:21.214595837 -0500
+++ compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile 2012-01-05 13:54:27.274520077 -0500
diff -up compat-wireless-3.3-rc1-2/drivers/misc/eeprom/Makefile.orig compat-wireless-3.3-rc1-2/drivers/misc/eeprom/Makefile
--- compat-wireless-3.3-rc1-2/drivers/misc/eeprom/Makefile.orig 2012-01-21 02:08:39.000000000 -0500
+++ compat-wireless-3.3-rc1-2/drivers/misc/eeprom/Makefile 2012-01-24 15:16:38.204409844 -0500
@@ -1 +1 @@
-obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
+#obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
diff -up compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile
--- compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig 2012-01-05 13:54:21.215595824 -0500
+++ compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile 2012-01-05 13:54:27.275520064 -0500
diff -up compat-wireless-3.3-rc1-2/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-3.3-rc1-2/drivers/net/ethernet/atheros/Makefile
--- compat-wireless-3.3-rc1-2/drivers/net/ethernet/atheros/Makefile.orig 2012-01-21 02:08:39.000000000 -0500
+++ compat-wireless-3.3-rc1-2/drivers/net/ethernet/atheros/Makefile 2012-01-24 15:16:38.204409844 -0500
@@ -2,7 +2,7 @@
# Makefile for the Atheros network device drivers.
#
@ -50,9 +32,9 @@ diff -up compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig c
+#obj-$(CONFIG_ATL2) += atlx/
+#obj-$(CONFIG_ATL1E) += atl1e/
+#obj-$(CONFIG_ATL1C) += atl1c/
diff -up compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig compat-wireless-2011-12-18/drivers/net/usb/Makefile
--- compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig 2012-01-05 13:54:21.215595824 -0500
+++ compat-wireless-2011-12-18/drivers/net/usb/Makefile 2012-01-05 13:54:27.275520064 -0500
diff -up compat-wireless-3.3-rc1-2/drivers/net/usb/Makefile.orig compat-wireless-3.3-rc1-2/drivers/net/usb/Makefile
--- compat-wireless-3.3-rc1-2/drivers/net/usb/Makefile.orig 2012-01-21 02:08:39.000000000 -0500
+++ compat-wireless-3.3-rc1-2/drivers/net/usb/Makefile 2012-01-24 15:16:38.205409832 -0500
@@ -2,7 +2,7 @@
# Makefile for USB Network drivers
#
@ -64,21 +46,21 @@ diff -up compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig compat-wireles
+#obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
+#obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
diff -up compat-wireless-2011-12-18/Makefile.orig compat-wireless-2011-12-18/Makefile
--- compat-wireless-2011-12-18/Makefile.orig 2012-01-05 13:54:21.216595811 -0500
+++ compat-wireless-2011-12-18/Makefile 2012-01-05 13:54:27.276520051 -0500
@@ -8,8 +8,8 @@ endif
export KLIB_BUILD ?= $(KLIB)/build
# Sometimes not available in the path
diff -up compat-wireless-3.3-rc1-2/Makefile.orig compat-wireless-3.3-rc1-2/Makefile
--- compat-wireless-3.3-rc1-2/Makefile.orig 2012-01-21 02:00:21.000000000 -0500
+++ compat-wireless-3.3-rc1-2/Makefile 2012-01-24 15:17:34.524705743 -0500
@@ -10,8 +10,8 @@ export KLIB_BUILD ?= $(KLIB)/build
MODPROBE := /sbin/modprobe
ifneq ($(wildcard $(MODPROBE)),)
-MADWIFI=$(shell $(MODPROBE) -l ath_pci)
-OLD_IWL=$(shell $(MODPROBE) -l iwl4965)
+MADWIFI=""
+OLD_IWL=""
endif
DESTDIR?=
@@ -41,8 +41,8 @@ endif
@@ -44,8 +44,8 @@ endif
endif

View File

@ -205,7 +205,7 @@ Summary: The Linux kernel
%define kversion 3.%{base_sublevel}
# The compat-wireless version
%define cwversion 3.2-1
%define cwversion 3.3-rc1-2
#######################################################################
# If cwversion is less than kversion, make sure with_backports is
@ -215,7 +215,7 @@ Summary: The Linux kernel
#
# (Uncomment the '#' and both spaces below to disable with_backports.)
#
%define with_backports 0
# % define with_backports 0
#######################################################################
%define make_target bzImage
@ -822,9 +822,11 @@ Patch22000: rcu-reintroduce-missing-calls.patch
# compat-wireless patches
Patch50000: compat-wireless-config-fixups.patch
Patch50001: compat-wireless-change-CONFIG_IWLAGN-CONFIG_IWLWIFI.patch
Patch50002: compat-wireless-pr_fmt-warning-avoidance.patch
Patch50003: compat-wireless-rtl8192cu-Fix-WARNING-on-suspend-resume.patch
Patch50001: compat-wireless-pr_fmt-warning-avoidance.patch
Patch50002: compat-wireless-rtl8192cu-Fix-WARNING-on-suspend-resume.patch
# Remove overlapping hardware support between b43 and brcmsmac
Patch50100: b43-add-option-to-avoid-duplicating-device-support-w.patch
%endif
@ -1582,17 +1584,12 @@ rm -rf compat-wireless-%{cwversion}
cd compat-wireless-%{cwversion}
ApplyPatch compat-wireless-config-fixups.patch
ApplyPatch compat-wireless-change-CONFIG_IWLAGN-CONFIG_IWLWIFI.patch
ApplyPatch compat-wireless-pr_fmt-warning-avoidance.patch
ApplyPatch compat-wireless-rtl8192cu-Fix-WARNING-on-suspend-resume.patch
ApplyPatch mac80211-fix-rx-key-NULL-ptr-deref-in-promiscuous-mode.patch
ApplyPatch mac80211-fix-work-removal-on-deauth-request.patch
#rhbz 731365, 773271
ApplyPatch mac80211_offchannel_rework_revert.patch
# Remove overlap between bcma/b43 and brcmsmac and reenable bcm4331
ApplyPatch bcma-brcmsmac-compat.patch
# Remove overlapping hardware support between b43 and brcmsmac
ApplyPatch b43-add-option-to-avoid-duplicating-device-support-w.patch
cd ..
@ -2295,6 +2292,9 @@ fi
# and build.
%changelog
* Tue Jan 24 2012 John W. Linville <linville@redhat.com>
- Update compat-wireless snapshot to version 3.3-rc1-2
* Tue Jan 24 2012 Josh Boyer <jwboyer@redhat.com>
- Re-enable the ARCMSR module (rhbz 784287)
- Add back a set of patches that were erroneously dropped during the rebase

View File

@ -1,3 +1,3 @@
364066fa18767ec0ae5f4e4abcf9dc51 linux-3.2.tar.xz
204381bc537b689edcb15df0efed6467 compat-wireless-3.2-1.tar.bz2
62ac6ac9b870162f693ecf5e8606423a patch-3.2.1.xz
8cfe037a7a7a356278ec3638e25ad506 compat-wireless-3.3-rc1-2.tar.bz2