kernel-6.10.8-200
* Wed Sep 04 2024 Augusto Caringi <acaringi@redhat.com> [6.10.8-0] - Add to BugsFixed (Augusto Caringi) - xfs: xfs_finobt_count_blocks() walks the wrong btree (Dave Chinner) - Linux v6.10.8 Resolves: Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
parent
d04face402
commit
80d48a1989
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/3b2f4b84968261c49a19cde5a2c01c32c09cc1f8
|
||||
3b2f4b84968261c49a19cde5a2c01c32c09cc1f8 xfs: xfs_finobt_count_blocks() walks the wrong btree
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/378f837843ce9ccefbf401f707cda2c10c03b258
|
||||
378f837843ce9ccefbf401f707cda2c10c03b258 Revert the F39 commits which should not have pushed
|
||||
|
||||
|
@ -1,3 +1,9 @@
|
||||
* Wed Sep 04 2024 Augusto Caringi <acaringi@redhat.com> [6.10.8-0]
|
||||
- Add to BugsFixed (Augusto Caringi)
|
||||
- xfs: xfs_finobt_count_blocks() walks the wrong btree (Dave Chinner)
|
||||
- Linux v6.10.8
|
||||
Resolves:
|
||||
|
||||
* Thu Aug 29 2024 Augusto Caringi <acaringi@redhat.com> [6.10.7-0]
|
||||
- KVM: PPC: Book3S HV nestedv2: Keep nested guest HASHPKEYR in sync (Shivaprasad G Bhat)
|
||||
- KVM: PPC: Book3S HV: Add one-reg interface for HASHPKEYR register (Shivaprasad G Bhat)
|
||||
|
13
kernel.spec
13
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.10.7
|
||||
%define specversion 6.10.7
|
||||
%define specrpmversion 6.10.8
|
||||
%define specversion 6.10.8
|
||||
%define patchversion 6.10
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.10.7
|
||||
%define tarfile_release 6.10.8
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 10
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 200%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.10.7
|
||||
%define kabiversion 6.10.8
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -4043,6 +4043,11 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Sep 04 2024 Augusto Caringi <acaringi@redhat.com> [6.10.8-0]
|
||||
- Add to BugsFixed (Augusto Caringi)
|
||||
- xfs: xfs_finobt_count_blocks() walks the wrong btree (Dave Chinner)
|
||||
- Linux v6.10.8
|
||||
|
||||
* Thu Aug 29 2024 Augusto Caringi <acaringi@redhat.com> [6.10.7-0]
|
||||
- KVM: PPC: Book3S HV nestedv2: Keep nested guest HASHPKEYR in sync (Shivaprasad G Bhat)
|
||||
- KVM: PPC: Book3S HV: Add one-reg interface for HASHPKEYR register (Shivaprasad G Bhat)
|
||||
|
@ -32,6 +32,7 @@
|
||||
drivers/pci/quirks.c | 24 ++++
|
||||
drivers/scsi/sd.c | 10 ++
|
||||
drivers/usb/core/hub.c | 7 +
|
||||
fs/xfs/libxfs/xfs_ialloc_btree.c | 2 +-
|
||||
include/linux/crypto.h | 1 +
|
||||
include/linux/efi.h | 22 ++-
|
||||
include/linux/lsm_hook_defs.h | 2 +
|
||||
@ -45,7 +46,7 @@
|
||||
security/lockdown/Kconfig | 13 ++
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 ++
|
||||
47 files changed, 827 insertions(+), 256 deletions(-)
|
||||
48 files changed, 828 insertions(+), 257 deletions(-)
|
||||
|
||||
diff --git a/Documentation/virt/kvm/api.rst b/Documentation/virt/kvm/api.rst
|
||||
index eec8df1dde06..88f49dd10cd0 100644
|
||||
@ -64,7 +65,7 @@ index eec8df1dde06..88f49dd10cd0 100644
|
||||
...
|
||||
PPC KVM_REG_PPC_TM_GPR31 64
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ab77d171e268..c46aa8337181 100644
|
||||
index 2e5ac6ab3d47..838301b19917 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1693,7 +1694,7 @@ index 568410e64ce6..6afbaee83950 100644
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
|
||||
index 6b64af7d4927..a7ad470b8b8c 100644
|
||||
index 7d2a294ebc3d..c2536099932b 100644
|
||||
--- a/drivers/scsi/sd.c
|
||||
+++ b/drivers/scsi/sd.c
|
||||
@@ -120,6 +120,14 @@ static const char *sd_cache_types[] = {
|
||||
@ -1711,7 +1712,7 @@ index 6b64af7d4927..a7ad470b8b8c 100644
|
||||
static void sd_set_flush_flag(struct scsi_disk *sdkp)
|
||||
{
|
||||
bool wc = false, fua = false;
|
||||
@@ -4253,6 +4261,8 @@ static int __init init_sd(void)
|
||||
@@ -4255,6 +4263,8 @@ static int __init init_sd(void)
|
||||
goto err_out_class;
|
||||
}
|
||||
|
||||
@ -1738,6 +1739,19 @@ index 4b93c0bd1d4b..b98906237306 100644
|
||||
/* Lock the device, then check to see if we were
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/fs/xfs/libxfs/xfs_ialloc_btree.c b/fs/xfs/libxfs/xfs_ialloc_btree.c
|
||||
index 42e9fd47f6c7..ffef1c75dd57 100644
|
||||
--- a/fs/xfs/libxfs/xfs_ialloc_btree.c
|
||||
+++ b/fs/xfs/libxfs/xfs_ialloc_btree.c
|
||||
@@ -749,7 +749,7 @@ xfs_finobt_count_blocks(
|
||||
if (error)
|
||||
return error;
|
||||
|
||||
- cur = xfs_inobt_init_cursor(pag, tp, agbp);
|
||||
+ cur = xfs_finobt_init_cursor(pag, tp, agbp);
|
||||
error = xfs_btree_count_blocks(cur, tree_blocks);
|
||||
xfs_btree_del_cursor(cur, error);
|
||||
xfs_trans_brelse(tp, agbp);
|
||||
diff --git a/include/linux/crypto.h b/include/linux/crypto.h
|
||||
index b164da5e129e..59021b8609a7 100644
|
||||
--- a/include/linux/crypto.h
|
||||
|
6
sources
6
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
|
||||
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
|
||||
SHA512 (linux-6.10.7.tar.xz) = 750c43a4a7fbbbf1180710e504de1bb5487a9afffa58e4d4b7694fc91ef17b70b39a659fa39874ea86d67abb4a839ba172a014c7727555927f48ccd8c19be8d7
|
||||
SHA512 (kernel-abi-stablelists-6.10.7.tar.xz) = ab1a46b72c77ed82ea86cf85b743658fba97469caad5baf955eaf0c55911efce15717f95b6643a93f4bd5c542c5f90581af58ea9f204d6b32b91169db2358e77
|
||||
SHA512 (kernel-kabi-dw-6.10.7.tar.xz) = 9d8b5c06988fdedb08279266a9597f6124907626e120e205eb8352e6fbdc0562443acb9ff6089cd95d1c2a50e184da84f5d35a93a8ba3945773d708f7e841173
|
||||
SHA512 (linux-6.10.8.tar.xz) = 6fe33537283a3c4028413713ba17ac1ba34b64ab919ebbaedc40fb212132e6ca701c7759051279e49983b756a6e2ddcd60c0561908f296e5dddec43ab8f5cb10
|
||||
SHA512 (kernel-abi-stablelists-6.10.8.tar.xz) = bd144182c26a062e9395bc3d392f58270e8307067c55d5f9ee7fd03f2915a3db6850a9cd6567c6ee19d8ae0c93b1ee98e69f9fa4c35199a5c26dc62517045de2
|
||||
SHA512 (kernel-kabi-dw-6.10.8.tar.xz) = 2a5e0abfd0ac16a93b9b235e10c430c88c970a80b3d48f20dfbd31b744ad561f9892b8940b06992fa0e5a0bc4de119b612e3e48acf75794b436b68c4877e633e
|
||||
|
Loading…
x
Reference in New Issue
Block a user