kernel-5.18.0-0.rc6.47
* Mon May 09 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc6.46] - redhat/self-test: Add test to verify Makefile declarations. (Prarit Bhargava) - redhat/Makefile: Add RHTEST (Prarit Bhargava) Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
57c6557291
commit
7ef390b6c4
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 44
|
RHEL_RELEASE = 47
|
||||||
|
|
||||||
#
|
#
|
||||||
# ZSTREAM
|
# ZSTREAM
|
||||||
|
@ -2,6 +2,8 @@
|
|||||||
|
|
||||||
# Adjusts the configuration options to build the variants correctly
|
# Adjusts the configuration options to build the variants correctly
|
||||||
|
|
||||||
|
test -n "$RHTEST" && exit 0
|
||||||
|
|
||||||
DEBUGBUILDSENABLED=$1
|
DEBUGBUILDSENABLED=$1
|
||||||
if [ -z "$DEBUGBUILDSENABLED" ]; then
|
if [ -z "$DEBUGBUILDSENABLED" ]; then
|
||||||
exit 1
|
exit 1
|
||||||
|
16
kernel.spec
16
kernel.spec
@ -85,7 +85,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||||
# to build the base kernel using the debug configuration. (Specifying
|
# to build the base kernel using the debug configuration. (Specifying
|
||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -129,13 +129,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define specversion 5.18.0
|
%define specversion 5.18.0
|
||||||
%define patchversion 5.18
|
%define patchversion 5.18
|
||||||
%define pkgrelease 0.rc5.20220506gitfe27d189e3f42e3.44
|
%define pkgrelease 0.rc6.47
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 18
|
%define patchlevel 18
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc5.20220506gitfe27d189e3f42e3.44%{?buildid}%{?dist}
|
%define specrelease 0.rc6.47%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -690,7 +690,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.18-rc5-115-gfe27d189e3f42e3.tar.xz
|
Source0: linux-5.18-rc6.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1382,8 +1382,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.18-rc5-115-gfe27d189e3f42e3 -c
|
%setup -q -n kernel-5.18-rc6 -c
|
||||||
mv linux-5.18-rc5-115-gfe27d189e3f42e3 linux-%{KVERREL}
|
mv linux-5.18-rc6 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -3025,6 +3025,10 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 09 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc6.46]
|
||||||
|
- redhat/self-test: Add test to verify Makefile declarations. (Prarit Bhargava)
|
||||||
|
- redhat/Makefile: Add RHTEST (Prarit Bhargava)
|
||||||
|
|
||||||
* Fri May 06 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc5.fe27d189e3f42e3.43]
|
* Fri May 06 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc5.fe27d189e3f42e3.43]
|
||||||
- redhat: shellcheck cleanup (Prarit Bhargava)
|
- redhat: shellcheck cleanup (Prarit Bhargava)
|
||||||
- redhat/self-test/data: Cleanup data (Prarit Bhargava)
|
- redhat/self-test/data: Cleanup data (Prarit Bhargava)
|
||||||
|
@ -124,7 +124,7 @@ index 000000000000..effb81d04bfd
|
|||||||
+
|
+
|
||||||
+endmenu
|
+endmenu
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 9a820c525b86..fbcfb1dc4578 100644
|
index 2284d1ca2503..c8012c1fbc32 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
|
@ -6,6 +6,8 @@
|
|||||||
# Globally disable suggestion of appending '|| exit' or '|| return' to cd/pushd/popd commands
|
# Globally disable suggestion of appending '|| exit' or '|| return' to cd/pushd/popd commands
|
||||||
# shellcheck disable=SC2164
|
# shellcheck disable=SC2164
|
||||||
|
|
||||||
|
test -n "$RHTEST" && exit 0
|
||||||
|
|
||||||
usage()
|
usage()
|
||||||
{
|
{
|
||||||
# alphabetical order please
|
# alphabetical order please
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.18-rc5-115-gfe27d189e3f42e3.tar.xz) = 4bbaaa8573f37489186f4282b1bdf3278c6a07d50fc37b26a06a1dd51787815f96fa76ea2ad6861b5a0a8af2185c15f2eb042bb198e66ec1afe21c24425bf3df
|
SHA512 (linux-5.18-rc6.tar.xz) = 48744c297f1978822f19555034cd479f6deccd4c5d2094ae713bbbec67bd3b773c47f85ee7c91c6d0d3ef4218db626da21a648ec296584bc33a01e391371e730
|
||||||
SHA512 (kernel-abi-stablelists-5.18.0-0.rc5.20220506gitfe27d189e3f42e3.44.tar.bz2) = caf1146458a06d7218d1224bf9470845d5f02f5d89b033ccc37f36d067a1bfac5debb8a29737003bc051f308f7a2464ec26cb78f2e0d3f25321cec2d10517764
|
SHA512 (kernel-abi-stablelists-5.18.0-0.rc6.47.tar.bz2) = 9d5a3da56bf4c3d2728edaa5f58c89c5511b368ddb9c29d16a7e3434355ce43e9636c629d4fdd528c31b549f0b36f22bcd9c5506f8c2420707ed380e52671c2c
|
||||||
SHA512 (kernel-kabi-dw-5.18.0-0.rc5.20220506gitfe27d189e3f42e3.44.tar.bz2) = 20b7fe864ccb9d8551e198ba64da02dbeeb82e321ee86d8f64bb973fe5d3d35be6c5aa36dbce18b3235b84897b4913b5641d9e9e3be416af26761b22bf2d0853
|
SHA512 (kernel-kabi-dw-5.18.0-0.rc6.47.tar.bz2) = fc9f35049e24964d671b85f2aa60131c0aebcfb31f0ef70112b19570d283c3730f1ca6c575f7d10b42cbcf45cde7f2995ff4e1a27aa7202d3f926ae01909b19b
|
||||||
|
Loading…
Reference in New Issue
Block a user