Linux v4.20-rc1-145-gaa4330e15c26
This commit is contained in:
parent
86eb60348e
commit
7b5b8ca4e4
@ -1,32 +0,0 @@
|
||||
From e94355905793eef85567e723feb43b72c98e8a83 Mon Sep 17 00:00:00 2001
|
||||
From: "Justin M. Forbes" <jforbes@fedoraproject.org>
|
||||
Date: Wed, 31 Oct 2018 11:56:22 -0500
|
||||
Subject: [PATCH] s390/mm: Fix ERROR: "__node_distance" undefined!
|
||||
|
||||
Fixes:
|
||||
ERROR: "__node_distance" [drivers/nvme/host/nvme-core.ko] undefined!
|
||||
make[1]: *** [scripts/Makefile.modpost:92: __modpost] Error 1
|
||||
make: *** [Makefile:1275: modules] Error 2
|
||||
+ exit 1
|
||||
|
||||
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
---
|
||||
arch/s390/numa/numa.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/s390/numa/numa.c b/arch/s390/numa/numa.c
|
||||
index 5bd374491f94..bef306e45da8 100644
|
||||
--- a/arch/s390/numa/numa.c
|
||||
+++ b/arch/s390/numa/numa.c
|
||||
@@ -55,6 +55,8 @@ int __node_distance(int a, int b)
|
||||
return mode->distance ? mode->distance(a, b) : 0;
|
||||
}
|
||||
|
||||
+EXPORT_SYMBOL(__node_distance);
|
||||
+
|
||||
int numa_debug_enabled;
|
||||
|
||||
/*
|
||||
--
|
||||
2.19.1
|
||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
b00d209241ff7ac336543f92ea764b9d6b03032a
|
||||
aa4330e15c26c5ef8dd184f515c0655db8c6df3a
|
||||
|
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%global rcrev 1
|
||||
# The git snapshot level
|
||||
%define gitrev 3
|
||||
%define gitrev 4
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -600,9 +600,6 @@ Patch501: Fix-for-module-sig-verification.patch
|
||||
# rhbz 1431375
|
||||
Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
|
||||
|
||||
# Fix build on s390
|
||||
Patch503: 0001-s390-mm-Fix-ERROR-__node_distance-undefined.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1875,6 +1872,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Nov 09 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.20.0-0.rc1.git4.1
|
||||
- Linux v4.20-rc1-145-gaa4330e15c26
|
||||
|
||||
* Thu Nov 8 2018 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Initial Qualcomm SD845 enablement
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-4.19.tar.xz) = ab67cc746b375a8b135e8b23e35e1d6787930d19b3c26b2679787d62951cbdbc3bb66f8ededeb9b890e5008b2459397f9018f1a6772fdef67780b06a4cb9f6f4
|
||||
SHA512 (patch-4.20-rc1.xz) = 60b0247b40be26429ce319cd6b27b67ca61afc4663ebe61f172349cc3e42ce6915427527693a519fc4afce43117c83513292e7dfa08b2d522baca3489cebf80a
|
||||
SHA512 (patch-4.20-rc1-git3.xz) = bf6aeb25167627679f459c5d85067593df193acfd0f822984bb37dcf50664b3aa18a0b715341df49e7d8ec952e1de14868483343951b6e193c1a417413e95b30
|
||||
SHA512 (patch-4.20-rc1-git4.xz) = c5a3c824786a01779720249209747e79880cf15f1a4df1c201a2c41723d455591a220268ceaa9e50ab0e6795387356a851e04f3ffe1f0bfb4d3cbca54aed47a2
|
||||
|
Loading…
Reference in New Issue
Block a user