kernel-6.3.4-201

* Sat May 27 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.4-1]
- Bump rhelver for build with xfs fix (Justin M. Forbes)
- xfs: fix livelock in delayed allocation at ENOSPC (Dave Chinner)
- Turn off some debug options found to impact performance (Justin M. Forbes)
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-05-27 09:26:07 -05:00
parent af549165ba
commit 7acde4384c
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
17 changed files with 69 additions and 48 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 0
RHEL_RELEASE = 1
#
# RHEL_REBASE_NUM

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/0e410712ded4b03690a7f8216433dd4a4f3a5fe7
0e410712ded4b03690a7f8216433dd4a4f3a5fe7 xfs: fix livelock in delayed allocation at ENOSPC
"https://gitlab.com/cki-project/kernel-ark/-/commit"/6a5320b108d9739ed27db75e0a1aaae72ea236c1
6a5320b108d9739ed27db75e0a1aaae72ea236c1 [PATCH] ALSA: hda/realtek: Add quirk for ThinkPad P1 Gen 6

View File

@ -1605,7 +1605,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_EFI is not set
# CONFIG_DEBUG_ENTRY is not set
@ -1665,7 +1665,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
CONFIG_DEBUG_SECTION_MISMATCH=y
@ -1756,7 +1756,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1605,7 +1605,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_EFI is not set
# CONFIG_DEBUG_ENTRY is not set
@ -1647,7 +1647,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1657,7 +1657,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
CONFIG_DEBUG_SECTION_MISMATCH=y
@ -1747,7 +1747,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1562,7 +1562,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
@ -1622,7 +1622,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1716,7 +1716,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1562,7 +1562,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
@ -1604,7 +1604,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1614,7 +1614,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1708,7 +1708,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1531,7 +1531,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
@ -1591,7 +1591,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1685,7 +1685,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1531,7 +1531,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
@ -1573,7 +1573,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1583,7 +1583,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1677,7 +1677,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1190,7 +1190,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
@ -1250,7 +1250,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1330,7 +1330,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1188,7 +1188,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
@ -1230,7 +1230,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1240,7 +1240,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1319,7 +1319,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1201,7 +1201,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
CONFIG_DEBUG_ENTRY=y
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
@ -1260,7 +1260,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1337,7 +1337,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1199,7 +1199,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
@ -1240,7 +1240,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1250,7 +1250,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1326,7 +1326,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1300,7 +1300,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_DEBUG_CREDENTIALS=y
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
@ -1361,7 +1361,7 @@ CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
CONFIG_DEBUG_PREEMPT=y
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_RWSEMS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1455,7 +1455,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -1298,7 +1298,7 @@ CONFIG_DE2104X=m
CONFIG_DEBUG_BOOT_PARAMS=y
# CONFIG_DEBUG_CGROUP_REF is not set
# CONFIG_DEBUG_CREDENTIALS is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_ENTRY is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
@ -1341,7 +1341,7 @@ CONFIG_DEBUG_LIST=y
# CONFIG_DEBUG_NET is not set
# CONFIG_DEBUG_NMI_SELFTEST is not set
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=0
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_PAGEALLOC is not set
@ -1351,7 +1351,7 @@ CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_PREEMPT is not set
CONFIG_DEBUG_RODATA_TEST=y
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_RWSEMS is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
@ -1444,7 +1444,7 @@ CONFIG_DM_CACHE=m
CONFIG_DM_CACHE_SMQ=m
CONFIG_DM_CLONE=m
CONFIG_DM_CRYPT=m
CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING=y
# CONFIG_DM_DEBUG_BLOCK_MANAGER_LOCKING is not set
# CONFIG_DM_DEBUG_BLOCK_STACK_TRACING is not set
CONFIG_DM_DEBUG=y
CONFIG_DM_DELAY=m

View File

@ -145,13 +145,13 @@ Summary: The Linux kernel
%define specrpmversion 6.3.4
%define specversion 6.3.4
%define patchversion 6.3
%define pkgrelease 200
%define pkgrelease 201
%define kversion 6
%define tarfile_release 6.3.4
# This is needed to do merge window version magic
%define patchlevel 3
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 200%{?buildid}%{?dist}
%define specrelease 201%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.3.4
@ -3406,6 +3406,11 @@ fi
#
#
%changelog
* Sat May 27 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.4-1]
- Bump rhelver for build with xfs fix (Justin M. Forbes)
- xfs: fix livelock in delayed allocation at ENOSPC (Dave Chinner)
- Turn off some debug options found to impact performance (Justin M. Forbes)
* Thu May 25 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.4-0]
- Revert "Turn off DEBUG_VM for non debug Fedora kernels" (Justin M. Forbes)
- Turn off DEBUG_VM for non debug Fedora kernels (Justin M. Forbes)

View File

@ -23,6 +23,7 @@
drivers/nvme/host/nvme.h | 4 +
drivers/pci/quirks.c | 24 ++++
drivers/usb/core/hub.c | 7 ++
fs/xfs/libxfs/xfs_bmap.c | 1 -
fs/xfs/xfs_buf_item_recover.c | 10 ++
include/linux/efi.h | 22 ++--
include/linux/lsm_hook_defs.h | 2 +
@ -36,7 +37,7 @@
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
sound/pci/hda/patch_realtek.c | 2 +
38 files changed, 502 insertions(+), 186 deletions(-)
39 files changed, 502 insertions(+), 187 deletions(-)
diff --git a/Makefile b/Makefile
index 3c5b60669018..154ee11110d4 100644
@ -1131,6 +1132,18 @@ index 97a0f8faea6e..d837548d2024 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
index 34de6e6898c4..3ce43068daa1 100644
--- a/fs/xfs/libxfs/xfs_bmap.c
+++ b/fs/xfs/libxfs/xfs_bmap.c
@@ -3505,7 +3505,6 @@ xfs_bmap_btalloc_at_eof(
* original non-aligned state so the caller can proceed on allocation
* failure as if this function was never called.
*/
- args->fsbno = ap->blkno;
args->alignment = 1;
return 0;
}
diff --git a/fs/xfs/xfs_buf_item_recover.c b/fs/xfs/xfs_buf_item_recover.c
index ffa94102094d..43167f543afc 100644
--- a/fs/xfs/xfs_buf_item_recover.c

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.3.4.tar.xz) = 5bd6379d647b0c578523988015091684f6196989393d3996a02dde14ba0cd6c54ec9d243f0d6161692f8af541efe7a642db248e5621dda51ccaeb0f788e8dc36
SHA512 (kernel-abi-stablelists-6.3.4.tar.bz2) = eae1c9d7a8d7e1b283bcaa3a06bafc956293c6d31073e89240ce0428e75d8e46366727cc9ad44e62d38cf9d6a1968be1695a81f84a6d083697c87aa1a823805a
SHA512 (kernel-kabi-dw-6.3.4.tar.bz2) = f3431f6115c2b7b0741c6109ae1116d4456d1711adfef74240a51bad0c6d690f0b6988d5aa630c0699ada90f551820842c7e57681c676d09ad583da554d679c6
SHA512 (kernel-abi-stablelists-6.3.4.tar.bz2) = 5b297e8817a2f9ccb388e4c07f3527dcc92a30f54237ced32ddd7ef86a61a963d672f36e87fef65dda6f9a39f20a890bc3a31d97658d6b085193274420f38034
SHA512 (kernel-kabi-dw-6.3.4.tar.bz2) = 8d00b14e3474a52a97cb7a2a01ca71ee7fb3eacdd10e6d5495616f2c427989088b87d0892d1c19ae05c1f46e5780f37553d27767bb8f0c6130b02f571e84d9ce