kernel-5.14.0-0.rc5.42
* Mon Aug 09 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.42] - pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
f1d22013a4
commit
7a99804b31
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 37
|
||||
RHEL_RELEASE = 42
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/c9d32e7b2e03eacf36f7a05ad68ca92dada6fd1f
|
||||
c9d32e7b2e03eacf36f7a05ad68ca92dada6fd1f pinctrl: tigerlake: Fix GPIO mapping for newer version of software
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/42130f93b60c5e750ed179c98da57046ea298c54
|
||||
42130f93b60c5e750ed179c98da57046ea298c54 Revert "Drop that for now"
|
||||
|
||||
|
17
kernel.spec
17
kernel.spec
@ -78,9 +78,9 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
%global distro_build 0.rc4.20210805git251a1524293d.37
|
||||
%global distro_build 0.rc5.42
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -124,13 +124,13 @@ Summary: The Linux kernel
|
||||
%define kversion 5.14
|
||||
|
||||
%define rpmversion 5.14.0
|
||||
%define pkgrelease 0.rc4.20210805git251a1524293d.37
|
||||
%define pkgrelease 0.rc5.42
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 14
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc4.20210805git251a1524293d.37%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc5.42%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -671,7 +671,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.14-rc4-22-g251a1524293d.tar.xz
|
||||
Source0: linux-5.14-rc5.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1357,8 +1357,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.14-rc4-22-g251a1524293d -c
|
||||
mv linux-5.14-rc4-22-g251a1524293d linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.14-rc5 -c
|
||||
mv linux-5.14-rc5 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2952,6 +2952,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.42]
|
||||
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
|
||||
|
||||
* Thu Aug 05 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc4.20210805git251a1524293d.37]
|
||||
- common: Update for CXL (Compute Express Link) configs (Peter Robinson)
|
||||
- redhat: configs: disable CRYPTO_SM modules (Herton R. Krzesinski) [1990040]
|
||||
|
@ -34,6 +34,7 @@
|
||||
drivers/nvme/host/nvme.h | 4 +
|
||||
drivers/pci/pci-driver.c | 29 ++
|
||||
drivers/pci/quirks.c | 24 +
|
||||
drivers/pinctrl/intel/pinctrl-tigerlake.c | 26 +-
|
||||
drivers/scsi/aacraid/linit.c | 2 +
|
||||
drivers/scsi/be2iscsi/be_main.c | 2 +
|
||||
drivers/scsi/hpsa.c | 4 +
|
||||
@ -81,7 +82,7 @@
|
||||
tools/testing/selftests/bpf/progs/linked_maps2.c | 76 ---
|
||||
tools/testing/selftests/bpf/progs/linked_vars1.c | 54 --
|
||||
tools/testing/selftests/bpf/progs/linked_vars2.c | 55 ---
|
||||
83 files changed, 1155 insertions(+), 1492 deletions(-)
|
||||
84 files changed, 1168 insertions(+), 1505 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index bdb22006f713..61a3a4a4730b 100644
|
||||
@ -137,7 +138,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 27a072cffcb9..1aee287a8f9c 100644
|
||||
index eae1314a5b86..a8dcae6b5b85 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -151,7 +152,7 @@ index 27a072cffcb9..1aee287a8f9c 100644
|
||||
# We are using a recursive build, so we need to do a little thinking
|
||||
# to get the ordering right.
|
||||
#
|
||||
@@ -1257,7 +1261,13 @@ define filechk_version.h
|
||||
@@ -1256,7 +1260,13 @@ define filechk_version.h
|
||||
((c) > 255 ? 255 : (c)))'; \
|
||||
echo \#define LINUX_VERSION_MAJOR $(VERSION); \
|
||||
echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \
|
||||
@ -183,7 +184,7 @@ index 2fb7012c3246..47718b4f2f75 100644
|
||||
The VM uses one page of physical memory for each page table.
|
||||
For systems with a lot of processes, this can use a lot of
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index b5b13a932561..37af638217aa 100644
|
||||
index fdcd54d39c1e..365b74034428 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -914,7 +914,7 @@ endchoice
|
||||
@ -1507,6 +1508,56 @@ index 6d74386eadc2..2333c1e4ae05 100644
|
||||
/*
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/pinctrl/intel/pinctrl-tigerlake.c b/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
index 3e4ef2b87526..0bcd19597e4a 100644
|
||||
--- a/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
+++ b/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
@@ -701,32 +701,32 @@ static const struct pinctrl_pin_desc tglh_pins[] = {
|
||||
|
||||
static const struct intel_padgroup tglh_community0_gpps[] = {
|
||||
TGL_GPP(0, 0, 24, 0), /* GPP_A */
|
||||
- TGL_GPP(1, 25, 44, 128), /* GPP_R */
|
||||
- TGL_GPP(2, 45, 70, 32), /* GPP_B */
|
||||
- TGL_GPP(3, 71, 78, INTEL_GPIO_BASE_NOMAP), /* vGPIO_0 */
|
||||
+ TGL_GPP(1, 25, 44, 32), /* GPP_R */
|
||||
+ TGL_GPP(2, 45, 70, 64), /* GPP_B */
|
||||
+ TGL_GPP(3, 71, 78, 96), /* vGPIO_0 */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community1_gpps[] = {
|
||||
- TGL_GPP(0, 79, 104, 96), /* GPP_D */
|
||||
- TGL_GPP(1, 105, 128, 64), /* GPP_C */
|
||||
- TGL_GPP(2, 129, 136, 160), /* GPP_S */
|
||||
- TGL_GPP(3, 137, 153, 192), /* GPP_G */
|
||||
- TGL_GPP(4, 154, 180, 224), /* vGPIO */
|
||||
+ TGL_GPP(0, 79, 104, 128), /* GPP_D */
|
||||
+ TGL_GPP(1, 105, 128, 160), /* GPP_C */
|
||||
+ TGL_GPP(2, 129, 136, 192), /* GPP_S */
|
||||
+ TGL_GPP(3, 137, 153, 224), /* GPP_G */
|
||||
+ TGL_GPP(4, 154, 180, 256), /* vGPIO */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community3_gpps[] = {
|
||||
- TGL_GPP(0, 181, 193, 256), /* GPP_E */
|
||||
- TGL_GPP(1, 194, 217, 288), /* GPP_F */
|
||||
+ TGL_GPP(0, 181, 193, 288), /* GPP_E */
|
||||
+ TGL_GPP(1, 194, 217, 320), /* GPP_F */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community4_gpps[] = {
|
||||
- TGL_GPP(0, 218, 241, 320), /* GPP_H */
|
||||
+ TGL_GPP(0, 218, 241, 352), /* GPP_H */
|
||||
TGL_GPP(1, 242, 251, 384), /* GPP_J */
|
||||
- TGL_GPP(2, 252, 266, 352), /* GPP_K */
|
||||
+ TGL_GPP(2, 252, 266, 416), /* GPP_K */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community5_gpps[] = {
|
||||
- TGL_GPP(0, 267, 281, 416), /* GPP_I */
|
||||
+ TGL_GPP(0, 267, 281, 448), /* GPP_I */
|
||||
TGL_GPP(1, 282, 290, INTEL_GPIO_BASE_NOMAP), /* JTAG */
|
||||
};
|
||||
|
||||
diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
|
||||
index 3168915adaa7..71b48e29b708 100644
|
||||
--- a/drivers/scsi/aacraid/linit.c
|
||||
|
6
sources
6
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (kernel-abi-whitelists-5.14.0-0.rc0.20210707git77d34a4683b0.12.tar.bz2) = 411f2a75d47633c61eb416d270a293d6965cf69b05fdada93480765da88185cea0378820f53b66fd405549374a5094868530f2451d1d2e6eda970afdc2d4bbb8
|
||||
SHA512 (linux-5.14-rc4-22-g251a1524293d.tar.xz) = 044bc0ad508f2f27c327b74061e1155ace5b190845417fc7c75676649c74ae8481d7b190122cf04c6c84c5df95548dbb22fee035827e87746b158553109bc214
|
||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc4.20210805git251a1524293d.37.tar.bz2) = 2b11caa911c84f82a6c70e9169f12e61b58451516aa260f030d5943ab6f17c3ae5bca7b8677d739d3a2190be33b1e39249985f3db1304342ae346a4dbd23cd00
|
||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc4.20210805git251a1524293d.37.tar.bz2) = 3193824dc4eb513b18e8e28538992acf9be3126b5dc62796cad3e6e554c37e4245131f0cab85cad09e9f7b2edb398d660294c74eaa4a0af4db52f908f77df5a8
|
||||
SHA512 (linux-5.14-rc5.tar.xz) = ad578a0f4454e4e9e5838fb62f7364b08922c92e99c903b683680510eea4a6916b588220d965057425e312bc919c2ff7f6f7b79564e9bef79dd97d9a6759b3ee
|
||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc5.42.tar.bz2) = b40af9144ca0d9c9752073c430e306c7335ebc551bcb2f70598306cd9a7a088f74115a71047a5ffd48112a4eb9d23053d0378c921026b90fd1f3b8f08629214c
|
||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc5.42.tar.bz2) = 03a827c1484ed6df7712223d3d500bdd33c089eee9844687ef7d8e56da7b063fcfaed151d0b12fffdb0b1ac74f7e02fb97822a4f40ba4a5b782c648de33325b9
|
||||
|
Loading…
Reference in New Issue
Block a user