Remove warnings about empty IPI masks.

Conflicts:
	kernel.spec
This commit is contained in:
Dave Jones 2013-01-23 10:54:21 -05:00
parent d483733654
commit 79cfaf9c9a
2 changed files with 18 additions and 0 deletions

View File

@ -685,6 +685,7 @@ Patch470: die-floppy-die.patch
Patch510: linux-2.6-silence-noise.patch
Patch520: quite-apm.patch
Patch530: linux-2.6-silence-fbcon-logo.patch
Patch540: silence-empty-ipi-mask-warning.patch
Patch700: linux-2.6-e1000-ich9-montevina.patch
@ -1412,6 +1413,9 @@ ApplyPatch linux-2.6-silence-noise.patch
# Make fbcon not show the penguins with 'quiet'
ApplyPatch linux-2.6-silence-fbcon-logo.patch
# no-one cares about these warnings.
ApplyPatch silence-empty-ipi-mask-warning.patch
# Changes to upstream defaults.
@ -2358,6 +2362,9 @@ fi
# ||----w |
# || ||
%changelog
* Wed Jan 23 2013 Dave Jones <davej@redhat.com>
- Remove warnings about empty IPI masks.
* Tue Jan 22 2013 Justin M. Forbes <jforbes@redhat.com> - 3.7.4-203
- Add i915 bugfix from airlied

View File

@ -0,0 +1,11 @@
--- linux-3.6.noarch/arch/x86/kernel/apic/ipi.c~ 2013-01-23 10:48:14.716069615 -0500
+++ linux-3.6.noarch/arch/x86/kernel/apic/ipi.c 2013-01-23 10:48:26.217046545 -0500
@@ -106,7 +106,7 @@ void default_send_IPI_mask_logical(const
unsigned long mask = cpumask_bits(cpumask)[0];
unsigned long flags;
- if (WARN_ONCE(!mask, "empty IPI mask"))
+ if (!mask)
return;
local_irq_save(flags);