Linux v3.12-10928-g527d151
- Drop ACPI blacklist year options and patch (removed with upstream commit 4c47cb197e13 )
This commit is contained in:
parent
806c8da830
commit
772b620d71
@ -36,7 +36,6 @@ https://dev.openwrt.org/browser/trunk/package/mac80211/patches/552-ath9k_rx_dma_
|
|||||||
Turn into CONFIG_ options and upstream ?
|
Turn into CONFIG_ options and upstream ?
|
||||||
|
|
||||||
* input-kill-stupid-messages.patch
|
* input-kill-stupid-messages.patch
|
||||||
* silence-acpi-blacklist.patch
|
|
||||||
* silence-fbcon-logo.patch
|
* silence-fbcon-logo.patch
|
||||||
* silence-noise.patch
|
* silence-noise.patch
|
||||||
Fedora local 'hush' patches. (TODO: push more upstream)
|
Fedora local 'hush' patches. (TODO: push more upstream)
|
||||||
|
@ -371,6 +371,7 @@ CONFIG_RCU_FANOUT_LEAF=16
|
|||||||
# CONFIG_OF_VIDEOMODE is not set
|
# CONFIG_OF_VIDEOMODE is not set
|
||||||
|
|
||||||
# CONFIG_POWERNV_MSI is not set
|
# CONFIG_POWERNV_MSI is not set
|
||||||
|
# CONFIG_CPU_LITTLE_ENDIAN is not set
|
||||||
|
|
||||||
CONFIG_POWER_RESET_GPIO=y
|
CONFIG_POWER_RESET_GPIO=y
|
||||||
CONFIG_FB_SSD1307=m
|
CONFIG_FB_SSD1307=m
|
||||||
|
@ -73,8 +73,6 @@ CONFIG_APM_CPU_IDLE=y
|
|||||||
# CONFIG_APM_DISPLAY_BLANK is not set
|
# CONFIG_APM_DISPLAY_BLANK is not set
|
||||||
# CONFIG_APM_ALLOW_INTS is not set
|
# CONFIG_APM_ALLOW_INTS is not set
|
||||||
|
|
||||||
CONFIG_ACPI_BLACKLIST_YEAR=1999
|
|
||||||
|
|
||||||
|
|
||||||
# CONFIG_X86_POWERNOW_K6 is not set
|
# CONFIG_X86_POWERNOW_K6 is not set
|
||||||
CONFIG_X86_POWERNOW_K7=y
|
CONFIG_X86_POWERNOW_K7=y
|
||||||
|
@ -38,7 +38,6 @@ CONFIG_MEM_SOFT_DIRTY=y
|
|||||||
|
|
||||||
CONFIG_KEXEC_JUMP=y
|
CONFIG_KEXEC_JUMP=y
|
||||||
|
|
||||||
CONFIG_ACPI_BLACKLIST_YEAR=0
|
|
||||||
CONFIG_ACPI_HOTPLUG_MEMORY=y
|
CONFIG_ACPI_HOTPLUG_MEMORY=y
|
||||||
|
|
||||||
# CONFIG_INTEL_SCU_IPC is not set
|
# CONFIG_INTEL_SCU_IPC is not set
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 9
|
%define gitrev 10
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -656,8 +656,6 @@ Patch1825: drm-i915-dp-stfu.patch
|
|||||||
Patch1826: drm-i915-hush-check-crtc-state.patch
|
Patch1826: drm-i915-hush-check-crtc-state.patch
|
||||||
|
|
||||||
# Quiet boot fixes
|
# Quiet boot fixes
|
||||||
# silence the ACPI blacklist code
|
|
||||||
Patch2802: silence-acpi-blacklist.patch
|
|
||||||
|
|
||||||
# fs fixes
|
# fs fixes
|
||||||
|
|
||||||
@ -1363,9 +1361,6 @@ ApplyPatch drm-i915-hush-check-crtc-state.patch
|
|||||||
|
|
||||||
# Radeon DRM
|
# Radeon DRM
|
||||||
|
|
||||||
# silence the ACPI blacklist code
|
|
||||||
ApplyPatch silence-acpi-blacklist.patch
|
|
||||||
|
|
||||||
# Patches headed upstream
|
# Patches headed upstream
|
||||||
ApplyPatch fs-proc-devtree-remove_proc_entry.patch
|
ApplyPatch fs-proc-devtree-remove_proc_entry.patch
|
||||||
|
|
||||||
@ -2215,6 +2210,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 21 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc0.git10.1
|
||||||
|
- Linux v3.12-10928-g527d151
|
||||||
|
- Drop ACPI blacklist year options and patch (removed with upstream commit 4c47cb197e13 )
|
||||||
|
|
||||||
* Wed Nov 20 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc0.git9.1
|
* Wed Nov 20 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc0.git9.1
|
||||||
- Linux v3.12-10710-gb4789b8
|
- Linux v3.12-10710-gb4789b8
|
||||||
|
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
diff -up linux-2.6.26.noarch/drivers/acpi/blacklist.c.jx linux-2.6.26.noarch/drivers/acpi/blacklist.c
|
|
||||||
--- linux-2.6.26.noarch/drivers/acpi/blacklist.c.jx 2008-07-13 17:51:29.000000000 -0400
|
|
||||||
+++ linux-2.6.26.noarch/drivers/acpi/blacklist.c 2008-08-12 14:21:39.000000000 -0400
|
|
||||||
@@ -81,18 +81,18 @@ static int __init blacklist_by_year(void
|
|
||||||
|
|
||||||
/* Doesn't exist? Likely an old system */
|
|
||||||
if (!dmi_get_date(DMI_BIOS_DATE, &year, NULL, NULL)) {
|
|
||||||
- printk(KERN_ERR PREFIX "no DMI BIOS year, "
|
|
||||||
+ printk(KERN_INFO PREFIX "no DMI BIOS year, "
|
|
||||||
"acpi=force is required to enable ACPI\n" );
|
|
||||||
return 1;
|
|
||||||
}
|
|
||||||
/* 0? Likely a buggy new BIOS */
|
|
||||||
if (year == 0) {
|
|
||||||
- printk(KERN_ERR PREFIX "DMI BIOS year==0, "
|
|
||||||
+ printk(KERN_INFO PREFIX "DMI BIOS year==0, "
|
|
||||||
"assuming ACPI-capable machine\n" );
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
if (year < CONFIG_ACPI_BLACKLIST_YEAR) {
|
|
||||||
- printk(KERN_ERR PREFIX "BIOS age (%d) fails cutoff (%d), "
|
|
||||||
+ printk(KERN_INFO PREFIX "BIOS age (%d) fails cutoff (%d), "
|
|
||||||
"acpi=force is required to enable ACPI\n",
|
|
||||||
year, CONFIG_ACPI_BLACKLIST_YEAR);
|
|
||||||
return 1;
|
|
Loading…
Reference in New Issue
Block a user