kernel-5.15-0.rc2.20210923git58e2cf5d7946.21
* Thu Sep 23 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc2.20210923git58e2cf5d7946.21] - redhat/configs: enable CONFIG_SQUASHFS_ZSTD which is already enabled in Fedora 34 (Tao Liu) [1998953] Resolves: rhbz#1998953 Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
10db88dce3
commit
7494012afa
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 21
|
||||
RHEL_RELEASE = 25
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
14
kernel.spec
14
kernel.spec
@ -78,9 +78,9 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
%global distro_build 0.rc2.20210923git58e2cf5d7946.21
|
||||
%global distro_build 0.rc3.25
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -125,13 +125,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.15.0
|
||||
%define patchversion 5.15
|
||||
%define pkgrelease 0.rc2.20210923git58e2cf5d7946.21
|
||||
%define pkgrelease 0.rc3.25
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 15
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc2.20210923git58e2cf5d7946.21%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc3.25%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -672,7 +672,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.15-rc2-51-g58e2cf5d7946.tar.xz
|
||||
Source0: linux-5.15-rc3.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1358,8 +1358,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.15-rc2-51-g58e2cf5d7946 -c
|
||||
mv linux-5.15-rc2-51-g58e2cf5d7946 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.15-rc3 -c
|
||||
mv linux-5.15-rc3 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
|
@ -141,7 +141,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5e7c1d854441..f2d34de5aa2b 100644
|
||||
index 437ccc66a1c2..22750d1ec561 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -232,7 +232,7 @@ index 2b5f001ff4a6..dae8c252bc2b 100644
|
||||
op-sink-microwatt = <1000000>;
|
||||
power-role = "dual";
|
||||
diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
|
||||
index 1c9c2f7a1c04..64a01859d685 100644
|
||||
index f3851724fe35..ef69eeab6f2a 100644
|
||||
--- a/arch/arm64/kernel/acpi.c
|
||||
+++ b/arch/arm64/kernel/acpi.c
|
||||
@@ -40,7 +40,11 @@ int acpi_pci_disabled = 1; /* skip ACPI PCI scan and IRQ initialization */
|
||||
@ -307,7 +307,7 @@ index 0f8885949e8c..a79e57a77076 100644
|
||||
setup_force_cpu_cap(X86_FEATURE_CPUID);
|
||||
cpu_parse_early_param();
|
||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||
index 79f164141116..3309c4c30e7b 100644
|
||||
index 40ed44ead063..544a885fa9a9 100644
|
||||
--- a/arch/x86/kernel/setup.c
|
||||
+++ b/arch/x86/kernel/setup.c
|
||||
@@ -20,6 +20,7 @@
|
||||
@ -377,7 +377,7 @@ index 79f164141116..3309c4c30e7b 100644
|
||||
/*
|
||||
* Dump out kernel offset information on panic.
|
||||
*/
|
||||
@@ -927,6 +973,13 @@ void __init setup_arch(char **cmdline_p)
|
||||
@@ -929,6 +975,13 @@ void __init setup_arch(char **cmdline_p)
|
||||
if (efi_enabled(EFI_BOOT))
|
||||
efi_init();
|
||||
|
||||
@ -391,7 +391,7 @@ index 79f164141116..3309c4c30e7b 100644
|
||||
dmi_setup();
|
||||
|
||||
/*
|
||||
@@ -1092,19 +1145,7 @@ void __init setup_arch(char **cmdline_p)
|
||||
@@ -1094,19 +1147,7 @@ void __init setup_arch(char **cmdline_p)
|
||||
/* Allocate bigger log buffer */
|
||||
setup_log_buf(1);
|
||||
|
||||
@ -412,7 +412,7 @@ index 79f164141116..3309c4c30e7b 100644
|
||||
|
||||
reserve_initrd();
|
||||
|
||||
@@ -1217,6 +1258,8 @@ void __init setup_arch(char **cmdline_p)
|
||||
@@ -1219,6 +1260,8 @@ void __init setup_arch(char **cmdline_p)
|
||||
efi_apply_memmap_quirks();
|
||||
#endif
|
||||
|
||||
@ -1573,10 +1573,10 @@ index 75dbe77b0b4b..029ff8576f8e 100644
|
||||
|
||||
err_netlink:
|
||||
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
|
||||
index 6600e138945e..4c601ede2509 100644
|
||||
index e486845d2c7e..c012fc0027f1 100644
|
||||
--- a/drivers/nvme/host/core.c
|
||||
+++ b/drivers/nvme/host/core.c
|
||||
@@ -263,6 +263,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
|
||||
@@ -262,6 +262,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
|
||||
|
||||
static blk_status_t nvme_error_status(u16 status)
|
||||
{
|
||||
@ -1586,7 +1586,7 @@ index 6600e138945e..4c601ede2509 100644
|
||||
switch (status & 0x7ff) {
|
||||
case NVME_SC_SUCCESS:
|
||||
return BLK_STS_OK;
|
||||
@@ -322,6 +325,7 @@ enum nvme_disposition {
|
||||
@@ -321,6 +324,7 @@ enum nvme_disposition {
|
||||
COMPLETE,
|
||||
RETRY,
|
||||
FAILOVER,
|
||||
@ -1594,7 +1594,7 @@ index 6600e138945e..4c601ede2509 100644
|
||||
};
|
||||
|
||||
static inline enum nvme_disposition nvme_decide_disposition(struct request *req)
|
||||
@@ -329,15 +333,16 @@ static inline enum nvme_disposition nvme_decide_disposition(struct request *req)
|
||||
@@ -328,15 +332,16 @@ static inline enum nvme_disposition nvme_decide_disposition(struct request *req)
|
||||
if (likely(nvme_req(req)->status == 0))
|
||||
return COMPLETE;
|
||||
|
||||
@ -1614,7 +1614,7 @@ index 6600e138945e..4c601ede2509 100644
|
||||
} else {
|
||||
if (blk_queue_dying(req->q))
|
||||
return COMPLETE;
|
||||
@@ -359,6 +364,14 @@ static inline void nvme_end_req(struct request *req)
|
||||
@@ -358,6 +363,14 @@ static inline void nvme_end_req(struct request *req)
|
||||
blk_mq_end_request(req, status);
|
||||
}
|
||||
|
||||
@ -1629,7 +1629,7 @@ index 6600e138945e..4c601ede2509 100644
|
||||
void nvme_complete_rq(struct request *req)
|
||||
{
|
||||
trace_nvme_complete_rq(req);
|
||||
@@ -377,6 +390,9 @@ void nvme_complete_rq(struct request *req)
|
||||
@@ -376,6 +389,9 @@ void nvme_complete_rq(struct request *req)
|
||||
case FAILOVER:
|
||||
nvme_failover_req(req);
|
||||
return;
|
||||
@ -1936,7 +1936,7 @@ index 6a90e6e53d09..7e48c3bf701d 100644
|
||||
PCI_ANY_ID, PCI_ANY_ID, },
|
||||
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_G7_FC,
|
||||
diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c b/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||
index e4298bf4a482..c889e7bedbcb 100644
|
||||
index 39d8754e63ac..011561b023a7 100644
|
||||
--- a/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||
+++ b/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||
@@ -149,6 +149,7 @@ megasas_set_ld_removed_by_fw(struct megasas_instance *instance);
|
||||
@ -1968,10 +1968,10 @@ index e4298bf4a482..c889e7bedbcb 100644
|
||||
/* Fusion */
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_PLASMA)},
|
||||
diff --git a/drivers/scsi/mpt3sas/mpt3sas_scsih.c b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
index 2f82b1e629af..e3d5c18788d6 100644
|
||||
index d383d4a03436..9504a0090c71 100644
|
||||
--- a/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
+++ b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
@@ -12548,6 +12548,7 @@ bool scsih_ncq_prio_supp(struct scsi_device *sdev)
|
||||
@@ -12547,6 +12547,7 @@ bool scsih_ncq_prio_supp(struct scsi_device *sdev)
|
||||
* The pci device ids are defined in mpi/mpi2_cnfg.h.
|
||||
*/
|
||||
static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||
@ -1979,7 +1979,7 @@ index 2f82b1e629af..e3d5c18788d6 100644
|
||||
/* Spitfire ~ 2004 */
|
||||
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SAS2004,
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
@@ -12566,6 +12567,7 @@ static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||
@@ -12565,6 +12566,7 @@ static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SAS2116_2,
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
@ -1987,7 +1987,7 @@ index 2f82b1e629af..e3d5c18788d6 100644
|
||||
/* Thunderbolt ~ 2208 */
|
||||
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SAS2208_1,
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
@@ -12590,9 +12592,11 @@ static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||
@@ -12589,9 +12591,11 @@ static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SWITCH_MPI_EP_1,
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.15-rc2-51-g58e2cf5d7946.tar.xz) = 55947b764a697680767a4739d5b4cd9803d92d9dd833aae1d57bdb9975fd2b8005b950920f7d5f53b8fc52252b87238e52b310c10f664c591d365148da594cfe
|
||||
SHA512 (kernel-abi-stablelists-5.15.0-0.rc2.20210923git58e2cf5d7946.21.tar.bz2) = 3f6870585f387ba1040547be61b57919900a5e989bd245a1e7963e670a80f3b4ac7bf135bbc9990d7386ff8c4c66c67ce3a7119036884678c3508571d67765bf
|
||||
SHA512 (kernel-kabi-dw-5.15.0-0.rc2.20210923git58e2cf5d7946.21.tar.bz2) = 108a1a819b1ea3feb6ea2a1d58acbc0da26864ed06c6f285551bac9254428943d5419a26ab2a1d286bdf275e68d5a3c975e5bbe083750da87906f8e192a65fa6
|
||||
SHA512 (linux-5.15-rc3.tar.xz) = 4037fdb0e181be7240aaee5056d56da90c609b48b68528364ee2b68f427fcba4eeaa37452d17c655c3610766459765c3258d84bc72d40c6d4106f384fe4b78c2
|
||||
SHA512 (kernel-abi-stablelists-5.15.0-0.rc3.25.tar.bz2) = d4a1fdf77b08c2826d7a64a3cee04bec94feaeeac218212b4300b0da32cabbef2f0ee460470d85318a3e1b20dcfbe8211b4442c02caa3a291a2ade950d0c4d79
|
||||
SHA512 (kernel-kabi-dw-5.15.0-0.rc3.25.tar.bz2) = 97403e9a00d49ef36deef21ca7460afd9d3029820efe08202619fdede5102b393a704b6f1078a67c9fc35571e0c0f660277f672d76a7bbb5ffdeb0af4202b9e5
|
||||
|
Loading…
Reference in New Issue
Block a user