Linux 2.6.36-rc7 upstream
This commit is contained in:
parent
dd6df43713
commit
72c4be84a6
3
.gitignore
vendored
3
.gitignore
vendored
@ -3,5 +3,4 @@ patch-*.bz2
|
|||||||
clog
|
clog
|
||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
/patch-2.6.36-rc6.bz2
|
/patch-2.6.36-rc7.bz2
|
||||||
/patch-2.6.36-rc6-git3.bz2
|
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 34
|
%global baserelease 35
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -82,9 +82,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 6
|
%define rcrev 7
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -682,7 +682,6 @@ Patch2912: linux-2.6-v4l-dvb-ir-core-update.patch
|
|||||||
Patch2917: hdpvr-ir-enable.patch
|
Patch2917: hdpvr-ir-enable.patch
|
||||||
|
|
||||||
Patch3000: linux-2.6-rcu-sched-warning.patch
|
Patch3000: linux-2.6-rcu-sched-warning.patch
|
||||||
Patch3010: linux-2.6-rcu-netpoll.patch
|
|
||||||
|
|
||||||
# fs fixes
|
# fs fixes
|
||||||
|
|
||||||
@ -1296,7 +1295,6 @@ ApplyPatch hdpvr-ir-enable.patch
|
|||||||
|
|
||||||
# silence another rcu_reference warning
|
# silence another rcu_reference warning
|
||||||
ApplyPatch linux-2.6-rcu-sched-warning.patch
|
ApplyPatch linux-2.6-rcu-sched-warning.patch
|
||||||
ApplyPatch linux-2.6-rcu-netpoll.patch
|
|
||||||
|
|
||||||
# Patches headed upstream
|
# Patches headed upstream
|
||||||
ApplyPatch disable-i8042-check-on-apple-mac.patch
|
ApplyPatch disable-i8042-check-on-apple-mac.patch
|
||||||
@ -1942,6 +1940,9 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 06 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.35.rc7.git0
|
||||||
|
- Linux 2.6.36-rc7 upstream.
|
||||||
|
|
||||||
* Wed Oct 06 2010 Dave Jones <davej@redhat.com>
|
* Wed Oct 06 2010 Dave Jones <davej@redhat.com>
|
||||||
- Another day, another rcu_dereference warning. (#640673)
|
- Another day, another rcu_dereference warning. (#640673)
|
||||||
|
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
|
|
||||||
diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
|
|
||||||
index 9fbc54a..435c502 100644
|
|
||||||
--- a/include/linux/rcupdate.h
|
|
||||||
+++ b/include/linux/rcupdate.h
|
|
||||||
@@ -454,7 +454,7 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
|
|
||||||
* Makes rcu_dereference_check() do the dirty work.
|
|
||||||
*/
|
|
||||||
#define rcu_dereference_bh(p) \
|
|
||||||
- rcu_dereference_check(p, rcu_read_lock_bh_held())
|
|
||||||
+ rcu_dereference_check(p, rcu_read_lock_bh_held() || irqs_disabled())
|
|
||||||
|
|
||||||
/**
|
|
||||||
* rcu_dereference_sched - fetch RCU-protected pointer, checking for RCU-sched
|
|
||||||
|
|
||||||
|
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
|||||||
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
||||||
df4f4d64d812b6eea0079acb62e8ca83 patch-2.6.36-rc6.bz2
|
d8e63ac9d7e25fb71a04ded58240ac96 patch-2.6.36-rc7.bz2
|
||||||
c99be287793f1b0b3eb7771443937359 patch-2.6.36-rc6-git3.bz2
|
|
||||||
|
Loading…
Reference in New Issue
Block a user