kernel-5.11.10-12

* Thu Mar 25 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.10-12]
- drm/i915/tgl/psr: Disable PSR on Tigerlake for now (Lyude Paul)
- Fedora: Turn off the SND_INTEL_BYT_PREFER_SOF option (Hans de Goede)
- ASoC: intel: atom: Stop advertising non working S24LE support (Hans de Goede)
- fix up RHEL config (Justin M. Forbes)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-03-25 08:49:10 -05:00
parent dd9778036d
commit 7268f6207c
5 changed files with 75 additions and 10 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 11
RHEL_RELEASE = 12
#
# Early y+1 numbering

View File

@ -1,3 +1,9 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/f93a5201c2ef7e9f70aa68621100f868764c2b15
f93a5201c2ef7e9f70aa68621100f868764c2b15 drm/i915/tgl/psr: Disable PSR on Tigerlake for now
https://gitlab.com/cki-project/kernel-ark/-/commit/63787bf2ade1acf5b4ae353d5f92dffa40519afb
63787bf2ade1acf5b4ae353d5f92dffa40519afb ASoC: intel: atom: Stop advertising non working S24LE support
https://gitlab.com/cki-project/kernel-ark/-/commit/d6e1043c3ee761b14ddae1707e78f10b26868c19
d6e1043c3ee761b14ddae1707e78f10b26868c19 KVM: PPC: Book3S HV: Save and restore FSCR in the P9 path

View File

@ -104,7 +104,7 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
%define rpmversion 5.11.9
%define rpmversion 5.11.10
%define stableversion 5.11
%define pkgrelease 200
@ -603,7 +603,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.11.9.tar.xz
Source0: linux-5.11.10.tar.xz
Source1: Makefile.rhelver
@ -1251,8 +1251,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.11.9 -c
mv linux-5.11.9 linux-%{KVERREL}
%setup -q -n kernel-5.11.10 -c
mv linux-5.11.10 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2765,6 +2765,12 @@ fi
#
#
%changelog
* Thu Mar 25 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.10-12]
- drm/i915/tgl/psr: Disable PSR on Tigerlake for now (Lyude Paul)
- Fedora: Turn off the SND_INTEL_BYT_PREFER_SOF option (Hans de Goede)
- ASoC: intel: atom: Stop advertising non working S24LE support (Hans de Goede)
- fix up RHEL config (Justin M. Forbes)
* Wed Mar 24 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.9-11]
- KVM: PPC: Book3S HV: Save and restore FSCR in the P9 path (Fabiano Rosas)
- drm/nouveau/kms/nve4-nv108: Don't advertise 256x256 cursor support yet (Lyude Paul)

View File

@ -27,6 +27,7 @@
drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/efi.c | 124 +++--
drivers/firmware/efi/secureboot.c | 38 ++
drivers/gpu/drm/i915/display/intel_psr.c | 9 +-
drivers/gpu/drm/nouveau/dispnv50/disp.c | 12 +-
drivers/gpu/drm/panel/Kconfig | 9 +
drivers/gpu/drm/panel/Makefile | 1 +
@ -68,7 +69,8 @@
security/security.c | 6 +
sound/hda/Kconfig | 14 +
sound/hda/intel-dsp-config.c | 29 +-
70 files changed, 2254 insertions(+), 270 deletions(-)
sound/soc/intel/atom/sst-mfld-platform-pcm.c | 6 +-
72 files changed, 2264 insertions(+), 275 deletions(-)
diff --git a/Documentation/ABI/testing/sysfs-platform_profile b/Documentation/ABI/testing/sysfs-platform_profile
new file mode 100644
@ -282,7 +284,7 @@ index 000000000000..c33a71263d9e
+ 2. Add the new profile name, along with a clear description of the
+ expected behaviour, to the sysfs-platform_profile ABI documentation.
diff --git a/Makefile b/Makefile
index 23403c8e0838..f066d200185e 100644
index 824d15c14be0..60669eb8738b 100644
--- a/Makefile
+++ b/Makefile
@@ -494,6 +494,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -1090,6 +1092,27 @@ index 000000000000..de0a3714a5d4
+ }
+ }
+}
diff --git a/drivers/gpu/drm/i915/display/intel_psr.c b/drivers/gpu/drm/i915/display/intel_psr.c
index b3631b722de3..0b8866900dfb 100644
--- a/drivers/gpu/drm/i915/display/intel_psr.c
+++ b/drivers/gpu/drm/i915/display/intel_psr.c
@@ -1708,9 +1708,14 @@ void intel_psr_init(struct drm_i915_private *dev_priv)
*/
dev_priv->hsw_psr_mmio_adjust = _SRD_CTL_EDP - _HSW_EDP_PSR_BASE;
- if (dev_priv->params.enable_psr == -1)
- if (INTEL_GEN(dev_priv) < 9 || !dev_priv->vbt.psr.enable)
+ if (dev_priv->params.enable_psr == -1) {
+ if (INTEL_GEN(dev_priv) < 9 || !dev_priv->vbt.psr.enable) {
dev_priv->params.enable_psr = 0;
+ } else if (INTEL_GEN(dev_priv) == 12) {
+ /* See https://gitlab.freedesktop.org/drm/intel/-/issues/3134 */
+ dev_priv->params.enable_psr = 0;
+ }
+ }
/* Set link_standby x link_off defaults */
if (IS_HASWELL(dev_priv) || IS_BROADWELL(dev_priv))
diff --git a/drivers/gpu/drm/nouveau/dispnv50/disp.c b/drivers/gpu/drm/nouveau/dispnv50/disp.c
index 5f4f09a601d4..857b76605a9e 100644
--- a/drivers/gpu/drm/nouveau/dispnv50/disp.c
@ -3860,3 +3883,33 @@ index c45686172517..68bb977c6a37 100644
.acpi_hid = "808622A8",
},
#endif
diff --git a/sound/soc/intel/atom/sst-mfld-platform-pcm.c b/sound/soc/intel/atom/sst-mfld-platform-pcm.c
index 9e9b05883557..aa5dd590ddd5 100644
--- a/sound/soc/intel/atom/sst-mfld-platform-pcm.c
+++ b/sound/soc/intel/atom/sst-mfld-platform-pcm.c
@@ -488,14 +488,14 @@ static struct snd_soc_dai_driver sst_platform_dai[] = {
.channels_min = SST_STEREO,
.channels_max = SST_STEREO,
.rates = SNDRV_PCM_RATE_44100|SNDRV_PCM_RATE_48000,
- .formats = SNDRV_PCM_FMTBIT_S16_LE | SNDRV_PCM_FMTBIT_S24_LE,
+ .formats = SNDRV_PCM_FMTBIT_S16_LE,
},
.capture = {
.stream_name = "Headset Capture",
.channels_min = 1,
.channels_max = 2,
.rates = SNDRV_PCM_RATE_44100|SNDRV_PCM_RATE_48000,
- .formats = SNDRV_PCM_FMTBIT_S16_LE | SNDRV_PCM_FMTBIT_S24_LE,
+ .formats = SNDRV_PCM_FMTBIT_S16_LE,
},
},
{
@@ -506,7 +506,7 @@ static struct snd_soc_dai_driver sst_platform_dai[] = {
.channels_min = SST_STEREO,
.channels_max = SST_STEREO,
.rates = SNDRV_PCM_RATE_44100|SNDRV_PCM_RATE_48000,
- .formats = SNDRV_PCM_FMTBIT_S16_LE | SNDRV_PCM_FMTBIT_S24_LE,
+ .formats = SNDRV_PCM_FMTBIT_S16_LE,
},
},
{

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.11.9.tar.xz) = 18ca50dccb7190e45d6f004e694eb7a57e3948dff75ceaca5adbd592155a2b8ef08f4b8326eedfc397a429e430fa79ed85ea5b231874874620e4868edf389d53
SHA512 (kernel-abi-whitelists-5.11.9-200.tar.bz2) = b12a59c930c835214beb2a27552269b86bb4fe106674333a344c2d054fec3b66867d390453ef9e9c85b4b5a63c664dfdd61a1a2caeaae735b4792ea040c8e659
SHA512 (kernel-kabi-dw-5.11.9-200.tar.bz2) = 38466b84cfc72ad32e26f29ff8544449025820a20afef745ebfc64d7d827620a45a40291c120325bebb9ac64dd584429e50acd3fb3fce567c46246a7481e21ae
SHA512 (linux-5.11.10.tar.xz) = be03e9b9b065493733e91e8cf4c38a8684c6b2a4b8eb18bd1e08f2e82e3e20dfa3eb3aaccbbaf73694db245188f1275c3ba1da6a4b5c9a346aeafdebbe85f145
SHA512 (kernel-abi-whitelists-5.11.10-200.tar.bz2) = 898f8ca896a981db23dcc81b4f202d850a16e57e8ae33308bcd34e26c7191e02d41c96959b2e0cf742b2fadd50c2cd4c6968c59f89350c1ad8bf6e604dd9572a
SHA512 (kernel-kabi-dw-5.11.10-200.tar.bz2) = 0fa4e361af96088f30b8650303ec4d0f865913b38e6bff55d81ec69d03efd23fa91263758f069790ffe476c7c39933935846f279da5fbd98db577296709f5e05