Linux v3.12-rc6-275-g320437af
This commit is contained in:
parent
1db147171e
commit
6f5740bae3
@ -1,35 +0,0 @@
|
||||
From 8ca95995e64f5d270889badb3e449dca91106a2b Mon Sep 17 00:00:00 2001
|
||||
From: Emmanuel Grumbach <emmanuel.grumbach@intel.com>
|
||||
Date: Sun, 15 Sep 2013 11:37:17 +0300
|
||||
Subject: [PATCH] iwlwifi: don't WARN on host commands sent when firmware is dead
|
||||
|
||||
This triggers automatic bug reports and add no valuable
|
||||
information. Print a simple error instead and drop the
|
||||
host command.
|
||||
|
||||
Signed-off-by: Emmanuel Grumbach <emmanuel.grumbach@intel.com>
|
||||
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
|
||||
---
|
||||
drivers/net/wireless/iwlwifi/iwl-trans.h | 6 ++++--
|
||||
1 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/iwlwifi/iwl-trans.h b/drivers/net/wireless/iwlwifi/iwl-trans.h
|
||||
index dd57a36..80b4750 100644
|
||||
--- a/drivers/net/wireless/iwlwifi/iwl-trans.h
|
||||
+++ b/drivers/net/wireless/iwlwifi/iwl-trans.h
|
||||
@@ -601,8 +601,10 @@ static inline int iwl_trans_send_cmd(struct iwl_trans *trans,
|
||||
{
|
||||
int ret;
|
||||
|
||||
- WARN_ONCE(trans->state != IWL_TRANS_FW_ALIVE,
|
||||
- "%s bad state = %d", __func__, trans->state);
|
||||
+ if (trans->state != IWL_TRANS_FW_ALIVE) {
|
||||
+ IWL_ERR(trans, "%s bad state = %d", __func__, trans->state);
|
||||
+ return -EIO;
|
||||
+ }
|
||||
|
||||
if (!(cmd->flags & CMD_ASYNC))
|
||||
lock_map_acquire_read(&trans->sync_cmd_lockdep_map);
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,59 +0,0 @@
|
||||
This reverts commit 9483f40d8d01918b399b4e24d0c1111db0afffeb.
|
||||
|
||||
Some devices stop to connect with above commit, see:
|
||||
https://bugzilla.kernel.org/show_bug.cgi?id=61621
|
||||
|
||||
Since there is no clear benefit of having MSI enabled, just revert
|
||||
change to fix the problem.
|
||||
|
||||
Cc: stable@vger.kernel.org # 3.11+
|
||||
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||
---
|
||||
drivers/net/wireless/rt2x00/rt2x00pci.c | 9 +--------
|
||||
1 file changed, 1 insertion(+), 8 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/rt2x00/rt2x00pci.c b/drivers/net/wireless/rt2x00/rt2x00pci.c
|
||||
index 76d95de..dc49e52 100644
|
||||
--- a/drivers/net/wireless/rt2x00/rt2x00pci.c
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00pci.c
|
||||
@@ -105,13 +105,11 @@ int rt2x00pci_probe(struct pci_dev *pci_dev, const struct rt2x00_ops *ops)
|
||||
goto exit_release_regions;
|
||||
}
|
||||
|
||||
- pci_enable_msi(pci_dev);
|
||||
-
|
||||
hw = ieee80211_alloc_hw(sizeof(struct rt2x00_dev), ops->hw);
|
||||
if (!hw) {
|
||||
rt2x00_probe_err("Failed to allocate hardware\n");
|
||||
retval = -ENOMEM;
|
||||
- goto exit_disable_msi;
|
||||
+ goto exit_release_regions;
|
||||
}
|
||||
|
||||
pci_set_drvdata(pci_dev, hw);
|
||||
@@ -152,9 +150,6 @@ exit_free_reg:
|
||||
exit_free_device:
|
||||
ieee80211_free_hw(hw);
|
||||
|
||||
-exit_disable_msi:
|
||||
- pci_disable_msi(pci_dev);
|
||||
-
|
||||
exit_release_regions:
|
||||
pci_release_regions(pci_dev);
|
||||
|
||||
@@ -179,8 +174,6 @@ void rt2x00pci_remove(struct pci_dev *pci_dev)
|
||||
rt2x00pci_free_reg(rt2x00dev);
|
||||
ieee80211_free_hw(hw);
|
||||
|
||||
- pci_disable_msi(pci_dev);
|
||||
-
|
||||
/*
|
||||
* Free the PCI device data.
|
||||
*/
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
@ -163,6 +163,7 @@ CONFIG_INFINIBAND_SRP=m
|
||||
CONFIG_INFINIBAND_SRPT=m
|
||||
CONFIG_INFINIBAND_USER_MAD=m
|
||||
CONFIG_INFINIBAND_USER_ACCESS=m
|
||||
# CONFIG_INFINIBAND_EXPERIMENTAL_UVERBS_FLOW_STEERING is not set #staging
|
||||
CONFIG_INFINIBAND_IPATH=m
|
||||
CONFIG_INFINIBAND_ISER=m
|
||||
CONFIG_INFINIBAND_ISERT=m
|
||||
|
19
kernel.spec
19
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 6
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -706,9 +706,6 @@ Patch25104: ansi_cprng-Fix-off-by-one-error-in-non-block-size-request.patch
|
||||
#rhbz 985522
|
||||
Patch25107: ntp-Make-periodic-RTC-update-more-reliable.patch
|
||||
|
||||
#rhbz 1010431
|
||||
Patch25108: Revert-rt2x00pci-Use-PCI-MSIs-whenever-possible.patch
|
||||
|
||||
#rhbz 902012
|
||||
Patch25114: elevator-Fix-a-race-in-elevator-switching-and-md.patch
|
||||
Patch25115: elevator-acquire-q-sysfs_lock-in-elevator_change.patch
|
||||
@ -723,7 +720,6 @@ Patch25123: iommu-Remove-stack-trace-from-broken-irq-remapping-warning.patch
|
||||
Patch25124: vfio-iommu-Fixed-interaction-of-VFIO_IOMMU_MAP_DMA.patch
|
||||
|
||||
#rhbz 896695
|
||||
Patch25126: 0001-iwlwifi-don-t-WARN-on-host-commands-sent-when-firmwa.patch
|
||||
Patch25127: 0002-iwlwifi-don-t-WARN-on-bad-firmware-state.patch
|
||||
|
||||
#rhbz 993744
|
||||
@ -741,9 +737,6 @@ Patch25132: rt2800usb-slow-down-TX-status-polling.patch
|
||||
#rhbz 1015558
|
||||
Patch25133: fix-buslogic.patch
|
||||
|
||||
#rhbz 989251
|
||||
Patch25134: tcp-fix-incorrect-ca_state-in-tail-loss-probe.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1418,9 +1411,6 @@ ApplyPatch ansi_cprng-Fix-off-by-one-error-in-non-block-size-request.patch
|
||||
#rhbz 985522
|
||||
ApplyPatch ntp-Make-periodic-RTC-update-more-reliable.patch
|
||||
|
||||
#rhbz 1010431
|
||||
ApplyPatch Revert-rt2x00pci-Use-PCI-MSIs-whenever-possible.patch
|
||||
|
||||
#rhbz 902012
|
||||
ApplyPatch elevator-Fix-a-race-in-elevator-switching-and-md.patch
|
||||
ApplyPatch elevator-acquire-q-sysfs_lock-in-elevator_change.patch
|
||||
@ -1435,7 +1425,6 @@ ApplyPatch iommu-Remove-stack-trace-from-broken-irq-remapping-warning.patch
|
||||
ApplyPatch vfio-iommu-Fixed-interaction-of-VFIO_IOMMU_MAP_DMA.patch
|
||||
|
||||
#rhbz 896695
|
||||
ApplyPatch 0001-iwlwifi-don-t-WARN-on-host-commands-sent-when-firmwa.patch
|
||||
ApplyPatch 0002-iwlwifi-don-t-WARN-on-bad-firmware-state.patch
|
||||
|
||||
#rhbz 993744
|
||||
@ -1453,9 +1442,6 @@ ApplyPatch rt2800usb-slow-down-TX-status-polling.patch
|
||||
#rhbz 1015558
|
||||
ApplyPatch fix-buslogic.patch
|
||||
|
||||
#rhbz 989251
|
||||
ApplyPatch tcp-fix-incorrect-ca_state-in-tail-loss-probe.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2259,6 +2245,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Wed Oct 23 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.12.0-0.rc6.git2.1
|
||||
- Linux v3.12-rc6-275-g320437af
|
||||
|
||||
* Tue Oct 22 2013 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Build virtio drivers as modules (rhbz 1019569)
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
fea363551ff45fbe4cb88497b863b261 linux-3.11.tar.xz
|
||||
7322cbc37897314ef00a57e32441728a patch-3.12-rc6.xz
|
||||
e20e63601ee9a6ae1abdffad43e415ba patch-3.12-rc6-git1.xz
|
||||
63d82f1333d6cf9a283fdfd8df783ab6 patch-3.12-rc6-git2.xz
|
||||
|
@ -1,107 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Yuchung Cheng <ycheng@google.com>
|
||||
Newsgroups: gmane.linux.network
|
||||
Subject: [PATCH net] tcp: fix incorrect ca_state in tail loss probe
|
||||
Date: Sat, 12 Oct 2013 10:16:27 -0700
|
||||
Lines: 34
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <1381598187-9681-1-git-send-email-ycheng@google.com>
|
||||
NNTP-Posting-Host: plane.gmane.org
|
||||
X-Trace: ger.gmane.org 1381598242 29686 80.91.229.3 (12 Oct 2013 17:17:22 GMT)
|
||||
X-Complaints-To: usenet@ger.gmane.org
|
||||
NNTP-Posting-Date: Sat, 12 Oct 2013 17:17:22 +0000 (UTC)
|
||||
Cc: netdev@vger.kernel.org, michael@sterretts.net,
|
||||
jwboyer@fedoraproject.org, sesse@google.com, dormando@rydia.net,
|
||||
Yuchung Cheng <ycheng@google.com>
|
||||
To: davem@davemloft.net, ncardwell@google.com, nanditad@google.com
|
||||
Original-X-From: netdev-owner@vger.kernel.org Sat Oct 12 19:17:23 2013
|
||||
Return-path: <netdev-owner@vger.kernel.org>
|
||||
Envelope-to: linux-netdev-2@plane.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by plane.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <netdev-owner@vger.kernel.org>)
|
||||
id 1VV2od-0004tp-02
|
||||
for linux-netdev-2@plane.gmane.org; Sat, 12 Oct 2013 19:17:23 +0200
|
||||
Original-Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1753183Ab3JLRRU (ORCPT <rfc822;linux-netdev-2@m.gmane.org>);
|
||||
Sat, 12 Oct 2013 13:17:20 -0400
|
||||
Original-Received: from mail-pb0-f74.google.com ([209.85.160.74]:35839 "EHLO
|
||||
mail-pb0-f74.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org
|
||||
with ESMTP id S1752493Ab3JLRRS (ORCPT
|
||||
<rfc822;netdev@vger.kernel.org>); Sat, 12 Oct 2013 13:17:18 -0400
|
||||
Original-Received: by mail-pb0-f74.google.com with SMTP id rq2so543459pbb.1
|
||||
for <netdev@vger.kernel.org>; Sat, 12 Oct 2013 10:17:18 -0700 (PDT)
|
||||
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
|
||||
d=google.com; s=20120113;
|
||||
h=from:to:cc:subject:date:message-id;
|
||||
bh=YSBIMZEgVuqyP2cau1199a1sz5d28JA7LPPsF6w9FYQ=;
|
||||
b=cCkXgePT7f0kRy+VBGvs3DZSLhVn0z7O74B7OHYpdZkQBznhNZ2b6ZGbkDqaKJXyLT
|
||||
GEsq/JXCgtwpC7aGSz9dPdAZU6kondKOAmfhh54u6f2+ymcZJ4zHpoA6mWuKJ4zlTF2w
|
||||
6tRhnT+/N5RkfIfYD/mcDx97X41kRT3NKJ6bsCoiNJIO2+6j8SrOi8C27InOkdIRY/AT
|
||||
I1uu2bvai1CfrC5yQ6UfpKUg2jioFDOi7i5nSEon+JnWeJavHpO01JMHuar7ZeGnAKJg
|
||||
kVLwyiRujU9Fz0CKIMPZihAngQu/0OgqORQIjygeqz+GPgtTxDGQP7IUNR/d+JOPVUse
|
||||
XlSA==
|
||||
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
|
||||
d=1e100.net; s=20130820;
|
||||
h=x-gm-message-state:from:to:cc:subject:date:message-id;
|
||||
bh=YSBIMZEgVuqyP2cau1199a1sz5d28JA7LPPsF6w9FYQ=;
|
||||
b=d95i7RXY0ff5vnWvrGqxWfSvvAE8SC6YAaBn3ZqbARIZm5GgynIAB/WYnrIOqpqGV6
|
||||
56jVM40bfzLrols1UZzyJWqPIgxee1zPrESh+WrSsDP2tTdYKl/zk13lbt/u7nOn9o3u
|
||||
HrAo2aY4DtV3P0ABEq1lKdazmmPACTc6256QQ2nxtHs5n7s7P1ERkpX7NGNqNf1zDBSv
|
||||
60xeoswRpMkh0G5ZUgpPYsIbXws9F64n5ytq34O2UDZPv5oPEd8I7P34HpqWkNsLoEBs
|
||||
XXTxs1SLc8TI3vdduhaQ+rmEvcE5vTaqjVCQAT2mMKTJJ9xIFueF5zExfI892PHAcJQ8
|
||||
jiaw==
|
||||
X-Gm-Message-State: ALoCoQkeL+3MY64KlpZKI1BuYMU+yTQcYF1C+U5u+kPpqROoekUMzIaH45qERBARAi/0vgJ5YM1Cwm+43d66vZMn/WdHPurbMHfFn3PYqeZSAzOEeuSA2jGTSZUkpuH8YwFqiNhABtj93ahsBXrA6POrXb531UvuahU+rnFLTGNLxVHv/08PW3l5PbN8UaTNpUI1qcf6O6MarFcB+fZLYPb339v4EIrLxg==
|
||||
X-Received: by 10.66.5.226 with SMTP id v2mr8825633pav.22.1381598238410;
|
||||
Sat, 12 Oct 2013 10:17:18 -0700 (PDT)
|
||||
Original-Received: from corp2gmr1-2.hot.corp.google.com (corp2gmr1-2.hot.corp.google.com [172.24.189.93])
|
||||
by gmr-mx.google.com with ESMTPS id a24si3247317yhl.1.1969.12.31.16.00.00
|
||||
(version=TLSv1.1 cipher=AES128-SHA bits=128/128);
|
||||
Sat, 12 Oct 2013 10:17:18 -0700 (PDT)
|
||||
Original-Received: from blast2.mtv.corp.google.com (blast2.mtv.corp.google.com [172.17.132.164])
|
||||
by corp2gmr1-2.hot.corp.google.com (Postfix) with ESMTP id 2F2B45A41A0;
|
||||
Sat, 12 Oct 2013 10:17:18 -0700 (PDT)
|
||||
Original-Received: by blast2.mtv.corp.google.com (Postfix, from userid 5463)
|
||||
id C6A85220C26; Sat, 12 Oct 2013 10:17:17 -0700 (PDT)
|
||||
X-Mailer: git-send-email 1.8.4
|
||||
Original-Sender: netdev-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <netdev.vger.kernel.org>
|
||||
X-Mailing-List: netdev@vger.kernel.org
|
||||
Xref: news.gmane.org gmane.linux.network:286793
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.network/286793>
|
||||
|
||||
On receiving an ACK that covers the loss probe sequence, TLP
|
||||
immediately sets the congestion state to Open, even though some packets
|
||||
are not recovered and retransmisssion are on the way. The later ACks
|
||||
may trigger a WARN_ON check in step D of tcp_fastretrans_alert(), e.g.,
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=989251
|
||||
|
||||
The fix is to follow the similar procedure in recovery by calling
|
||||
tcp_try_keep_open(). The sender switches to Open state if no packets
|
||||
are retransmissted. Otherwise it goes to Disorder and let subsequent
|
||||
ACKs move the state to Recovery or Open.
|
||||
|
||||
Reported-By: Michael Sterrett <michael@sterretts.net>
|
||||
Tested-By: Dormando <dormando@rydia.net>
|
||||
Signed-off-by: Yuchung Cheng <ycheng@google.com>
|
||||
---
|
||||
net/ipv4/tcp_input.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
|
||||
index 113dc5f..53974c7 100644
|
||||
--- a/net/ipv4/tcp_input.c
|
||||
+++ b/net/ipv4/tcp_input.c
|
||||
@@ -3291,7 +3291,7 @@ static void tcp_process_tlp_ack(struct sock *sk, u32 ack, int flag)
|
||||
tcp_init_cwnd_reduction(sk, true);
|
||||
tcp_set_ca_state(sk, TCP_CA_CWR);
|
||||
tcp_end_cwnd_reduction(sk);
|
||||
- tcp_set_ca_state(sk, TCP_CA_Open);
|
||||
+ tcp_try_keep_open(sk);
|
||||
NET_INC_STATS_BH(sock_net(sk),
|
||||
LINUX_MIB_TCPLOSSPROBERECOVERY);
|
||||
}
|
||||
--
|
||||
1.8.4
|
||||
|
Loading…
Reference in New Issue
Block a user