Linux v3.19-8784-gb2b89ebfc0f0

This commit is contained in:
Josh Boyer 2015-02-18 16:50:20 -05:00
parent 25e750dec7
commit 6bfe64015d
10 changed files with 26 additions and 16 deletions

View File

@ -163,10 +163,10 @@ index 0c86ec9e10ed..b02dfaacc76c 100644
extern int modules_disabled; /* for sysctl */
diff --git a/kernel/module.c b/kernel/module.c
index c641bc22d10b..ad861480c8e4 100644
index f6e8beef7b1e..d6d52757fad6 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -3887,6 +3887,13 @@ void module_layout(struct module *mod,
@@ -3892,6 +3892,13 @@ void module_layout(struct module *mod,
EXPORT_SYMBOL(module_layout);
#endif

View File

@ -41,10 +41,10 @@ index 42999fe2dbd0..0c86ec9e10ed 100644
#ifdef CONFIG_SYSFS
diff --git a/kernel/module.c b/kernel/module.c
index 8426ad48362c..c641bc22d10b 100644
index b34813f725e9..f6e8beef7b1e 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -3886,3 +3886,13 @@ void module_layout(struct module *mod,
@@ -3891,3 +3891,13 @@ void module_layout(struct module *mod,
}
EXPORT_SYMBOL(module_layout);
#endif

View File

@ -228,7 +228,7 @@ index 7b40c5f07dce..8a60477b96e1 100644
return 0;
diff --git a/kernel/module.c b/kernel/module.c
index ad861480c8e4..7f4745c58671 100644
index d6d52757fad6..e6f37db77e5f 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -108,9 +108,9 @@ struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 33cb15efd257..1eafc166bffd 100644
index dd8796caa239..edbbaccff485 100644
--- a/Makefile
+++ b/Makefile
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
@ -59,7 +59,7 @@ index 33cb15efd257..1eafc166bffd 100644
ifdef CONFIG_DEBUG_INFO
ifdef CONFIG_DEBUG_INFO_SPLIT
diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
index ecb3516f6546..f9fd2dbc72c4 100644
index c5cefb3c009c..b663e8e211b0 100644
--- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug
@@ -165,7 +165,23 @@ config DEBUG_INFO_DWARF4
@ -85,8 +85,8 @@ index ecb3516f6546..f9fd2dbc72c4 100644
+ environment to automatically compile everything both ways,
+ generating an error if anything differs.
config ENABLE_WARN_DEPRECATED
bool "Enable __deprecated logic"
config GDB_SCRIPTS
bool "Provide GDB scripts for kernel debugging"
--
2.1.0

View File

@ -211,6 +211,7 @@ CONFIG_AXP288_ADC=m
CONFIG_MTD_NAND_SUNXI=m
CONFIG_SERIO_SUN4I_PS2=m
CONFIG_KEYBOARD_SUN4I_LRADC=m
CONFIG_PWM_SUN4I=m
# Exynos
CONFIG_ARCH_EXYNOS3=y

View File

@ -306,6 +306,7 @@ CONFIG_MTD_CFI_I2=y
# CONFIG_MTD_ONENAND is not set
# CONFIG_MTD_NAND_ECC_BCH is not set
# CONFIG_MTD_NAND_DISKONCHIP is not set
# CONFIG_MTD_NAND_HISI504 is not set
# CONFIG_MTD_LPDDR is not set
CONFIG_MTD_UBI=m
CONFIG_MTD_UBI_WL_THRESHOLD=4096
@ -380,6 +381,7 @@ CONFIG_BLK_DEV_THROTTLING=y
CONFIG_SCSI_VIRTIO=m
CONFIG_VIRTIO_BLK=m
CONFIG_VIRTIO_PCI=m
CONFIG_VIRTIO_PCI_LEGACY=y
CONFIG_VIRTIO_BALLOON=m
CONFIG_VIRTIO_MMIO=m
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
@ -4114,6 +4116,8 @@ CONFIG_MFD_VIPERBOARD=m
# CONFIG_MFD_HI6421_PMIC is not set
# CONFIG_MFD_RK808 is not set
# CONFIG_MFD_RN5T618 is not set
# CONFIG_MFD_DA9150 is not set
# CONFIG_MFD_RT5033 is not set
# CONFIG_EZX_PCAP is not set
# CONFIG_INTEL_SOC_PMIC is not set
@ -4514,6 +4518,7 @@ CONFIG_KGDB_SERIAL_CONSOLE=y
CONFIG_KGDB_TESTS=y
CONFIG_KGDB_LOW_LEVEL_TRAP=y
# CONFIG_KGDB_TESTS_ON_BOOT is not set
# CONFIG_GDB_SCRIPTS is not set
#

View File

@ -17788,10 +17788,10 @@ index 44b1537..a4a53a7 100644
}
static void xgene_enet_setup_ops(struct xgene_enet_pdata *pdata)
@@ -1030,17 +1027,17 @@ static const struct acpi_device_id xgene_enet_acpi_match[] = {
MODULE_DEVICE_TABLE(acpi, xgene_enet_acpi_match);
@@ -1031,18 +1031,18 @@ MODULE_DEVICE_TABLE(acpi, xgene_enet_acpi_match);
#endif
#ifdef CONFIG_OF
-static struct of_device_id xgene_enet_of_match[] = {
+static struct of_device_id xgene_enet_match[] = {
{.compatible = "apm,xgene-enet",},
@ -17800,6 +17800,7 @@ index 44b1537..a4a53a7 100644
-MODULE_DEVICE_TABLE(of, xgene_enet_of_match);
+MODULE_DEVICE_TABLE(of, xgene_enet_match);
#endif
static struct platform_driver xgene_enet_driver = {
.driver = {

View File

@ -42,7 +42,7 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
%global baserelease 2
%global baserelease 1
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@ -69,7 +69,7 @@ Summary: The Linux kernel
# The rc snapshot level
%define rcrev 0
# The git snapshot level
%define gitrev 8
%define gitrev 9
# Set rpm version accordingly
%define rpmversion 3.%{upstream_sublevel}.0
%endif
@ -2212,6 +2212,9 @@ fi
#
#
%changelog
* Wed Feb 18 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.20.0-0.rc0.git9.1
- Linux v3.19-8784-gb2b89ebfc0f0
* Wed Feb 18 2015 Kyle McMartin <kyle@fedoraproject.org> - 3.20.0-0.rc0.git8.2
- kernel-arm64.patch: Revert dropping some of the xgene fixes we carried
against upstream. (#1193875)

View File

@ -13,7 +13,7 @@ Signed-off-by: Matthew Garrett <matthew.garrett@nebula.com>
1 file changed, 8 insertions(+)
diff --git a/kernel/kexec.c b/kernel/kexec.c
index c85277639b34..2126bc321505 100644
index 38c25b1f2fd5..f2b5272156ce 100644
--- a/kernel/kexec.c
+++ b/kernel/kexec.c
@@ -36,6 +36,7 @@
@ -24,7 +24,7 @@ index c85277639b34..2126bc321505 100644
#include <asm/page.h>
#include <asm/uaccess.h>
@@ -1251,6 +1252,13 @@ SYSCALL_DEFINE4(kexec_load, unsigned long, entry, unsigned long, nr_segments,
@@ -1247,6 +1248,13 @@ SYSCALL_DEFINE4(kexec_load, unsigned long, entry, unsigned long, nr_segments,
return -EPERM;
/*

View File

@ -1,3 +1,3 @@
d3fc8316d4d4d04b65cbc2d70799e763 linux-3.19.tar.xz
15d8d2f97ce056488451a5bfb2944603 perf-man-3.19.tar.gz
f25719547922635de5a295f2fe8a934e patch-3.19-git8.xz
af577efdd72c39570ba52854e2276d78 patch-3.19-git9.xz