Linux v3.9.3
This commit is contained in:
parent
9184c309b4
commit
6bdd2efb6b
@ -1,43 +0,0 @@
|
||||
From 7362f04c2888b14c20f8aaa02e1a897025261768 Mon Sep 17 00:00:00 2001
|
||||
From: Viresh Kumar <viresh.kumar@linaro.org>
|
||||
Date: Fri, 15 Mar 2013 08:48:20 +0000
|
||||
Subject: DMA: OF: Check properties value before running be32_to_cpup() on it
|
||||
|
||||
In of_dma_controller_register() routine we are calling of_get_property() as an
|
||||
parameter to be32_to_cpup(). In case the property doesn't exist we will get a
|
||||
crash.
|
||||
|
||||
This patch changes this code to check if we got a valid property first and then
|
||||
runs be32_to_cpup() on it.
|
||||
|
||||
Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
|
||||
Signed-off-by: Vinod Koul <vinod.koul@intel.com>
|
||||
---
|
||||
diff --git a/drivers/dma/of-dma.c b/drivers/dma/of-dma.c
|
||||
index 6036cd0..00db454 100644
|
||||
--- a/drivers/dma/of-dma.c
|
||||
+++ b/drivers/dma/of-dma.c
|
||||
@@ -93,6 +93,7 @@ int of_dma_controller_register(struct device_node *np,
|
||||
{
|
||||
struct of_dma *ofdma;
|
||||
int nbcells;
|
||||
+ const __be32 *prop;
|
||||
|
||||
if (!np || !of_dma_xlate) {
|
||||
pr_err("%s: not enough information provided\n", __func__);
|
||||
@@ -103,8 +104,11 @@ int of_dma_controller_register(struct device_node *np,
|
||||
if (!ofdma)
|
||||
return -ENOMEM;
|
||||
|
||||
- nbcells = be32_to_cpup(of_get_property(np, "#dma-cells", NULL));
|
||||
- if (!nbcells) {
|
||||
+ prop = of_get_property(np, "#dma-cells", NULL);
|
||||
+ if (prop)
|
||||
+ nbcells = be32_to_cpup(prop);
|
||||
+
|
||||
+ if (!prop || !nbcells) {
|
||||
pr_err("%s: #dma-cells property is missing or invalid\n",
|
||||
__func__);
|
||||
kfree(ofdma);
|
||||
--
|
||||
cgit v0.9.1
|
@ -1,52 +0,0 @@
|
||||
From 3cebd7639faa9b315d0c82056c518f59ed080a84 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Wed, 15 May 2013 11:18:17 +1000
|
||||
Subject: [PATCH] drm/radeon: restore nomodeset operation (v2)
|
||||
|
||||
When UMS was deprecated it removed support for nomodeset commandline
|
||||
we really want this in distro land so we can debug stuff, everyone
|
||||
should fallback to vesa correctly.
|
||||
|
||||
v2: oops -1 isn't used anymore, restore original behaviour
|
||||
-1 is default, so we can boot with nomodeset on the command line,
|
||||
then use radeon.modeset=1 to override it for debugging later.
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Signed-off-by: Dave Airlie <airlied@redhat.com>
|
||||
---
|
||||
drivers/gpu/drm/radeon/radeon_drv.c | 12 +++++++++++-
|
||||
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/radeon/radeon_drv.c b/drivers/gpu/drm/radeon/radeon_drv.c
|
||||
index d33f484..094e7e5 100644
|
||||
--- a/drivers/gpu/drm/radeon/radeon_drv.c
|
||||
+++ b/drivers/gpu/drm/radeon/radeon_drv.c
|
||||
@@ -147,7 +147,7 @@ static inline void radeon_unregister_atpx_handler(void) {}
|
||||
#endif
|
||||
|
||||
int radeon_no_wb;
|
||||
-int radeon_modeset = 1;
|
||||
+int radeon_modeset = -1;
|
||||
int radeon_dynclks = -1;
|
||||
int radeon_r4xx_atom = 0;
|
||||
int radeon_agpmode = 0;
|
||||
@@ -456,6 +456,16 @@ static struct pci_driver radeon_kms_pci_driver = {
|
||||
|
||||
static int __init radeon_init(void)
|
||||
{
|
||||
+#ifdef CONFIG_VGA_CONSOLE
|
||||
+ if (vgacon_text_force() && radeon_modeset == -1) {
|
||||
+ DRM_INFO("VGACON disable radeon kernel modesetting.\n");
|
||||
+ radeon_modeset = 0;
|
||||
+ }
|
||||
+#endif
|
||||
+ /* set to modesetting by default if not nomodeset */
|
||||
+ if (radeon_modeset == -1)
|
||||
+ radeon_modeset = 1;
|
||||
+
|
||||
if (radeon_modeset == 1) {
|
||||
DRM_INFO("radeon kernel modesetting enabled.\n");
|
||||
driver = &kms_driver;
|
||||
--
|
||||
1.8.1.2
|
||||
|
14
kernel.spec
14
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 302
|
||||
%global baserelease 301
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -74,7 +74,7 @@ Summary: The Linux kernel
|
||||
%if 0%{?released_kernel}
|
||||
|
||||
# Do we have a -stable update to apply?
|
||||
%define stable_update 2
|
||||
%define stable_update 3
|
||||
# Is it a -stable RC?
|
||||
%define stable_rc 0
|
||||
# Set rpm version accordingly
|
||||
@ -675,8 +675,6 @@ Patch1702: drm-qxl-backport-fixes.patch
|
||||
Patch1824: drm-intel-next.patch
|
||||
Patch1825: drm-i915-dp-stfu.patch
|
||||
# radeon drm fix
|
||||
# 924507
|
||||
Patch1900: drm-radeon-fix-nomodeset.patch
|
||||
|
||||
# Quiet boot fixes
|
||||
# silence the ACPI blacklist code
|
||||
@ -703,8 +701,6 @@ Patch14010: lis3-improve-handling-of-null-rate.patch
|
||||
|
||||
# ARM
|
||||
Patch21000: arm-export-read_current_timer.patch
|
||||
# https://lists.ozlabs.org/pipermail/devicetree-discuss/2013-March/029029.html
|
||||
Patch21001: arm-of-dma.patch
|
||||
|
||||
# lpae
|
||||
Patch21002: arm-lpae-ax88796.patch
|
||||
@ -1311,7 +1307,6 @@ ApplyPatch debug-bad-pte-modules.patch
|
||||
# ARM
|
||||
#
|
||||
ApplyPatch arm-export-read_current_timer.patch
|
||||
ApplyPatch arm-of-dma.patch
|
||||
ApplyPatch arm-lpae-ax88796.patch
|
||||
ApplyPatch arm-omap-ehci-fix.patch
|
||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||
@ -1398,8 +1393,6 @@ ApplyPatch drm-qxl-backport-fixes.patch
|
||||
ApplyOptionalPatch drm-intel-next.patch
|
||||
ApplyPatch drm-i915-dp-stfu.patch
|
||||
|
||||
ApplyPatch drm-radeon-fix-nomodeset.patch
|
||||
|
||||
# silence the ACPI blacklist code
|
||||
ApplyPatch silence-acpi-blacklist.patch
|
||||
|
||||
@ -2287,6 +2280,9 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Mon May 20 2013 Josh Boyer <jwboyer@redhat.com> - 3.9.3-301
|
||||
- Linux v3.9.3
|
||||
|
||||
* Thu May 16 2013 Josh Boyer <jwboyer@redhat.com>
|
||||
- Fix config-local usage (rhbz 950841)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user