kernel-5.15-0.rc4.20211009git5d6ab0bb408f.37
* Sat Oct 09 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211009git5d6ab0bb408f.37] - redhat: fix typo and make the output more silent for dist-git sync (Herton R. Krzesinski) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
2f1ff80800
commit
6a61f6e69b
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 36
|
RHEL_RELEASE = 39
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
17
kernel.spec
17
kernel.spec
@ -83,9 +83,9 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||||
# to build the base kernel using the debug configuration. (Specifying
|
# to build the base kernel using the debug configuration. (Specifying
|
||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%global distro_build 0.rc4.20211008git1da38549dd64.36
|
%global distro_build 0.rc5.39
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -130,13 +130,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define rpmversion 5.15.0
|
%define rpmversion 5.15.0
|
||||||
%define patchversion 5.15
|
%define patchversion 5.15
|
||||||
%define pkgrelease 0.rc4.20211008git1da38549dd64.36
|
%define pkgrelease 0.rc5.39
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 15
|
%define patchlevel 15
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc4.20211008git1da38549dd64.36%{?buildid}%{?dist}
|
%define specrelease 0.rc5.39%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -677,7 +677,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.15-rc4-193-g1da38549dd64.tar.xz
|
Source0: linux-5.15-rc5.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1368,8 +1368,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.15-rc4-193-g1da38549dd64 -c
|
%setup -q -n kernel-5.15-rc5 -c
|
||||||
mv linux-5.15-rc4-193-g1da38549dd64 linux-%{KVERREL}
|
mv linux-5.15-rc5 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2968,6 +2968,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 09 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211009git5d6ab0bb408f.37]
|
||||||
|
- redhat: fix typo and make the output more silent for dist-git sync (Herton R. Krzesinski)
|
||||||
|
|
||||||
* Thu Oct 07 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211007git5af4055fa813.35]
|
* Thu Oct 07 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211007git5af4055fa813.35]
|
||||||
- Fedora NTFS config updates (Justin M. Forbes)
|
- Fedora NTFS config updates (Justin M. Forbes)
|
||||||
- Fedora 5.15 configs part 1 (Justin M. Forbes)
|
- Fedora 5.15 configs part 1 (Justin M. Forbes)
|
||||||
|
@ -88,7 +88,7 @@
|
|||||||
87 files changed, 1377 insertions(+), 1523 deletions(-)
|
87 files changed, 1377 insertions(+), 1523 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
index 91ba391f9b32..88296cfdc5e5 100644
|
index 43dc35fe5bc0..ada907ac43ff 100644
|
||||||
--- a/Documentation/admin-guide/kernel-parameters.txt
|
--- a/Documentation/admin-guide/kernel-parameters.txt
|
||||||
+++ b/Documentation/admin-guide/kernel-parameters.txt
|
+++ b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
@@ -5892,6 +5892,15 @@
|
@@ -5892,6 +5892,15 @@
|
||||||
@ -141,7 +141,7 @@ index 000000000000..effb81d04bfd
|
|||||||
+
|
+
|
||||||
+endmenu
|
+endmenu
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 7b74223d1309..ef9d05c382c3 100644
|
index 4d0c0ed9236e..ca36f5a601f0 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
@ -171,7 +171,7 @@ index 7b74223d1309..ef9d05c382c3 100644
|
|||||||
|
|
||||||
$(version_h): PATCHLEVEL := $(if $(PATCHLEVEL), $(PATCHLEVEL), 0)
|
$(version_h): PATCHLEVEL := $(if $(PATCHLEVEL), $(PATCHLEVEL), 0)
|
||||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||||
index fc196421b2ce..0a6b267128ae 100644
|
index 59baf6c132a7..9c4714443ef5 100644
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1469,9 +1469,9 @@ config HIGHMEM
|
@@ -1469,9 +1469,9 @@ config HIGHMEM
|
||||||
@ -187,7 +187,7 @@ index fc196421b2ce..0a6b267128ae 100644
|
|||||||
The VM uses one page of physical memory for each page table.
|
The VM uses one page of physical memory for each page table.
|
||||||
For systems with a lot of processes, this can use a lot of
|
For systems with a lot of processes, this can use a lot of
|
||||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||||
index 5c7ae4c3954b..7c81c15fc327 100644
|
index fee914c716aa..99bb34aac703 100644
|
||||||
--- a/arch/arm64/Kconfig
|
--- a/arch/arm64/Kconfig
|
||||||
+++ b/arch/arm64/Kconfig
|
+++ b/arch/arm64/Kconfig
|
||||||
@@ -911,7 +911,7 @@ endchoice
|
@@ -911,7 +911,7 @@ endchoice
|
||||||
@ -295,10 +295,10 @@ index 67e5fff96ee0..0d58c1f07176 100644
|
|||||||
/* boot_command_line has been already set up in early.c */
|
/* boot_command_line has been already set up in early.c */
|
||||||
*cmdline_p = boot_command_line;
|
*cmdline_p = boot_command_line;
|
||||||
diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
|
diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
|
||||||
index 0f8885949e8c..a79e57a77076 100644
|
index b3410f1ac217..c0645c5b4860 100644
|
||||||
--- a/arch/x86/kernel/cpu/common.c
|
--- a/arch/x86/kernel/cpu/common.c
|
||||||
+++ b/arch/x86/kernel/cpu/common.c
|
+++ b/arch/x86/kernel/cpu/common.c
|
||||||
@@ -1310,6 +1310,7 @@ static void __init early_identify_cpu(struct cpuinfo_x86 *c)
|
@@ -1311,6 +1311,7 @@ static void __init early_identify_cpu(struct cpuinfo_x86 *c)
|
||||||
cpu_detect(c);
|
cpu_detect(c);
|
||||||
get_cpu_vendor(c);
|
get_cpu_vendor(c);
|
||||||
get_cpu_cap(c);
|
get_cpu_cap(c);
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.15-rc4-193-g1da38549dd64.tar.xz) = 3a697f8c3ec03ca51be291460c6ebb95c8f419e12e3968b16f3ed89519a5a3d0d51bd736f7c27cfa317288e8472f4c83c27eaf6634828fd2a5fa86afb7f0de76
|
SHA512 (linux-5.15-rc5.tar.xz) = 94c5edb8020abdeb00dec17b34e4ca138b052da587be057e2d6fbac4a606559e6c8d96b00ae682f91685afbdae26f43c1872ba0054dd99d0ff662cb3857ebb76
|
||||||
SHA512 (kernel-abi-stablelists-5.15.0-0.rc4.20211008git1da38549dd64.36.tar.bz2) = 9d79424672248e243dbc6a7395b7d51ce3fbd01e5fa4a7335f1d4c16bd740d6d435b2b24874db2f7ef5a7531064b5d665d2f27114265e915e2fd61b7bb75dcce
|
SHA512 (kernel-abi-stablelists-5.15.0-0.rc5.39.tar.bz2) = 491cfa43dd17df104bce96f5934893f2702541bbb7582a557bbcc174de989d6d3d7cdf6c93f603568b74d7c6bfc51f5bf35fb733e887c4ba707bdb266076b49f
|
||||||
SHA512 (kernel-kabi-dw-5.15.0-0.rc4.20211008git1da38549dd64.36.tar.bz2) = 1ebeca8501a85c7d6c70a3b946557b60c78779b830f7a3ccbe1b24062580c351727f0461bafe77fe2e27160ba98a6cb899259805745bb785e05f9ce41f1704cb
|
SHA512 (kernel-kabi-dw-5.15.0-0.rc5.39.tar.bz2) = 1f706caa13c481b4f46f1eb5fd8cb0e75b2c30a979a2ad5e95db412cd381740238d9e31e8b156f09aba5e195b1ed7360c2dbc7122589cbbbf2e27cc0d33f3936
|
||||||
|
Loading…
Reference in New Issue
Block a user