kernel-6.8.2-300

* Tue Mar 26 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.2-0]
- xfs: fix SEEK_HOLE/DATA for regions with active COW extents (Dave Chinner)
- redhat: make libperf-devel require libperf %%{version}-%%{release} (Jan Stancek)
- kernel.spec: drop custom mode also for System.map ghost entry (Jan Stancek)
- kernel.spec: fix libperf-debuginfo content (Jan Stancek)
- redhat/kernel.spec.template: enable cross for base/RT (Peter Robinson)
- redhat/kernel.spec.template: Fix cross compiling (Peter Robinson)
- Add more bugs to BugsFixed (Justin M. Forbes)
- Add bug to BugsFixed (Justin M. Forbes)
- Turn on CONFIG_READ_ONLY_THP_FOR_FS for Fedora (Justin M. Forbes)
- Change fedora-stable-release.sh to use git am (Justin M. Forbes)
- drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set (Javier Martinez Canillas)
- Revert libcpupower soname bump for F38/39 (Justin M. Forbes)
- Fix up requires for UKI (Justin M. Forbes)
- drm/amd: Flush GFXOFF requests in prepare stage (Mario Limonciello)
- Linux v6.8.2
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2024-03-26 18:50:42 -05:00
parent 18e40bfa26
commit 69f6e97d76
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
21 changed files with 174 additions and 34 deletions

View File

@ -1,3 +1,12 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/fccd579ad79c032dd402f674fd94e80ad52519f6
fccd579ad79c032dd402f674fd94e80ad52519f6 xfs: fix SEEK_HOLE/DATA for regions with active COW extents
"https://gitlab.com/cki-project/kernel-ark/-/commit"/43f3e284f6c98c0cb6133ac90e0b4bba02975053
43f3e284f6c98c0cb6133ac90e0b4bba02975053 drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set
"https://gitlab.com/cki-project/kernel-ark/-/commit"/6a6428d08805f225c5425fc7c2b3c093267cb206
6a6428d08805f225c5425fc7c2b3c093267cb206 drm/amd: Flush GFXOFF requests in prepare stage
"https://gitlab.com/cki-project/kernel-ark/-/commit"/bbd16c78228ab6d4515fc98bd574a9a213e9428c "https://gitlab.com/cki-project/kernel-ark/-/commit"/bbd16c78228ab6d4515fc98bd574a9a213e9428c
bbd16c78228ab6d4515fc98bd574a9a213e9428c scsi: sd: Add "probe_type" module parameter to allow synchronous probing bbd16c78228ab6d4515fc98bd574a9a213e9428c scsi: sd: Add "probe_type" module parameter to allow synchronous probing

View File

@ -2778,6 +2778,7 @@ CONFIG_GPIO_TPS65086=m
CONFIG_GPIO_TPS65219=m CONFIG_GPIO_TPS65219=m
CONFIG_GPIO_TPS6586X=y CONFIG_GPIO_TPS6586X=y
# CONFIG_GPIO_TS4900 is not set # CONFIG_GPIO_TS4900 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
CONFIG_GPIO_VIRTIO=m CONFIG_GPIO_VIRTIO=m
CONFIG_GPIO_WATCHDOG=m CONFIG_GPIO_WATCHDOG=m
@ -6397,7 +6398,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -2761,6 +2761,7 @@ CONFIG_GPIO_TPS65086=m
CONFIG_GPIO_TPS65219=m CONFIG_GPIO_TPS65219=m
CONFIG_GPIO_TPS6586X=y CONFIG_GPIO_TPS6586X=y
# CONFIG_GPIO_TS4900 is not set # CONFIG_GPIO_TS4900 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
CONFIG_GPIO_VIRTIO=m CONFIG_GPIO_VIRTIO=m
CONFIG_GPIO_WATCHDOG=m CONFIG_GPIO_WATCHDOG=m
@ -6370,7 +6371,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -2261,6 +2261,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -6963,6 +6964,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -2245,6 +2245,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -6938,6 +6939,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -2778,6 +2778,7 @@ CONFIG_GPIO_TPS65086=m
CONFIG_GPIO_TPS65219=m CONFIG_GPIO_TPS65219=m
CONFIG_GPIO_TPS6586X=y CONFIG_GPIO_TPS6586X=y
# CONFIG_GPIO_TS4900 is not set # CONFIG_GPIO_TS4900 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
CONFIG_GPIO_VIRTIO=m CONFIG_GPIO_VIRTIO=m
CONFIG_GPIO_WATCHDOG=m CONFIG_GPIO_WATCHDOG=m
@ -6397,7 +6398,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -2257,6 +2257,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -6959,6 +6960,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -2761,6 +2761,7 @@ CONFIG_GPIO_TPS65086=m
CONFIG_GPIO_TPS65219=m CONFIG_GPIO_TPS65219=m
CONFIG_GPIO_TPS6586X=y CONFIG_GPIO_TPS6586X=y
# CONFIG_GPIO_TS4900 is not set # CONFIG_GPIO_TS4900 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
CONFIG_GPIO_VIRTIO=m CONFIG_GPIO_VIRTIO=m
CONFIG_GPIO_WATCHDOG=m CONFIG_GPIO_WATCHDOG=m
@ -6370,7 +6371,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -2241,6 +2241,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -6934,6 +6935,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -2296,6 +2296,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -7012,6 +7013,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -2280,6 +2280,7 @@ CONFIG_GPIO_TEGRA186=y
CONFIG_GPIO_TEGRA=y CONFIG_GPIO_TEGRA=y
# CONFIG_GPIO_THUNDERX is not set # CONFIG_GPIO_THUNDERX is not set
# CONFIG_GPIO_TPIC2810 is not set # CONFIG_GPIO_TPIC2810 is not set
# CONFIG_GPIO_VF610 is not set
# CONFIG_GPIO_VIPERBOARD is not set # CONFIG_GPIO_VIPERBOARD is not set
# CONFIG_GPIO_VIRTIO is not set # CONFIG_GPIO_VIRTIO is not set
# CONFIG_GPIO_VX855 is not set # CONFIG_GPIO_VX855 is not set
@ -6987,6 +6988,8 @@ CONFIG_TEE=m
CONFIG_TEGRA186_GPC_DMA=m CONFIG_TEGRA186_GPC_DMA=m
CONFIG_TEGRA186_TIMER=y CONFIG_TEGRA186_TIMER=y
CONFIG_TEGRA20_APB_DMA=y CONFIG_TEGRA20_APB_DMA=y
CONFIG_TEGRA210_ADMA=m
CONFIG_TEGRA_ACONNECT=m
CONFIG_TEGRA_BPMP_THERMAL=m CONFIG_TEGRA_BPMP_THERMAL=m
# CONFIG_TEGRA_GMI is not set # CONFIG_TEGRA_GMI is not set
CONFIG_TEGRA_HOST1X_FIREWALL=y CONFIG_TEGRA_HOST1X_FIREWALL=y

View File

@ -5225,7 +5225,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -5196,7 +5196,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -5146,7 +5146,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -5117,7 +5117,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -5631,7 +5631,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -5603,7 +5603,7 @@ CONFIG_RDS_TCP=m
CONFIG_RD_XZ=y CONFIG_RD_XZ=y
CONFIG_RD_ZSTD=y CONFIG_RD_ZSTD=y
# CONFIG_READABLE_ASM is not set # CONFIG_READABLE_ASM is not set
# CONFIG_READ_ONLY_THP_FOR_FS is not set CONFIG_READ_ONLY_THP_FOR_FS=y
CONFIG_REALTEK_AUTOPM=y CONFIG_REALTEK_AUTOPM=y
CONFIG_REALTEK_PHY=m CONFIG_REALTEK_PHY=m
# CONFIG_REED_SOLOMON_TEST is not set # CONFIG_REED_SOLOMON_TEST is not set

View File

@ -1,3 +1,21 @@
* Tue Mar 26 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.2-0]
- xfs: fix SEEK_HOLE/DATA for regions with active COW extents (Dave Chinner)
- redhat: make libperf-devel require libperf %%{version}-%%{release} (Jan Stancek)
- kernel.spec: drop custom mode also for System.map ghost entry (Jan Stancek)
- kernel.spec: fix libperf-debuginfo content (Jan Stancek)
- redhat/kernel.spec.template: enable cross for base/RT (Peter Robinson)
- redhat/kernel.spec.template: Fix cross compiling (Peter Robinson)
- Add more bugs to BugsFixed (Justin M. Forbes)
- Add bug to BugsFixed (Justin M. Forbes)
- Turn on CONFIG_READ_ONLY_THP_FOR_FS for Fedora (Justin M. Forbes)
- Change fedora-stable-release.sh to use git am (Justin M. Forbes)
- drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set (Javier Martinez Canillas)
- Revert libcpupower soname bump for F38/39 (Justin M. Forbes)
- Fix up requires for UKI (Justin M. Forbes)
- drm/amd: Flush GFXOFF requests in prepare stage (Mario Limonciello)
- Linux v6.8.2
Resolves:
* Wed Mar 20 2024 Augusto Caringi <acaringi@redhat.com> [6.8.1-0] * Wed Mar 20 2024 Augusto Caringi <acaringi@redhat.com> [6.8.1-0]
- redhat/configs: Enable CONFIG_MITIGATION_RFDS (Augusto Caringi) - redhat/configs: Enable CONFIG_MITIGATION_RFDS (Augusto Caringi)
- fedora: Enable MCP9600 (Peter Robinson) - fedora: Enable MCP9600 (Peter Robinson)

View File

@ -160,18 +160,18 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.) # the --with-release option overrides this setting.)
%define debugbuildsenabled 1 %define debugbuildsenabled 1
# define buildid .local # define buildid .local
%define specrpmversion 6.8.1 %define specrpmversion 6.8.2
%define specversion 6.8.1 %define specversion 6.8.2
%define patchversion 6.8 %define patchversion 6.8
%define pkgrelease 300 %define pkgrelease 300
%define kversion 6 %define kversion 6
%define tarfile_release 6.8.1 %define tarfile_release 6.8.2
# This is needed to do merge window version magic # This is needed to do merge window version magic
%define patchlevel 8 %define patchlevel 8
# This allows pkg_release to have configurable %%{?dist} tag # This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}%{?dist} %define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version # This defines the kabi tarball version
%define kabiversion 6.8.1 %define kabiversion 6.8.2
# If this variable is set to 1, a bpf selftests build failure will cause a # If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error # fatal kernel package build error
@ -391,8 +391,6 @@ Summary: The Linux kernel
%define with_bpftool 0 %define with_bpftool 0
%define with_kernel_abi_stablelists 0 %define with_kernel_abi_stablelists 0
%define with_selftests 0 %define with_selftests 0
%define with_cross 0
%define with_cross_headers 0
%define with_ipaclones 0 %define with_ipaclones 0
%endif %endif
@ -422,8 +420,6 @@ Summary: The Linux kernel
%define with_bpftool 0 %define with_bpftool 0
%define with_kernel_abi_stablelists 0 %define with_kernel_abi_stablelists 0
%define with_selftests 0 %define with_selftests 0
%define with_cross 0
%define with_cross_headers 0
%define with_ipaclones 0 %define with_ipaclones 0
%define with_headers 0 %define with_headers 0
%define with_efiuki 0 %define with_efiuki 0
@ -1133,6 +1129,7 @@ This package contains the kernel source perf library.
%package -n libperf-devel %package -n libperf-devel
Summary: Developement files for the perf library from kernel source Summary: Developement files for the perf library from kernel source
Requires: libperf = %{version}-%{release}
%description -n libperf-devel %description -n libperf-devel
This package includes libraries and header files needed for development This package includes libraries and header files needed for development
of applications which use perf library from kernel source. of applications which use perf library from kernel source.
@ -1149,7 +1146,7 @@ This package provides debug information for the libperf package.
# symlinks because of the trailing nonmatching alternation and # symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling # the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file. # of matching the pattern against the symlinks file.
%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_libdir}/libperf.so(\.debug)?|XXX' -o libperf-debuginfo.list} %{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_libdir}/libperf.so.*(\.debug)?|XXX' -o libperf-debuginfo.list}
# with_libperf # with_libperf
%endif %endif
@ -1553,7 +1550,7 @@ Provides: installonlypkg(kernel)\
Provides: kernel-%{?1:%{1}-}uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\ Provides: kernel-%{?1:%{1}-}uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
Requires: kernel%{?1:-%{1}}-modules-core-uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\ Requires: kernel%{?1:-%{1}}-modules-core-uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
Requires(pre): %{kernel_prereq}\ Requires(pre): %{kernel_prereq}\
Requires(pre): systemd >= 254-1\ Requires(pre): systemd\
%endif\ %endif\
%endif\ %endif\
%if %{with_gcov}\ %if %{with_gcov}\
@ -2484,7 +2481,7 @@ BuildKernel() {
fi fi
# build and copy the vmlinux-gdb plugin files into kernel-debuginfo # build and copy the vmlinux-gdb plugin files into kernel-debuginfo
%{make} %{?_smp_mflags} scripts_gdb %{make} ARCH=$Arch %{?_smp_mflags} scripts_gdb
cp -a --parents scripts/gdb/{,linux/}*.py $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer cp -a --parents scripts/gdb/{,linux/}*.py $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
# this should be a relative symlink (Kbuild creates an absolute one) # this should be a relative symlink (Kbuild creates an absolute one)
ln -s scripts/gdb/vmlinux-gdb.py $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer/vmlinux-gdb.py ln -s scripts/gdb/vmlinux-gdb.py $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer/vmlinux-gdb.py
@ -3823,7 +3820,7 @@ fi\
%ghost /%{image_install_path}/dtb-%{KVERREL}%{?3:+%{3}} \ %ghost /%{image_install_path}/dtb-%{KVERREL}%{?3:+%{3}} \
%endif\ %endif\
/lib/modules/%{KVERREL}%{?3:+%{3}}/System.map\ /lib/modules/%{KVERREL}%{?3:+%{3}}/System.map\
%ghost %attr(0600, root, root) /boot/System.map-%{KVERREL}%{?3:+%{3}}\ %ghost /boot/System.map-%{KVERREL}%{?3:+%{3}}\
%dir /lib/modules\ %dir /lib/modules\
%dir /lib/modules/%{KVERREL}%{?3:+%{3}}\ %dir /lib/modules/%{KVERREL}%{?3:+%{3}}\
/lib/modules/%{KVERREL}%{?3:+%{3}}/symvers.%compext\ /lib/modules/%{KVERREL}%{?3:+%{3}}/symvers.%compext\
@ -3962,6 +3959,26 @@ fi\
# #
# #
%changelog %changelog
* Tue Mar 26 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.2-300]
- Config updates for stable (Justin M. Forbes)
* Tue Mar 26 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.2-0]
- xfs: fix SEEK_HOLE/DATA for regions with active COW extents (Dave Chinner)
- redhat: make libperf-devel require libperf %%{version}-%%{release} (Jan Stancek)
- kernel.spec: drop custom mode also for System.map ghost entry (Jan Stancek)
- kernel.spec: fix libperf-debuginfo content (Jan Stancek)
- redhat/kernel.spec.template: enable cross for base/RT (Peter Robinson)
- redhat/kernel.spec.template: Fix cross compiling (Peter Robinson)
- Add more bugs to BugsFixed (Justin M. Forbes)
- Add bug to BugsFixed (Justin M. Forbes)
- Turn on CONFIG_READ_ONLY_THP_FOR_FS for Fedora (Justin M. Forbes)
- Change fedora-stable-release.sh to use git am (Justin M. Forbes)
- drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set (Javier Martinez Canillas)
- Revert libcpupower soname bump for F38/39 (Justin M. Forbes)
- Fix up requires for UKI (Justin M. Forbes)
- drm/amd: Flush GFXOFF requests in prepare stage (Mario Limonciello)
- Linux v6.8.2
* Wed Mar 20 2024 Augusto Caringi <acaringi@redhat.com> [6.8.1-0] * Wed Mar 20 2024 Augusto Caringi <acaringi@redhat.com> [6.8.1-0]
- redhat/configs: Enable CONFIG_MITIGATION_RFDS (Augusto Caringi) - redhat/configs: Enable CONFIG_MITIGATION_RFDS (Augusto Caringi)
- fedora: Enable MCP9600 (Peter Robinson) - fedora: Enable MCP9600 (Peter Robinson)

View File

@ -12,6 +12,8 @@
drivers/firmware/efi/Makefile | 1 + drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/efi.c | 124 +++++++++++---- drivers/firmware/efi/efi.c | 124 +++++++++++----
drivers/firmware/efi/secureboot.c | 38 +++++ drivers/firmware/efi/secureboot.c | 38 +++++
drivers/firmware/sysfb.c | 18 ++-
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 2 +
drivers/hid/hid-rmi.c | 66 -------- drivers/hid/hid-rmi.c | 66 --------
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 +++ drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 +++
drivers/input/rmi4/rmi_driver.c | 124 +++++++++------ drivers/input/rmi4/rmi_driver.c | 124 +++++++++------
@ -19,6 +21,7 @@
drivers/pci/quirks.c | 24 +++ drivers/pci/quirks.c | 24 +++
drivers/scsi/sd.c | 10 ++ drivers/scsi/sd.c | 10 ++
drivers/usb/core/hub.c | 7 + drivers/usb/core/hub.c | 7 +
fs/xfs/xfs_iomap.c | 4 +-
include/linux/efi.h | 22 ++- include/linux/efi.h | 22 ++-
include/linux/lsm_hook_defs.h | 2 + include/linux/lsm_hook_defs.h | 2 +
include/linux/module.h | 1 + include/linux/module.h | 1 +
@ -33,10 +36,10 @@
security/lockdown/Kconfig | 13 ++ security/lockdown/Kconfig | 13 ++
security/lockdown/lockdown.c | 1 + security/lockdown/lockdown.c | 1 +
security/security.c | 12 ++ security/security.c | 12 ++
35 files changed, 652 insertions(+), 174 deletions(-) 38 files changed, 673 insertions(+), 177 deletions(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 95b320ada47c..0c5f6bdb7c1d 100644 index 33d8e822f6f1..0451e4e79e5c 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \ @@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -230,10 +233,10 @@ index 1687483ff319..390b67f19181 100644
return ctx.rc; return ctx.rc;
} }
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
index e6ed1ba91e5c..6a87d6ca4a84 100644 index 617f3e0e963d..92d9066ab4c2 100644
--- a/drivers/acpi/scan.c --- a/drivers/acpi/scan.c
+++ b/drivers/acpi/scan.c +++ b/drivers/acpi/scan.c
@@ -1761,6 +1761,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device) @@ -1757,6 +1757,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
if (!acpi_match_device_ids(device, ignore_serial_bus_ids)) if (!acpi_match_device_ids(device, ignore_serial_bus_ids))
return false; return false;
@ -540,6 +543,55 @@ index 000000000000..de0a3714a5d4
+ } + }
+ } + }
+} +}
diff --git a/drivers/firmware/sysfb.c b/drivers/firmware/sysfb.c
index 3c197db42c9d..16e4a2e90fae 100644
--- a/drivers/firmware/sysfb.c
+++ b/drivers/firmware/sysfb.c
@@ -34,6 +34,22 @@
#include <linux/screen_info.h>
#include <linux/sysfb.h>
+static int skip_simpledrm;
+
+static int __init simpledrm_disable(char *opt)
+{
+ if (!opt)
+ return -EINVAL;
+
+ get_option(&opt, &skip_simpledrm);
+
+ if (skip_simpledrm)
+ pr_info("The simpledrm driver will not be probed\n");
+
+ return 0;
+}
+early_param("nvidia-drm.modeset", simpledrm_disable);
+
static struct platform_device *pd;
static DEFINE_MUTEX(disable_lock);
static bool disabled;
@@ -85,7 +101,7 @@ static __init int sysfb_init(void)
/* try to create a simple-framebuffer device */
compatible = sysfb_parse_mode(si, &mode);
- if (compatible) {
+ if (compatible && !skip_simpledrm) {
pd = sysfb_create_simplefb(si, &mode);
if (!IS_ERR(pd))
goto unlock_mutex;
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
index 94bdb5fa6ebc..1fbaf7b81d69 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
@@ -4524,6 +4524,8 @@ int amdgpu_device_prepare(struct drm_device *dev)
if (r)
goto unprepare;
+ flush_delayed_work(&adev->gfx.gfx_off_delay_work);
+
for (i = 0; i < adev->num_ip_blocks; i++) {
if (!adev->ip_blocks[i].status.valid)
continue;
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
index d4af17fdba46..154f0403cbf4 100644 index d4af17fdba46..154f0403cbf4 100644
--- a/drivers/hid/hid-rmi.c --- a/drivers/hid/hid-rmi.c
@ -643,7 +695,7 @@ index d4af17fdba46..154f0403cbf4 100644
data->xport.ops = &hid_rmi_ops; data->xport.ops = &hid_rmi_ops;
diff --git a/drivers/hwtracing/coresight/coresight-etm4x-core.c b/drivers/hwtracing/coresight/coresight-etm4x-core.c diff --git a/drivers/hwtracing/coresight/coresight-etm4x-core.c b/drivers/hwtracing/coresight/coresight-etm4x-core.c
index ce1995a2827f..57f9e9de4747 100644 index 2e2cabc5f50a..8b44d990f978 100644
--- a/drivers/hwtracing/coresight/coresight-etm4x-core.c --- a/drivers/hwtracing/coresight/coresight-etm4x-core.c
+++ b/drivers/hwtracing/coresight/coresight-etm4x-core.c +++ b/drivers/hwtracing/coresight/coresight-etm4x-core.c
@@ -10,6 +10,7 @@ @@ -10,6 +10,7 @@
@ -886,7 +938,7 @@ index 42eaebb3bf5c..7a35119c3144 100644
if (data->f01_container->dev.driver) { if (data->f01_container->dev.driver) {
/* Driver already bound, so enable ATTN now. */ /* Driver already bound, so enable ATTN now. */
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index d14413916f93..ff6cbc3fa509 100644 index cd1210026ac5..448d146c6757 100644
--- a/drivers/iommu/iommu.c --- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c +++ b/drivers/iommu/iommu.c
@@ -8,6 +8,7 @@ @@ -8,6 +8,7 @@
@ -897,7 +949,7 @@ index d14413916f93..ff6cbc3fa509 100644
#include <linux/kernel.h> #include <linux/kernel.h>
#include <linux/bits.h> #include <linux/bits.h>
#include <linux/bug.h> #include <linux/bug.h>
@@ -3095,6 +3096,27 @@ int iommu_dev_disable_feature(struct device *dev, enum iommu_dev_features feat) @@ -3106,6 +3107,27 @@ int iommu_dev_disable_feature(struct device *dev, enum iommu_dev_features feat)
} }
EXPORT_SYMBOL_GPL(iommu_dev_disable_feature); EXPORT_SYMBOL_GPL(iommu_dev_disable_feature);
@ -926,7 +978,7 @@ index d14413916f93..ff6cbc3fa509 100644
* iommu_setup_default_domain - Set the default_domain for the group * iommu_setup_default_domain - Set the default_domain for the group
* @group: Group to change * @group: Group to change
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
index d797df6e5f3e..a6921ee1535a 100644 index 2ebbe51a7efe..503f79c60365 100644
--- a/drivers/pci/quirks.c --- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c +++ b/drivers/pci/quirks.c
@@ -4433,6 +4433,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000, @@ -4433,6 +4433,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
@ -1006,6 +1058,28 @@ index e38a4124f610..0a607946e5f9 100644
/* Lock the device, then check to see if we were /* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */ * disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev); usb_lock_device(hdev);
diff --git a/fs/xfs/xfs_iomap.c b/fs/xfs/xfs_iomap.c
index 18c8f168b153..055cdec2e9ad 100644
--- a/fs/xfs/xfs_iomap.c
+++ b/fs/xfs/xfs_iomap.c
@@ -1323,7 +1323,7 @@ xfs_seek_iomap_begin(
if (cow_fsb != NULLFILEOFF && cow_fsb <= offset_fsb) {
if (data_fsb < cow_fsb + cmap.br_blockcount)
end_fsb = min(end_fsb, data_fsb);
- xfs_trim_extent(&cmap, offset_fsb, end_fsb);
+ xfs_trim_extent(&cmap, offset_fsb, end_fsb - offset_fsb);
seq = xfs_iomap_inode_sequence(ip, IOMAP_F_SHARED);
error = xfs_bmbt_to_iomap(ip, iomap, &cmap, flags,
IOMAP_F_SHARED, seq);
@@ -1348,7 +1348,7 @@ xfs_seek_iomap_begin(
imap.br_state = XFS_EXT_NORM;
done:
seq = xfs_iomap_inode_sequence(ip, 0);
- xfs_trim_extent(&imap, offset_fsb, end_fsb);
+ xfs_trim_extent(&imap, offset_fsb, end_fsb - offset_fsb);
error = xfs_bmbt_to_iomap(ip, iomap, &imap, flags, 0, seq);
out_unlock:
xfs_iunlock(ip, lockmode);
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index c74f47711f0b..e7bbf3b7a938 100644 index c74f47711f0b..e7bbf3b7a938 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
@ -1313,7 +1387,7 @@ index d0eb20f90b26..a99c045730e9 100644
size_t *uctx_len, void *val, size_t val_len, size_t *uctx_len, void *val, size_t val_len,
u64 id, u64 flags) u64 id, u64 flags)
diff --git a/kernel/module/main.c b/kernel/module/main.c diff --git a/kernel/module/main.c b/kernel/module/main.c
index 36681911c05a..7c0a6425dd38 100644 index b0b99348e1a8..c35cc48d782c 100644
--- a/kernel/module/main.c --- a/kernel/module/main.c
+++ b/kernel/module/main.c +++ b/kernel/module/main.c
@@ -528,6 +528,7 @@ static struct module_attribute modinfo_##field = { \ @@ -528,6 +528,7 @@ static struct module_attribute modinfo_##field = { \

View File

@ -1,5 +1,5 @@
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6 SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
SHA512 (linux-6.8.1.tar.xz) = 27550debb3b1cf07f0ff49a28c390381078e4d1f30a5a08f83dcba9daae822f3fb9fa48d842fef683c1a21d9a5f1ed8da9393b477cbe29fa9330eab81f4d8495 SHA512 (linux-6.8.2.tar.xz) = 4a397c678ee94879b1bf02308580277256005c4cbc204fa6b14a1fabb96fa64518eecfef22d5a127a3000980cdce11b4cada4464dc0a3d6657effae45cdf679e
SHA512 (kernel-abi-stablelists-6.8.1.tar.xz) = fdfb154bac4f8297d2117cd8f741b35a028687b9c4845d8c788232a2273e0f441d31cccdc65887c2e7a1f8a2e6292cd21487b4593474405d543eace9f918afaa SHA512 (kernel-abi-stablelists-6.8.2.tar.xz) = 7d7192a7f6d42defa2cd7c4b9cc906be18d8e42f5eb8cf3c249726d95ed1895b314e9664512d42bfe01f6457b5aa2da9c0b92250bba1fc3d7ca74a3836b367c6
SHA512 (kernel-kabi-dw-6.8.1.tar.xz) = 89bc7384bf2359d479f4fae1c0133861d1eec7f79954c580ada27a929e41fe6d71ddb94ddc7379b5e6d2ab826e34037781fb6552052bae463dd3c9bca693244a SHA512 (kernel-kabi-dw-6.8.2.tar.xz) = a1fbec386c9694af1bdba5940d59820377b6ffce34df596b1ee04c605f4c5e7f65400494882db3d0181c9602d913851b9b902ba0f87941f19f5b2f3f6fdce0c6