riscv: fix vdso_install and a warning

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2018-11-07 22:11:46 +01:00
parent 65627459ed
commit 676aad9847
Signed by: davidlt
GPG Key ID: 7108702C938B13C1
2 changed files with 42 additions and 0 deletions

View File

@ -616,6 +616,10 @@ Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
# Fix build on s390
Patch503: 0001-s390-mm-Fix-ERROR-__node_distance-undefined.patch
# 600 - RISC-V
Patch600: riscv64-fixes.patch
# END OF PATCH DEFINITIONS
%endif

38
riscv64-fixes.patch Normal file
View File

@ -0,0 +1,38 @@
From c45bb6761613476a411a3e4d42d60e0b0dc85472 Mon Sep 17 00:00:00 2001
From: Fedora Kernel Team <kernel-team@fedoraproject.org>
Date: Wed, 7 Nov 2018 20:48:31 +0000
Subject: [PATCH] riscv64 fixes
---
arch/riscv/Makefile | 4 ++++
arch/riscv/include/asm/module.h | 1 +
2 files changed, 5 insertions(+)
diff --git a/arch/riscv/Makefile b/arch/riscv/Makefile
index d101461..4af153a 100644
--- a/arch/riscv/Makefile
+++ b/arch/riscv/Makefile
@@ -77,4 +77,8 @@ core-y += arch/riscv/kernel/ arch/riscv/mm/
libs-y += arch/riscv/lib/
+PHONY += vdso_install
+vdso_install:
+ $(Q)$(MAKE) $(build)=arch/riscv/kernel/vdso $@
+
all: vmlinux
diff --git a/arch/riscv/include/asm/module.h b/arch/riscv/include/asm/module.h
index 349df33..cd2af4b 100644
--- a/arch/riscv/include/asm/module.h
+++ b/arch/riscv/include/asm/module.h
@@ -8,6 +8,7 @@
#define MODULE_ARCH_VERMAGIC "riscv"
+struct module;
u64 module_emit_got_entry(struct module *mod, u64 val);
u64 module_emit_plt_entry(struct module *mod, u64 val);
--
2.19.1