Update compat-wireless with snapshot from 2012-01-26
Drop brcmfmac GCC 4.7 compatibility patch (included in above) Include config.mk from compat-wireless build in files for installation
This commit is contained in:
parent
30a3098cab
commit
6701fedd73
@ -1,27 +0,0 @@
|
||||
Alexandre Oliva <oliva@lsd.ic.unicamp.br> sent me a patch:
|
||||
|
||||
"I see you ran into the same problem I did in brcmfmac. I wasn't sure a
|
||||
build with compat-wireless would run into the same problem I did without
|
||||
it and with Linux-libre.
|
||||
|
||||
It's an issue brought about by GCC 4.7's partial-inlining, that ends up
|
||||
splitting the udelay function just at the wrong spot, in such a way that
|
||||
some sanity checks for constants fails, and we end up calling
|
||||
bad_udelay.
|
||||
|
||||
This patch fixes the problem. Feel free to push it upstream if it makes
|
||||
sense to you."
|
||||
|
||||
diff --git a/drivers/net/wireless/brcm80211/brcmfmac/wl_cfg80211.c b/drivers/net/wireless/brcm80211/brcmfmac/wl_cfg80211.c
|
||||
index 5eddabe..eda1d4e 100644
|
||||
--- a/drivers/net/wireless/brcm80211/brcmfmac/wl_cfg80211.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmfmac/wl_cfg80211.c
|
||||
@@ -2463,7 +2463,7 @@ static s32 brcmf_init_iscan(struct brcmf_cfg80211_priv *cfg_priv)
|
||||
return err;
|
||||
}
|
||||
|
||||
-static void brcmf_delay(u32 ms)
|
||||
+static __always_inline void brcmf_delay(u32 ms)
|
||||
{
|
||||
if (ms < 1000 / HZ) {
|
||||
cond_resched();
|
150
compat-move-br_port_exists-to-compat-2_6_36_h.patch
Normal file
150
compat-move-br_port_exists-to-compat-2_6_36_h.patch
Normal file
@ -0,0 +1,150 @@
|
||||
From linux-wireless-owner@vger.kernel.org Thu Jan 26 18:23:05 2012
|
||||
Return-Path: linville@tuxdriver.com
|
||||
Received: from zmta01.collab.prod.int.phx2.redhat.com (LHLO
|
||||
zmta01.collab.prod.int.phx2.redhat.com) (10.5.5.31) by
|
||||
zmail15.collab.prod.int.phx2.redhat.com with LMTP; Thu, 26 Jan 2012
|
||||
18:23:05 -0500 (EST)
|
||||
Received: from localhost (localhost.localdomain [127.0.0.1]) by
|
||||
zmta01.collab.prod.int.phx2.redhat.com (Postfix) with ESMTP id BEE90114AAB
|
||||
for <linville@redhat.com>; Thu, 26 Jan 2012 18:23:05 -0500 (EST)
|
||||
Received: from zmta01.collab.prod.int.phx2.redhat.com ([127.0.0.1]) by
|
||||
localhost (zmta01.collab.prod.int.phx2.redhat.com [127.0.0.1])
|
||||
(amavisd-new, port 10024) with ESMTP id vqGh0M65OdhD for
|
||||
<linville@redhat.com>; Thu, 26 Jan 2012 18:23:05 -0500 (EST)
|
||||
Received: from int-mx10.intmail.prod.int.phx2.redhat.com
|
||||
(int-mx10.intmail.prod.int.phx2.redhat.com [10.5.11.23]) by
|
||||
zmta01.collab.prod.int.phx2.redhat.com (Postfix) with ESMTP id AB0BE114A54
|
||||
for <linville@mail.corp.redhat.com>; Thu, 26 Jan 2012 18:23:05 -0500 (EST)
|
||||
Received: from mx1.redhat.com (ext-mx13.extmail.prod.ext.phx2.redhat.com
|
||||
[10.5.110.18]) by int-mx10.intmail.prod.int.phx2.redhat.com (8.14.4/8.14.4)
|
||||
with ESMTP id q0QNN44o004565 for <linville@redhat.com>; Thu, 26 Jan 2012
|
||||
18:23:05 -0500
|
||||
Received: from smtp.tuxdriver.com (charlotte.tuxdriver.com [70.61.120.58])
|
||||
by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id q0QNN2jG004833 for
|
||||
<linville@redhat.com>; Thu, 26 Jan 2012 18:23:03 -0500
|
||||
Received: from sapphire.tuxdriver.com ([70.61.120.61] helo=localhost) by
|
||||
smtp.tuxdriver.com with esmtp (Exim 4.63) (envelope-from
|
||||
<linville@tuxdriver.com>) id 1RqYej-0005zd-E7 for linville@redhat.com; Thu,
|
||||
26 Jan 2012 18:23:01 -0500
|
||||
Resent-From: "John W. Linville" <linville@tuxdriver.com>
|
||||
Resent-Date: Thu, 26 Jan 2012 18:22:43 -0500
|
||||
Resent-Message-ID: <20120126232243.GA2190@tuxdriver.com>
|
||||
Resent-To: linville@redhat.com
|
||||
Received: from vger.kernel.org ([209.132.180.67]) by smtp.tuxdriver.com
|
||||
with esmtp (Exim 4.63) (envelope-from
|
||||
<linux-wireless-owner@vger.kernel.org>) id 1RqYC2-0005sF-Ja for
|
||||
linville@tuxdriver.com; Thu, 26 Jan 2012 17:53:25 -0500
|
||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id
|
||||
S1753594Ab2AZWxH (ORCPT <rfc822;linville@tuxdriver.com>); Thu, 26 Jan 2012
|
||||
17:53:07 -0500
|
||||
Received: from server19320154104.serverpool.info ([193.201.54.104]:51996
|
||||
"EHLO hauke-m.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id
|
||||
S1753449Ab2AZWxG (ORCPT <rfc822;linux-wireless@vger.kernel.org>); Thu, 26
|
||||
Jan 2012 17:53:06 -0500
|
||||
Received: from localhost (localhost [127.0.0.1]) by hauke-m.de (Postfix)
|
||||
with ESMTP id CCCF88F60; Thu, 26 Jan 2012 23:53:03 +0100 (CET)
|
||||
X-Virus-Scanned: Debian amavisd-new at hauke-m.de
|
||||
Received: from hauke-m.de ([127.0.0.1]) by localhost (hauke-m.de
|
||||
[127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LKxWWkfakUtI; Thu, 26
|
||||
Jan 2012 23:51:49 +0100 (CET)
|
||||
Received: from localhost.localdomain (unknown [134.102.132.222]) by
|
||||
hauke-m.de (Postfix) with ESMTPSA id DBFF98F61; Thu, 26 Jan 2012 23:51:48
|
||||
+0100 (CET)
|
||||
From: Hauke Mehrtens <hauke@hauke-m.de>
|
||||
To: mcgrof@gmail.com, mcgrof@qca.qualcomm.com
|
||||
Cc: linux-wireless@vger.kernel.org, Hauke Mehrtens <hauke@hauke-m.de>
|
||||
Subject: [PATCH] compat: move br_port_exists() to compat-2.6.36.h
|
||||
Date: Thu, 26 Jan 2012 23:51:45 +0100
|
||||
Message-Id: <1327618305-23077-1-git-send-email-hauke@hauke-m.de>
|
||||
Sender: linux-wireless-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-wireless.vger.kernel.org>
|
||||
X-Mailing-List: linux-wireless@vger.kernel.org
|
||||
X-Spam-Status: No
|
||||
X-RedHat-Spam-Score: -0.01 (T_RP_MATCHES_RCVD)
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.11.23
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.110.18
|
||||
X-Evolution-Source: imap://linville@mail.corp.redhat.com/
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Mime-Version: 1.0
|
||||
|
||||
br_port_exists() was moved to a new compat-*.h file for every new
|
||||
kernel release, as it is not in mainline. This patch moves it to compat-
|
||||
2.6.36.h so it has not to be moved any more for a new kernel version.
|
||||
|
||||
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
||||
---
|
||||
include/linux/compat-2.6.36.h | 15 +++++++++++++++
|
||||
include/linux/compat-3.3.h | 17 -----------------
|
||||
2 files changed, 15 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/include/linux/compat-2.6.36.h b/include/linux/compat-2.6.36.h
|
||||
index b5d9975..314fb35 100644
|
||||
--- a/include/linux/compat-2.6.36.h
|
||||
+++ b/include/linux/compat-2.6.36.h
|
||||
@@ -142,6 +142,8 @@ extern struct workqueue_struct *system_nrt_wq;
|
||||
void compat_system_workqueue_create(void);
|
||||
void compat_system_workqueue_destroy(void);
|
||||
|
||||
+#define br_port_exists(dev) (dev->br_port)
|
||||
+
|
||||
#else
|
||||
|
||||
static inline void compat_system_workqueue_create(void)
|
||||
@@ -152,6 +154,19 @@ static inline void compat_system_workqueue_destroy(void)
|
||||
{
|
||||
}
|
||||
|
||||
+/*
|
||||
+ * This is not part of The 2.6.37 kernel yet but we
|
||||
+ * we use it to optimize the backport code we
|
||||
+ * need to implement. Instead of using ifdefs
|
||||
+ * to check what version of the check we use
|
||||
+ * we just replace all checks on current code
|
||||
+ * with this. I'll submit this upstream too, that
|
||||
+ * way all we'd have to do is to implement this
|
||||
+ * for older kernels, then we would not have to
|
||||
+ * edit the upstrema code for backport efforts.
|
||||
+ */
|
||||
+#define br_port_exists(dev) (dev->priv_flags & IFF_BRIDGE_PORT)
|
||||
+
|
||||
#endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,36)) */
|
||||
|
||||
#endif /* LINUX_26_36_COMPAT_H */
|
||||
diff --git a/include/linux/compat-3.3.h b/include/linux/compat-3.3.h
|
||||
index 821333c..4965f23 100644
|
||||
--- a/include/linux/compat-3.3.h
|
||||
+++ b/include/linux/compat-3.3.h
|
||||
@@ -8,23 +8,6 @@
|
||||
/* include to override NL80211_FEATURE_SK_TX_STATUS */
|
||||
#include <linux/nl80211.h>
|
||||
|
||||
-/*
|
||||
- * This is not part of The 2.6.37 kernel yet but we
|
||||
- * we use it to optimize the backport code we
|
||||
- * need to implement. Instead of using ifdefs
|
||||
- * to check what version of the check we use
|
||||
- * we just replace all checks on current code
|
||||
- * with this. I'll submit this upstream too, that
|
||||
- * way all we'd have to do is to implement this
|
||||
- * for older kernels, then we would not have to
|
||||
- * edit the upstrema code for backport efforts.
|
||||
- */
|
||||
-#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36))
|
||||
-#define br_port_exists(dev) (dev->priv_flags & IFF_BRIDGE_PORT)
|
||||
-#else
|
||||
-#define br_port_exists(dev) (dev->br_port)
|
||||
-#endif
|
||||
-
|
||||
static inline void skb_complete_wifi_ack(struct sk_buff *skb, bool acked)
|
||||
{
|
||||
WARN_ON(1);
|
||||
--
|
||||
1.7.5.4
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up compat-wireless-2011-12-18/config.mk.orig compat-wireless-2011-12-18/config.mk
|
||||
--- compat-wireless-2011-12-18/config.mk.orig 2012-01-05 13:54:21.214595837 -0500
|
||||
+++ compat-wireless-2011-12-18/config.mk 2012-01-05 13:54:35.668415136 -0500
|
||||
diff -up compat-wireless-2012-01-24/config.mk.orig compat-wireless-2012-01-24/config.mk
|
||||
--- compat-wireless-2012-01-24/config.mk.orig 2012-01-24 16:12:12.000000000 -0500
|
||||
+++ compat-wireless-2012-01-24/config.mk 2012-01-25 13:34:20.315899694 -0500
|
||||
@@ -14,6 +14,9 @@ else
|
||||
include $(KLIB_BUILD)/.config
|
||||
endif
|
||||
@ -11,33 +11,15 @@ diff -up compat-wireless-2011-12-18/config.mk.orig compat-wireless-2011-12-18/co
|
||||
ifneq ($(wildcard $(KLIB_BUILD)/Makefile),)
|
||||
|
||||
COMPAT_LATEST_VERSION = 3
|
||||
@@ -395,7 +398,7 @@ ifdef CONFIG_CRC_CCITT
|
||||
CONFIG_RT2800PCI=m
|
||||
CONFIG_RT2800PCI_RT33XX=y
|
||||
CONFIG_RT2800PCI_RT35XX=y
|
||||
-# CONFIG_RT2800PCI_RT53XX=y
|
||||
+CONFIG_RT2800PCI_RT53XX=y
|
||||
endif #CONFIG_CRC_CCITT
|
||||
NEED_RT2X00=y
|
||||
|
||||
@@ -525,7 +528,7 @@ ifdef CONFIG_CRC_CCITT
|
||||
CONFIG_RT2800USB=m
|
||||
CONFIG_RT2800USB_RT33XX=y
|
||||
CONFIG_RT2800USB_RT35XX=y
|
||||
-# CONFIG_RT2800USB_RT53XX=y
|
||||
+CONFIG_RT2800USB_RT53XX=y
|
||||
CONFIG_RT2800USB_UNKNOWN=y
|
||||
endif #CONFIG_CRC_CCITT
|
||||
CONFIG_RT2X00_LIB_USB=m
|
||||
diff -up compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile.orig compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile
|
||||
--- compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile.orig 2012-01-05 13:54:21.214595837 -0500
|
||||
+++ compat-wireless-2011-12-18/drivers/misc/eeprom/Makefile 2012-01-05 13:54:27.274520077 -0500
|
||||
diff -up compat-wireless-2012-01-24/drivers/misc/eeprom/Makefile.orig compat-wireless-2012-01-24/drivers/misc/eeprom/Makefile
|
||||
--- compat-wireless-2012-01-24/drivers/misc/eeprom/Makefile.orig 2012-01-24 16:12:15.000000000 -0500
|
||||
+++ compat-wireless-2012-01-24/drivers/misc/eeprom/Makefile 2012-01-25 13:34:20.316899682 -0500
|
||||
@@ -1 +1 @@
|
||||
-obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
|
||||
+#obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
|
||||
diff -up compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile
|
||||
--- compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig 2012-01-05 13:54:21.215595824 -0500
|
||||
+++ compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile 2012-01-05 13:54:27.275520064 -0500
|
||||
diff -up compat-wireless-2012-01-24/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-2012-01-24/drivers/net/ethernet/atheros/Makefile
|
||||
--- compat-wireless-2012-01-24/drivers/net/ethernet/atheros/Makefile.orig 2012-01-24 16:12:13.000000000 -0500
|
||||
+++ compat-wireless-2012-01-24/drivers/net/ethernet/atheros/Makefile 2012-01-25 13:34:20.316899682 -0500
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for the Atheros network device drivers.
|
||||
#
|
||||
@ -50,9 +32,9 @@ diff -up compat-wireless-2011-12-18/drivers/net/ethernet/atheros/Makefile.orig c
|
||||
+#obj-$(CONFIG_ATL2) += atlx/
|
||||
+#obj-$(CONFIG_ATL1E) += atl1e/
|
||||
+#obj-$(CONFIG_ATL1C) += atl1c/
|
||||
diff -up compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig compat-wireless-2011-12-18/drivers/net/usb/Makefile
|
||||
--- compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig 2012-01-05 13:54:21.215595824 -0500
|
||||
+++ compat-wireless-2011-12-18/drivers/net/usb/Makefile 2012-01-05 13:54:27.275520064 -0500
|
||||
diff -up compat-wireless-2012-01-24/drivers/net/usb/Makefile.orig compat-wireless-2012-01-24/drivers/net/usb/Makefile
|
||||
--- compat-wireless-2012-01-24/drivers/net/usb/Makefile.orig 2012-01-24 16:12:15.000000000 -0500
|
||||
+++ compat-wireless-2012-01-24/drivers/net/usb/Makefile 2012-01-25 13:34:20.316899682 -0500
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for USB Network drivers
|
||||
#
|
||||
@ -64,21 +46,21 @@ diff -up compat-wireless-2011-12-18/drivers/net/usb/Makefile.orig compat-wireles
|
||||
+#obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
|
||||
+#obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
|
||||
|
||||
diff -up compat-wireless-2011-12-18/Makefile.orig compat-wireless-2011-12-18/Makefile
|
||||
--- compat-wireless-2011-12-18/Makefile.orig 2012-01-05 13:54:21.216595811 -0500
|
||||
+++ compat-wireless-2011-12-18/Makefile 2012-01-05 13:54:27.276520051 -0500
|
||||
@@ -8,8 +8,8 @@ endif
|
||||
export KLIB_BUILD ?= $(KLIB)/build
|
||||
# Sometimes not available in the path
|
||||
diff -up compat-wireless-2012-01-24/Makefile.orig compat-wireless-2012-01-24/Makefile
|
||||
--- compat-wireless-2012-01-24/Makefile.orig 2012-01-24 16:12:12.000000000 -0500
|
||||
+++ compat-wireless-2012-01-24/Makefile 2012-01-25 13:34:58.502422295 -0500
|
||||
@@ -10,8 +10,8 @@ export KLIB_BUILD ?= $(KLIB)/build
|
||||
MODPROBE := /sbin/modprobe
|
||||
|
||||
ifneq ($(wildcard $(MODPROBE)),)
|
||||
-MADWIFI=$(shell $(MODPROBE) -l ath_pci)
|
||||
-OLD_IWL=$(shell $(MODPROBE) -l iwl4965)
|
||||
+MADWIFI=""
|
||||
+OLD_IWL=""
|
||||
endif
|
||||
|
||||
DESTDIR?=
|
||||
|
||||
@@ -41,8 +41,8 @@ endif
|
||||
@@ -44,8 +44,8 @@ endif
|
||||
|
||||
endif
|
||||
|
||||
|
137
compat-wireless-fix-some-config-options.patch
Normal file
137
compat-wireless-fix-some-config-options.patch
Normal file
@ -0,0 +1,137 @@
|
||||
From linux-wireless-owner@vger.kernel.org Thu Jan 26 18:23:33 2012
|
||||
Return-Path: linville@tuxdriver.com
|
||||
Received: from zmta02.collab.prod.int.phx2.redhat.com (LHLO
|
||||
zmta02.collab.prod.int.phx2.redhat.com) (10.5.5.32) by
|
||||
zmail15.collab.prod.int.phx2.redhat.com with LMTP; Thu, 26 Jan 2012
|
||||
18:23:33 -0500 (EST)
|
||||
Received: from localhost (localhost.localdomain [127.0.0.1]) by
|
||||
zmta02.collab.prod.int.phx2.redhat.com (Postfix) with ESMTP id 3BF74128BE0
|
||||
for <linville@redhat.com>; Thu, 26 Jan 2012 18:23:33 -0500 (EST)
|
||||
Received: from zmta02.collab.prod.int.phx2.redhat.com ([127.0.0.1]) by
|
||||
localhost (zmta02.collab.prod.int.phx2.redhat.com [127.0.0.1])
|
||||
(amavisd-new, port 10024) with ESMTP id 130PQ7pzqAEV for
|
||||
<linville@redhat.com>; Thu, 26 Jan 2012 18:23:33 -0500 (EST)
|
||||
Received: from int-mx09.intmail.prod.int.phx2.redhat.com
|
||||
(int-mx09.intmail.prod.int.phx2.redhat.com [10.5.11.22]) by
|
||||
zmta02.collab.prod.int.phx2.redhat.com (Postfix) with ESMTP id 24E00128BDF
|
||||
for <linville@mail.corp.redhat.com>; Thu, 26 Jan 2012 18:23:33 -0500 (EST)
|
||||
Received: from mx1.redhat.com (ext-mx11.extmail.prod.ext.phx2.redhat.com
|
||||
[10.5.110.16]) by int-mx09.intmail.prod.int.phx2.redhat.com (8.14.4/8.14.4)
|
||||
with ESMTP id q0QNNXuF014708 for <linville@redhat.com>; Thu, 26 Jan 2012
|
||||
18:23:33 -0500
|
||||
Received: from smtp.tuxdriver.com (charlotte.tuxdriver.com [70.61.120.58])
|
||||
by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id q0QNNWYF026587 for
|
||||
<linville@redhat.com>; Thu, 26 Jan 2012 18:23:32 -0500
|
||||
Received: from sapphire.tuxdriver.com ([70.61.120.61] helo=localhost) by
|
||||
smtp.tuxdriver.com with esmtp (Exim 4.63) (envelope-from
|
||||
<linville@tuxdriver.com>) id 1RqYfD-0005zt-9K for linville@redhat.com; Thu,
|
||||
26 Jan 2012 18:23:31 -0500
|
||||
Resent-From: "John W. Linville" <linville@tuxdriver.com>
|
||||
Resent-Date: Thu, 26 Jan 2012 18:23:12 -0500
|
||||
Resent-Message-ID: <20120126232312.GB2190@tuxdriver.com>
|
||||
Resent-To: linville@redhat.com
|
||||
Received: from vger.kernel.org ([209.132.180.67]) by smtp.tuxdriver.com
|
||||
with esmtp (Exim 4.63) (envelope-from
|
||||
<linux-wireless-owner@vger.kernel.org>) id 1RqYEt-0005tm-3A for
|
||||
linville@tuxdriver.com; Thu, 26 Jan 2012 17:56:21 -0500
|
||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id
|
||||
S1752042Ab2AZWzw (ORCPT <rfc822;linville@tuxdriver.com>); Thu, 26 Jan 2012
|
||||
17:55:52 -0500
|
||||
Received: from server19320154104.serverpool.info ([193.201.54.104]:52032
|
||||
"EHLO hauke-m.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id
|
||||
S1751796Ab2AZWzv (ORCPT <rfc822;linux-wireless@vger.kernel.org>); Thu, 26
|
||||
Jan 2012 17:55:51 -0500
|
||||
Received: from localhost (localhost [127.0.0.1]) by hauke-m.de (Postfix)
|
||||
with ESMTP id E6CFE8F61; Thu, 26 Jan 2012 23:55:50 +0100 (CET)
|
||||
X-Virus-Scanned: Debian amavisd-new at hauke-m.de
|
||||
Received: from hauke-m.de ([127.0.0.1]) by localhost (hauke-m.de
|
||||
[127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HGH3hmHAsDa7; Thu, 26
|
||||
Jan 2012 23:55:47 +0100 (CET)
|
||||
Received: from localhost.localdomain (unknown [134.102.132.222]) by
|
||||
hauke-m.de (Postfix) with ESMTPSA id F1F248F60; Thu, 26 Jan 2012 23:55:46
|
||||
+0100 (CET)
|
||||
From: Hauke Mehrtens <hauke@hauke-m.de>
|
||||
To: mcgrof@gmail.com, mcgrof@qca.qualcomm.com
|
||||
Cc: linux-wireless@vger.kernel.org, Hauke Mehrtens <hauke@hauke-m.de>
|
||||
Subject: [PATCH] compat-wireless: fix some config options
|
||||
Date: Thu, 26 Jan 2012 23:55:44 +0100
|
||||
Message-Id: <1327618544-23163-1-git-send-email-hauke@hauke-m.de>
|
||||
Sender: linux-wireless-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-wireless.vger.kernel.org>
|
||||
X-Mailing-List: linux-wireless@vger.kernel.org
|
||||
X-Spam-Status: No
|
||||
X-RedHat-Spam-Score: -0.01 (T_RP_MATCHES_RCVD)
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.11.22
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.110.16
|
||||
X-Evolution-Source: imap://linville@mail.corp.redhat.com/
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Mime-Version: 1.0
|
||||
|
||||
Adds some missing config options interceded in the last time and remove
|
||||
some old now unused config options.
|
||||
|
||||
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
||||
---
|
||||
config.mk | 8 +++++---
|
||||
1 files changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/config.mk b/config.mk
|
||||
index 4d2ad5c..9433ce9 100644
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -281,6 +281,8 @@ CONFIG_ATH9K_COMMON=m
|
||||
# for long range considerations.
|
||||
CONFIG_ATH9K_RATE_CONTROL=y
|
||||
|
||||
+CONFIG_ATH9K_BTCOEX_SUPPORT=y
|
||||
+
|
||||
# PCI Drivers
|
||||
ifdef CONFIG_PCI
|
||||
|
||||
@@ -288,10 +290,10 @@ CONFIG_ATH5K_PCI=y
|
||||
CONFIG_ATH9K_PCI=y
|
||||
|
||||
CONFIG_IWLWIFI=m
|
||||
+CONFIG_IWLWIFI_P2P=y
|
||||
# CONFIG_IWLWIFI_DEBUG=y
|
||||
# CONFIG_IWLWIFI_DEBUGFS=y
|
||||
# CONFIG_IWLWIFI_DEVICE_TRACING=y
|
||||
-# CONFIG_IWLWIFI_DEVICE_SVTOOL=y
|
||||
# CONFIG_IWLWIFI_DEBUG_EXPERIMENTAL_UCODE=y
|
||||
|
||||
CONFIG_IWLEGACY=m
|
||||
@@ -314,7 +316,6 @@ CONFIG_B43_PHY_LP=y
|
||||
CONFIG_B43_PHY_N=y
|
||||
CONFIG_B43_PHY_HT=y
|
||||
# CONFIG_B43_PHY_LCN=y
|
||||
-# CONFIG_B43_FORCE_PIO=y
|
||||
# CONFIG_B43_DEBUG=y
|
||||
|
||||
CONFIG_B43LEGACY=m
|
||||
@@ -375,7 +376,7 @@ CONFIG_BCMA_BLOCKIO=y
|
||||
CONFIG_BCMA_HOST_PCI=y
|
||||
# CONFIG_BCMA_DEBUG=y
|
||||
CONFIG_B43_BCMA=y
|
||||
-CONFIG_B43_BCMA_PIO=y
|
||||
+CONFIG_B43_BCMA_EXTRA=y
|
||||
|
||||
CONFIG_P54_PCI=m
|
||||
|
||||
@@ -614,6 +615,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
|
||||
ifndef CONFIG_COMPAT_KERNEL_2_6_29
|
||||
CONFIG_BRCMFMAC=m
|
||||
+CONFIG_BRCMFMAC_SDIO=y
|
||||
endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
|
||||
endif #CONFIG_MMC
|
||||
--
|
||||
1.7.5.4
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||
|
||||
|
14
compat-wireless-use-kconfig_h.patch
Normal file
14
compat-wireless-use-kconfig_h.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up compat-wireless-2012-01-24/include/linux/compat-2.6.h.orig compat-wireless-2012-01-24/include/linux/compat-2.6.h
|
||||
--- compat-wireless-2012-01-24/include/linux/compat-2.6.h.orig 2012-01-26 11:05:25.687613527 -0500
|
||||
+++ compat-wireless-2012-01-24/include/linux/compat-2.6.h 2012-01-26 11:05:48.997322113 -0500
|
||||
@@ -2,7 +2,9 @@
|
||||
#define LINUX_26_COMPAT_H
|
||||
|
||||
#include <linux/version.h>
|
||||
-#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
|
||||
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,1,0))
|
||||
+#include <linux/kconfig.h>
|
||||
+#elif (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
|
||||
#include <generated/autoconf.h>
|
||||
#else
|
||||
#include <linux/autoconf.h>
|
23
kernel.spec
23
kernel.spec
@ -208,7 +208,7 @@ Summary: The Linux kernel
|
||||
%define kversion 3.%{base_sublevel}
|
||||
|
||||
# The compat-wireless version
|
||||
%define cwversion 2012-01-09
|
||||
%define cwversion 2012-01-26
|
||||
|
||||
#######################################################################
|
||||
# If cwversion is less than kversion, make sure with_backports is
|
||||
@ -218,7 +218,7 @@ Summary: The Linux kernel
|
||||
#
|
||||
# (Uncomment the '#' and both spaces below to disable with_backports.)
|
||||
#
|
||||
%define with_backports 0
|
||||
# % define with_backports 0
|
||||
#######################################################################
|
||||
|
||||
%define make_target bzImage
|
||||
@ -745,8 +745,9 @@ Patch21091: kmemleak.patch
|
||||
Patch50000: compat-wireless-config-fixups.patch
|
||||
Patch50001: compat-wireless-pr_fmt-warning-avoidance.patch
|
||||
Patch50002: compat-wireless-integrated-build.patch
|
||||
|
||||
Patch50100: brcmfmac-gcc47.patch
|
||||
Patch50003: compat-wireless-use-kconfig_h.patch
|
||||
Patch50004: compat-move-br_port_exists-to-compat-2_6_36_h.patch
|
||||
Patch50005: compat-wireless-fix-some-config-options.patch
|
||||
|
||||
|
||||
%endif
|
||||
@ -1498,8 +1499,9 @@ cd compat-wireless-%{cwversion}
|
||||
ApplyPatch compat-wireless-config-fixups.patch
|
||||
ApplyPatch compat-wireless-pr_fmt-warning-avoidance.patch
|
||||
ApplyPatch compat-wireless-integrated-build.patch
|
||||
|
||||
ApplyPatch brcmfmac-gcc47.patch
|
||||
ApplyPatch compat-wireless-use-kconfig_h.patch
|
||||
ApplyPatch compat-move-br_port_exists-to-compat-2_6_36_h.patch
|
||||
ApplyPatch compat-wireless-fix-some-config-options.patch
|
||||
|
||||
cd ..
|
||||
|
||||
@ -1785,6 +1787,9 @@ BuildKernel() {
|
||||
|
||||
cd ../compat-wireless-%{cwversion}/
|
||||
|
||||
install -m 644 config.mk \
|
||||
$RPM_BUILD_ROOT/boot/config.mk-compat-wireless-%{cwversion}-$KernelVer
|
||||
|
||||
make -s ARCH=$Arch V=1 %{?_smp_mflags} \
|
||||
KLIB_BUILD=../linux-%{kversion}.%{_target_cpu} \
|
||||
KMODPATH_ARG="INSTALL_MOD_PATH=$RPM_BUILD_ROOT" \
|
||||
@ -2224,6 +2229,7 @@ fi
|
||||
/lib/modules/%{KVERREL}%{?2:.%{2}}/source\
|
||||
/lib/modules/%{KVERREL}%{?2:.%{2}}/updates\
|
||||
%if %{with_backports}\
|
||||
/boot/config.mk-compat-wireless-%{cwversion}-%{KVERREL}%{?2:.%{2}}\
|
||||
/lib/modules/%{KVERREL}%{?2:.%{2}}/backports\
|
||||
%endif\
|
||||
%ifarch %{vdso_arches}\
|
||||
@ -2272,6 +2278,11 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Jan 27 2012 John W. Linville <linville@redhat.com>
|
||||
- Update compat-wireless with snapshot from 2012-01-26
|
||||
- Drop brcmfmac GCC 4.7 compatibility patch (included in above)
|
||||
- Include config.mk from compat-wireless build in files for installation
|
||||
|
||||
* Fri Jan 27 2012 Josh Boyer <jwboyer@redhat.com> - 3.3.0-0.rc1.git4.1
|
||||
- Linux 3.3-rc1-git4 (upstream 74ea15d909b31158f9b63190a95b52bc05586d4b)
|
||||
- Enable the non-staging GMA500 driver (rhbz 785053)
|
||||
|
Loading…
Reference in New Issue
Block a user