add some highbank fixes that are queued for 3.12
also provide a way to turn off modules extra processing.
This commit is contained in:
parent
9cb73b95df
commit
663b7fc9c8
200
arm-highbank-for-3.12.patch
Normal file
200
arm-highbank-for-3.12.patch
Normal file
@ -0,0 +1,200 @@
|
||||
diff --git a/arch/arm/include/asm/mach/arch.h b/arch/arm/include/asm/mach/arch.h
|
||||
index 441efc4..d91b168 100644
|
||||
--- a/arch/arm/include/asm/mach/arch.h
|
||||
+++ b/arch/arm/include/asm/mach/arch.h
|
||||
@@ -35,7 +35,7 @@ struct machine_desc {
|
||||
unsigned int nr_irqs; /* number of IRQs */
|
||||
|
||||
#ifdef CONFIG_ZONE_DMA
|
||||
- unsigned long dma_zone_size; /* size of DMA-able area */
|
||||
+ phys_addr_t dma_zone_size; /* size of DMA-able area */
|
||||
#endif
|
||||
|
||||
unsigned int video_start; /* start of video RAM */
|
||||
diff --git a/arch/arm/include/asm/outercache.h b/arch/arm/include/asm/outercache.h
|
||||
index 12f71a1..f94784f 100644
|
||||
--- a/arch/arm/include/asm/outercache.h
|
||||
+++ b/arch/arm/include/asm/outercache.h
|
||||
@@ -37,10 +37,10 @@ struct outer_cache_fns {
|
||||
void (*resume)(void);
|
||||
};
|
||||
|
||||
-#ifdef CONFIG_OUTER_CACHE
|
||||
-
|
||||
extern struct outer_cache_fns outer_cache;
|
||||
|
||||
+#ifdef CONFIG_OUTER_CACHE
|
||||
+
|
||||
static inline void outer_inv_range(phys_addr_t start, phys_addr_t end)
|
||||
{
|
||||
if (outer_cache.inv_range)
|
||||
diff --git a/arch/arm/mach-highbank/Kconfig b/arch/arm/mach-highbank/Kconfig
|
||||
index cd9fcb1..b9dd13a 100644
|
||||
--- a/arch/arm/mach-highbank/Kconfig
|
||||
+++ b/arch/arm/mach-highbank/Kconfig
|
||||
@@ -1,9 +1,14 @@
|
||||
config ARCH_HIGHBANK
|
||||
bool "Calxeda ECX-1000/2000 (Highbank/Midway)" if ARCH_MULTI_V7
|
||||
+ select ARCH_DMA_ADDR_T_64BIT if ARM_LPAE
|
||||
select ARCH_HAS_CPUFREQ
|
||||
+ select ARCH_HAS_HOLES_MEMORYMODEL
|
||||
select ARCH_HAS_OPP
|
||||
select ARCH_WANT_OPTIONAL_GPIOLIB
|
||||
select ARM_AMBA
|
||||
+ select ARM_ERRATA_764369
|
||||
+ select ARM_ERRATA_775420
|
||||
+ select ARM_ERRATA_798181
|
||||
select ARM_GIC
|
||||
select ARM_TIMER_SP804
|
||||
select CACHE_L2X0
|
||||
@@ -18,3 +23,4 @@ config ARCH_HIGHBANK
|
||||
select PL320_MBOX
|
||||
select SPARSE_IRQ
|
||||
select USE_OF
|
||||
+ select ZONE_DMA if ARM_LPAE
|
||||
diff --git a/arch/arm/mach-highbank/highbank.c b/arch/arm/mach-highbank/highbank.c
|
||||
index 8881579..8e63ccd 100644
|
||||
--- a/arch/arm/mach-highbank/highbank.c
|
||||
+++ b/arch/arm/mach-highbank/highbank.c
|
||||
@@ -18,14 +18,11 @@
|
||||
#include <linux/clocksource.h>
|
||||
#include <linux/dma-mapping.h>
|
||||
#include <linux/io.h>
|
||||
-#include <linux/irq.h>
|
||||
#include <linux/irqchip.h>
|
||||
-#include <linux/irqdomain.h>
|
||||
#include <linux/of.h>
|
||||
#include <linux/of_irq.h>
|
||||
#include <linux/of_platform.h>
|
||||
#include <linux/of_address.h>
|
||||
-#include <linux/smp.h>
|
||||
#include <linux/amba/bus.h>
|
||||
#include <linux/clk-provider.h>
|
||||
|
||||
@@ -35,7 +32,6 @@
|
||||
#include <asm/hardware/cache-l2x0.h>
|
||||
#include <asm/mach/arch.h>
|
||||
#include <asm/mach/map.h>
|
||||
-#include <asm/mach/time.h>
|
||||
|
||||
#include "core.h"
|
||||
#include "sysregs.h"
|
||||
@@ -65,13 +61,11 @@ void highbank_set_cpu_jump(int cpu, void *jump_addr)
|
||||
HB_JUMP_TABLE_PHYS(cpu) + 15);
|
||||
}
|
||||
|
||||
-#ifdef CONFIG_CACHE_L2X0
|
||||
static void highbank_l2x0_disable(void)
|
||||
{
|
||||
/* Disable PL310 L2 Cache controller */
|
||||
highbank_smc1(0x102, 0x0);
|
||||
}
|
||||
-#endif
|
||||
|
||||
static void __init highbank_init_irq(void)
|
||||
{
|
||||
@@ -80,12 +74,13 @@ static void __init highbank_init_irq(void)
|
||||
if (of_find_compatible_node(NULL, NULL, "arm,cortex-a9"))
|
||||
highbank_scu_map_io();
|
||||
|
||||
-#ifdef CONFIG_CACHE_L2X0
|
||||
/* Enable PL310 L2 Cache controller */
|
||||
- highbank_smc1(0x102, 0x1);
|
||||
- l2x0_of_init(0, ~0UL);
|
||||
- outer_cache.disable = highbank_l2x0_disable;
|
||||
-#endif
|
||||
+ if (IS_ENABLED(CONFIG_CACHE_L2X0) &&
|
||||
+ of_find_compatible_node(NULL, NULL, "arm,pl310-cache")) {
|
||||
+ highbank_smc1(0x102, 0x1);
|
||||
+ l2x0_of_init(0, ~0UL);
|
||||
+ outer_cache.disable = highbank_l2x0_disable;
|
||||
+ }
|
||||
}
|
||||
|
||||
static void __init highbank_timer_init(void)
|
||||
@@ -176,6 +171,9 @@ static const char *highbank_match[] __initconst = {
|
||||
};
|
||||
|
||||
DT_MACHINE_START(HIGHBANK, "Highbank")
|
||||
+#if defined(CONFIG_ZONE_DMA) && defined(CONFIG_ARM_LPAE)
|
||||
+ .dma_zone_size = (4ULL * SZ_1G),
|
||||
+#endif
|
||||
.smp = smp_ops(highbank_smp_ops),
|
||||
.init_irq = highbank_init_irq,
|
||||
.init_time = highbank_timer_init,
|
||||
diff --git a/arch/arm/mm/init.c b/arch/arm/mm/init.c
|
||||
index 15225d8..c0bb66e 100644
|
||||
--- a/arch/arm/mm/init.c
|
||||
+++ b/arch/arm/mm/init.c
|
||||
@@ -207,7 +207,7 @@ static void __init arm_bootmem_init(unsigned long start_pfn,
|
||||
|
||||
#ifdef CONFIG_ZONE_DMA
|
||||
|
||||
-unsigned long arm_dma_zone_size __read_mostly;
|
||||
+phys_addr_t arm_dma_zone_size __read_mostly;
|
||||
EXPORT_SYMBOL(arm_dma_zone_size);
|
||||
|
||||
/*
|
||||
diff --git a/drivers/dma/amba-pl08x.c b/drivers/dma/amba-pl08x.c
|
||||
index 06fe45c..bff41d4 100644
|
||||
--- a/drivers/dma/amba-pl08x.c
|
||||
+++ b/drivers/dma/amba-pl08x.c
|
||||
@@ -133,6 +133,8 @@ struct pl08x_bus_data {
|
||||
u8 buswidth;
|
||||
};
|
||||
|
||||
+#define IS_BUS_ALIGNED(bus) IS_ALIGNED((bus)->addr, (bus)->buswidth)
|
||||
+
|
||||
/**
|
||||
* struct pl08x_phy_chan - holder for the physical channels
|
||||
* @id: physical index to this channel
|
||||
@@ -845,10 +847,13 @@ static int pl08x_fill_llis_for_desc(struct pl08x_driver_data *pl08x,
|
||||
|
||||
pl08x_choose_master_bus(&bd, &mbus, &sbus, cctl);
|
||||
|
||||
- dev_vdbg(&pl08x->adev->dev, "src=0x%08x%s/%u dst=0x%08x%s/%u len=%zu\n",
|
||||
- bd.srcbus.addr, cctl & PL080_CONTROL_SRC_INCR ? "+" : "",
|
||||
+ dev_vdbg(&pl08x->adev->dev,
|
||||
+ "src=0x%08llx%s/%u dst=0x%08llx%s/%u len=%zu\n",
|
||||
+ (u64)bd.srcbus.addr,
|
||||
+ cctl & PL080_CONTROL_SRC_INCR ? "+" : "",
|
||||
bd.srcbus.buswidth,
|
||||
- bd.dstbus.addr, cctl & PL080_CONTROL_DST_INCR ? "+" : "",
|
||||
+ (u64)bd.dstbus.addr,
|
||||
+ cctl & PL080_CONTROL_DST_INCR ? "+" : "",
|
||||
bd.dstbus.buswidth,
|
||||
bd.remainder);
|
||||
dev_vdbg(&pl08x->adev->dev, "mbus=%s sbus=%s\n",
|
||||
@@ -886,8 +891,8 @@ static int pl08x_fill_llis_for_desc(struct pl08x_driver_data *pl08x,
|
||||
return 0;
|
||||
}
|
||||
|
||||
- if ((bd.srcbus.addr % bd.srcbus.buswidth) ||
|
||||
- (bd.dstbus.addr % bd.dstbus.buswidth)) {
|
||||
+ if (!IS_BUS_ALIGNED(&bd.srcbus) ||
|
||||
+ !IS_BUS_ALIGNED(&bd.dstbus)) {
|
||||
dev_err(&pl08x->adev->dev,
|
||||
"%s src & dst address must be aligned to src"
|
||||
" & dst width if peripheral is flow controller",
|
||||
@@ -908,9 +913,9 @@ static int pl08x_fill_llis_for_desc(struct pl08x_driver_data *pl08x,
|
||||
*/
|
||||
if (bd.remainder < mbus->buswidth)
|
||||
early_bytes = bd.remainder;
|
||||
- else if ((mbus->addr) % (mbus->buswidth)) {
|
||||
- early_bytes = mbus->buswidth - (mbus->addr) %
|
||||
- (mbus->buswidth);
|
||||
+ else if (!IS_BUS_ALIGNED(mbus)) {
|
||||
+ early_bytes = mbus->buswidth -
|
||||
+ (mbus->addr & (mbus->buswidth - 1));
|
||||
if ((bd.remainder - early_bytes) < mbus->buswidth)
|
||||
early_bytes = bd.remainder;
|
||||
}
|
||||
@@ -928,7 +933,7 @@ static int pl08x_fill_llis_for_desc(struct pl08x_driver_data *pl08x,
|
||||
* Master now aligned
|
||||
* - if slave is not then we must set its width down
|
||||
*/
|
||||
- if (sbus->addr % sbus->buswidth) {
|
||||
+ if (!IS_BUS_ALIGNED(sbus)) {
|
||||
dev_dbg(&pl08x->adev->dev,
|
||||
"%s set down bus width to one byte\n",
|
||||
__func__);
|
25
kernel.spec
25
kernel.spec
@ -122,6 +122,8 @@ Summary: The Linux kernel
|
||||
%define with_doc %{?_without_doc: 0} %{?!_without_doc: 1}
|
||||
# kernel-headers
|
||||
%define with_headers %{?_without_headers: 0} %{?!_without_headers: 1}
|
||||
# kernel-modules-extra
|
||||
%define with_extra %{?_without_extra: 0} %{?!_without_extra: 1}
|
||||
# perf
|
||||
%define with_perf %{?_without_perf: 0} %{?!_without_perf: 1}
|
||||
# tools
|
||||
@ -702,6 +704,7 @@ Patch21001: arm-lpae-ax88796.patch
|
||||
Patch21003: arm-dma-amba_pl08x-avoid-64bit-division.patch
|
||||
Patch21004: arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
|
||||
Patch21005: arm-exynos-mp.patch
|
||||
Patch21006: arm-highbank-for-3.12.patch
|
||||
|
||||
# ARM omap
|
||||
Patch21010: arm-omap-load-tfp410.patch
|
||||
@ -979,14 +982,18 @@ Summary: %{variant_summary}\
|
||||
Group: System Environment/Kernel\
|
||||
%kernel_reqprovconf\
|
||||
%{expand:%%kernel_devel_package %1 %{!?-n:%1}%{?-n:%{-n*}}}\
|
||||
%if %{with_extra}\
|
||||
%{expand:%%kernel_modules_extra_package %1 %{!?-n:%1}%{?-n:%{-n*}}}\
|
||||
%endif\
|
||||
%{expand:%%kernel_debuginfo_package %1}\
|
||||
%{nil}
|
||||
|
||||
|
||||
# First the auxiliary packages of the main kernel package.
|
||||
%kernel_devel_package
|
||||
%if %{with_extra}
|
||||
%kernel_modules_extra_package
|
||||
%endif
|
||||
%kernel_debuginfo_package
|
||||
|
||||
|
||||
@ -1310,9 +1317,10 @@ ApplyPatch debug-bad-pte-modules.patch
|
||||
# ARM
|
||||
#
|
||||
ApplyPatch arm-lpae-ax88796.patch
|
||||
ApplyPatch arm-dma-amba_pl08x-avoid-64bit-division.patch
|
||||
#ApplyPatch arm-dma-amba_pl08x-avoid-64bit-division.patch
|
||||
ApplyPatch arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
|
||||
ApplyPatch arm-exynos-mp.patch
|
||||
ApplyPatch arm-highbank-for-3.12.patch
|
||||
ApplyPatch arm-omap-load-tfp410.patch
|
||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||
ApplyPatch arm-wandboard-quad.patch
|
||||
@ -1606,7 +1614,7 @@ BuildKernel() {
|
||||
%ifarch %{arm} aarch64
|
||||
%{make} -s ARCH=$Arch V=1 dtbs
|
||||
mkdir -p $RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer
|
||||
install -m 644 arch/$Arch/boot/dts/*.dtb $RPM_BUILD_ROOT/boot/dtb-$KernelVer/
|
||||
install -m 644 arch/$Arch/boot/dts/*.dtb $RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer/
|
||||
rm -f arch/$Arch/boot/dts/*.dtb
|
||||
%endif
|
||||
|
||||
@ -1764,8 +1772,10 @@ BuildKernel() {
|
||||
rm -f modules.{alias*,builtin.bin,dep*,*map,symbols*,devname,softdep}
|
||||
popd
|
||||
|
||||
%if %{with_extra}
|
||||
# Call the modules-extra script to move things around
|
||||
%{SOURCE17} $RPM_BUILD_ROOT/lib/modules/$KernelVer %{SOURCE16}
|
||||
%endif
|
||||
|
||||
%if %{signmodules}
|
||||
# Save the signing keys so we can sign the modules in __modsign_install_post
|
||||
@ -2075,7 +2085,9 @@ fi\
|
||||
#
|
||||
%define kernel_variant_post(v:r:) \
|
||||
%{expand:%%kernel_devel_post %{?-v*}}\
|
||||
%if %{with_extra}\
|
||||
%{expand:%%kernel_modules_extra_post %{?-v*}}\
|
||||
%endif\
|
||||
%{expand:%%kernel_variant_posttrans %{?-v*}}\
|
||||
%{expand:%%post %{?-v*}}\
|
||||
%{-r:\
|
||||
@ -2233,7 +2245,9 @@ fi
|
||||
%{expand:%%files %{?2:%{2}-}devel}\
|
||||
%defattr(-,root,root)\
|
||||
/usr/src/kernels/%{KVERREL}%{?2:+%{2}}\
|
||||
%if %{with_extra}\
|
||||
%{expand:%%files %{?2:%{2}-}modules-extra}\
|
||||
%endif\
|
||||
%defattr(-,root,root)\
|
||||
/lib/modules/%{KVERREL}%{?2:+%{2}}/extra\
|
||||
%if %{with_debuginfo}\
|
||||
@ -2266,6 +2280,13 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Sep 03 2013 Kyle McMartin <kyle@redhat.com>
|
||||
- Pull in some Calxeda highbank fixes that are destined for 3.12
|
||||
- Add a %with_extra twiddle to disable building kernel-modules-extra
|
||||
subpackages.
|
||||
- Fix dtbs install path to use %install_image_path (not that it's different
|
||||
at the moment.)
|
||||
|
||||
* Tue Sep 03 2013 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Add keyring patches to support krb5 (rhbz 1003043)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user