Backport driver for Cypress PS/2 trackpad (rhbz 799564)
This commit is contained in:
parent
1c73ec9b84
commit
655567cad9
1063
Input-add-support-for-Cypress-PS2-Trackpads.patch
Normal file
1063
Input-add-support-for-Cypress-PS2-Trackpads.patch
Normal file
File diff suppressed because it is too large
Load Diff
30
Input-increase-struct-ps2dev-cmdbuf-to-8-bytes.patch
Normal file
30
Input-increase-struct-ps2dev-cmdbuf-to-8-bytes.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 80524f083e2c3e70057f5bb476db92baa14cb22b Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Mostafa <kamal@canonical.com>
|
||||
Date: Tue, 20 Nov 2012 23:04:35 -0800
|
||||
Subject: [PATCH] Input: increase struct ps2dev cmdbuf[] to 8 bytes
|
||||
|
||||
Cypress PS/2 Trackpad (drivers/input/mouse/cypress_ps2.c) needs
|
||||
this larger cmdbuf[] to handle 8-byte packet responses.
|
||||
|
||||
Signed-off-by: Kamal Mostafa <kamal@canonical.com>
|
||||
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
||||
---
|
||||
include/linux/libps2.h | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/include/linux/libps2.h b/include/linux/libps2.h
|
||||
index 79603a6..4ad06e8 100644
|
||||
--- a/include/linux/libps2.h
|
||||
+++ b/include/linux/libps2.h
|
||||
@@ -36,7 +36,7 @@ struct ps2dev {
|
||||
wait_queue_head_t wait;
|
||||
|
||||
unsigned long flags;
|
||||
- unsigned char cmdbuf[6];
|
||||
+ unsigned char cmdbuf[8];
|
||||
unsigned char cmdcnt;
|
||||
unsigned char nak;
|
||||
};
|
||||
--
|
||||
1.7.7.6
|
||||
|
13
kernel.spec
13
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -753,6 +753,10 @@ Patch21227: iwlegacy-fix-IBSS-cleanup.patch
|
||||
Patch21228: iwlwifi-audit-single-frames-from-AGG-queue-in-RS.patch
|
||||
Patch21229: Revert-iwlwifi-fix-the-reclaimed-packet-tracking-upon.patch
|
||||
|
||||
#rhbz 799564
|
||||
Patch21240: Input-increase-struct-ps2dev-cmdbuf-to-8-bytes.patch
|
||||
Patch21241: Input-add-support-for-Cypress-PS2-Trackpads.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1451,6 +1455,10 @@ ApplyPatch iwlegacy-fix-IBSS-cleanup.patch
|
||||
ApplyPatch iwlwifi-audit-single-frames-from-AGG-queue-in-RS.patch
|
||||
ApplyPatch Revert-iwlwifi-fix-the-reclaimed-packet-tracking-upon.patch
|
||||
|
||||
#rhbz 799564
|
||||
ApplyPatch Input-increase-struct-ps2dev-cmdbuf-to-8-bytes.patch
|
||||
ApplyPatch Input-add-support-for-Cypress-PS2-Trackpads.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2306,6 +2314,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Jan 29 2013 Josh Boyer <jwboyer@redhat.com>
|
||||
- Backport driver for Cypress PS/2 trackpad (rhbz 799564)
|
||||
|
||||
* Mon Jan 28 2013 Josh Boyer <jwboyer@redhat.com> - 3.8.0-0.rc5.git0.1
|
||||
- Linux v3.8-rc5
|
||||
- Add patches to fix issues with iwlwifi (rhbz 863424)
|
||||
|
Loading…
Reference in New Issue
Block a user