Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2019-02-18 11:54:01 +01:00
commit 625fa4a062
Signed by: davidlt
GPG Key ID: 7108702C938B13C1
134 changed files with 1732 additions and 339 deletions

5
.gitignore vendored
View File

@ -1,12 +1,11 @@
clog
*.xz
*.gz
*.bz2
*.rpm
*.orig
*.sign
kernel-[234].*/
kernel-[2345]*/
perf-man-*.tar.gz
kernel-headers/
kernel-tools/
/linux-5.0-rc1.tar.gz
/linux-5.0-rc2.tar.gz

View File

@ -0,0 +1,35 @@
From 0de1315ee843713bafb9a59bc040a024f688c62a Mon Sep 17 00:00:00 2001
From: Laura Abbott <labbott@redhat.com>
Date: Wed, 23 Jan 2019 13:56:47 +0100
Subject: [PATCH] Correct warning with gcc9
Suggested from Arnd
Signed-off-by: Laura Abbott <labbott@redhat.com>
---
include/linux/module.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/module.h b/include/linux/module.h
index 8fa38d3e7538..f2a24b59cca4 100644
--- a/include/linux/module.h
+++ b/include/linux/module.h
@@ -129,13 +129,13 @@ extern void cleanup_module(void);
#define module_init(initfn) \
static inline initcall_t __maybe_unused __inittest(void) \
{ return initfn; } \
- int init_module(void) __attribute__((alias(#initfn)));
+ int init_module(void) __attribute__((cold, alias(#initfn)));
/* This is only required if you want to be unloadable. */
#define module_exit(exitfn) \
static inline exitcall_t __maybe_unused __exittest(void) \
{ return exitfn; } \
- void cleanup_module(void) __attribute__((alias(#exitfn)));
+ void cleanup_module(void) __attribute__((cold, alias(#exitfn)));
#endif
--
2.20.1

View File

@ -0,0 +1,25 @@
From 12cec6680e67d6b4fed9e30cd8c1f13871996cc1 Mon Sep 17 00:00:00 2001
From: Laura Abbott <labbott@redhat.com>
Date: Wed, 23 Jan 2019 14:36:37 +0100
Subject: [PATCH] Drop that for now
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index f5b1d0d168e0..5f31107b22d1 100644
--- a/Makefile
+++ b/Makefile
@@ -430,7 +430,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
KBUILD_CFLAGS := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs \
-fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
-Werror-implicit-function-declaration -Werror=implicit-int \
- -Wno-format-security \
+ -Wno-format-security -Wno-address-of-packed-member \
-std=gnu89
KBUILD_CPPFLAGS := -D__KERNEL__
KBUILD_AFLAGS_KERNEL :=
--
2.20.1

View File

@ -0,0 +1,63 @@
From b0b46a5b622fdbe69207675c5d50b77cb8ae43b7 Mon Sep 17 00:00:00 2001
From: Heiko Carstens <heiko.carstens@de.ibm.com>
Date: Tue, 5 Feb 2019 13:43:49 +0100
Subject: [PATCH] s390/jump_label: Correct asm contraint
On Tue, Jan 29, 2019 at 08:25:58AM +0100, Laura Abbott wrote:
> On 1/23/19 5:24 AM, Heiko Carstens wrote:
> >On Wed, Jan 23, 2019 at 01:55:13PM +0100, Laura Abbott wrote:
> >>There's a build failure with gcc9:
> >>
> >> ./arch/s390/include/asm/jump_label.h: Assembler messages:
> >> ./arch/s390/include/asm/jump_label.h:23: Error: bad expression
> >> ./arch/s390/include/asm/jump_label.h:23: Error: junk at end of line, first unrecognized character is `r'
> >> make[1]: *** [scripts/Makefile.build:277: init/main.o] Error 1
...
> I've had to turn off s390 in Fedora until this gets fixed :(
Laura, the patch below should fix this (temporarily). If possible,
could you give it a try? It seems to work for me.
rom 4067027c2ccc8d3f1dc3bb19fe2d00da0c65bcd8 Mon Sep 17 00:00:00 2001
From: Heiko Carstens <heiko.carstens@de.ibm.com>
Date: Tue, 5 Feb 2019 13:21:56 +0100
Subject: [PATCH] s390: disable section anchors
Disable section anchors to allow to compile with the current gcc 9
experimental version. The section anchors is a new feature for s390
with gcc 9, however it breaks our current usage of the 'X' constraint
within the asm goto construct within our jump label implementation.
Fixing this seems to be non-trivial, therefore (hopefully) temporarily
disable section anchors. We will hopefully have a better solution
before gcc 9 is released, so that this can be removed again.
Reported-by: Laura Abbott <labbott@redhat.com>
Suggested-by: Ilya Leoshkevich <iii@linux.ibm.com>
Signed-off-by: Heiko Carstens <heiko.carstens@de.ibm.com>
---
arch/s390/Makefile | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/arch/s390/Makefile b/arch/s390/Makefile
index e21053e5e0da..1eac75bc3a29 100644
--- a/arch/s390/Makefile
+++ b/arch/s390/Makefile
@@ -62,6 +62,14 @@ cflags-y += -Wa,-I$(srctree)/arch/$(ARCH)/include
#
cflags-$(CONFIG_FRAME_POINTER) += -fno-optimize-sibling-calls
+#
+# Disable section anchors. This gcc 9 feature currently breaks the 'X'
+# constraint like it is used in the asm goto construct.
+#
+ifeq ($(call cc-option-yn,-fno-section-anchors),y)
+cflags-y += -fno-section-anchors
+endif
+
ifeq ($(call cc-option-yn,-mpacked-stack),y)
cflags-$(CONFIG_PACK_STACK) += -mpacked-stack -D__PACK_STACK
aflags-$(CONFIG_PACK_STACK) += -D__PACK_STACK
--
2.20.1

View File

@ -1,42 +0,0 @@
From linux-netdev Thu Jan 03 12:26:34 2019
From: Oliver Hartkopp <socketcan () hartkopp ! net>
Date: Thu, 03 Jan 2019 12:26:34 +0000
To: linux-netdev
Subject: [PATCH] can: gw: ensure DLC boundaries after CAN frame modification
Message-Id: <20190103122634.2530-1-socketcan () hartkopp ! net>
X-MARC-Message: https://marc.info/?l=linux-netdev&m=154651842302479
The CAN frame modification rules allow bitwise logical operations which can
be also applied to the can_dlc field. Ensure the manipulation result to
maintain the can_dlc boundaries so that the CAN drivers do not accidently
write arbitrary content beyond the data registers in the CAN controllers
I/O mem when processing can-gw manipulated outgoing frames. When passing these
frames to user space this issue did not have any effect to the kernel or any
leaked data as we always strictly copy sizeof(struct can_frame) bytes.
Reported-by: Muyu Yu <ieatmuttonchuan@gmail.com>
Reported-by: Marcus Meissner <meissner@suse.de>
Tested-by: Muyu Yu <ieatmuttonchuan@gmail.com>
Signed-off-by: Oliver Hartkopp <socketcan@hartkopp.net>
Cc: linux-stable <stable@vger.kernel.org> # >= v3.2
---
net/can/gw.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/net/can/gw.c b/net/can/gw.c
index faa3da88a127..9000d9b8a133 100644
--- a/net/can/gw.c
+++ b/net/can/gw.c
@@ -418,6 +418,10 @@ static void can_can_gw_rcv(struct sk_buff *skb, void *data)
/* check for checksum updates when the CAN frame has been modified */
if (modidx) {
+ /* ensure DLC boundaries after the different mods */
+ if (cf->can_dlc > 8)
+ cf->can_dlc = 8;
+
if (gwj->mod.csumfunc.crc8)
(*gwj->mod.csumfunc.crc8)(cf, &gwj->mod.csum.crc8);
--
2.19.2

View File

@ -1,138 +0,0 @@
From patchwork Sun Dec 23 20:59:17 2018
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Stefan Wahren <stefan.wahren@i2se.com>
X-Patchwork-Id: 10741809
Return-Path:
<linux-arm-kernel-bounces+patchwork-linux-arm=patchwork.kernel.org@lists.infradead.org>
Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org
[172.30.200.125])
by pdx-korg-patchwork-2.web.codeaurora.org (Postfix) with ESMTP id 2E9B66C2
for <patchwork-linux-arm@patchwork.kernel.org>;
Sun, 23 Dec 2018 21:00:35 +0000 (UTC)
Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1])
by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 1BF3B28783
for <patchwork-linux-arm@patchwork.kernel.org>;
Sun, 23 Dec 2018 21:00:35 +0000 (UTC)
Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486)
id 0FE412878E; Sun, 23 Dec 2018 21:00:35 +0000 (UTC)
X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on
pdx-wl-mail.web.codeaurora.org
X-Spam-Level:
X-Spam-Status: No, score=-5.2 required=2.0 tests=BAYES_00,DKIM_SIGNED,
DKIM_VALID,MAILING_LIST_MULTI,RCVD_IN_DNSWL_MED autolearn=ham version=3.3.1
Received: from bombadil.infradead.org (bombadil.infradead.org
[198.137.202.133])
(using TLSv1.2 with cipher AES256-GCM-SHA384 (256/256 bits))
(No client certificate requested)
by mail.wl.linuxfoundation.org (Postfix) with ESMTPS id B7EB128783
for <patchwork-linux-arm@patchwork.kernel.org>;
Sun, 23 Dec 2018 21:00:34 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;
d=lists.infradead.org; s=bombadil.20170209; h=Sender:
Content-Transfer-Encoding:Content-Type:MIME-Version:Cc:List-Subscribe:
List-Help:List-Post:List-Archive:List-Unsubscribe:List-Id:Message-Id:Date:
Subject:To:From:Reply-To:Content-ID:Content-Description:Resent-Date:
Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:In-Reply-To:
References:List-Owner; bh=0Cfst0aavwq2BzhOoJiKH5s4NpJ/Us+GjXPJ4zrLsg0=; b=ZZ4
op3YV27iZX0UKzSqXuUq2LaE+MP3aEAQmT8Rdvb/NFFHbn+wqbOszDRj6XW3ajga4pCSwUf3L4gvo
ZheL4Sb+6+oiR1HdK8EBuDjmzKY1qn/zgS8gwvVv6TSbD2Bz8Lw0hQ/tW2MwUuIDngXtzfUoFvHrp
wADpWDQf/OcQj2dRuqMLquQTkjTnYDP94Ml87y52NZhbu9+9n3h0+0X7oerCqM/RLjCwl9atrORaV
DAWfKL1pif2kz0UoT1x6vjaOmbSa3NqSXmUo+2dM64jUixp5JllINpIuIDUX2KNTo2pRF3og+BnsP
8TFZ0aIA+N69i6dOIQTBKCcJIb86Jjw==;
Received: from localhost ([127.0.0.1] helo=bombadil.infradead.org)
by bombadil.infradead.org with esmtp (Exim 4.90_1 #2 (Red Hat Linux))
id 1gbArL-0005Ta-RL; Sun, 23 Dec 2018 21:00:27 +0000
Received: from mout.kundenserver.de ([212.227.126.131])
by bombadil.infradead.org with esmtps (Exim 4.90_1 #2 (Red Hat Linux))
id 1gbArH-0004QG-NL
for linux-arm-kernel@lists.infradead.org; Sun, 23 Dec 2018 21:00:25 +0000
Received: from localhost.localdomain ([37.4.249.153]) by
mrelayeu.kundenserver.de (mreue012 [212.227.15.167]) with ESMTPSA (Nemesis)
id 1MSZDt-1gz0AW3YfB-00SsKG; Sun, 23 Dec 2018 21:59:57 +0100
From: Stefan Wahren <stefan.wahren@i2se.com>
To: Al Cooper <alcooperx@gmail.com>, Adrian Hunter <adrian.hunter@intel.com>,
Ulf Hansson <ulf.hansson@linaro.org>
Subject: [PATCH 1/2] mmc: sdhci-iproc: handle mmc_of_parse() errors during
probe
Date: Sun, 23 Dec 2018 21:59:17 +0100
Message-Id: <1545598758-4502-1-git-send-email-stefan.wahren@i2se.com>
X-Mailer: git-send-email 2.7.4
X-Provags-ID: V03:K1:FsBhp74NqgbMckX6QGEkM7zbuM0fjnbtNqB9c5GjfSu+JG+zOVC
nt6p6+TF28Gk+lb0VFAh2hNrWHdwlR1sqk5ygcbOiXLgQ93PecRf9Zl130rJ7qR4Km04fzv
AR0JypQ0XgjJ+nia824FdeQ9oO4xRynoGH5q7Raco0HsIMewr0syOybYSJgsqI5UUptIo+5
FhdCMrpIfxuFpRh23naog==
X-UI-Out-Filterresults: notjunk:1;V03:K0:7uvqm/6Tn2w=:qedwftyLF+r+WaFGRyzPKR
vItrffDfG7f534X5qt1icf/24c6TYj93h3+1AKvP593z2hpmJxIemKNrdRT7/zXPP+Ipke8UQ
I08zvqpRa5wcGU3iO0jQaPt/WU58GkdmjkiuWzotVkbcj4+NuMi4iMPfiAMd1VdT5ouv2omWI
/7S/9AqsTnPbNYo+5i1oNsSFDmrxWvlKZC9K+Ab8vTe8J9L+wUiRCWFHsOr0C9lC1J3MRHbgZ
OPX3nnGBLnuKcWjrMJyIjqsNOJ2w89xWpOFvNfsPTrVhHX/xApgyQQcbDBXvwgMh709QJowTD
88M4HvgmrK3Ah0BS164aJZtufA38R7Fpay/nQ6hojx7BKV6OM712L+vkkzNuK4MrfQKtQeiv5
sf7mvN2YqPw13dJxC70+a8u2MvwhX7Udha2YtQJT7ZhcqlIYkVb4HoDJ565iYqAe/jp9npFjh
3wPekqu1cY3V/0rhdWVETv/Atcchi598SE0RS4cL8/C7Z189r2wCrohPWDDedc8/AmF+J9y4N
2lAHyAmq7u7IUBkxmYHzFu+KvE6jVNgVFm6mB21lO2gHqTIz6toyP36igFPxPp0FZrigwqCWb
Ot1jt/Ep+g9ykC8xjM36X5RKjfDrAOpgwSb+FWRqaablXguW1xgCC2weNx8PjENo21hCxHNgG
2jSstrMAZFww3b39FzyTblcT3LcsuU6JOjyIMPCApzh0y7wgI+VVT+y3jyezQpszpAxbbdYnS
WH896vn09u7vjjjfG9zlqROWkG+q3ZLGfxrm4gRjo5HnJF78W1Fq11QIq0U=
X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3
X-CRM114-CacheID: sfid-20181223_130024_058181_62761026
X-CRM114-Status: GOOD ( 14.51 )
X-BeenThere: linux-arm-kernel@lists.infradead.org
X-Mailman-Version: 2.1.21
Precedence: list
List-Id: <linux-arm-kernel.lists.infradead.org>
List-Unsubscribe:
<http://lists.infradead.org/mailman/options/linux-arm-kernel>,
<mailto:linux-arm-kernel-request@lists.infradead.org?subject=unsubscribe>
List-Archive: <http://lists.infradead.org/pipermail/linux-arm-kernel/>
List-Post: <mailto:linux-arm-kernel@lists.infradead.org>
List-Help: <mailto:linux-arm-kernel-request@lists.infradead.org?subject=help>
List-Subscribe:
<http://lists.infradead.org/mailman/listinfo/linux-arm-kernel>,
<mailto:linux-arm-kernel-request@lists.infradead.org?subject=subscribe>
Cc: Stefan Wahren <stefan.wahren@i2se.com>,
Florian Fainelli <f.fainelli@gmail.com>,
Scott Branden <sbranden@broadcom.com>,
Ray Jui <rjui@broadcom.com>, linux-mmc@vger.kernel.org,
stable@vger.kernel.org,
Eric Anholt <eric@anholt.net>, bcm-kernel-feedback-list@broadcom.com,
Gregory Fong <gregory.0xf0@gmail.com>,
Brian Norris <computersforpeace@gmail.com>,
linux-arm-kernel@lists.infradead.org
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Sender: "linux-arm-kernel" <linux-arm-kernel-bounces@lists.infradead.org>
Errors-To:
linux-arm-kernel-bounces+patchwork-linux-arm=patchwork.kernel.org@lists.infradead.org
X-Virus-Scanned: ClamAV using ClamSMTP
We need to handle mmc_of_parse() errors during probe.
This finally fixes the wifi regression on Raspberry Pi 3 series.
In error case the wifi chip was permanently in reset because of
the power sequence depending on the deferred probe of the GPIO expander.
Fixes: b580c52d58d9 ("mmc: sdhci-iproc: add IPROC SDHCI driver")
Cc: stable@vger.kernel.org
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
---
drivers/mmc/host/sdhci-iproc.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/sdhci-iproc.c b/drivers/mmc/host/sdhci-iproc.c
index 0db9905..9d12c06 100644
--- a/drivers/mmc/host/sdhci-iproc.c
+++ b/drivers/mmc/host/sdhci-iproc.c
@@ -296,7 +296,10 @@ static int sdhci_iproc_probe(struct platform_device *pdev)
iproc_host->data = iproc_data;
- mmc_of_parse(host->mmc);
+ ret = mmc_of_parse(host->mmc);
+ if (ret)
+ goto err;
+
sdhci_get_property(pdev);
host->mmc->caps |= iproc_host->data->mmc_caps;

View File

@ -17,8 +17,8 @@ i686=generic:generic-x86:generic-x86-i686
i686-debug=generic:generic-x86:generic-x86-i686:debug:debug-x86
# ppc64le
ppc64le=generic:generic-powerpc:generic-powerpc-powerpc64le
ppc64le-debug=generic:generic-powerpc:generic-powerpc-powerpc64le:debug
ppc64le=generic:generic-powerpc
ppc64le-debug=generic:generic-powerpc:generic-powerpc:debug
# s390x
s390x=generic:generic-s390x

View File

@ -0,0 +1 @@
CONFIG_HSA_AMD=y

View File

@ -1 +1 @@
# CONFIG_MPL115_I2C is not set
CONFIG_MPL115_I2C=m

View File

@ -0,0 +1 @@
# CONFIG_NFC_MRVL_SPI is not set

View File

@ -1 +1 @@
# CONFIG_NFC_NCI_SPI is not set
CONFIG_NFC_NCI_SPI=m

View File

@ -1 +1 @@
# CONFIG_XFRM_INTERFACE is not set
CONFIG_XFRM_INTERFACE=m

View File

@ -0,0 +1 @@
CONFIG_XFRM_OFFLOAD=y

View File

@ -0,0 +1 @@
CONFIG_88EU_AP_MODE=y

View File

@ -1 +0,0 @@
CONFIG_LEDS_GPIO=m

View File

@ -0,0 +1 @@
CONFIG_PHY_QCOM_UFS_14NM=m

View File

@ -1 +1 @@
# CONFIG_SPI_MESON_SPICC is not set
CONFIG_SPI_MESON_SPICC=m

View File

@ -0,0 +1 @@
CONFIG_AHCI_QORIQ=m

View File

@ -1 +1 @@
# CONFIG_ARCH_LAYERSCAPE is not set
CONFIG_ARCH_LAYERSCAPE=y

View File

@ -0,0 +1 @@
CONFIG_ARM64_ERRATUM_845719=y

View File

@ -0,0 +1 @@
CONFIG_ARMV8_DEPRECATED=y

View File

@ -1 +1 @@
# CONFIG_COMPAT is not set
CONFIG_COMPAT=y

View File

@ -0,0 +1 @@
CONFIG_CP15_BARRIER_EMULATION=y

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_CCP_CRYPTO=m

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_FSL_CAAM_CRYPTO_API_QI=m

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_FSL_DPAA2_CAAM=m

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_SP_CCP=y

View File

@ -1 +0,0 @@
CONFIG_DEBUG_WX=y

View File

@ -0,0 +1 @@
CONFIG_EDAC_LAYERSCAPE=m

View File

@ -0,0 +1 @@
# CONFIG_FSL_BMAN_TEST is not set

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA=y

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA2=y

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA2_ETH=m

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA2_ETHSW=m

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA2_PTP_CLOCK=m

View File

@ -0,0 +1 @@
# CONFIG_FSL_DPAA_CHECKING is not set

View File

@ -0,0 +1 @@
CONFIG_FSL_DPAA_ETH=m

View File

@ -0,0 +1 @@
CONFIG_FSL_EDMA=m

View File

@ -0,0 +1 @@
CONFIG_FSL_FMAN=m

View File

@ -0,0 +1 @@
CONFIG_FSL_MC_BUS=y

View File

@ -0,0 +1 @@
CONFIG_FSL_MC_DPIO=m

View File

@ -0,0 +1 @@
CONFIG_FSL_PQ_MDIO=m

View File

@ -0,0 +1 @@
# CONFIG_FSL_QMAN_TEST is not set

View File

@ -0,0 +1 @@
CONFIG_GIANFAR=m

View File

@ -0,0 +1 @@
CONFIG_GPIO_MPC8XXX=y

View File

@ -0,0 +1 @@
CONFIG_NET_VENDOR_FREESCALE=y

View File

@ -0,0 +1 @@
CONFIG_PCI_LAYERSCAPE=y

View File

@ -0,0 +1 @@
CONFIG_PTP_1588_CLOCK_QORIQ=m

View File

@ -0,0 +1 @@
CONFIG_SETEND_EMULATION=y

View File

@ -0,0 +1 @@
CONFIG_SPI_FSL_DSPI=m

View File

@ -0,0 +1 @@
CONFIG_SWP_EMULATION=y

View File

@ -0,0 +1 @@
CONFIG_VIDEO_QCOM_CAMSS=m

View File

@ -1 +0,0 @@
# CONFIG_88EU_AP_MODE is not set

View File

@ -1 +0,0 @@
# CONFIG_MFD_ARIZONA_SPI is not set

View File

@ -1 +0,0 @@
# CONFIG_NET_VENDOR_MICROCHIP is not set

View File

@ -0,0 +1 @@
CONFIG_AMX3_PM=m

View File

@ -0,0 +1 @@
CONFIG_BACKLIGHT_TPS65217=m

View File

@ -0,0 +1 @@
CONFIG_CHARGER_TPS65217=m

View File

@ -0,0 +1 @@
CONFIG_MFD_TPS65217=m

View File

@ -0,0 +1 @@
CONFIG_REGULATOR_TPS65217=m

View File

@ -0,0 +1 @@
CONFIG_SOC_TI=y

View File

@ -0,0 +1 @@
CONFIG_WKUP_M3_IPC=m

View File

@ -1 +0,0 @@
# CONFIG_ARCH_MXC is not set

View File

@ -1 +1 @@
# CONFIG_CRYPTO_DEV_NX is not set
CONFIG_CRYPTO_DEV_NX=y

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_NX_COMPRESS=m

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_NX_COMPRESS_POWERNV=m

View File

@ -0,0 +1 @@
CONFIG_CRYPTO_DEV_NX_COMPRESS_PSERIES=m

View File

@ -1 +0,0 @@
CONFIG_GPIO_PCA953X=m

Some files were not shown because too many files have changed in this diff Show More