kernel-5.18.0-0.rc1.3e732ebf7316ac8.18
* Wed Apr 06 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc1.3e732ebf7316ac8.18] - tools/power/x86/intel-speed-select: fix build failure when using -Wl,--as-needed (Herton R. Krzesinski) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
d86cbb69b2
commit
622fee5906
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 18
|
||||
RHEL_RELEASE = 19
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,6 +1,15 @@
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/9e0d609a1538c26606fe04613e8ce3a4244ff3c2
|
||||
9e0d609a1538c26606fe04613e8ce3a4244ff3c2 tools/power/x86/intel-speed-select: fix build failure when using -Wl,--as-needed
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/9a4f5172b1f7ca55a805fca7cd025b9a1f8c1eae
|
||||
9a4f5172b1f7ca55a805fca7cd025b9a1f8c1eae mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/4254c840c8f3f59b221709274c049e34587de909
|
||||
4254c840c8f3f59b221709274c049e34587de909 Add Partner Supported taint flag to kAFS
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/0308c0e25aac4bd0fafa852d8b5625be8885e419
|
||||
0308c0e25aac4bd0fafa852d8b5625be8885e419 Add Partner Supported taint flag
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/8e648aae90c1d739b5ead43fb84c2cae550a8344
|
||||
8e648aae90c1d739b5ead43fb84c2cae550a8344 Fix up rng merge
|
||||
|
||||
|
@ -3067,7 +3067,7 @@ CONFIG_INPUT=y
|
||||
CONFIG_INPUT_YEALINK=m
|
||||
CONFIG_INTEGRITY_ASYMMETRIC_KEYS=y
|
||||
CONFIG_INTEGRITY_AUDIT=y
|
||||
# CONFIG_INTEGRITY_PLATFORM_KEYRING is not set
|
||||
CONFIG_INTEGRITY_PLATFORM_KEYRING=y
|
||||
CONFIG_INTEGRITY_SIGNATURE=y
|
||||
CONFIG_INTEGRITY_TRUSTED_KEYRING=y
|
||||
CONFIG_INTEGRITY=y
|
||||
|
@ -3052,7 +3052,7 @@ CONFIG_INPUT=y
|
||||
CONFIG_INPUT_YEALINK=m
|
||||
CONFIG_INTEGRITY_ASYMMETRIC_KEYS=y
|
||||
CONFIG_INTEGRITY_AUDIT=y
|
||||
# CONFIG_INTEGRITY_PLATFORM_KEYRING is not set
|
||||
CONFIG_INTEGRITY_PLATFORM_KEYRING=y
|
||||
CONFIG_INTEGRITY_SIGNATURE=y
|
||||
CONFIG_INTEGRITY_TRUSTED_KEYRING=y
|
||||
CONFIG_INTEGRITY=y
|
||||
|
@ -3003,7 +3003,7 @@ CONFIG_INPUT=y
|
||||
CONFIG_INPUT_YEALINK=m
|
||||
CONFIG_INTEGRITY_ASYMMETRIC_KEYS=y
|
||||
CONFIG_INTEGRITY_AUDIT=y
|
||||
# CONFIG_INTEGRITY_PLATFORM_KEYRING is not set
|
||||
CONFIG_INTEGRITY_PLATFORM_KEYRING=y
|
||||
CONFIG_INTEGRITY_SIGNATURE=y
|
||||
CONFIG_INTEGRITY_TRUSTED_KEYRING=y
|
||||
CONFIG_INTEGRITY=y
|
||||
|
@ -2988,7 +2988,7 @@ CONFIG_INPUT=y
|
||||
CONFIG_INPUT_YEALINK=m
|
||||
CONFIG_INTEGRITY_ASYMMETRIC_KEYS=y
|
||||
CONFIG_INTEGRITY_AUDIT=y
|
||||
# CONFIG_INTEGRITY_PLATFORM_KEYRING is not set
|
||||
CONFIG_INTEGRITY_PLATFORM_KEYRING=y
|
||||
CONFIG_INTEGRITY_SIGNATURE=y
|
||||
CONFIG_INTEGRITY_TRUSTED_KEYRING=y
|
||||
CONFIG_INTEGRITY=y
|
||||
|
27
kernel.spec
27
kernel.spec
@ -85,9 +85,9 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc1.18
|
||||
%global distro_build 0.rc1.20220406git3e732ebf7316ac8.19
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -132,13 +132,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.18.0
|
||||
%define patchversion 5.18
|
||||
%define pkgrelease 0.rc1.18
|
||||
%define pkgrelease 0.rc1.20220406git3e732ebf7316ac8.19
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 18
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc1.18%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc1.20220406git3e732ebf7316ac8.19%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -698,7 +698,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.18-rc1.tar.xz
|
||||
Source0: linux-5.18-rc1-16-g3e732ebf7316ac8.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1390,8 +1390,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.18-rc1 -c
|
||||
mv linux-5.18-rc1 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.18-rc1-16-g3e732ebf7316ac8 -c
|
||||
mv linux-5.18-rc1-16-g3e732ebf7316ac8 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2246,7 +2246,7 @@ chmod +x tools/power/cpupower/utils/version-gen.sh
|
||||
%{tools_make}
|
||||
popd
|
||||
pushd tools/power/x86/intel-speed-select
|
||||
%{make} CFLAGS+="-D_GNU_SOURCE -Iinclude -I/usr/include/libnl3" LDFLAGS+="-lnl-genl-3 -lnl-3"
|
||||
%{make} CFLAGS+="-D_GNU_SOURCE -Iinclude -I/usr/include/libnl3
|
||||
popd
|
||||
%endif
|
||||
%endif
|
||||
@ -2511,7 +2511,7 @@ install -m644 %{SOURCE2001} %{buildroot}%{_sysconfdir}/sysconfig/cpupower
|
||||
%{tools_make} DESTDIR=%{buildroot} install
|
||||
popd
|
||||
pushd tools/power/x86/intel-speed-select
|
||||
%{make} CFLAGS+="-D_GNU_SOURCE -Iinclude -I/usr/include/libnl3" LDFLAGS+="-lnl-genl-3 -lnl-3" DESTDIR=%{buildroot} install
|
||||
%{tools_make} CFLAGS+="-D_GNU_SOURCE -Iinclude -I/usr/include/libnl" DESTDIR=%{buildroot} install
|
||||
popd
|
||||
%endif
|
||||
pushd tools/thermal/tmon
|
||||
@ -3018,8 +3018,13 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Apr 04 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc1.17]
|
||||
- redhat/kernel.spec.template: Fix intel-speed-select compile (Prarit Bhargava)
|
||||
* Wed Apr 06 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc1.3e732ebf7316ac8.18]
|
||||
- tools/power/x86/intel-speed-select: fix build failure when using -Wl,--as-needed (Herton R. Krzesinski)
|
||||
|
||||
* Wed Apr 06 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc1.3e732ebf7316ac8.17]
|
||||
- Add Partner Supported taint flag to kAFS (Alice Mitchell) [2038999]
|
||||
- Add Partner Supported taint flag (Alice Mitchell) [2038999]
|
||||
- Enabled INTEGRITY_MACHINE_KEYRING for all configs. (Peter Robinson)
|
||||
|
||||
* Mon Apr 04 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc1.16]
|
||||
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
|
||||
|
@ -45,10 +45,11 @@
|
||||
drivers/scsi/qla4xxx/ql4_os.c | 2 +
|
||||
drivers/usb/core/hub.c | 7 +
|
||||
drivers/virtio/virtio_mem.c | 13 +
|
||||
fs/afs/main.c | 3 +
|
||||
fs/ext4/super.c | 5 +
|
||||
fs/xfs/xfs_super.c | 5 +
|
||||
include/linux/efi.h | 22 +-
|
||||
include/linux/kernel.h | 19 +
|
||||
include/linux/kernel.h | 21 +
|
||||
include/linux/lsm_hook_defs.h | 2 +
|
||||
include/linux/lsm_hooks.h | 6 +
|
||||
include/linux/mmzone.h | 11 +-
|
||||
@ -65,7 +66,7 @@
|
||||
kernel/module.c | 2 +
|
||||
kernel/module_signing.c | 9 +-
|
||||
kernel/panic.c | 14 +
|
||||
kernel/rh_messages.c | 179 +++++++
|
||||
kernel/rh_messages.c | 209 +++++++++
|
||||
kernel/sysctl.c | 5 +
|
||||
mm/cma.c | 10 +
|
||||
scripts/mod/modpost.c | 8 +
|
||||
@ -74,7 +75,8 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
76 files changed, 1735 insertions(+), 192 deletions(-)
|
||||
tools/power/x86/intel-speed-select/Makefile | 2 +-
|
||||
78 files changed, 1771 insertions(+), 193 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index 3f1cc5e317ed..fbc0870dd787 100644
|
||||
@ -2092,6 +2094,20 @@ index e7d6b679596d..e604370ed3c1 100644
|
||||
atomic_set(&vm->config_changed, 1);
|
||||
queue_work(system_freezable_wq, &vm->wq);
|
||||
}
|
||||
diff --git a/fs/afs/main.c b/fs/afs/main.c
|
||||
index eae288c8d40a..8b8bf447cedc 100644
|
||||
--- a/fs/afs/main.c
|
||||
+++ b/fs/afs/main.c
|
||||
@@ -201,6 +201,9 @@ static int __init afs_init(void)
|
||||
goto error_proc;
|
||||
}
|
||||
|
||||
+#ifdef CONFIG_RHEL_DIFFERENCES
|
||||
+ mark_partner_supported(KBUILD_MODNAME, THIS_MODULE);
|
||||
+#endif
|
||||
return ret;
|
||||
|
||||
error_proc:
|
||||
diff --git a/fs/ext4/super.c b/fs/ext4/super.c
|
||||
index 81749eaddf4c..f5de0c0c14cd 100644
|
||||
--- a/fs/ext4/super.c
|
||||
@ -2203,10 +2219,10 @@ index ccd4d3f91c98..e64643e3e364 100644
|
||||
enum efi_secureboot_mode efi_get_secureboot_mode(efi_get_variable_t *get_var)
|
||||
{
|
||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||
index 08ba5995aa8b..5745b60e3b78 100644
|
||||
index 08ba5995aa8b..1aa251e902cd 100644
|
||||
--- a/include/linux/kernel.h
|
||||
+++ b/include/linux/kernel.h
|
||||
@@ -517,4 +517,23 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
||||
@@ -517,4 +517,25 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
||||
/* OTHER_WRITABLE? Generally considered a bad idea. */ \
|
||||
BUILD_BUG_ON_ZERO((perms) & 2) + \
|
||||
(perms))
|
||||
@ -2220,6 +2236,7 @@ index 08ba5995aa8b..5745b60e3b78 100644
|
||||
+void mark_driver_deprecated(const char *driver_name);
|
||||
+void mark_hardware_disabled(const char *driver_name, char *fmt, ...);
|
||||
+void mark_tech_preview(const char *msg, struct module *mod);
|
||||
+void mark_partner_supported(const char *msg, struct module *mod);
|
||||
+#else
|
||||
+static inline void mark_hardware_unsupported(const char *driver_name, char *fmt, ...) { }
|
||||
+static inline void mark_driver_unmaintained(const char *driver_name) { }
|
||||
@ -2227,6 +2244,7 @@ index 08ba5995aa8b..5745b60e3b78 100644
|
||||
+static inline void mark_driver_deprecated(const char *driver_name) { }
|
||||
+static inline void mark_hardware_disabled(const char *driver_name, char *fmt, ...) { }
|
||||
+static inline void mark_tech_preview(const char *msg, struct module *mod) { }
|
||||
+static inline void mark_partner_supported(const char *msg, struct module *mod) { }
|
||||
+#endif
|
||||
+
|
||||
#endif
|
||||
@ -2298,7 +2316,7 @@ index 1e135fd5c076..6ec4d001c1e2 100644
|
||||
|
||||
/* Exported symbols */
|
||||
diff --git a/include/linux/panic.h b/include/linux/panic.h
|
||||
index f5844908a089..901d51012738 100644
|
||||
index f5844908a089..0382f4a116e9 100644
|
||||
--- a/include/linux/panic.h
|
||||
+++ b/include/linux/panic.h
|
||||
@@ -74,7 +74,24 @@ static inline void set_arch_panic_timeout(int timeout, int arch_default_timeout)
|
||||
@ -2315,7 +2333,7 @@ index f5844908a089..901d51012738 100644
|
||||
+#define TAINT_23 23
|
||||
+#define TAINT_24 24
|
||||
+#define TAINT_25 25
|
||||
+#define TAINT_26 26
|
||||
+#define TAINT_PARTNER_SUPPORTED 26
|
||||
+#define TAINT_SUPPORT_REMOVED 27
|
||||
+/* Bits 28 - 31 are reserved for Red Hat use only */
|
||||
+#define TAINT_RESERVED28 28
|
||||
@ -3043,7 +3061,7 @@ index 8723ae70ea1f..fb2d773498c2 100644
|
||||
+ return ret;
|
||||
}
|
||||
diff --git a/kernel/panic.c b/kernel/panic.c
|
||||
index eb4dfb932c85..c884a0b18445 100644
|
||||
index eb4dfb932c85..310c8958e081 100644
|
||||
--- a/kernel/panic.c
|
||||
+++ b/kernel/panic.c
|
||||
@@ -404,6 +404,20 @@ const struct taint_flag taint_flags[TAINT_FLAGS_COUNT] = {
|
||||
@ -3058,7 +3076,7 @@ index eb4dfb932c85..c884a0b18445 100644
|
||||
+ [ TAINT_23 ] = { '?', '-', false },
|
||||
+ [ TAINT_24 ] = { '?', '-', false },
|
||||
+ [ TAINT_25 ] = { '?', '-', false },
|
||||
+ [ TAINT_26 ] = { '?', '-', false },
|
||||
+ [ TAINT_PARTNER_SUPPORTED ] = { 'p', ' ', true },
|
||||
+ [ TAINT_SUPPORT_REMOVED ] = { 'h', ' ', false },
|
||||
+ [ TAINT_RESERVED28 ] = { '?', '-', false },
|
||||
+ [ TAINT_RESERVED29 ] = { '?', '-', false },
|
||||
@ -3069,10 +3087,10 @@ index eb4dfb932c85..c884a0b18445 100644
|
||||
/**
|
||||
diff --git a/kernel/rh_messages.c b/kernel/rh_messages.c
|
||||
new file mode 100644
|
||||
index 000000000000..345a979cd0e4
|
||||
index 000000000000..586c3319f530
|
||||
--- /dev/null
|
||||
+++ b/kernel/rh_messages.c
|
||||
@@ -0,0 +1,179 @@
|
||||
@@ -0,0 +1,209 @@
|
||||
+#include <linux/kernel.h>
|
||||
+#include <linux/module.h>
|
||||
+
|
||||
@ -3252,6 +3270,36 @@ index 000000000000..345a979cd0e4
|
||||
+#endif
|
||||
+}
|
||||
+EXPORT_SYMBOL(mark_tech_preview);
|
||||
+
|
||||
+/**
|
||||
+ * mark_partner_supported() - Mark driver or kernel subsystem as 'Partner Supported'
|
||||
+ * @msg: Driver or kernel subsystem name
|
||||
+ *
|
||||
+ * Called to clarify the support status of a driver. This does TAINT the
|
||||
+ * kernel. Calling this function indicates that the driver or subsystem is
|
||||
+ * supported by one of our partners and not by Red Hat directly.
|
||||
+ */
|
||||
+void mark_partner_supported(const char *msg, struct module *mod)
|
||||
+{
|
||||
+ const char *str = NULL;
|
||||
+
|
||||
+ if (msg)
|
||||
+ str = msg;
|
||||
+#ifdef CONFIG_MODULES
|
||||
+ else if (mod && mod->name)
|
||||
+ str = mod->name;
|
||||
+#endif
|
||||
+
|
||||
+ pr_warn("Notice: %s is a Partner Supported GPL module and not supported directly by Red Hat.\n"
|
||||
+ "Please contact your provider for support.\n",
|
||||
+ (str ? str : "kernel"));
|
||||
+ add_taint(TAINT_PARTNER_SUPPORTED, LOCKDEP_STILL_OK);
|
||||
+#ifdef CONFIG_MODULES
|
||||
+ if (mod)
|
||||
+ mod->taints |= (1U << TAINT_PARTNER_SUPPORTED);
|
||||
+#endif
|
||||
+}
|
||||
+EXPORT_SYMBOL(mark_partner_supported);
|
||||
diff --git a/kernel/sysctl.c b/kernel/sysctl.c
|
||||
index 830aaf8ca08e..080bafbeabef 100644
|
||||
--- a/kernel/sysctl.c
|
||||
@ -3419,32 +3467,16 @@ index b7cf5cbfdc67..3cde9062fcf6 100644
|
||||
#ifdef CONFIG_PERF_EVENTS
|
||||
int security_perf_event_open(struct perf_event_attr *attr, int type)
|
||||
{
|
||||
From 5834cadfb4eb3051a4fddae48579706f3e050c16 Mon Sep 17 00:00:00 2001
|
||||
From: "Justin M. Forbes" <jforbes@fedoraproject.org>
|
||||
Date: Fri, 1 Apr 2022 17:14:48 -0500
|
||||
Subject: [PATCH] Fix build flag passing for intel-speed-select
|
||||
|
||||
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
---
|
||||
tools/power/x86/intel-speed-select/Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-speed-select/Makefile
|
||||
index 846f785e278d..b1ae862cec9d 100644
|
||||
index 846f785e278d..7221f2f55e8b 100644
|
||||
--- a/tools/power/x86/intel-speed-select/Makefile
|
||||
+++ b/tools/power/x86/intel-speed-select/Makefile
|
||||
@@ -40,9 +40,9 @@ prepare: $(OUTPUT)include/linux/isst_if.h $(OUTPUT)include/linux/thermal.h
|
||||
ISST_IN := $(OUTPUT)intel-speed-select-in.o
|
||||
|
||||
@@ -42,7 +42,7 @@ ISST_IN := $(OUTPUT)intel-speed-select-in.o
|
||||
$(ISST_IN): prepare FORCE
|
||||
- $(Q)$(MAKE) $(build)=intel-speed-select
|
||||
+ $(Q)$(MAKE) CFLAGS="$(CFLAGS)" $(build)=intel-speed-select
|
||||
$(Q)$(MAKE) $(build)=intel-speed-select
|
||||
$(OUTPUT)intel-speed-select: $(ISST_IN)
|
||||
- $(QUIET_LINK)$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
|
||||
+ $(QUIET_LINK)$(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
|
||||
+ $(QUIET_LINK)$(CC) $(CFLAGS) $< $(LDFLAGS) -o $@
|
||||
|
||||
clean:
|
||||
rm -f $(ALL_PROGRAMS)
|
||||
--
|
||||
2.35.1
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.18-rc1.tar.xz) = 155c3f491d890d3a9b03ce85e6ec1db2c43b569a40a06f3d290da560c442d08803e6f5653915008a85ac83d2e645ca51a97005676f13b0c3feae2d3cbac7b30b
|
||||
SHA512 (kernel-abi-stablelists-5.18.0-0.rc1.18.tar.bz2) = 938df52ea372a9876fb51f7becff2c7fa51db9894135af4b944bd9dfe16298d32197a1a6f9b4704abb79504d70df8e70993e55d2920119734c3b69afc76fa718
|
||||
SHA512 (kernel-kabi-dw-5.18.0-0.rc1.18.tar.bz2) = 8a3d9da5820b7f56f9de8228ef021e7d0533b48f4fe12106e1ec83d8717914bd11a23ede0208a45d6732e0df3a16e7925ce68aa1b6b71ebd8c1fdd2513123aac
|
||||
SHA512 (linux-5.18-rc1-16-g3e732ebf7316ac8.tar.xz) = 4a7e991fbcc80832d0e05eb0ae1dad514e542c74b8a32c059e9c215f736a46b12d101ba578bd2014135eaee57a9dc807d667bc9975584817f9655cb91aa861b1
|
||||
SHA512 (kernel-abi-stablelists-5.18.0-0.rc1.20220406git3e732ebf7316ac8.19.tar.bz2) = 71de10f2fd9e25ccdb7942357d6129f972067c254a688e0b9b08d24bd46d00d08a0c4db9ccd9d0bb73ed7fb5b9463bfbf93ecdce20a61ddfa165014564edc0a7
|
||||
SHA512 (kernel-kabi-dw-5.18.0-0.rc1.20220406git3e732ebf7316ac8.19.tar.bz2) = aa551e25333ed0cf4ff9f016ec3bb3fd7be8ca2627bd06a481092aef0e1817692080aa0555efc85cb96307da0c8ffc291e8d337e50c8ad87233884af6163cae5
|
||||
|
Loading…
Reference in New Issue
Block a user