Update to 3.0-rc3
Add another conflicts to deal with 2 digit versions (libdm.) Now that $SUBLEVEL in Makefile is optional, drop it and simplify linux-3.0-fix-uts-release.patch linux-2.6-i386-nx-emulation.patch: fix simple reject drm-intel-eeebox-eb1007-quirk.patch, revert-ftrace-remove-unnecessary-disabling-of-irqs.patch, ath5k-disable-fast-channel-switching-by-default.patch: drop upstream patches.
This commit is contained in:
parent
33b31a1c76
commit
61c4903272
@ -1,74 +0,0 @@
|
||||
From 8fa0f2e505a58f6694a94f68d90e509530e68679 Mon Sep 17 00:00:00 2001
|
||||
From: Nick Kossifidis <mickflemm@gmail.com>
|
||||
Date: Thu, 2 Jun 2011 03:09:48 +0300
|
||||
Subject: ath5k: Disable fast channel switching by default
|
||||
|
||||
Disable fast channel change by default on AR2413/AR5413 due to
|
||||
some bug reports (it still works for me but it's better to be safe).
|
||||
Add a module parameter "fastchanswitch" in case anyone wants to enable
|
||||
it and play with it.
|
||||
|
||||
Signed-off-by: Nick Kossifidis <mickflemm@gmail.com>
|
||||
Tested-by: Sedat Dilek <sedat.dilek@gmail.com>
|
||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
||||
---
|
||||
drivers/net/wireless/ath/ath5k/base.c | 11 ++++++++++-
|
||||
drivers/net/wireless/ath/ath5k/reset.c | 5 ++++-
|
||||
2 files changed, 14 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/ath/ath5k/base.c b/drivers/net/wireless/ath/ath5k/base.c
|
||||
index 2204762..b6c5d37 100644
|
||||
--- a/drivers/net/wireless/ath/ath5k/base.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/base.c
|
||||
@@ -72,6 +72,11 @@ static int modparam_all_channels;
|
||||
module_param_named(all_channels, modparam_all_channels, bool, S_IRUGO);
|
||||
MODULE_PARM_DESC(all_channels, "Expose all channels the device can use.");
|
||||
|
||||
+static int modparam_fastchanswitch;
|
||||
+module_param_named(fastchanswitch, modparam_fastchanswitch, bool, S_IRUGO);
|
||||
+MODULE_PARM_DESC(fastchanswitch, "Enable fast channel switching for AR2413/AR5413 radios.");
|
||||
+
|
||||
+
|
||||
/* Module info */
|
||||
MODULE_AUTHOR("Jiri Slaby");
|
||||
MODULE_AUTHOR("Nick Kossifidis");
|
||||
@@ -2686,6 +2691,7 @@ ath5k_reset(struct ath5k_softc *sc, struct ieee80211_channel *chan,
|
||||
struct ath5k_hw *ah = sc->ah;
|
||||
struct ath_common *common = ath5k_hw_common(ah);
|
||||
int ret, ani_mode;
|
||||
+ bool fast;
|
||||
|
||||
ATH5K_DBG(sc, ATH5K_DEBUG_RESET, "resetting\n");
|
||||
|
||||
@@ -2705,7 +2711,10 @@ ath5k_reset(struct ath5k_softc *sc, struct ieee80211_channel *chan,
|
||||
ath5k_drain_tx_buffs(sc);
|
||||
if (chan)
|
||||
sc->curchan = chan;
|
||||
- ret = ath5k_hw_reset(ah, sc->opmode, sc->curchan, chan != NULL,
|
||||
+
|
||||
+ fast = ((chan != NULL) && modparam_fastchanswitch) ? 1 : 0;
|
||||
+
|
||||
+ ret = ath5k_hw_reset(ah, sc->opmode, sc->curchan, fast,
|
||||
skip_pcu);
|
||||
if (ret) {
|
||||
ATH5K_ERR(sc, "can't reset hardware (%d)\n", ret);
|
||||
diff --git a/drivers/net/wireless/ath/ath5k/reset.c b/drivers/net/wireless/ath/ath5k/reset.c
|
||||
index 3510de2..126a4ea 100644
|
||||
--- a/drivers/net/wireless/ath/ath5k/reset.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/reset.c
|
||||
@@ -1124,8 +1124,11 @@ int ath5k_hw_reset(struct ath5k_hw *ah, enum nl80211_iftype op_mode,
|
||||
/* Non fatal, can happen eg.
|
||||
* on mode change */
|
||||
ret = 0;
|
||||
- } else
|
||||
+ } else {
|
||||
+ ATH5K_DBG(ah->ah_sc, ATH5K_DEBUG_RESET,
|
||||
+ "fast chan change successful\n");
|
||||
return 0;
|
||||
+ }
|
||||
}
|
||||
|
||||
/*
|
||||
--
|
||||
1.7.5.2
|
||||
|
@ -1,36 +0,0 @@
|
||||
From ab737b006568d01204cc51368c7e2067eecb2cff Mon Sep 17 00:00:00 2001
|
||||
From: Hans de Goede <hdegoede@redhat.com>
|
||||
Date: Thu, 7 Apr 2011 13:31:57 +0200
|
||||
Subject: [PATCH] drm/i915: Add a no lvds quirk for the Asus EeeBox PC EB1007
|
||||
|
||||
I found this while figuring out why gnome-shell would not run on my
|
||||
Asus EeeBox PC EB1007. As a standalone "pc" this device cleary does not have
|
||||
an internal panel, yet it claims it does. Add a quirk to fix this.
|
||||
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
---
|
||||
drivers/gpu/drm/i915/intel_lvds.c | 8 ++++++++
|
||||
1 files changed, 8 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/i915/intel_lvds.c b/drivers/gpu/drm/i915/intel_lvds.c
|
||||
index a562bd2..954822a 100644
|
||||
--- a/drivers/gpu/drm/i915/intel_lvds.c
|
||||
+++ b/drivers/gpu/drm/i915/intel_lvds.c
|
||||
@@ -724,6 +724,14 @@ static const struct dmi_system_id intel_no_lvds[] = {
|
||||
DMI_MATCH(DMI_PRODUCT_NAME, "U800"),
|
||||
},
|
||||
},
|
||||
+ {
|
||||
+ .callback = intel_no_lvds_dmi_callback,
|
||||
+ .ident = "Asus EeeBox PC EB1007",
|
||||
+ .matches = {
|
||||
+ DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK Computer INC."),
|
||||
+ DMI_MATCH(DMI_PRODUCT_NAME, "EB1007"),
|
||||
+ },
|
||||
+ },
|
||||
|
||||
{ } /* terminating entry */
|
||||
};
|
||||
--
|
||||
1.7.4.2
|
||||
|
26
kernel.spec
26
kernel.spec
@ -83,7 +83,7 @@ Summary: The Linux kernel
|
||||
# % define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
%define upstream_sublevel 0
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
@ -433,7 +433,7 @@ Summary: The Linux kernel
|
||||
# First the general kernel 2.6 required versions as per
|
||||
# Documentation/Changes
|
||||
#
|
||||
%define kernel_dot_org_conflicts ppp < 2.4.3-3, isdn4k-utils < 3.2-32, nfs-utils < 1.0.7-12, e2fsprogs < 1.37-4, util-linux < 2.12, jfsutils < 1.1.7-2, reiserfs-utils < 3.6.19-2, xfsprogs < 2.6.13-4, procps < 3.2.5-6.3, oprofile < 0.9.1-2, module-init-tools < 3.13-1
|
||||
%define kernel_dot_org_conflicts ppp < 2.4.3-3, isdn4k-utils < 3.2-32, nfs-utils < 1.0.7-12, e2fsprogs < 1.37-4, util-linux < 2.12, jfsutils < 1.1.7-2, reiserfs-utils < 3.6.19-2, xfsprogs < 2.6.13-4, procps < 3.2.5-6.3, oprofile < 0.9.1-2, module-init-tools < 3.13-1, device-mapper-libs < 2.02.84-2
|
||||
|
||||
#
|
||||
# Then a series of requirements that are distribution specific, either
|
||||
@ -531,7 +531,7 @@ BuildRequires: rpm-build >= 4.4.2.1-4
|
||||
%endif
|
||||
|
||||
# Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
|
||||
Source0: ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-3.0-rc2.tar.bz2
|
||||
Source0: ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-3.0-rc3.tar.bz2
|
||||
|
||||
Source11: genkey
|
||||
Source14: find-provides
|
||||
@ -672,7 +672,6 @@ Patch1824: drm-intel-next.patch
|
||||
Patch1825: drm-intel-make-lvds-work.patch
|
||||
Patch1826: drm-intel-edp-fixes.patch
|
||||
Patch1827: drm-i915-gen4-has-non-power-of-two-strides.patch
|
||||
Patch1828: drm-intel-eeebox-eb1007-quirk.patch
|
||||
|
||||
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
||||
|
||||
@ -717,9 +716,6 @@ Patch12401: mm-slub-do-not-wake-kswapd-for-slubs-speculative-high-order-allocati
|
||||
Patch12402: mm-slub-do-not-take-expensive-steps-for-slubs-speculative-high-order-allocations.patch
|
||||
Patch12403: mm-vmscan-if-kswapd-has-been-running-too-long-allow-it-to-sleep.patch
|
||||
|
||||
Patch12404: revert-ftrace-remove-unnecessary-disabling-of-irqs.patch
|
||||
Patch12405: ath5k-disable-fast-channel-switching-by-default.patch
|
||||
|
||||
%endif
|
||||
|
||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||
@ -1284,7 +1280,6 @@ ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
||||
# rhbz#681285 (i965: crash in brw_wm_surface_state.c::prepare_wm_surfaces()
|
||||
# where intelObj->mt == NULL)
|
||||
#ApplyPatch drm-i915-gen4-has-non-power-of-two-strides.patch
|
||||
ApplyPatch drm-intel-eeebox-eb1007-quirk.patch
|
||||
|
||||
# linux1394 git patches
|
||||
#ApplyPatch linux-2.6-firewire-git-update.patch
|
||||
@ -1326,12 +1321,6 @@ ApplyPatch mm-slub-do-not-wake-kswapd-for-slubs-speculative-high-order-allocatio
|
||||
ApplyPatch mm-slub-do-not-take-expensive-steps-for-slubs-speculative-high-order-allocations.patch
|
||||
ApplyPatch mm-vmscan-if-kswapd-has-been-running-too-long-allow-it-to-sleep.patch
|
||||
|
||||
# rhbz#710921
|
||||
ApplyPatch revert-ftrace-remove-unnecessary-disabling-of-irqs.patch
|
||||
|
||||
# rhbz#709122
|
||||
ApplyPatch ath5k-disable-fast-channel-switching-by-default.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -1940,6 +1929,15 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Tue Jun 14 2011 Kyle McMartin <kmcmartin@redhat.com>
|
||||
- Update to 3.0-rc3, add another conflicts to deal with 2 digit
|
||||
versions (libdm.)
|
||||
- Simplify linux-3.0-fix-uts-release.patch now that SUBLEVEL is optional.
|
||||
- revert-ftrace-remove-unnecessary-disabling-of-irqs.patch: drop upstreamed
|
||||
patch.
|
||||
- drm-intel-eeebox-eb1007-quirk.patch: ditto.
|
||||
- ath5k-disable-fast-channel-switching-by-default.patch: ditto.
|
||||
|
||||
* Thu Jun 09 2011 Kyle McMartin <kmcmartin@redhat.com>
|
||||
- ath5k-disable-fast-channel-switching-by-default.patch (rhbz#709122)
|
||||
(korgbz#34992) [a99168ee in wireless-next]
|
||||
|
@ -143,8 +143,8 @@
|
||||
set_user_gs(regs, 0);
|
||||
+
|
||||
regs->fs = 0;
|
||||
set_fs(USER_DS);
|
||||
regs->ds = __USER_DS;
|
||||
regs->es = __USER_DS;
|
||||
@@ -252,6 +255,11 @@ start_thread(struct pt_regs *regs, unsigned long new_ip, unsigned long new_sp)
|
||||
regs->cs = __USER_CS;
|
||||
regs->ip = new_ip;
|
||||
|
@ -1,34 +1,12 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index afb8e0d..e435bf5 100644
|
||||
index badb923..7b2e16d 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,6 +1,5 @@
|
||||
@@ -1,6 +1,6 @@
|
||||
VERSION = 3
|
||||
PATCHLEVEL = 0
|
||||
-SUBLEVEL = 0
|
||||
EXTRAVERSION = -rc2
|
||||
+SUBLEVEL =
|
||||
EXTRAVERSION = -rc3
|
||||
NAME = Sneaky Weasel
|
||||
|
||||
@@ -378,9 +377,9 @@ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||
|
||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
||||
-KERNELVERSION = $(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
|
||||
+KERNELVERSION = $(VERSION).$(PATCHLEVEL)$(EXTRAVERSION)
|
||||
|
||||
-export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
|
||||
+export VERSION PATCHLEVEL KERNELRELEASE KERNELVERSION
|
||||
export ARCH SRCARCH CONFIG_SHELL HOSTCC HOSTCFLAGS CROSS_COMPILE AS LD CC
|
||||
export CPP AR NM STRIP OBJCOPY OBJDUMP
|
||||
export MAKE AWK GENKSYMS INSTALLKERNEL PERL UTS_MACHINE
|
||||
@@ -1005,8 +1004,8 @@ endef
|
||||
|
||||
define filechk_version.h
|
||||
(echo \#define LINUX_VERSION_CODE $(shell \
|
||||
- expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256 + $(SUBLEVEL)); \
|
||||
- echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
|
||||
+ expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256); \
|
||||
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8))';)
|
||||
endef
|
||||
|
||||
include/linux/version.h: $(srctree)/Makefile FORCE
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 2735da6316af256e62d5f6c15ffa451182734bc3 Mon Sep 17 00:00:00 2001
|
||||
From: Kyle McMartin <kyle@mcmartin.ca>
|
||||
Date: Thu, 9 Jun 2011 10:19:15 -0400
|
||||
Subject: Revert "ftrace: Remove unnecessary disabling of irqs"
|
||||
|
||||
This reverts commit 8ab2b7efd3e2ccf2c2dda3206b8171ecdbd0af40.
|
||||
---
|
||||
kernel/trace/ftrace.c | 4 ++++
|
||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
|
||||
index 1ee417f..a75432a 100644
|
||||
--- a/kernel/trace/ftrace.c
|
||||
+++ b/kernel/trace/ftrace.c
|
||||
@@ -3330,6 +3330,7 @@ static int ftrace_process_locs(struct module *mod,
|
||||
{
|
||||
unsigned long *p;
|
||||
unsigned long addr;
|
||||
+ unsigned long flags;
|
||||
|
||||
mutex_lock(&ftrace_lock);
|
||||
p = start;
|
||||
@@ -3346,7 +3347,10 @@ static int ftrace_process_locs(struct module *mod,
|
||||
ftrace_record_ip(addr);
|
||||
}
|
||||
|
||||
+ /* disable interrupts to prevent kstop machine */
|
||||
+ local_irq_save(flags);
|
||||
ftrace_update_code(mod);
|
||||
+ local_irq_restore(flags);
|
||||
mutex_unlock(&ftrace_lock);
|
||||
|
||||
return 0;
|
||||
--
|
||||
1.7.5.2
|
||||
|
Loading…
Reference in New Issue
Block a user