Linux v3.13-8631-gba635f8
This commit is contained in:
parent
743557a9bd
commit
5fdcc0c769
@ -1,34 +1,105 @@
|
||||
From 80f13c7cb8c2b83b6b38a953ad69b91cab9dc614 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@fedoraproject.org>
|
||||
Date: Sat, 25 Jan 2014 10:00:41 -0500
|
||||
Subject: [PATCH] usb: phy: Quiet unable to find transceiver message
|
||||
|
||||
commit 1ae5799ef6317 ("usb: hcd: Initialize USB phy if needed") allows
|
||||
the USB layer to initialize external PHYs if needed. However, a PHY is
|
||||
not needed in all cases. The usb_get_phy_device function will print
|
||||
an error message, "unable to find transceiver" but everything still
|
||||
functions normally.
|
||||
Delivered-To: jwboyer@gmail.com
|
||||
Received: by 10.76.27.197 with SMTP id v5csp121130oag;
|
||||
Mon, 27 Jan 2014 07:29:10 -0800 (PST)
|
||||
X-Received: by 10.68.137.65 with SMTP id qg1mr20771227pbb.124.1390836550393;
|
||||
Mon, 27 Jan 2014 07:29:10 -0800 (PST)
|
||||
Return-Path: <balbi@ti.com>
|
||||
Received: from bastion.fedoraproject.org (bastion02.fedoraproject.org. [209.132.181.3])
|
||||
by mx.google.com with ESMTP id yy4si11903048pbc.9.2014.01.27.07.29.07
|
||||
for <jwboyer@gmail.com>;
|
||||
Mon, 27 Jan 2014 07:29:07 -0800 (PST)
|
||||
Received-SPF: fail (google.com: domain of balbi@ti.com does not designate 209.132.181.3 as permitted sender) client-ip=209.132.181.3;
|
||||
Authentication-Results: mx.google.com;
|
||||
spf=hardfail (google.com: domain of balbi@ti.com does not designate 209.132.181.3 as permitted sender) smtp.mail=balbi@ti.com
|
||||
Received: by bastion02.phx2.fedoraproject.org (Postfix)
|
||||
id 9A80D40273; Mon, 27 Jan 2014 15:29:06 +0000 (UTC)
|
||||
Delivered-To: jwboyer@fedoraproject.org
|
||||
Received: from mx1.redhat.com (ext-mx13.extmail.prod.ext.phx2.redhat.com [10.5.110.18])
|
||||
by bastion02.phx2.fedoraproject.org (Postfix) with ESMTP id 85E144011D
|
||||
for <jwboyer@fedoraproject.org>; Mon, 27 Jan 2014 15:29:06 +0000 (UTC)
|
||||
Received: from devils.ext.ti.com (devils.ext.ti.com [198.47.26.153])
|
||||
by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id s0RFT29Q007074
|
||||
for <jwboyer@fedoraproject.org>; Mon, 27 Jan 2014 10:29:03 -0500
|
||||
Received: from dlelxv90.itg.ti.com ([172.17.2.17])
|
||||
by devils.ext.ti.com (8.13.7/8.13.7) with ESMTP id s0RFT1Wo001747;
|
||||
Mon, 27 Jan 2014 09:29:01 -0600
|
||||
Received: from DFLE72.ent.ti.com (dfle72.ent.ti.com [128.247.5.109])
|
||||
by dlelxv90.itg.ti.com (8.14.3/8.13.8) with ESMTP id s0RFT1qC011168;
|
||||
Mon, 27 Jan 2014 09:29:01 -0600
|
||||
Received: from dflp33.itg.ti.com (10.64.6.16) by DFLE72.ent.ti.com
|
||||
(128.247.5.109) with Microsoft SMTP Server id 14.2.342.3; Mon, 27 Jan 2014
|
||||
09:29:01 -0600
|
||||
Received: from localhost (ileax41-snat.itg.ti.com [10.172.224.153]) by
|
||||
dflp33.itg.ti.com (8.14.3/8.13.8) with ESMTP id s0RFT0hK021639; Mon, 27 Jan
|
||||
2014 09:29:01 -0600
|
||||
From: Felipe Balbi <balbi@ti.com>
|
||||
To: Greg KH <gregkh@linuxfoundation.org>
|
||||
CC: <jwboyer@fedoraproject.org>,
|
||||
Linux USB Mailing List
|
||||
<linux-usb@vger.kernel.org>,
|
||||
Felipe Balbi <balbi@ti.com>
|
||||
Subject: [PATCH] usb: phy: move some error messages to debug
|
||||
Date: Mon, 27 Jan 2014 09:27:46 -0600
|
||||
Message-ID: <1390836466-16007-1-git-send-email-balbi@ti.com>
|
||||
X-Mailer: git-send-email 1.8.5.2
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain
|
||||
X-RedHat-Spam-Score: -7.473 (BAYES_00,DCC_REPUT_13_19,RCVD_IN_DNSWL_HI,RP_MATCHES_RCVD,SPF_PASS)
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.110.18
|
||||
|
||||
Drop the severity of this message to pr_debug.
|
||||
the PHY layer is supposed to be optional,
|
||||
considering some PHY have no control bus
|
||||
for SW to poke around.
|
||||
|
||||
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||
After commit 1ae5799 (usb: hcd: Initialize
|
||||
USB phy if needed) any HCD which didn't provide
|
||||
a PHY driver would emit annoying error messages.
|
||||
|
||||
In this patch we're decreasing those messages
|
||||
to debugging only and we also add a PHY prefix
|
||||
so we know where they're coming from.
|
||||
|
||||
Reported-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||
Signed-off-by: Felipe Balbi <balbi@ti.com>
|
||||
---
|
||||
drivers/usb/phy/phy.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
drivers/usb/phy/phy.c | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/drivers/usb/phy/phy.c b/drivers/usb/phy/phy.c
|
||||
index e6f61e4..c7fe880 100644
|
||||
index e6f61e4..29840c2 100644
|
||||
--- a/drivers/usb/phy/phy.c
|
||||
+++ b/drivers/usb/phy/phy.c
|
||||
@@ -130,7 +130,7 @@ struct usb_phy *usb_get_phy(enum usb_phy_type type)
|
||||
|
||||
phy = __usb_find_phy(&phy_list, type);
|
||||
if (IS_ERR(phy) || !try_module_get(phy->dev->driver->owner)) {
|
||||
- pr_err("unable to find transceiver of type %s\n",
|
||||
+ pr_debug("PHY: unable to find transceiver of type %s\n",
|
||||
usb_phy_type_string(type));
|
||||
goto err0;
|
||||
}
|
||||
@@ -228,7 +228,7 @@ struct usb_phy *usb_get_phy_dev(struct device *dev, u8 index)
|
||||
|
||||
phy = __usb_find_phy_dev(dev, &phy_bind_list, index);
|
||||
if (IS_ERR(phy) || !try_module_get(phy->dev->driver->owner)) {
|
||||
- pr_err("unable to find transceiver\n");
|
||||
+ pr_debug("unable to find transceiver\n");
|
||||
+ pr_debug("PHY: unable to find transceiver\n");
|
||||
goto err0;
|
||||
}
|
||||
|
||||
--
|
||||
1.8.5.3
|
||||
@@ -424,10 +424,8 @@ int usb_bind_phy(const char *dev_name, u8 index,
|
||||
unsigned long flags;
|
||||
|
||||
phy_bind = kzalloc(sizeof(*phy_bind), GFP_KERNEL);
|
||||
- if (!phy_bind) {
|
||||
- pr_err("phy_bind(): No memory for phy_bind");
|
||||
+ if (!phy_bind)
|
||||
return -ENOMEM;
|
||||
- }
|
||||
|
||||
phy_bind->dev_name = dev_name;
|
||||
phy_bind->phy_dev_name = phy_dev_name;
|
||||
--
|
||||
1.8.5.2
|
||||
|
||||
|
11
kernel.spec
11
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 11
|
||||
%define gitrev 12
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -403,7 +403,7 @@ Group: System Environment/Kernel
|
||||
License: GPLv2 and Redistributable, no modification permitted
|
||||
URL: http://www.kernel.org/
|
||||
Version: %{rpmversion}
|
||||
Release: %{pkg_release}.1
|
||||
Release: %{pkg_release}
|
||||
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
|
||||
# SET %%nobuildarches (ABOVE) INSTEAD
|
||||
ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x %{arm} aarch64
|
||||
@ -633,6 +633,7 @@ Patch25187: revert-fsnotify-changes.patch
|
||||
Patch25188: 0001-usb-phy-Quiet-unable-to-find-transceiver-message.patch
|
||||
|
||||
Patch25189: ath9k-fix-bad-udelay.patch
|
||||
Patch25190: perf-fix-asm-hash-build.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
@ -1291,6 +1292,7 @@ ApplyPatch revert-fsnotify-changes.patch
|
||||
ApplyPatch 0001-usb-phy-Quiet-unable-to-find-transceiver-message.patch
|
||||
|
||||
ApplyPatch ath9k-fix-bad-udelay.patch
|
||||
ApplyPatch perf-fix-asm-hash-build.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
@ -2071,7 +2073,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Jan 27 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc0.git11.1.1
|
||||
* Mon Jan 27 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc0.git12.1
|
||||
- Linux v3.13-8631-gba635f8
|
||||
|
||||
* Mon Jan 27 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc0.git11.1
|
||||
- Linux v3.13-8598-g77d143d
|
||||
|
||||
* Sat Jan 25 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc0.git10.1
|
||||
|
84
perf-fix-asm-hash-build.patch
Normal file
84
perf-fix-asm-hash-build.patch
Normal file
@ -0,0 +1,84 @@
|
||||
|
||||
Delivered-To: jwboyer@gmail.com
|
||||
Received: by 10.76.27.197 with SMTP id v5csp113980oag;
|
||||
Mon, 27 Jan 2014 05:43:50 -0800 (PST)
|
||||
X-Received: by 10.68.130.130 with SMTP id oe2mr3424108pbb.135.1390830230109;
|
||||
Mon, 27 Jan 2014 05:43:50 -0800 (PST)
|
||||
Return-Path: <linux-kernel-owner@vger.kernel.org>
|
||||
Received: from vger.kernel.org (vger.kernel.org. [209.132.180.67])
|
||||
by mx.google.com with ESMTP id rx8si11409416pac.134.2014.01.27.05.43.10
|
||||
for <multiple recipients>;
|
||||
Mon, 27 Jan 2014 05:43:50 -0800 (PST)
|
||||
Received-SPF: pass (google.com: best guess record for domain of linux-kernel-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) client-ip=209.132.180.67;
|
||||
Authentication-Results: mx.google.com;
|
||||
spf=pass (google.com: best guess record for domain of linux-kernel-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) smtp.mail=linux-kernel-owner@vger.kernel.org
|
||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1753622AbaA0Njl (ORCPT <rfc822;padmanabhlinux@gmail.com>
|
||||
+ 99 others); Mon, 27 Jan 2014 08:39:41 -0500
|
||||
Received: from mx1.redhat.com ([209.132.183.28]:64570 "EHLO mx1.redhat.com"
|
||||
rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP
|
||||
id S1753380AbaA0Njl (ORCPT <rfc822;linux-kernel@vger.kernel.org>);
|
||||
Mon, 27 Jan 2014 08:39:41 -0500
|
||||
Received: from int-mx09.intmail.prod.int.phx2.redhat.com (int-mx09.intmail.prod.int.phx2.redhat.com [10.5.11.22])
|
||||
by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id s0RDdFjh026600
|
||||
(version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=OK);
|
||||
Mon, 27 Jan 2014 08:39:15 -0500
|
||||
Received: from localhost (vpn1-5-245.ams2.redhat.com [10.36.5.245])
|
||||
by int-mx09.intmail.prod.int.phx2.redhat.com (8.14.4/8.14.4) with ESMTP id s0RDdDfN025726;
|
||||
Mon, 27 Jan 2014 08:39:14 -0500
|
||||
From: Francesco Fusco <ffusco@redhat.com>
|
||||
To: acme@infradead.org
|
||||
Cc: linux-kernel@vger.kernel.org
|
||||
Subject: [PATCH] tools: perf: util: fix include for non x86 architectures
|
||||
Date: Mon, 27 Jan 2014 14:39:13 +0100
|
||||
Message-Id: <2cf8143aad65a6aa6fe30325ef8a65847141afa2.1390829373.git.ffusco@redhat.com>
|
||||
In-Reply-To: <cover.1390829373.git.ffusco@redhat.com>
|
||||
References: <cover.1390829373.git.ffusco@redhat.com>
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.11.22
|
||||
Sender: linux-kernel-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-kernel.vger.kernel.org>
|
||||
X-Mailing-List: linux-kernel@vger.kernel.org
|
||||
|
||||
Commit 71ae8aac ("lib: introduce arch optimized hash library")
|
||||
added an include to <linux/hash.h> for setting up an architecture
|
||||
specific fast hash. Since perf includes directly the non-uapi
|
||||
kernel header, it cannot find <asm/hash.h> on non-x86 and thus
|
||||
prevents perf to be compiled on every architecture other than
|
||||
x86. The problem is the inclusion of <asm/hash.h> in hash.h
|
||||
that results in the following error originating from
|
||||
util/evlist.c:
|
||||
|
||||
fatal error: asm/hash.h: No such file or directory
|
||||
|
||||
This commit simply adds an empty <asm/hash.h> stub/file to fix
|
||||
the compile issue on non-x86 architectures. As perf does not use
|
||||
any of these new functions, it fixes the compilation and therefore
|
||||
seems to be the most appropriate solution to go with.
|
||||
|
||||
Signed-off-by: Francesco Fusco <ffusco@redhat.com>
|
||||
---
|
||||
tools/perf/util/include/asm/hash.h | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
create mode 100644 tools/perf/util/include/asm/hash.h
|
||||
|
||||
diff --git a/tools/perf/util/include/asm/hash.h b/tools/perf/util/include/asm/hash.h
|
||||
new file mode 100644
|
||||
index 0000000..d82b170b
|
||||
--- /dev/null
|
||||
+++ b/tools/perf/util/include/asm/hash.h
|
||||
@@ -0,0 +1,6 @@
|
||||
+#ifndef __ASM_GENERIC_HASH_H
|
||||
+#define __ASM_GENERIC_HASH_H
|
||||
+
|
||||
+/* Stub */
|
||||
+
|
||||
+#endif /* __ASM_GENERIC_HASH_H */
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||
Please read the FAQ at http://www.tux.org/lkml/
|
Loading…
Reference in New Issue
Block a user