Add model Zero dts

This commit is contained in:
Lubomir Rintel 2016-02-14 19:45:08 +01:00
parent bfeccd5029
commit 5f525a07f1
2 changed files with 62 additions and 0 deletions

View File

@ -0,0 +1,59 @@
From d9be5aeb6f4024e4fef844003b031ef008f79807 Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Tue, 2 Feb 2016 11:22:26 +0100
Subject: [PATCH 1/4] ARM: bcm2835: dt: Add Raspberry Pi Zero
Notable difference from the other Raspberry Pi boards is the lack of PWR LED.
Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/bcm2835-rpi-zero.dts | 24 ++++++++++++++++++++++++
2 files changed, 25 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm2835-rpi-zero.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index a8a0767..6db8ef8 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -64,6 +64,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
bcm2835-rpi-b-rev2.dtb \
bcm2835-rpi-b-plus.dtb \
bcm2835-rpi-a-plus.dtb \
+ bcm2835-rpi-zero.dtb \
bcm2836-rpi-2-b.dtb \
bcm2837-rpi-3-b.dtb
dtb-$(CONFIG_ARCH_BCM_5301X) += \
diff --git a/arch/arm/boot/dts/bcm2835-rpi-zero.dts b/arch/arm/boot/dts/bcm2835-rpi-zero.dts
new file mode 100644
index 0000000..f9afc1a
--- /dev/null
+++ b/arch/arm/boot/dts/bcm2835-rpi-zero.dts
@@ -0,0 +1,24 @@
+/dts-v1/;
+#include "bcm2835.dtsi"
+#include "bcm2835-rpi.dtsi"
+
+/ {
+ compatible = "raspberrypi,model-zero", "brcm,bcm2835";
+ model = "Raspberry Pi Zero";
+
+ leds {
+ act {
+ gpios = <&gpio 47 0>;
+ };
+ };
+};
+
+&gpio {
+ pinctrl-0 = <&gpioout &alt0 &i2s_alt0 &alt3>;
+
+ /* I2S interface */
+ i2s_alt0: i2s_alt0 {
+ brcm,pins = <18 19 20 21>;
+ brcm,function = <BCM2835_FSEL_ALT0>;
+ };
+};
--
2.5.5

View File

@ -657,6 +657,8 @@ Patch702: x86-build-Build-compressed-x86-kernels-as-PIE.patch
# Follow on for CVE-2016-3156
Patch703: ipv4-fib-don-t-warn-when-primary-address-is-missing-.patch
Patch66601: 0001-ARM-bcm2835-dt-Add-Raspberry-Pi-Zero.patch
# END OF PATCH DEFINITIONS
%endif
@ -2180,6 +2182,7 @@ fi
%changelog
* Tue Apr 26 2016 Lubomir Rintel <lkundrak@v3.sk> - 4.5.1-300.pi1
- Build for bcm2835/rpi
- Add Raspberry Pi Zero dts
* Tue Apr 26 2016 Justin M. Forbes <jforbes@fedoraproject.org>
- Change CONFIG_DW_DMAC to built-in to fix sound on some intel platforms