Add patch to enable keyboard backlight on Sony laptops (rhbz 728478)
This commit is contained in:
parent
18bb3c2c93
commit
5f05fc562a
11
kernel.spec
11
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -777,6 +777,9 @@ Patch21300: ACPICA-Fix-regression-in-FADT-revision-checks.patch
|
||||
#rhbz 798296
|
||||
Patch21301: cifs-fix-dentry-refcount-leak-when-opening-a-FIFO.patch
|
||||
|
||||
#rhbz 728478
|
||||
Patch21302: sony-laptop-Enable-keyboard-backlight-by-default.patch
|
||||
|
||||
# compat-wireless patches
|
||||
Patch50000: compat-wireless-config-fixups.patch
|
||||
Patch50001: compat-wireless-pr_fmt-warning-avoidance.patch
|
||||
@ -1499,6 +1502,9 @@ ApplyPatch ACPICA-Fix-regression-in-FADT-revision-checks.patch
|
||||
#rhbz 798296
|
||||
ApplyPatch cifs-fix-dentry-refcount-leak-when-opening-a-FIFO.patch
|
||||
|
||||
#rhbz 728478
|
||||
ApplyPatch sony-laptop-Enable-keyboard-backlight-by-default.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2370,6 +2376,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Feb 28 2012 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add patch to enable keyboard backlight on Sony laptops (rhbz 728478)
|
||||
|
||||
* Tue Feb 28 2012 Dave Jones <davej@redhat.com>
|
||||
- Disable CONFIG_USB_DEVICEFS (Deprecated).
|
||||
|
||||
|
44
sony-laptop-Enable-keyboard-backlight-by-default.patch
Normal file
44
sony-laptop-Enable-keyboard-backlight-by-default.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 0dbc2bc96b1ec741bdd43451c286ccd45da3310b Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@redhat.com>
|
||||
Date: Wed, 2 Nov 2011 14:31:59 -0400
|
||||
Subject: [PATCH] sony-laptop: Enable keyboard backlight by default
|
||||
|
||||
When the keyboard backlight support was originally added, the commit said
|
||||
to default it to on with a 10 second timeout. That actually wasn't the
|
||||
case, as the default value is commented out for the kbd_backlight parameter.
|
||||
Because it is a static variable, it gets set to 0 by default without some
|
||||
other form of initialization.
|
||||
|
||||
However, it seems the function to set the value wasn't actually called
|
||||
immediately, so whatever state the keyboard was in initially would remain.
|
||||
Then commit df410d522410e67660 was introduced during the 2.6.39 timeframe to
|
||||
immediately set whatever value was present (as well as attempt to
|
||||
restore/reset the state on module removal or resume). That seems to have
|
||||
now forced the light off immediately when the module is loaded unless
|
||||
the option kbd_backlight=1 is specified.
|
||||
|
||||
Let's enable it by default again (for the first time). This should solve
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=728478
|
||||
|
||||
Acked-by: Mattia Dongili <malattia@linux.it>
|
||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||
---
|
||||
drivers/platform/x86/sony-laptop.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/drivers/platform/x86/sony-laptop.c b/drivers/platform/x86/sony-laptop.c
|
||||
index c006dee..40c4705 100644
|
||||
--- a/drivers/platform/x86/sony-laptop.c
|
||||
+++ b/drivers/platform/x86/sony-laptop.c
|
||||
@@ -127,7 +127,7 @@ MODULE_PARM_DESC(minor,
|
||||
"default is -1 (automatic)");
|
||||
#endif
|
||||
|
||||
-static int kbd_backlight; /* = 1 */
|
||||
+static int kbd_backlight = 1;
|
||||
module_param(kbd_backlight, int, 0444);
|
||||
MODULE_PARM_DESC(kbd_backlight,
|
||||
"set this to 0 to disable keyboard backlight, "
|
||||
--
|
||||
1.7.7.6
|
||||
|
Loading…
Reference in New Issue
Block a user