kernel-5.13.0-0.rc3.25

* Mon May 24 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc3.25]
- Override %%{debugbuildsenabled} if the --with-release option is used (David Ward)
- Improve comments in SPEC file, and move some option tests and macros (David Ward)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-05-24 09:19:22 -05:00
parent 80fa87205c
commit 5e01d8e869
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 43 additions and 36 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 22
RHEL_RELEASE = 25
#
# Early y+1 numbering

View File

@ -59,14 +59,21 @@
Summary: The Linux kernel
# For a kernel released for public testing, released_kernel should be 1.
# For internal testing builds during development, it should be 0.
# For rawhide and/or a kernel built from an rc or git snapshot,
# released_kernel should be 0.
# For a stable, released kernel, released_kernel should be 1.
# Set released_kernel to 1 when the upstream source tarball contains a
# kernel release. (This includes prepatch or "rc" releases.)
# Set released_kernel to 0 when the upstream source tarball contains an
# unreleased kernel development snapshot.
%global released_kernel 0
%global distro_build 0.rc2.20210521git79a106fc6585.22
# Set debugbuildsenabled to 1 to build separate base and debug kernels
# (on supported architectures). The kernel-debug-* subpackages will
# contain the debug kernel.
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
%global distro_build 0.rc3.25
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -106,24 +113,23 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
# The kernel tarball/base version
%define kversion 5.13
%define rpmversion 5.13.0
%define pkgrelease 0.rc2.20210521git79a106fc6585.22
%define pkgrelease 0.rc3.25
# This is needed to do merge window version magic
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc2.20210521git79a106fc6585.22%{?buildid}%{?dist}
%define specrelease 0.rc3.25%{?buildid}%{?dist}
%define pkg_release %{specrelease}
# What parts do we want to build? These are the kernels that are built IF the
# architecture allows it. All should default to 1 (enabled) and be flipped to
# 0 (disabled) by later arch-specific checks.
# The following build options are enabled by default.
# Use either --without <opt> in your rpmbuild command or force values
# to 0 in here to disable them.
# The following build options are enabled by default, but may become disabled
# by later architecture-specific checks. These can also be disabled by using
# --without <opt> in the rpmbuild command, or by forcing these values to 0.
#
# standard kernel
%define with_up %{?_without_up: 0} %{?!_without_up: 1}
@ -131,6 +137,8 @@ Summary: The Linux kernel
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
%define with_zfcpdump %{?_without_zfcpdump: 0} %{?!_without_zfcpdump: 1}
# kernel-doc
%define with_doc %{?_without_doc: 0} %{?!_without_doc: 1}
# kernel-headers
@ -144,10 +152,6 @@ Summary: The Linux kernel
%define with_bpftool %{?_without_bpftool: 0} %{?!_without_bpftool: 1}
# kernel-debuginfo
%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
# Control whether to install the vdso directories.
%define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
%define with_zfcpdump %{?_without_zfcpdump: 0} %{?!_without_zfcpdump: 1}
# kernel-abi-whitelists
%define with_kernel_abi_whitelists %{?_without_kernel_abi_whitelists: 0} %{?!_without_kernel_abi_whitelists: 1}
# internal samples and selftests
@ -173,6 +177,9 @@ Summary: The Linux kernel
%define with_kabidwchk %{?_without_kabidwchk: 0} %{?!_without_kabidwchk: 1}
%define with_kabidw_base %{?_with_kabidw_base: 1} %{?!_with_kabidw_base: 0}
#
# Control whether to install the vdso directories.
%define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
#
# should we do C=1 builds with sparse
%define with_sparse %{?_with_sparse: 1} %{?!_with_sparse: 0}
#
@ -200,14 +207,6 @@ Summary: The Linux kernel
# Want to build a vanilla kernel build without any non-upstream patches?
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
# The kernel tarball/base version
%define kversion 5.13
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
%define with_headers 0
@ -275,6 +274,10 @@ Summary: The Linux kernel
%define nopatches 1
%endif
%if %{with_release}
%define debugbuildsenabled 1
%endif
%if !%{debugbuildsenabled}
%define with_debug 0
%endif
@ -620,7 +623,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.13-rc2-191-g79a106fc6585.tar.xz
Source0: linux-5.13-rc3.tar.xz
Source1: Makefile.rhelver
@ -1289,8 +1292,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.13-rc2-191-g79a106fc6585 -c
mv linux-5.13-rc2-191-g79a106fc6585 linux-%{KVERREL}
%setup -q -n kernel-5.13-rc3 -c
mv linux-5.13-rc3 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2792,6 +2795,10 @@ fi
#
#
%changelog
* Mon May 24 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc3.25]
- Override %%{debugbuildsenabled} if the --with-release option is used (David Ward)
- Improve comments in SPEC file, and move some option tests and macros (David Ward)
* Fri May 21 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc2.20210521git79a106fc6585.22]
- configs: enable CONFIG_EXFAT_FS (Pavel Reichl) [1943423]
- Revert s390x/zfcpdump part of a9d179c40281 and ecbfddd98621 (Vladis Dronov)

View File

@ -144,7 +144,7 @@ index 000000000000..effb81d04bfd
+
+endmenu
diff --git a/Makefile b/Makefile
index 0ed7e061c8e9..9319af840cbd 100644
index e4468353425a..95ea0abae436 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -2447,7 +2447,7 @@ index 825284baaf46..0b2b3f510b16 100644
* if the commandline contains a ':', then that's the extended
* syntax -- if not, it must be the classic syntax
diff --git a/kernel/module.c b/kernel/module.c
index b5dd92e35b02..d49412abb842 100644
index 7e78dfabca97..5095efe4d1e1 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -738,6 +738,7 @@ static struct module_attribute modinfo_##field = { \

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.13-rc2-191-g79a106fc6585.tar.xz) = ac52e8a728f297a67baba67832541b510a926fa73554c3b9c549020dc9f957da6dbdb82d88ceae7d24e9d1bfcbee02c12daf461e6dbcd487f07cedf27f718d65
SHA512 (kernel-abi-whitelists-5.13.0-0.rc2.20210521git79a106fc6585.22.tar.bz2) = 2d663943edff5268cbc95f436cf5d1b5be819ceb827e395f5a61d9e83ac940da41bd861f0a64d372c0a888a5a58f430b4e53d17eea1ff90fa1bfe0594ffcc04f
SHA512 (kernel-kabi-dw-5.13.0-0.rc2.20210521git79a106fc6585.22.tar.bz2) = 41ace74800cbc7b088cee86fd19d4e39daa5e3d1e39fa85ac245134fc9b32490ec05975751b10fa39abe025c1eb30a2f81d024e6cff2fb2c8d84bec5f01b04ad
SHA512 (linux-5.13-rc3.tar.xz) = 2c468404f85a64cb85f8e04afc7ea87e98364e85f58aefbc100826491afd6d42eddc0b5acdd771692ae12c27e9beead8cd651c7f9565aaea19be166719978b1a
SHA512 (kernel-abi-whitelists-5.13.0-0.rc3.25.tar.bz2) = b78c68c1f193fa02c3b7f1af3a5b9ef66aa7e69458cf5432eb09aa1a5202373b81dbccb014ea52443f6487b2e40bc9848c28a7228f2751795780779dfd920a5f
SHA512 (kernel-kabi-dw-5.13.0-0.rc3.25.tar.bz2) = c4ac466115ae039ef4acc20aebb6804a00f05449371bd8d75c9a97cb2dadd1e002df5870d6347a19c0674abc3ba1da9d0edd2d693ec8784fcfd5980443dd49ff