kernel-6.5.0-0.rc6.43
* Mon Aug 14 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.5.0-0.rc6.43.el127] - Linux v6.5.0-0.rc6 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
df5b5fc101
commit
5c30685a34
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 40
|
||||
RHEL_RELEASE = 43
|
||||
|
||||
#
|
||||
# RHEL_REBASE_NUM
|
||||
|
@ -1,18 +0,0 @@
|
||||
#! /bin/bash
|
||||
|
||||
# This is the armv7hl override file for the core/drivers package split. The
|
||||
# module directories listed here and in the generic list in filter-modules.sh
|
||||
# will be moved to the resulting kernel-modules package for this arch.
|
||||
# Anything not listed in those files will be in the kernel-core package.
|
||||
#
|
||||
# Please review the default list in filter-modules.sh before making
|
||||
# modifications to the overrides below. If something should be removed across
|
||||
# all arches, remove it in the default instead of per-arch.
|
||||
|
||||
driverdirs="atm auxdisplay bcma bluetooth firewire fpga infiniband media memstick message nfc ntb pcmcia ssb soundwire staging tty uio w1"
|
||||
|
||||
ethdrvs="3com adaptec alteon altera amd atheros broadcom cadence chelsio cisco dec dlink emulex mellanox micrel myricom natsemi neterion nvidia packetengines qlogic rdc sfc silan sis sun tehuti via wiznet xircom"
|
||||
|
||||
drmdrvs="amd arm armada bridge ast exynos etnaviv hisilicon i2c imx meson mgag200 msm nouveau omapdrm panel pl111 radeon rockchip sti stm sun4i tegra tilcdc tiny vc4"
|
||||
|
||||
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwpoison-inject target_core_user sbp_target cxgbit chcr bq27xxx_battery_hdq mlx5_vdpa dfl-emif spi-altera-dfl hid-playstation hid-nintendo intel-m10-bmc-pmci intel-m10-bmc-hwmon"
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
177
kernel.spec
177
kernel.spec
@ -23,18 +23,6 @@
|
||||
{error:clang_lto requires --with toolchain_clang}
|
||||
%endif
|
||||
|
||||
# Cross compile on copr for arm
|
||||
# See https://bugzilla.redhat.com/1879599
|
||||
%if 0%{?_with_cross_arm:1}
|
||||
%global _target_cpu armv7hl
|
||||
%global _arch arm
|
||||
%global _build_arch arm
|
||||
%global _with_cross 1
|
||||
# Enforces buildroot if cross_arm
|
||||
# See https://bugzilla.redhat.com/2149446
|
||||
%global buildroot %{_buildrootdir}/%{NAME}-%{VERSION}-%{RELEASE}.%{_build_cpu}
|
||||
%endif
|
||||
|
||||
# RPM macros strip everything in BUILDROOT, either with __strip
|
||||
# or find-debuginfo.sh. Make use of __spec_install_post override
|
||||
# and save/restore binaries we want to package as unstripped.
|
||||
@ -174,13 +162,13 @@ Summary: The Linux kernel
|
||||
%define specrpmversion 6.5.0
|
||||
%define specversion 6.5.0
|
||||
%define patchversion 6.5
|
||||
%define pkgrelease 0.rc5.20230811git25aa0bebba72.40
|
||||
%define pkgrelease 0.rc6.43
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.5-rc5-182-g25aa0bebba72
|
||||
%define tarfile_release 6.5-rc6
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 5
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc5.20230811git25aa0bebba72.40%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc6.43%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.5.0
|
||||
|
||||
@ -204,8 +192,6 @@ Summary: The Linux kernel
|
||||
#
|
||||
# standard kernel
|
||||
%define with_up %{?_without_up: 0} %{?!_without_up: 1}
|
||||
# kernel PAE (only valid for ARM (lpae))
|
||||
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
|
||||
# build also debug variants
|
||||
%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
|
||||
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
|
||||
@ -220,7 +206,6 @@ Summary: The Linux kernel
|
||||
# Supported variants
|
||||
# (base) with_debug with_gcov
|
||||
# up X X X
|
||||
# pae X X
|
||||
# zfcpdump X X
|
||||
# arm64_16k X X X
|
||||
# arm64_64k X X X
|
||||
@ -248,8 +233,6 @@ Summary: The Linux kernel
|
||||
#
|
||||
# Only build the base kernel (--with baseonly):
|
||||
%define with_baseonly %{?_with_baseonly: 1} %{?!_with_baseonly: 0}
|
||||
# Only build the pae kernel (--with paeonly):
|
||||
%define with_paeonly %{?_with_paeonly: 1} %{?!_with_paeonly: 0}
|
||||
# Only build the debug variants (--with dbgonly):
|
||||
%define with_dbgonly %{?_with_dbgonly: 1} %{?!_with_dbgonly: 0}
|
||||
# Only build the realtime kernel (--with rtonly):
|
||||
@ -398,14 +381,8 @@ Summary: The Linux kernel
|
||||
# and debuginfo generation. Currently we rely on the old alldebug setting.
|
||||
%global _build_id_links alldebug
|
||||
|
||||
# kernel PAE is only built on ARMv7
|
||||
%ifnarch armv7hl
|
||||
%define with_pae 0
|
||||
%endif
|
||||
|
||||
# if requested, only build base kernel
|
||||
%if %{with_baseonly}
|
||||
%define with_pae 0
|
||||
%define with_debug 0
|
||||
%define with_realtime 0
|
||||
%define with_vdso_install 0
|
||||
@ -419,13 +396,6 @@ Summary: The Linux kernel
|
||||
%define with_ipaclones 0
|
||||
%endif
|
||||
|
||||
# if requested, only build pae kernel
|
||||
%if %{with_paeonly}
|
||||
%define with_up 0
|
||||
%define with_debug 0
|
||||
%define with_realtime 0
|
||||
%endif
|
||||
|
||||
# if requested, only build debug kernel
|
||||
%if %{with_dbgonly}
|
||||
%define with_vdso_install 0
|
||||
@ -441,7 +411,6 @@ Summary: The Linux kernel
|
||||
%if %{with_rtonly}
|
||||
%define with_realtime 1
|
||||
%define with_up 0
|
||||
%define with_pae 0
|
||||
%define with_debug 0
|
||||
%define with_debuginfo 0
|
||||
%define with_vdso_install 0
|
||||
@ -567,25 +536,6 @@ Summary: The Linux kernel
|
||||
%define vmlinux_decompressor arch/s390/boot/vmlinux
|
||||
%endif
|
||||
|
||||
%ifarch %{arm}
|
||||
%define all_arch_configs %{name}-%{specrpmversion}-arm*.config
|
||||
%define skip_nonpae_vdso 1
|
||||
%define asmarch arm
|
||||
%define hdrarch arm
|
||||
%define make_target bzImage
|
||||
%define kernel_image arch/arm/boot/zImage
|
||||
# http://lists.infradead.org/pipermail/linux-arm-kernel/2012-March/091404.html
|
||||
%define kernel_mflags KALLSYMS_EXTRA_PASS=1
|
||||
# we only build headers/perf/tools on the base arm arches
|
||||
# just like we used to only build them on i386 for x86
|
||||
%ifnarch armv7hl
|
||||
%define with_headers 0
|
||||
%define with_cross_headers 0
|
||||
%endif
|
||||
# These currently don't compile on armv7
|
||||
%define with_selftests 0
|
||||
%endif
|
||||
|
||||
%ifarch aarch64
|
||||
%define all_arch_configs %{name}-%{specrpmversion}-aarch64*.config
|
||||
%define asmarch arm64
|
||||
@ -610,14 +560,13 @@ Summary: The Linux kernel
|
||||
%if 0%{?fedora}
|
||||
%define nobuildarches i386
|
||||
%else
|
||||
%define nobuildarches i386 i686 %{arm}
|
||||
%define nobuildarches i386 i686
|
||||
%endif
|
||||
|
||||
%ifarch %nobuildarches
|
||||
# disable BuildKernel commands
|
||||
%define with_up 0
|
||||
%define with_debug 0
|
||||
%define with_pae 0
|
||||
%define with_zfcpdump 0
|
||||
%define with_arm64_16k 0
|
||||
%define with_arm64_64k 0
|
||||
@ -633,19 +582,13 @@ Summary: The Linux kernel
|
||||
|
||||
# Architectures we build tools/cpupower on
|
||||
%if 0%{?fedora}
|
||||
%define cpupowerarchs %{ix86} x86_64 ppc64le %{arm} aarch64
|
||||
%define cpupowerarchs %{ix86} x86_64 ppc64le aarch64
|
||||
%else
|
||||
%define cpupowerarchs i686 x86_64 ppc64le aarch64
|
||||
%endif
|
||||
|
||||
%if 0%{?use_vdso}
|
||||
|
||||
%if 0%{?skip_nonpae_vdso}
|
||||
%define _use_vdso 0
|
||||
%else
|
||||
%define _use_vdso 1
|
||||
%endif
|
||||
|
||||
%else
|
||||
%define _use_vdso 0
|
||||
%endif
|
||||
@ -699,9 +642,9 @@ Release: %{pkg_release}
|
||||
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
|
||||
# SET %%nobuildarches (ABOVE) INSTEAD
|
||||
%if 0%{?fedora}
|
||||
ExclusiveArch: noarch x86_64 s390x %{arm} aarch64 ppc64le
|
||||
ExclusiveArch: noarch x86_64 s390x aarch64 ppc64le
|
||||
%else
|
||||
ExclusiveArch: noarch i386 i686 x86_64 s390x %{arm} aarch64 ppc64le
|
||||
ExclusiveArch: noarch i386 i686 x86_64 s390x aarch64 ppc64le
|
||||
%endif
|
||||
ExclusiveOS: Linux
|
||||
%ifnarch %{nobuildarches}
|
||||
@ -745,7 +688,7 @@ BuildRequires: java-devel
|
||||
BuildRequires: libbpf-devel >= 0.6.0-1
|
||||
BuildRequires: libbabeltrace-devel
|
||||
BuildRequires: libtraceevent-devel
|
||||
%ifnarch %{arm} s390x
|
||||
%ifnarch s390x
|
||||
BuildRequires: numactl-devel
|
||||
%endif
|
||||
%ifarch aarch64
|
||||
@ -773,10 +716,8 @@ BuildRequires: zlib-devel binutils-devel
|
||||
%endif
|
||||
%if %{with_selftests}
|
||||
BuildRequires: clang llvm-devel fuse-devel
|
||||
%ifnarch %{arm}
|
||||
BuildRequires: numactl-devel
|
||||
%endif
|
||||
BuildRequires: libcap-devel libcap-ng-devel rsync libmnl-devel
|
||||
BuildRequires: numactl-devel
|
||||
%endif
|
||||
BuildConflicts: rhbuildsys(DiskFree) < 500Mb
|
||||
%if %{with_debuginfo}
|
||||
@ -936,11 +877,10 @@ Source32: %{name}-x86_64-rhel.config
|
||||
Source33: %{name}-x86_64-debug-rhel.config
|
||||
|
||||
Source34: filter-x86_64.sh.rhel
|
||||
Source35: filter-armv7hl.sh.rhel
|
||||
Source37: filter-aarch64.sh.rhel
|
||||
Source38: filter-ppc64le.sh.rhel
|
||||
Source39: filter-s390x.sh.rhel
|
||||
Source40: filter-modules.sh.rhel
|
||||
Source35: filter-aarch64.sh.rhel
|
||||
Source36: filter-ppc64le.sh.rhel
|
||||
Source37: filter-s390x.sh.rhel
|
||||
Source38: filter-modules.sh.rhel
|
||||
|
||||
Source41: x509.genkey.centos
|
||||
# ARM64 64K page-size kernel config
|
||||
@ -955,25 +895,20 @@ Source51: mod-extra.list.fedora
|
||||
|
||||
Source52: %{name}-aarch64-fedora.config
|
||||
Source53: %{name}-aarch64-debug-fedora.config
|
||||
Source54: %{name}-armv7hl-fedora.config
|
||||
Source55: %{name}-armv7hl-debug-fedora.config
|
||||
Source56: %{name}-armv7hl-lpae-fedora.config
|
||||
Source57: %{name}-armv7hl-lpae-debug-fedora.config
|
||||
Source58: %{name}-aarch64-16k-fedora.config
|
||||
Source59: %{name}-aarch64-16k-debug-fedora.config
|
||||
Source60: %{name}-ppc64le-fedora.config
|
||||
Source61: %{name}-ppc64le-debug-fedora.config
|
||||
Source62: %{name}-s390x-fedora.config
|
||||
Source63: %{name}-s390x-debug-fedora.config
|
||||
Source64: %{name}-x86_64-fedora.config
|
||||
Source65: %{name}-x86_64-debug-fedora.config
|
||||
Source54: %{name}-aarch64-16k-fedora.config
|
||||
Source55: %{name}-aarch64-16k-debug-fedora.config
|
||||
Source56: %{name}-ppc64le-fedora.config
|
||||
Source57: %{name}-ppc64le-debug-fedora.config
|
||||
Source58: %{name}-s390x-fedora.config
|
||||
Source59: %{name}-s390x-debug-fedora.config
|
||||
Source60: %{name}-x86_64-fedora.config
|
||||
Source61: %{name}-x86_64-debug-fedora.config
|
||||
|
||||
Source67: filter-x86_64.sh.fedora
|
||||
Source68: filter-armv7hl.sh.fedora
|
||||
Source70: filter-aarch64.sh.fedora
|
||||
Source71: filter-ppc64le.sh.fedora
|
||||
Source72: filter-s390x.sh.fedora
|
||||
Source73: filter-modules.sh.fedora
|
||||
Source62: filter-x86_64.sh.fedora
|
||||
Source63: filter-aarch64.sh.fedora
|
||||
Source64: filter-ppc64le.sh.fedora
|
||||
Source65: filter-s390x.sh.fedora
|
||||
Source66: filter-modules.sh.fedora
|
||||
%endif
|
||||
|
||||
Source75: partial-kgcov-snip.config
|
||||
@ -1337,8 +1272,8 @@ Linux kernel, suitable for the kabi-dw tool.
|
||||
# This macro creates a kernel-<subpackage>-debuginfo package.
|
||||
# %%kernel_debuginfo_package <subpackage>
|
||||
#
|
||||
# Explanation of the find_debuginfo_opts: We build multiple kernels (debug
|
||||
# pae etc.) so the regex filters those kernels appropriately. We also
|
||||
# Explanation of the find_debuginfo_opts: We build multiple kernels (debug,
|
||||
# rt, 64k etc.) so the regex filters those kernels appropriately. We also
|
||||
# have to package several binaries as part of kernel-devel but getting
|
||||
# unique build-ids is tricky for these userspace binaries. We don't really
|
||||
# care about debugging those so we just filter those out and remove it.
|
||||
@ -1606,15 +1541,6 @@ This package provides kernel modules for the %{?2:%{2} }kernel package for Red H
|
||||
%{nil}
|
||||
|
||||
# Now, each variant package.
|
||||
|
||||
%if %{with_pae}
|
||||
%define variant_summary The Linux kernel compiled for Cortex-A15
|
||||
%kernel_variant_package lpae
|
||||
%description lpae-core
|
||||
This package includes a version of the Linux kernel with support for
|
||||
Cortex-A15 devices with LPAE and HW virtualisation support
|
||||
%endif
|
||||
|
||||
%if %{with_zfcpdump}
|
||||
%define variant_summary The Linux kernel compiled for zfcpdump usage
|
||||
%kernel_variant_package -o zfcpdump
|
||||
@ -2054,7 +1980,7 @@ BuildKernel() {
|
||||
mkdir -p $RPM_BUILD_ROOT%{debuginfodir}/%{image_install_path}
|
||||
%endif
|
||||
|
||||
%ifarch %{arm} aarch64
|
||||
%ifarch aarch64
|
||||
%{make} ARCH=$Arch dtbs INSTALL_DTBS_PATH=$RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer
|
||||
%{make} ARCH=$Arch dtbs_install INSTALL_DTBS_PATH=$RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer
|
||||
cp -r $RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer $RPM_BUILD_ROOT/lib/modules/$KernelVer/dtb
|
||||
@ -2344,16 +2270,6 @@ BuildKernel() {
|
||||
cp -a --parents arch/arm/include/asm/xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
# arch/arm64/include/asm/opcodes.h references arch/arm
|
||||
cp -a --parents arch/arm/include/asm/opcodes.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
%endif
|
||||
# include the machine specific headers for ARM variants, if available.
|
||||
%ifarch %{arm}
|
||||
if [ -d arch/%{asmarch}/mach-${Variant}/include ]; then
|
||||
cp -a --parents arch/%{asmarch}/mach-${Variant}/include $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
fi
|
||||
# include a few files for 'make prepare'
|
||||
cp -a --parents arch/arm/tools/gen-mach-types $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/arm/tools/mach-types $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
|
||||
%endif
|
||||
cp -a include $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
|
||||
%ifarch i686 x86_64
|
||||
@ -2631,13 +2547,11 @@ BuildKernel() {
|
||||
# the F17 UsrMove feature.
|
||||
ln -sf $DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
%ifnarch armv7hl
|
||||
# Generate vmlinux.h and put it to kernel-devel path
|
||||
# zfcpdump build does not have btf anymore
|
||||
if [ "$Variant" != "zfcpdump" ]; then
|
||||
bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
|
||||
fi
|
||||
%endif
|
||||
|
||||
# prune junk from kernel-devel
|
||||
find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
|
||||
@ -2725,10 +2639,6 @@ BuildKernel %make_target %kernel_image %{_use_vdso} 16k
|
||||
BuildKernel %make_target %kernel_image %{_use_vdso} 64k
|
||||
%endif
|
||||
|
||||
%if %{with_pae}
|
||||
BuildKernel %make_target %kernel_image %{use_vdso} lpae
|
||||
%endif
|
||||
|
||||
%if %{with_realtime_base}
|
||||
BuildKernel %make_target %kernel_image %{_use_vdso} rt
|
||||
%endif
|
||||
@ -2738,7 +2648,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
|
||||
%endif
|
||||
|
||||
%ifnarch noarch i686 %{nobuildarches}
|
||||
%if !%{with_debug} && !%{with_zfcpdump} && !%{with_pae} && !%{with_up} && !%{with_arm64_16k} && !%{with_arm64_64k} && !%{with_realtime}
|
||||
%if !%{with_debug} && !%{with_zfcpdump} && !%{with_up} && !%{with_arm64_16k} && !%{with_arm64_64k} && !%{with_realtime}
|
||||
# If only building the user space tools, then initialize the build environment
|
||||
# and some variables so that the various userspace tools can be built.
|
||||
InitBuildVars
|
||||
@ -2887,9 +2797,6 @@ find Documentation -type d | xargs chmod u+w
|
||||
# TODO - this needs to be fixed in same way as we have it in c9s
|
||||
%define __modsign_install_post \
|
||||
if [ "%{signmodules}" -eq "1" ]; then \
|
||||
if [ "%{with_pae}" -ne "0" ]; then \
|
||||
%{modsign_cmd} certs/signing_key.pem.sign+lpae certs/signing_key.x509.sign+lpae $RPM_BUILD_ROOT/lib/modules/%{KVERREL}+lpae/ \
|
||||
fi \
|
||||
if [ "%{with_up_base}" -ne "0" ]; then \
|
||||
%{modsign_cmd} certs/signing_key.pem.sign certs/signing_key.x509.sign $RPM_BUILD_ROOT/lib/modules/%{KVERREL}/ \
|
||||
fi \
|
||||
@ -2995,11 +2902,7 @@ find $RPM_BUILD_ROOT/usr/include \
|
||||
%endif
|
||||
|
||||
%if %{with_cross_headers}
|
||||
%if 0%{?fedora}
|
||||
HDR_ARCH_LIST='arm arm64 powerpc s390 x86'
|
||||
%else
|
||||
HDR_ARCH_LIST='arm64 powerpc s390 x86'
|
||||
%endif
|
||||
mkdir -p $RPM_BUILD_ROOT/usr/tmp-headers
|
||||
|
||||
for arch in $HDR_ARCH_LIST; do
|
||||
@ -3430,11 +3333,6 @@ fi\
|
||||
%kernel_variant_post -r kernel-smp
|
||||
%endif
|
||||
|
||||
%if %{with_pae}
|
||||
%kernel_variant_preun lpae
|
||||
%kernel_variant_post -v lpae -r (kernel|kernel-smp)
|
||||
%endif
|
||||
|
||||
%if %{with_zfcpdump}
|
||||
%kernel_variant_preun zfcpdump
|
||||
%kernel_variant_post -v zfcpdump
|
||||
@ -3671,7 +3569,7 @@ fi\
|
||||
%ghost /%{image_install_path}/%{?-k:%{-k*}}%{!?-k:vmlinuz}-%{KVERREL}%{?3:+%{3}}\
|
||||
/lib/modules/%{KVERREL}%{?3:+%{3}}/.vmlinuz.hmac \
|
||||
%ghost /%{image_install_path}/.vmlinuz-%{KVERREL}%{?3:+%{3}}.hmac \
|
||||
%ifarch %{arm} aarch64\
|
||||
%ifarch aarch64\
|
||||
/lib/modules/%{KVERREL}%{?3:+%{3}}/dtb \
|
||||
%ghost /%{image_install_path}/dtb-%{KVERREL}%{?3:+%{3}} \
|
||||
%endif\
|
||||
@ -3815,6 +3713,19 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Aug 14 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.5.0-0.rc6.43.el127]
|
||||
- Linux v6.5.0-0.rc6
|
||||
|
||||
* Sun Aug 13 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.5.0-0.rc5.a785fd28d31f.42.el127]
|
||||
- all: run evaluate_configs to de-dupe merged aarch64 (Peter Robinson)
|
||||
- all: arm: merge the arm and arm/aarch64 (Peter Robinson)
|
||||
- fedora: remove ARMv7 AKA armhfp configurations (Peter Robinson)
|
||||
- fedora: remove ARMv7 AKA armhfp support (Peter Robinson)
|
||||
- Linux v6.5.0-0.rc5.a785fd28d31f
|
||||
|
||||
* Sat Aug 12 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.5.0-0.rc5.f8de32cc060b.41.el127]
|
||||
- Linux v6.5.0-0.rc5.f8de32cc060b
|
||||
|
||||
* Fri Aug 11 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.5.0-0.rc5.25aa0bebba72.40.el127]
|
||||
- redhat/configs: enable CONFIG_VIRTIO_MEM on aarch64 (David Hildenbrand) [2044155]
|
||||
- redhat/configs: enable CONFIG_MEMORY_HOTREMOVE aarch64 (David Hildenbrand) [2062054]
|
||||
|
@ -118,7 +118,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 6bbf9db6b414..e321cd641d46 100644
|
||||
index 00cfb37a9ab8..ec716b2b5554 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -420,10 +420,10 @@ index c2c786eb95ab..4e3aa80cd5cf 100644
|
||||
return ctx.rc;
|
||||
}
|
||||
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
||||
index 5b145f1aaa1b..59cb691d7f07 100644
|
||||
index 87e385542576..7e9de6e3eb9f 100644
|
||||
--- a/drivers/acpi/scan.c
|
||||
+++ b/drivers/acpi/scan.c
|
||||
@@ -1748,6 +1748,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
||||
@@ -1749,6 +1749,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
||||
if (!acpi_match_device_ids(device, ignore_serial_bus_ids))
|
||||
return false;
|
||||
|
||||
@ -1210,7 +1210,7 @@ index ee4da9ab8013..d395d11eadc4 100644
|
||||
if (ret < 0)
|
||||
goto err_allowedips;
|
||||
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
|
||||
index 37b6fa746662..62a97e568b7f 100644
|
||||
index f3a01b79148c..9a1a74d183ce 100644
|
||||
--- a/drivers/nvme/host/core.c
|
||||
+++ b/drivers/nvme/host/core.c
|
||||
@@ -251,6 +251,9 @@ void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.5-rc5-182-g25aa0bebba72.tar.xz) = f141881f689648095119e86d525c58ae1fa80cd5bcb1579ef80addd3c0a1418c4c74c42e06370f8b651ede1c6e94053da1e8c48904f0ce7699f1cbe2a405cf9a
|
||||
SHA512 (kernel-abi-stablelists-6.5.0.tar.bz2) = 354ec7034d45815f4b42fbd7a9a723147337a6a9837826905d1014e5f851e5048b26f20110974287b1cc1756af9287c8384d4b8b0ba9b19345a6087c2460a9f9
|
||||
SHA512 (kernel-kabi-dw-6.5.0.tar.bz2) = 769bcf00964f4a76a3276633d4afabf51d7b4c65e504d6129ced1b9387603638f9213d4ece696ef91498889ee950ff5ce38072002da79ace1d227c6c9708f4fa
|
||||
SHA512 (linux-6.5-rc6.tar.xz) = e5ac3513eb366e10cbf27c1b7994fa830626aa20c5fd6ec261b6aee7267c22000ecc31b0ec94d154c864bc361eca5539cad08006f96d6312fd3038dd9727323a
|
||||
SHA512 (kernel-abi-stablelists-6.5.0.tar.bz2) = 6107f982f8ee7bb003c3338f39f7be48ea12e7d14fcc99fc193b4ca7e100409de12320451fab7b806b24d661a1937dd53e6a36093563bd3b8405b0834d627add
|
||||
SHA512 (kernel-kabi-dw-6.5.0.tar.bz2) = 2705fa93054d143dce4ee74cfe2e3906c19b97ec7118ad1a95dd18c999929dd66aab267dbdfcf5be71988de0eb5073ce52169d62dd30e491475fab6bddc48a5a
|
||||
|
Loading…
Reference in New Issue
Block a user