Attempt to fix perf compile on riscv64
[..] /usr/bin/ld: perf-in.o: in function `memcpy': /usr/include/bits/string_fortified.h:29:(.text+0x60c9c): undefined reference to `syscalltbl__id_at_idx' /usr/bin/ld: perf-in.o: in function `tp_field__swapped_u32': /builddir/build/BUILD/kernel-6.11.0-build/kernel-6.11-rc5-15-g3e9bff3bbe13/linux-6.11.0-0.rc5.20240827git3e9bff3bbe13.44.0.riscv64.fc41.riscv64/tools/perf/builtin-trace.c:237:(.text+0x60e10): undefined reference to `syscalltbl__id_at_idx' /usr/bin/ld: perf-in.o: in function `__bswap_16': /usr/include/bits/byteswap.h:37:(.text+0x60e6c): undefined reference to `syscalltbl__id_at_idx' collect2: error: ld returned 1 exit status make[2]: *** [Makefile.perf:793: perf] Error 1 make[1]: *** [Makefile.perf:290: sub-make] Error 2 make: *** [Makefile:70: all] Error 2 [..] Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
2a0bc6290b
commit
5ad7b9a81f
@ -0,0 +1,26 @@
|
||||
From e8cd261d6379da46155bcb3a17c9ba0bf8054817 Mon Sep 17 00:00:00 2001
|
||||
From: David Abdurachmanov <davidlt@rivosinc.com>
|
||||
Date: Fri, 30 Aug 2024 06:38:21 +0000
|
||||
Subject: [PATCH] Set NO_SYSCALL_TABLE=0 for riscv
|
||||
|
||||
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
|
||||
---
|
||||
tools/perf/Makefile.config | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/perf/Makefile.config b/tools/perf/Makefile.config
|
||||
index fa679db61..3391a5d17 100644
|
||||
--- a/tools/perf/Makefile.config
|
||||
+++ b/tools/perf/Makefile.config
|
||||
@@ -36,7 +36,7 @@ ifneq ($(NO_SYSCALL_TABLE),1)
|
||||
NO_SYSCALL_TABLE := 0
|
||||
endif
|
||||
else
|
||||
- ifeq ($(SRCARCH),$(filter $(SRCARCH),powerpc arm64 s390 mips loongarch))
|
||||
+ ifeq ($(SRCARCH),$(filter $(SRCARCH),powerpc arm64 s390 mips loongarch riscv))
|
||||
NO_SYSCALL_TABLE := 0
|
||||
endif
|
||||
endif
|
||||
--
|
||||
2.46.0
|
||||
|
Loading…
Reference in New Issue
Block a user