kernel-5.16.9-0

* Fri Feb 11 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.9-0]
- tipc: improve size validations for received domain records (Jon Maloy)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-02-11 10:04:54 -06:00
parent f38101bdd0
commit 595cb283e6
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 17 additions and 65 deletions

View File

@ -1,3 +1,6 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/ebcfc72287e1a1c6758e2d80776e8c797c14c14e
ebcfc72287e1a1c6758e2d80776e8c797c14c14e tipc: improve size validations for received domain records
https://gitlab.com/cki-project/kernel-ark/-/commit/f797526f9dc15ef9cbd53acc02e6ae5fcdf01cf8
f797526f9dc15ef9cbd53acc02e6ae5fcdf01cf8 drm/i915/psr: Disable PSR2 selective fetch for all TGL steps

View File

@ -130,7 +130,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.16
%define rpmversion 5.16.8
%define rpmversion 5.16.9
%define patchversion 5.16
%define pkgrelease 200
@ -692,7 +692,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.16.8.tar.xz
Source0: linux-5.16.9.tar.xz
Source1: Makefile.rhelver
@ -1386,8 +1386,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.16.8 -c
mv linux-5.16.8 linux-%{KVERREL}
%setup -q -n kernel-5.16.9 -c
mv linux-5.16.9 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2986,10 +2986,13 @@ fi
#
#
%changelog
* Tue Feb 08 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.8-200]
- v5.16.8 rebase
* Fri Feb 11 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.9-0]
- tipc: improve size validations for received domain records (Jon Maloy)
* Tue Feb 08 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.8-0]
- drm/i915/psr: Disable PSR2 selective fetch for all TGL steps (Lyude Paul)
- Set a value for CONFIG_FRAMEBUFFER_CONSOLE_LEGACY_ACCELERATION coming in with 5.16.8 (Justin M. Forbes)
- ath11k: add support for WCN6855 hw2.1 (Baochen Qiang)
- ata: libata-core: Fix ata_dev_config_cpr() (Damien Le Moal)
- Fix up Changelog for 5.16.7 (Justin M. Forbes)

View File

@ -11,7 +11,6 @@
drivers/acpi/irq.c | 17 ++-
drivers/acpi/scan.c | 9 ++
drivers/ata/libahci.c | 18 +++
drivers/ata/libata-core.c | 14 +--
drivers/char/ipmi/ipmi_dmi.c | 15 +++
drivers/char/ipmi/ipmi_msghandler.c | 16 ++-
drivers/char/random.c | 115 +++++++++++++++++++
@ -32,7 +31,6 @@
drivers/nvme/host/nvme.h | 4 +
drivers/pci/quirks.c | 24 ++++
drivers/usb/core/hub.c | 7 ++
include/linux/ata.h | 2 +-
include/linux/efi.h | 22 ++--
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -49,10 +47,10 @@
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
tools/testing/selftests/netfilter/nft_nat.sh | 5 +-
51 files changed, 827 insertions(+), 205 deletions(-)
49 files changed, 820 insertions(+), 196 deletions(-)
diff --git a/Makefile b/Makefile
index 0cbab4df51b9..aff665749e8b 100644
index 1f32bb42f328..592f45010531 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -448,40 +446,6 @@ index f76b8418e6fb..350e52fccc30 100644
/* wait for engine to stop. This could be as long as 500 msec */
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
index 1cdf8cfcc31b..94bc5dbb31e1 100644
--- a/drivers/ata/libata-core.c
+++ b/drivers/ata/libata-core.c
@@ -2486,23 +2486,21 @@ static void ata_dev_config_cpr(struct ata_device *dev)
struct ata_cpr_log *cpr_log = NULL;
u8 *desc, *buf = NULL;
- if (!ata_identify_page_supported(dev,
- ATA_LOG_CONCURRENT_POSITIONING_RANGES))
+ if (ata_id_major_version(dev->id) < 11 ||
+ !ata_log_supported(dev, ATA_LOG_CONCURRENT_POSITIONING_RANGES))
goto out;
/*
- * Read IDENTIFY DEVICE data log, page 0x47
- * (concurrent positioning ranges). We can have at most 255 32B range
- * descriptors plus a 64B header.
+ * Read the concurrent positioning ranges log (0x47). We can have at
+ * most 255 32B range descriptors plus a 64B header.
*/
buf_len = (64 + 255 * 32 + 511) & ~511;
buf = kzalloc(buf_len, GFP_KERNEL);
if (!buf)
goto out;
- err_mask = ata_read_log_page(dev, ATA_LOG_IDENTIFY_DEVICE,
- ATA_LOG_CONCURRENT_POSITIONING_RANGES,
- buf, buf_len >> 9);
+ err_mask = ata_read_log_page(dev, ATA_LOG_CONCURRENT_POSITIONING_RANGES,
+ 0, buf, buf_len >> 9);
if (err_mask)
goto out;
diff --git a/drivers/char/ipmi/ipmi_dmi.c b/drivers/char/ipmi/ipmi_dmi.c
index bbf7029e224b..cf7faa970dd6 100644
--- a/drivers/char/ipmi/ipmi_dmi.c
@ -1643,24 +1607,6 @@ index ac6c5ccfe1cb..ec784479eece 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/include/linux/ata.h b/include/linux/ata.h
index 199e47e97d64..21292b5bbb55 100644
--- a/include/linux/ata.h
+++ b/include/linux/ata.h
@@ -324,12 +324,12 @@ enum {
ATA_LOG_NCQ_NON_DATA = 0x12,
ATA_LOG_NCQ_SEND_RECV = 0x13,
ATA_LOG_IDENTIFY_DEVICE = 0x30,
+ ATA_LOG_CONCURRENT_POSITIONING_RANGES = 0x47,
/* Identify device log pages: */
ATA_LOG_SECURITY = 0x06,
ATA_LOG_SATA_SETTINGS = 0x08,
ATA_LOG_ZONED_INFORMATION = 0x09,
- ATA_LOG_CONCURRENT_POSITIONING_RANGES = 0x47,
/* Identify device SATA settings log:*/
ATA_LOG_DEVSLP_OFFSET = 0x30,
diff --git a/include/linux/efi.h b/include/linux/efi.h
index ef8dbc0a1522..836a5dfc6156 100644
--- a/include/linux/efi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.16.8.tar.xz) = 46ba28f1a85abd4704cad4fb3d0030a94993d77599e2aaefd961c5b2a72498146dd75bc1c859684528e86d67aaa6f600a18129a5d5691b5d8e52392d0e878236
SHA512 (kernel-abi-stablelists-5.16.8-200.tar.bz2) = eed9d60700693c1eb3b27896c18fbec8689ff26f071b95122405ecb05be14efb0009a93a53a29dc4d14cbcc37c70346534cb5ebcc0af5e9489d90adaa3008d22
SHA512 (kernel-kabi-dw-5.16.8-200.tar.bz2) = 04b9e21e76364fc7342549dd8cf374f34e43bb3d36b0792662636d2a37c499d7ee15a0170768744bdddd3d0bc30d349705cff7fa6e568977ea4117ac414e3cfb
SHA512 (linux-5.16.9.tar.xz) = 6e09a51817922ac552af008fbf072ba6a6974ff990f2e2105f34e291f7dbca103975f9d75c3d455f482890ebdfba15b8c7bf14a8f22b26b4690e5c80ffb76cb9
SHA512 (kernel-abi-stablelists-5.16.9-200.tar.bz2) = d202b95dc93b4e51442e0ecaa89700f0359bb15522ea0127bcf68e33b6b6c88f2d62fea1019c86abf10f8ea062d8df631bfb54c18d4725206fffb70d45fe90ea
SHA512 (kernel-kabi-dw-5.16.9-200.tar.bz2) = cfc68b2457ccd7deec9c329dbe3f49d06f539e409ac410ee360efc86378663f38ea01f52a6a6928d29f4474c4b632f3fad737256b2fde3c19cb62b8688e0fdaa