Build fixes
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
51aa5c5b1d
commit
5934d86345
13
gcc11-plugins-fix.patch
Normal file
13
gcc11-plugins-fix.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/scripts/gcc-plugins/Makefile b/scripts/gcc-plugins/Makefile
|
||||
index d66949bfeba4..a6c35d651704 100644
|
||||
--- a/scripts/gcc-plugins/Makefile
|
||||
+++ b/scripts/gcc-plugins/Makefile
|
||||
@@ -22,7 +22,7 @@ always-y += $(GCC_PLUGIN)
|
||||
GCC_PLUGINS_DIR = $(shell $(CC) -print-file-name=plugin)
|
||||
|
||||
plugin_cxxflags = -Wp,-MMD,$(depfile) $(KBUILD_HOSTCXXFLAGS) -fPIC \
|
||||
- -I $(GCC_PLUGINS_DIR)/include -I $(obj) -std=gnu++98 \
|
||||
+ -I $(GCC_PLUGINS_DIR)/include -I $(obj) -std=gnu++11 \
|
||||
-fno-rtti -fno-exceptions -fasynchronous-unwind-tables \
|
||||
-ggdb -Wno-narrowing -Wno-unused-variable -Wno-c++11-compat \
|
||||
-Wno-format-diag
|
@ -3269,7 +3269,7 @@ CONFIG_KALLSYMS_ALL=y
|
||||
CONFIG_KALLSYMS=y
|
||||
CONFIG_KARMA_PARTITION=y
|
||||
CONFIG_KASAN_GENERIC=y
|
||||
CONFIG_KASAN_HW_TAGS=y
|
||||
# CONFIG_KASAN_HW_TAGS is not set
|
||||
CONFIG_KASAN_INLINE=y
|
||||
# CONFIG_KASAN_OUTLINE is not set
|
||||
# CONFIG_KASAN_SW_TAGS is not set
|
||||
|
@ -2599,7 +2599,7 @@ CONFIG_KALLSYMS_BASE_RELATIVE=y
|
||||
CONFIG_KALLSYMS=y
|
||||
# CONFIG_KARMA_PARTITION is not set
|
||||
CONFIG_KASAN_GENERIC=y
|
||||
CONFIG_KASAN_HW_TAGS=y
|
||||
# CONFIG_KASAN_HW_TAGS is not set
|
||||
CONFIG_KASAN_INLINE=y
|
||||
# CONFIG_KASAN_OUTLINE is not set
|
||||
# CONFIG_KASAN_SW_TAGS is not set
|
||||
|
@ -379,6 +379,7 @@ Summary: The Linux kernel
|
||||
%define make_target vmlinux
|
||||
%define kernel_image vmlinux
|
||||
%define kernel_image_elf 1
|
||||
%define use_vdso 0
|
||||
%define all_arch_configs kernel-%{version}-ppc64le*.config
|
||||
%endif
|
||||
|
||||
@ -742,6 +743,7 @@ Source4000: README.rst
|
||||
|
||||
Patch1: patch-%{rpmversion}-redhat.patch
|
||||
Patch2: secureboot_merge_fix.patch
|
||||
Patch3: gcc11-plugins-fix.patch
|
||||
%endif
|
||||
|
||||
# empty final patch to facilitate testing of kernel patches
|
||||
@ -1246,6 +1248,7 @@ cp -a %{SOURCE1} .
|
||||
|
||||
ApplyOptionalPatch patch-%{rpmversion}-redhat.patch
|
||||
ApplyOptionalPatch secureboot_merge_fix.patch
|
||||
ApplyOptionalPatch gcc11-plugins-fix.patch
|
||||
%endif
|
||||
|
||||
ApplyOptionalPatch linux-kernel-test.patch
|
||||
|
Loading…
Reference in New Issue
Block a user