fix i.MX6 gpu module loading, fix Jetson TX1 usb
This commit is contained in:
parent
e07a3bae84
commit
57a67d35d1
37
0001-gpu-ipu-v3-Fix-imx-ipuv3-crtc-module-autoloading.patch
Normal file
37
0001-gpu-ipu-v3-Fix-imx-ipuv3-crtc-module-autoloading.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 88fd0f33c3cc5aa6a26f56902241941ac717e9f8 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Wed, 27 Apr 2016 13:44:05 +0100
|
||||
Subject: [PATCH] gpu: ipu-v3: Fix imx-ipuv3-crtc module autoloading
|
||||
|
||||
---
|
||||
drivers/gpu/ipu-v3/ipu-common.c | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/gpu/ipu-v3/ipu-common.c b/drivers/gpu/ipu-v3/ipu-common.c
|
||||
index e00db3f..abb98c7 100644
|
||||
--- a/drivers/gpu/ipu-v3/ipu-common.c
|
||||
+++ b/drivers/gpu/ipu-v3/ipu-common.c
|
||||
@@ -1068,7 +1068,6 @@ static int ipu_add_client_devices(struct ipu_soc *ipu, unsigned long ipu_base)
|
||||
goto err_register;
|
||||
}
|
||||
|
||||
- pdev->dev.of_node = of_node;
|
||||
pdev->dev.parent = dev;
|
||||
|
||||
ret = platform_device_add_data(pdev, ®->pdata,
|
||||
@@ -1079,6 +1078,12 @@ static int ipu_add_client_devices(struct ipu_soc *ipu, unsigned long ipu_base)
|
||||
platform_device_put(pdev);
|
||||
goto err_register;
|
||||
}
|
||||
+
|
||||
+ /*
|
||||
+ * Set of_node only after calling platform_device_add. Otherwise
|
||||
+ * the platform:imx-ipuv3-crtc modalias won't be used.
|
||||
+ */
|
||||
+ pdev->dev.of_node = of_node;
|
||||
}
|
||||
|
||||
return 0;
|
||||
--
|
||||
2.7.4
|
||||
|
10
kernel.spec
10
kernel.spec
@ -507,6 +507,12 @@ Patch422: geekbox-v4-device-tree-support.patch
|
||||
# http://www.spinics.net/lists/arm-kernel/msg483898.html
|
||||
Patch423: Initial-AllWinner-A64-and-PINE64-support.patch
|
||||
|
||||
# rhbz 1321330 http://www.spinics.net/lists/dri-devel/msg105829.html
|
||||
Patch425: 0001-gpu-ipu-v3-Fix-imx-ipuv3-crtc-module-autoloading.patch
|
||||
|
||||
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
||||
Patch426: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
||||
|
||||
# http://patchwork.ozlabs.org/patch/587554/
|
||||
Patch430: ARM-tegra-usb-no-reset.patch
|
||||
|
||||
@ -2136,6 +2142,10 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Thu Apr 28 2016 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Add patch to fix i.MX6 gpu module loading
|
||||
- Add patch to fix Jetson TX1 usb
|
||||
|
||||
* Wed Apr 27 2016 Josh Boyer <jwboyer@fedoraproject.org> - 4.6.0-0.rc5.git1.1
|
||||
- Linux v4.6-rc5-69-gf28f20da704d
|
||||
- Require /usr/bin/kernel-install to fix installation after systemd package
|
||||
|
53
usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
Normal file
53
usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From patchwork Wed Apr 6 07:54:05 2016
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: usb: phy: tegra: Add 38.4MHz clock table entry
|
||||
From: Hunter Laux <hunterlaux@gmail.com>
|
||||
X-Patchwork-Id: 606877
|
||||
Message-Id: <1459929245-23449-1-git-send-email-hunterlaux@gmail.com>
|
||||
To: Stephen Warren <swarren@wwwdotorg.org>,
|
||||
Thierry Reding <thierry.reding@gmail.com>,
|
||||
Alexandre Courbot <gnurou@gmail.com>, linux-tegra@vger.kernel.org
|
||||
Cc: Hunter Laux <hunterlaux@gmail.com>
|
||||
Date: Wed, 6 Apr 2016 00:54:05 -0700
|
||||
|
||||
The Tegra210 uses a 38.4MHz OSC. This clock table entry is required to
|
||||
use the ehci phy on the Jetson TX1.
|
||||
|
||||
The xtal_freq_count is actually a 12 bit value, so it should be a u16
|
||||
instead of u8.
|
||||
|
||||
Signed-off-by: Hunter Laux <hunterlaux@gmail.com>
|
||||
---
|
||||
drivers/usb/phy/phy-tegra-usb.c | 10 +++++++++-
|
||||
1 file changed, 9 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/usb/phy/phy-tegra-usb.c b/drivers/usb/phy/phy-tegra-usb.c
|
||||
index 5fe4a57..f0431f0 100644
|
||||
--- a/drivers/usb/phy/phy-tegra-usb.c
|
||||
+++ b/drivers/usb/phy/phy-tegra-usb.c
|
||||
@@ -164,7 +164,7 @@ struct tegra_xtal_freq {
|
||||
u8 enable_delay;
|
||||
u8 stable_count;
|
||||
u8 active_delay;
|
||||
- u8 xtal_freq_count;
|
||||
+ u16 xtal_freq_count;
|
||||
u16 debounce;
|
||||
};
|
||||
|
||||
@@ -201,6 +201,14 @@ static const struct tegra_xtal_freq tegra_freq_table[] = {
|
||||
.xtal_freq_count = 0xFE,
|
||||
.debounce = 0xFDE8,
|
||||
},
|
||||
+ {
|
||||
+ .freq = 38400000,
|
||||
+ .enable_delay = 0x00,
|
||||
+ .stable_count = 0x00,
|
||||
+ .active_delay = 0x18,
|
||||
+ .xtal_freq_count = 0x177,
|
||||
+ .debounce = 0xBB80,
|
||||
+ },
|
||||
};
|
||||
|
||||
static void set_pts(struct tegra_usb_phy *phy, u8 pts_val)
|
Loading…
Reference in New Issue
Block a user