kernel-6.10.5-200
* Wed Aug 14 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.5-0] - Revert "ata: libata-scsi: Honor the D_SENSE bit for CK_COND=1 and no error" (Niklas Cassel) - Linux v6.10.5 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
27e98f5c04
commit
57278db1e1
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/3a19264d7608d1c0cb6adff9f45883887a30ba29
|
||||
3a19264d7608d1c0cb6adff9f45883887a30ba29 Revert "ata: libata-scsi: Honor the D_SENSE bit for CK_COND=1 and no error"
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/2c6b48dfc4f3aad194a99c23f8d3e604c1a5593f
|
||||
2c6b48dfc4f3aad194a99c23f8d3e604c1a5593f wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion
|
||||
|
||||
|
@ -1,3 +1,8 @@
|
||||
* Wed Aug 14 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.5-0]
|
||||
- Revert "ata: libata-scsi: Honor the D_SENSE bit for CK_COND=1 and no error" (Niklas Cassel)
|
||||
- Linux v6.10.5
|
||||
Resolves:
|
||||
|
||||
* Sun Aug 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.4-0]
|
||||
- wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion (Janne Grunau)
|
||||
- New config for 6.10.3 (Justin M. Forbes)
|
||||
|
12
kernel.spec
12
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.10.4
|
||||
%define specversion 6.10.4
|
||||
%define specrpmversion 6.10.5
|
||||
%define specversion 6.10.5
|
||||
%define patchversion 6.10
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.10.4
|
||||
%define tarfile_release 6.10.5
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 10
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 200%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.10.4
|
||||
%define kabiversion 6.10.5
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -4043,6 +4043,10 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Aug 14 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.5-0]
|
||||
- Revert "ata: libata-scsi: Honor the D_SENSE bit for CK_COND=1 and no error" (Niklas Cassel)
|
||||
- Linux v6.10.5
|
||||
|
||||
* Sun Aug 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.4-0]
|
||||
- wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion (Janne Grunau)
|
||||
- New config for 6.10.3 (Justin M. Forbes)
|
||||
|
@ -12,6 +12,7 @@
|
||||
drivers/acpi/irq.c | 17 ++-
|
||||
drivers/acpi/scan.c | 9 ++
|
||||
drivers/ata/libahci.c | 18 +++
|
||||
drivers/ata/libata-scsi.c | 15 ++-
|
||||
drivers/char/ipmi/ipmi_dmi.c | 15 +++
|
||||
drivers/char/ipmi/ipmi_msghandler.c | 16 ++-
|
||||
drivers/char/random.c | 122 +++++++++++++++++
|
||||
@ -40,10 +41,10 @@
|
||||
security/lockdown/Kconfig | 13 ++
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 ++
|
||||
42 files changed, 789 insertions(+), 259 deletions(-)
|
||||
43 files changed, 802 insertions(+), 261 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index aec5cc0babf8..d1c4b7c6cdea 100644
|
||||
index f9badb79ae8f..4d0eadfc33a1 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -82,10 +83,10 @@ index ee5115252aac..7f3796df8404 100644
|
||||
The VM uses one page of physical memory for each page table.
|
||||
For systems with a lot of processes, this can use a lot of
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index 5d91259ee7b5..3a9f1962da72 100644
|
||||
index 11bbdc15c6e5..9cecc1448e3c 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -1368,7 +1368,7 @@ endchoice
|
||||
@@ -1364,7 +1364,7 @@ endchoice
|
||||
|
||||
config ARM64_FORCE_52BIT
|
||||
bool "Force 52-bit virtual addresses for userspace"
|
||||
@ -616,6 +617,32 @@ index 83431aae74d8..f2a9c0d644af 100644
|
||||
/* wait for engine to stop. This could be as long as 500 msec */
|
||||
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
|
||||
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
|
||||
diff --git a/drivers/ata/libata-scsi.c b/drivers/ata/libata-scsi.c
|
||||
index 076fbeadce01..4e0847601103 100644
|
||||
--- a/drivers/ata/libata-scsi.c
|
||||
+++ b/drivers/ata/libata-scsi.c
|
||||
@@ -941,8 +941,19 @@ static void ata_gen_passthru_sense(struct ata_queued_cmd *qc)
|
||||
&sense_key, &asc, &ascq);
|
||||
ata_scsi_set_sense(qc->dev, cmd, sense_key, asc, ascq);
|
||||
} else {
|
||||
- /* ATA PASS-THROUGH INFORMATION AVAILABLE */
|
||||
- ata_scsi_set_sense(qc->dev, cmd, RECOVERED_ERROR, 0, 0x1D);
|
||||
+ /*
|
||||
+ * ATA PASS-THROUGH INFORMATION AVAILABLE
|
||||
+ *
|
||||
+ * Note: we are supposed to call ata_scsi_set_sense(), which
|
||||
+ * respects the D_SENSE bit, instead of unconditionally
|
||||
+ * generating the sense data in descriptor format. However,
|
||||
+ * because hdparm, hddtemp, and udisks incorrectly assume sense
|
||||
+ * data in descriptor format, without even looking at the
|
||||
+ * RESPONSE CODE field in the returned sense data (to see which
|
||||
+ * format the returned sense data is in), we are stuck with
|
||||
+ * being bug compatible with older kernels.
|
||||
+ */
|
||||
+ scsi_build_sense(cmd, 1, RECOVERED_ERROR, 0, 0x1D);
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/drivers/char/ipmi/ipmi_dmi.c b/drivers/char/ipmi/ipmi_dmi.c
|
||||
index bbf7029e224b..cf7faa970dd6 100644
|
||||
--- a/drivers/char/ipmi/ipmi_dmi.c
|
||||
@ -1582,7 +1609,7 @@ index 568410e64ce6..6afbaee83950 100644
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
|
||||
index 1b7561abe05d..13f23905fb25 100644
|
||||
index 6b64af7d4927..a7ad470b8b8c 100644
|
||||
--- a/drivers/scsi/sd.c
|
||||
+++ b/drivers/scsi/sd.c
|
||||
@@ -120,6 +120,14 @@ static const char *sd_cache_types[] = {
|
||||
@ -1600,7 +1627,7 @@ index 1b7561abe05d..13f23905fb25 100644
|
||||
static void sd_set_flush_flag(struct scsi_disk *sdkp)
|
||||
{
|
||||
bool wc = false, fua = false;
|
||||
@@ -4252,6 +4260,8 @@ static int __init init_sd(void)
|
||||
@@ -4253,6 +4261,8 @@ static int __init init_sd(void)
|
||||
goto err_out_class;
|
||||
}
|
||||
|
||||
|
6
sources
6
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
|
||||
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
|
||||
SHA512 (linux-6.10.4.tar.xz) = df461b2523b280f95e67ccff9f93faa04725f13653de24588bad29cc0deac4860a9a135f4aeddd169311e7039de401d1451a547b477ff7a5ddd0cdc0d5e658dd
|
||||
SHA512 (kernel-abi-stablelists-6.10.4.tar.xz) = ef976a858c2b0ac0a6d5c5d02e5f729668fa8487b64b58505d961399fd01a3b2eb8edac675a5e0cea0516f9cbd2b38c1107099bee26ba7c3ade3429cf7812143
|
||||
SHA512 (kernel-kabi-dw-6.10.4.tar.xz) = efbd1b5618897d67deff04cb63fbff51a6d8066a56f2fe52849323547c217065d2cac286902fcb417fff6aa770647134879a177be00df7b62cf87c481cf43956
|
||||
SHA512 (linux-6.10.5.tar.xz) = dfeefdd26d83e5302492e6664112a989b16ac5d9517cedbe9f67b2b7d95fc022142ce963a2f15eec80460620b4e01cbe1dafa03792b7e23ac5e7f4dcc8e91473
|
||||
SHA512 (kernel-abi-stablelists-6.10.5.tar.xz) = 4613278147c9ec1265e7d17c4711cf078e7a8bd39e2287a801689479cb79b0a9d6f2ff01a681c729626df394a7e46e5ab2169305fecef9ddc389ec4c3e5d6bce
|
||||
SHA512 (kernel-kabi-dw-6.10.5.tar.xz) = d3f44cfa453b446891cf6ba9f885f21980e13924f1c4749cb2887e0ef420c7ea41243aa32a871b10b98952b28515ca80d400b7811cc24716783b96fd1ed244f2
|
||||
|
Loading…
Reference in New Issue
Block a user