Test rust fix
Signed-off-by: Jason Montleon <jmontleo@redhat.com>
This commit is contained in:
parent
e8f01d22f5
commit
5453a7e1bb
@ -1,3 +1,33 @@
|
||||
From 04dfb31b2071b74126c972edb40b2e6c32456dfd Mon Sep 17 00:00:00 2001
|
||||
From: Jason Montleon <jmontleo@redhat.com>
|
||||
Date: Mon, 16 Sep 2024 01:32:22 -0400
|
||||
Subject: [PATCH] Fix rust builds on riscv64
|
||||
|
||||
Signed-off-by: Jason Montleon <jmontleo@redhat.com>
|
||||
---
|
||||
rust/Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/rust/Makefile b/rust/Makefile
|
||||
index f168d2c98a15..dfff0304bde2 100644
|
||||
--- a/rust/Makefile
|
||||
+++ b/rust/Makefile
|
||||
@@ -228,11 +228,12 @@ bindgen_skip_c_flags := -mno-fp-ret-in-387 -mpreferred-stack-boundary=% \
|
||||
-fzero-call-used-regs=% -fno-stack-clash-protection \
|
||||
-fno-inline-functions-called-once -fsanitize=bounds-strict \
|
||||
-fstrict-flex-arrays=% -fmin-function-alignment=% \
|
||||
- --param=% --param asan-%
|
||||
+ --param=% --param asan-% -mno-riscv-attribute
|
||||
|
||||
# Derived from `scripts/Makefile.clang`.
|
||||
BINDGEN_TARGET_x86 := x86_64-linux-gnu
|
||||
BINDGEN_TARGET_arm64 := aarch64-linux-gnu
|
||||
+BINDGEN_TARGET_riscv := riscv64-linux-gnu
|
||||
BINDGEN_TARGET := $(BINDGEN_TARGET_$(SRCARCH))
|
||||
|
||||
# All warnings are inhibited since GCC builds are very experimental,
|
||||
--
|
||||
2.46.0
|
||||
From mboxrd@z Thu Jan 1 00:00:00 1970
|
||||
Return-Path: <linux-riscv-bounces+linux-riscv=archiver.kernel.org@lists.infradead.org>
|
||||
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
|
||||
|
Loading…
Reference in New Issue
Block a user