Refresh from git tree

This commit is contained in:
Josh Boyer 2015-05-07 08:15:54 -04:00
parent 8211a26005
commit 5448a3eac2
66 changed files with 5 additions and 203 deletions

View File

@ -25,6 +25,3 @@ index c68e72414a67..4277938af700 100644
if (!(*ppos)) {
/* parse the table header to get the table length */
if (count <= sizeof(struct acpi_table_header))
--
2.1.0

View File

@ -9,7 +9,7 @@ Patch for disconnect issues with storage attached to a
1 file changed, 7 insertions(+)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index d7c3d5a35946..a1121fc01e8c 100644
index 3b7151687776..4b19e7e5bc01 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5006,6 +5006,13 @@ static void hub_event(struct work_struct *work)
@ -26,6 +26,3 @@ index d7c3d5a35946..a1121fc01e8c 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
--
2.1.0

View File

@ -51,6 +51,3 @@ index c74cbd892032..1293d0e0bf90 100644
/*
* All runtime access to EFI goes through this structure:
*/
--
2.1.0

View File

@ -173,6 +173,3 @@ index 1293d0e0bf90..706b16fa6de8 100644
/**
* efi_range_is_wc - check the WC bit on an address range
* @start: starting kvirt address
--
2.1.0

View File

@ -180,6 +180,3 @@ index 0372c3961016..55dacebb687b 100644
bool secure_modules(void)
{
#ifdef CONFIG_MODULE_SIG
--
2.1.0

View File

@ -58,6 +58,3 @@ index ec53f594e9c9..0372c3961016 100644
+#endif
+}
+EXPORT_SYMBOL(secure_modules);
--
2.1.0

View File

@ -243,6 +243,3 @@ index 55dacebb687b..9d4deeb9268e 100644
static int param_set_bool_enable_only(const char *val,
const struct kernel_param *kp)
--
2.1.0

View File

@ -47,6 +47,3 @@ index e77658cd037c..8e9cb25f45cb 100644
if (hidpp->quirks & HIDPP_QUIRK_CLASS_WTP) {
ret = wtp_allocate(hdev, id);
if (ret)
--
2.1.0

View File

@ -45,6 +45,3 @@ index f65e78b46999..ef06dc30b9b1 100644
input_mt_init_slots(input, td->maxcontacts, td->mt_flags);
td->mt_flags = 0;
--
2.1.0

View File

@ -218,6 +218,3 @@ index 2875ddf37289..40b98dda8f38 100644
.pm = &mxt_pm_ops,
},
.probe = mxt_probe,
--
2.1.0

View File

@ -510,6 +510,3 @@ index 95ee92a91bd2..1b3b845d92f4 100644
}
static int mxt_input_open(struct input_dev *dev)
--
2.1.0

View File

@ -98,6 +98,3 @@ index 1b3b845d92f4..2875ddf37289 100644
/* For multi touch */
error = input_mt_init_slots(input_dev, num_mt_slots, mt_flags);
if (error) {
--
2.1.0

View File

@ -106,6 +106,3 @@ index 875f64e8935b..c15e93f5a418 100644
return 0;
}
--
2.1.0

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index f499cd2f5738..9c4ef4809f28 100644
index 0649a6011a76..2c07988a4f10 100644
--- a/Makefile
+++ b/Makefile
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
@ -87,6 +87,3 @@ index c5cefb3c009c..b663e8e211b0 100644
config GDB_SCRIPTS
bool "Provide GDB scripts for kernel debugging"
--
2.1.0

View File

@ -180,6 +180,3 @@ index 000000000000..94b0eb38a284
+ return rc;
+}
+late_initcall(load_uefi_certs);
--
2.1.0

View File

@ -78,6 +78,3 @@ index 94b0eb38a284..ae28b974d49a 100644
}
mok = get_cert_list(L"MokListRT", &mok_var, &moksize);
--
2.1.0

View File

@ -111,6 +111,3 @@ index b91c4da68365..98f5637304d1 100644
return -EPERM;
dev = pci_get_bus_and_slot(bus, dfn);
--
2.1.0

View File

@ -36,6 +36,3 @@ index efe38c1bc234..16b8af1188e1 100644
if (p < (unsigned long) high_memory) {
unsigned long to_write = min_t(unsigned long, count,
(unsigned long)high_memory - p);
--
2.1.0

View File

@ -40,6 +40,3 @@ index 26eb70c8f518..db70d550f526 100644
module_param(brightness_switch_enabled, bool, 0644);
/*
--
2.1.0

View File

@ -90,6 +90,3 @@ index 183eaab7c380..96e3f56519e7 100644
+#define BLIST_MAX_1024 0x40000000 /* maximum 1024 sector cdb length */
#endif
--
2.1.0

View File

@ -33,6 +33,3 @@ index f9eeae871593..aa1dcf3d0216 100644
return acpi_rsdp;
#endif
--
2.1.0

View File

@ -79,6 +79,3 @@ index 27c43499977a..c42feb2bacd0 100644
{ },
};
--
2.1.0

View File

@ -71,6 +71,3 @@ index db70d550f526..70ea37bea84f 100644
return 0;
}
--
2.1.0

View File

@ -1841,6 +1841,3 @@ index 000000000000..c352d5c2989b
+ { }
+};
+MODULE_DEVICE_TABLE(mdio, amd_xgbe_phy_a0_ids);
--
2.1.0

View File

@ -40,6 +40,3 @@ index 9688dda39e7a..8e3e77f3121f 100644
clkout2_pin: pinmux_clkout2_pin {
pinctrl-single,pins = <
0x1b4 (PIN_OUTPUT_PULLDOWN | MUX_MODE3) /* xdma_event_intr1.clkout2 */
--
2.1.0

View File

@ -64,6 +64,3 @@ index c3255e0c90aa..1fd496fe1a68 100644
};
/include/ "tps65217.dtsi"
--
2.1.0

View File

@ -267,6 +267,3 @@ index 1fd496fe1a68..9688dda39e7a 100644
+ };
+ };
};
--
2.1.0

View File

@ -36,6 +36,3 @@ index 0fd89c38cf02..20660917a06f 100644
hdmi {
compatible = "ti,tilcdc,slave";
i2c = <&i2c0>;
--
2.1.0

View File

@ -34,6 +34,3 @@ index 5c42d259fa68..0fd89c38cf02 100644
};
};
--
2.1.0

View File

@ -55,6 +55,3 @@ index 231fba0d03e5..0de5a6ddd5eb 100644
.init_irq = highbank_init_irq,
.init_machine = highbank_init,
.dt_compat = highbank_match,
--
2.1.0

View File

@ -60,6 +60,3 @@ index 99b46f8030ad..8b6ddd16dcc5 100644
+ pinctrl-0 = <&pinctrl_usdhc3>;
+ status = "okay";
+};
--
2.1.0

View File

@ -14,10 +14,10 @@ Signed-off-by: Mark Salter <msalter@redhat.com>
1 file changed, 19 insertions(+)
diff --git a/arch/arm64/kernel/setup.c b/arch/arm64/kernel/setup.c
index e8420f635bd4..84733810614c 100644
index 781f4697dc26..164d618d988c 100644
--- a/arch/arm64/kernel/setup.c
+++ b/arch/arm64/kernel/setup.c
@@ -547,3 +547,22 @@ const struct seq_operations cpuinfo_op = {
@@ -559,3 +559,22 @@ const struct seq_operations cpuinfo_op = {
.stop = c_stop,
.show = c_show
};
@ -40,6 +40,3 @@ index e8420f635bd4..84733810614c 100644
+ return 0;
+}
+early_initcall(arm64_console_setup);
--
2.1.0

View File

@ -48,6 +48,3 @@ index 7543a56e0f45..93b5a6998371 100644
status = wmi_evaluate_method(ASUS_WMI_MGMT_GUID,
1, asus->debug.method_id,
&input, &output);
--
2.1.0

View File

@ -36,6 +36,3 @@ index bba85d1a6cd1..ebbee8f17130 100644
ath_err(common,
"DMA failed to stop in %d ms AR_CR=0x%08x AR_DIAG_SW=0x%08x DMADBG_7=0x%08x\n",
AH_RX_STOP_DMA_TIMEOUT / 1000,
--
2.1.0

View File

@ -504,6 +504,3 @@ index 000000000000..25ab9869d566
+#endif /* __KERNEL__ */
+
+#endif /* __CRASH_H__ */
--
2.1.0

View File

@ -30,6 +30,3 @@ index 9a782b02e4d5..d97b5032d4b0 100644
default !EXPERT
help
Provides the way to make tasks work with different objects using
--
2.1.0

View File

@ -27,6 +27,3 @@ index a08cda955285..e320e1e679cf 100644
#else
--
2.1.0

View File

@ -56,6 +56,3 @@ index bfb0b2280df0..06b10fe7e65b 100644
err = i8042_platform_init();
if (err)
return err;
--
2.1.0

View File

@ -26,6 +26,3 @@ index f75173c20f47..1003782a38c4 100644
intel_dump_pipe_config(crtc, &pipe_config,
"[hw state]");
intel_dump_pipe_config(crtc, crtc->config,
--
2.1.0

View File

@ -37,6 +37,3 @@ index cf7e431cbc73..c74cbd892032 100644
#ifdef CONFIG_EFI
/*
--
2.1.0

View File

@ -778,6 +778,3 @@ index 470e8dfcb517..c15e1de5273c 100644
extern int efi_reboot_quirk_mode;
extern bool efi_poweroff_required(void);
--
2.1.0

View File

@ -52,6 +52,3 @@ index 105e7360d747..83fc4e9888ee 100644
return 1;
}
--
2.1.0

View File

@ -24,6 +24,3 @@ index ab403a636357..5dac78119fa7 100644
prompt "Force module signing when UEFI Secure Boot is enabled"
---help---
UEFI Secure Boot provides a mechanism for ensuring that the
--
2.1.0

View File

@ -73,6 +73,3 @@ index bed43081720f..aa522429b751 100644
/* Now release the pages and zero block aligned part of pages*/
truncate_pagecache_range(inode, start, end - 1);
--
2.1.0

View File

@ -33,6 +33,3 @@ index 2329daae5255..48a8e82c7e2e 100644
}
/**
--
2.1.0

View File

@ -28,6 +28,3 @@ index 387c51f4b4e4..04a1c7d47aba 100644
goto out;
case ATKBD_RET_ERR:
atkbd->err_count++;
--
2.1.0

View File

@ -60,6 +60,3 @@ index 32d710eaf1fc..af4a20b86ee7 100644
cp = can_get_proto(protocol);
}
--
2.1.0

View File

@ -26,6 +26,3 @@ index 208d5439e59b..787b0d699969 100644
sock_put(sk);
isk->inet_num = 0;
isk->inet_sport = 0;
--
2.3.6

View File

@ -120,6 +120,3 @@ index 86a4fe75f453..161637ed5611 100755
}
--
2.1.0

View File

@ -38,6 +38,3 @@ index 38c25b1f2fd5..f2b5272156ce 100644
* Verify we have a legal set of flags
* This leaves us room for future extensions.
*/
--
2.1.0

View File

@ -32,6 +32,3 @@ index 87da53bb1fef..c767ba0cbab7 100644
help
Use dynamic allocation for cpumask_var_t, instead of putting
them on the stack. This is a bit more expensive, but avoids
--
2.1.0

View File

@ -34,6 +34,3 @@ index 23dac3babfe3..8cfe5eeac1e6 100644
ATA_HORKAGE_ZERO_AFTER_TRIM, },
/*
--
2.3.6

View File

@ -73,6 +73,3 @@ index 3ef4627f9cb1..2b2d2e8e5eeb 100644
if (err)
return err;
--
2.1.0

View File

@ -10434,6 +10434,3 @@ index 000000000000..dd8500da98a6
+#endif
+
+#endif
--
2.1.0

View File

@ -20,6 +20,3 @@ index 72b1fc3ab910..86907eaa4883 100644
static int pcspkr_event(struct input_dev *dev, unsigned int type, unsigned int code, int value)
{
--
2.1.0

View File

@ -32,6 +32,3 @@ index 69e84427f913..f21cf4291476 100644
MODULE_AUTHOR("Tony Lindgren <tony@atomide.com>");
MODULE_DESCRIPTION("One-register-per-pin type device tree based pinctrl driver");
--
2.1.0

View File

@ -282,6 +282,3 @@ index 358a337af598..790752ac074a 100644
extern void tty_buffer_free_all(struct tty_port *port);
extern void tty_buffer_flush(struct tty_struct *tty, struct tty_ldisc *ld);
extern void tty_buffer_init(struct tty_port *port);
--
2.1.0

View File

@ -9,7 +9,7 @@ Upstream-status: Fedora mustard (might be worth dropping...)
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index 6b78476d04bb..d490145a317d 100644
index 3290a3ed5b31..3c682f62925c 100644
--- a/drivers/scsi/sd.c
+++ b/drivers/scsi/sd.c
@@ -2750,13 +2750,18 @@ static int sd_try_extended_inquiry(struct scsi_device *sdp)
@ -32,6 +32,3 @@ index 6b78476d04bb..d490145a317d 100644
/*
* If the device is offline, don't try and read capacity or any
* of the other niceties.
--
2.1.0

View File

@ -23,6 +23,3 @@ index 20ef5143c0c0..3123e1da2fed 100644
default n
help
This selects Yama, which extends DAC support with additional
--
2.1.0

View File

@ -50,6 +50,3 @@ index b97210671a81..2d12ad82fe75 100644
fs_initcall(fb_console_init);
#ifdef MODULE
--
2.1.0

View File

@ -92,6 +92,3 @@ index dbcb7a8915b8..2da716c3b648 100644
memset(&props, 0, sizeof(props));
props.type = BACKLIGHT_PLATFORM;
props.max_brightness = HCI_LCD_BRIGHTNESS_LEVELS - 1;
--
2.1.0

View File

@ -38,6 +38,3 @@ index 0e11d61408ff..cc5ca2cac706 100644
hcd = usb_create_hcd(driver, &pdev->dev, dev_name(&pdev->dev));
if (!hcd)
--
2.1.0

View File

@ -73,6 +73,3 @@ index 3174bf8e3538..d0a8abec3df9 100644
set_sample_period();
if (watchdog_user_enabled)
--
2.1.0

View File

@ -65,6 +65,3 @@ index 297110c12635..efe38c1bc234 100644
if (!access_ok(VERIFY_READ, buf, count))
return -EFAULT;
while (count-- > 0 && i < 65536) {
--
2.1.0

View File

@ -37,6 +37,3 @@ index 113e70784854..26c2f83fc470 100644
if (copy_from_user(&regs, uregs, sizeof regs)) {
err = -EFAULT;
break;
--
2.1.0

View File

@ -46,6 +46,3 @@ index c4a0666de6f5..26e651336787 100644
dev->is_busmaster = 0;
} else {
pci_read_config_word(dev, PCI_COMMAND, &cmd);
--
2.1.0