Add patch to fix Intel wifi regression in 3.1.5 (rhbz 767173)
This commit is contained in:
parent
6a7c0501a4
commit
5356296344
38
iwlwifi-allow-to-switch-to-HT40-if-not-associated.patch
Normal file
38
iwlwifi-allow-to-switch-to-HT40-if-not-associated.patch
Normal file
@ -0,0 +1,38 @@
|
||||
My previous patch
|
||||
34a5b4b6af104cf18eb50748509528b9bdbc4036 iwlwifi: do not re-configure
|
||||
HT40 after associated
|
||||
|
||||
Fix the case of HT40 after association on specified AP, but it break the
|
||||
association for some APs and cause not able to establish connection.
|
||||
We need to address HT40 before and after addociation.
|
||||
|
||||
CC: stable@vger.kernel.org #3.0+
|
||||
Reported-by: Andrej Gelenberg <andrej.gelenberg@udo.edu>
|
||||
Signed-off-by: Wey-Yi Guy <wey-yi.w.guy@intel.com>
|
||||
Tested-by: Andrej Gelenberg <andrej.gelenberg@udo.edu>
|
||||
---
|
||||
drivers/net/wireless/iwlwifi/iwl-agn-rxon.c | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c b/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
|
||||
index a7a6def..5c7c17c 100644
|
||||
--- a/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
|
||||
+++ b/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
|
||||
@@ -606,8 +606,8 @@ int iwlagn_mac_config(struct ieee80211_hw *hw, u32 changed)
|
||||
if (ctx->ht.enabled) {
|
||||
/* if HT40 is used, it should not change
|
||||
* after associated except channel switch */
|
||||
- if (iwl_is_associated_ctx(ctx) &&
|
||||
- !ctx->ht.is_40mhz)
|
||||
+ if (!ctx->ht.is_40mhz ||
|
||||
+ !iwl_is_associated_ctx(ctx))
|
||||
iwlagn_config_ht40(conf, ctx);
|
||||
} else
|
||||
ctx->ht.is_40mhz = false;
|
||||
--
|
||||
1.7.0.4
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
11
kernel.spec
11
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 5
|
||||
%global baserelease 6
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -803,6 +803,9 @@ Patch21045: nfs-client-freezer.patch
|
||||
#rhbz 590880
|
||||
Patch21046: alps.patch
|
||||
|
||||
#rhbz 767173
|
||||
Patch21047: iwlwifi-allow-to-switch-to-HT40-if-not-associated.patch
|
||||
|
||||
%endif
|
||||
|
||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||
@ -1477,6 +1480,9 @@ ApplyPatch nfs-client-freezer.patch
|
||||
#rhbz 590880
|
||||
ApplyPatch alps.patch
|
||||
|
||||
#rhbz 767173
|
||||
ApplyPatch iwlwifi-allow-to-switch-to-HT40-if-not-associated.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2208,6 +2214,9 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Thu Dec 15 2011 Josh Boyer <jwboyer@redhat.com> - 3.1.5-6
|
||||
- Add patch to fix Intel wifi regression in 3.1.5 (rhbz 767173)
|
||||
|
||||
* Thu Dec 15 2011 Dave Jones <davej@redhat.com> - 3.1.5-5
|
||||
- Change configfs to be built-in. (rhbz 767857)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user