Linux 3.3-rc5-git1 (upstream 500dd2370e77c9551ba298bdeeb91b02d8402199)
This commit is contained in:
parent
ed314e28a7
commit
53294d9ceb
@ -1,49 +0,0 @@
|
||||
From 9a4b860f36f995ecda36d8312a56ae1d34a6c541 Mon Sep 17 00:00:00 2001
|
||||
From: Johan Hedberg <johan.hedberg@intel.com>
|
||||
Date: Sun, 8 Jan 2012 22:51:16 +0200
|
||||
Subject: [PATCH] Bluetooth: Remove bogus inline declaration from
|
||||
l2cap_chan_connect
|
||||
|
||||
As reported by Dan Carpenter this function causes a Sparse warning and
|
||||
shouldn't be declared inline:
|
||||
|
||||
include/net/bluetooth/l2cap.h:837:30 error: marked inline, but without a
|
||||
definition"
|
||||
|
||||
Reported-by: Dan Carpenter <dan.carpenter@oracle.com>
|
||||
Signed-off-by: Johan Hedberg <johan.hedberg@intel.com>
|
||||
Acked-by: Marcel Holtmann <marcel@holtmann.org>
|
||||
---
|
||||
include/net/bluetooth/l2cap.h | 2 +-
|
||||
net/bluetooth/l2cap_core.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/net/bluetooth/l2cap.h b/include/net/bluetooth/l2cap.h
|
||||
index 68f5891..124f7cf 100644
|
||||
--- a/include/net/bluetooth/l2cap.h
|
||||
+++ b/include/net/bluetooth/l2cap.h
|
||||
@@ -834,7 +834,7 @@ int l2cap_add_scid(struct l2cap_chan *chan, __u16 scid);
|
||||
struct l2cap_chan *l2cap_chan_create(struct sock *sk);
|
||||
void l2cap_chan_close(struct l2cap_chan *chan, int reason);
|
||||
void l2cap_chan_destroy(struct l2cap_chan *chan);
|
||||
-inline int l2cap_chan_connect(struct l2cap_chan *chan, __le16 psm, u16 cid,
|
||||
+int l2cap_chan_connect(struct l2cap_chan *chan, __le16 psm, u16 cid,
|
||||
bdaddr_t *dst);
|
||||
int l2cap_chan_send(struct l2cap_chan *chan, struct msghdr *msg, size_t len,
|
||||
u32 priority);
|
||||
diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c
|
||||
index faf0b11..980abdb 100644
|
||||
--- a/net/bluetooth/l2cap_core.c
|
||||
+++ b/net/bluetooth/l2cap_core.c
|
||||
@@ -1120,7 +1120,7 @@ static struct l2cap_chan *l2cap_global_chan_by_psm(int state, __le16 psm, bdaddr
|
||||
return c1;
|
||||
}
|
||||
|
||||
-inline int l2cap_chan_connect(struct l2cap_chan *chan, __le16 psm, u16 cid, bdaddr_t *dst)
|
||||
+int l2cap_chan_connect(struct l2cap_chan *chan, __le16 psm, u16 cid, bdaddr_t *dst)
|
||||
{
|
||||
struct sock *sk = chan->sk;
|
||||
bdaddr_t *src = &bt_sk(sk)->src;
|
||||
--
|
||||
1.7.6.5
|
||||
|
@ -1,17 +0,0 @@
|
||||
include/linux/compat.h | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/include/linux/compat.h b/include/linux/compat.h
|
||||
index 41c9f6515f46..7e05fcee75a1 100644
|
||||
--- a/include/linux/compat.h
|
||||
+++ b/include/linux/compat.h
|
||||
@@ -561,5 +561,9 @@ asmlinkage ssize_t compat_sys_process_vm_writev(compat_pid_t pid,
|
||||
unsigned long liovcnt, const struct compat_iovec __user *rvec,
|
||||
unsigned long riovcnt, unsigned long flags);
|
||||
|
||||
+#else
|
||||
+
|
||||
+#define is_compat_task() (0)
|
||||
+
|
||||
#endif /* CONFIG_COMPAT */
|
||||
#endif /* _LINUX_COMPAT_H */
|
17
kernel.spec
17
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -87,7 +87,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 5
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
%define gitrev 1
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -758,9 +758,6 @@ Patch21096: hfsplus-Add-an-ioctl-to-bless-files.patch
|
||||
#rhbz 788260
|
||||
Patch21233: jbd2-clear-BH_Delay-and-BH_Unwritten-in-journal_unmap_buf.patch
|
||||
|
||||
#rhbz 787373
|
||||
Patch21234: Bluetooth-Remove-bogus-inline-decl-from-l2cap_chan_connect.patch
|
||||
|
||||
#rhbz 754518
|
||||
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||
Patch21236: scsi-fix-sd_revalidate_disk-oops.patch
|
||||
@ -774,8 +771,6 @@ Patch21270: s390x-enable-keys-compat.patch
|
||||
#rhbz 795544
|
||||
Patch21280: ums_realtek-do-not-use-stack-memory-for-DMA-in-__do_.patch
|
||||
|
||||
Patch21291: fix-autofs4-build.patch
|
||||
|
||||
# compat-wireless patches
|
||||
Patch50000: compat-wireless-config-fixups.patch
|
||||
Patch50001: compat-wireless-pr_fmt-warning-avoidance.patch
|
||||
@ -1480,9 +1475,6 @@ ApplyPatch hfsplus-Add-an-ioctl-to-bless-files.patch
|
||||
#rhbz 788269
|
||||
ApplyPatch jbd2-clear-BH_Delay-and-BH_Unwritten-in-journal_unmap_buf.patch
|
||||
|
||||
#rhbz 787373
|
||||
ApplyPatch Bluetooth-Remove-bogus-inline-decl-from-l2cap_chan_connect.patch
|
||||
|
||||
#rhbz 754518
|
||||
ApplyPatch scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||
ApplyPatch scsi-fix-sd_revalidate_disk-oops.patch
|
||||
@ -1495,8 +1487,6 @@ ApplyPatch s390x-enable-keys-compat.patch
|
||||
#rhbz 795544
|
||||
ApplyPatch ums_realtek-do-not-use-stack-memory-for-DMA-in-__do_.patch
|
||||
|
||||
ApplyPatch fix-autofs4-build.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2368,7 +2358,8 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Feb 27 2012 Josh Boyer <jwboyer@redhat.com> - 3.3.0-0.rc5.git0.4
|
||||
* Mon Feb 27 2012 Josh Boyer <jwboyer@redhat.com> - 3.3.0-0.rc5.git1.1
|
||||
- Linux 3.3-rc5-git1 (upstream 500dd2370e77c9551ba298bdeeb91b02d8402199)
|
||||
- Reenable debugging options.
|
||||
|
||||
* Sun Feb 26 2012 Josh Boyer <jwboyer@redhat.com> - 3.3.0-0.rc5.git0.3
|
||||
|
Loading…
Reference in New Issue
Block a user