kernel-6.2.11-300

* Thu Apr 13 2023 Augusto Caringi <acaringi@redhat.com> [6.2.11-0]
- Linux v6.2.11
Resolves:

Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
Augusto Caringi 2023-04-13 16:32:43 -03:00
parent e8485a1a69
commit 527ebac8b3
3 changed files with 15 additions and 33 deletions

View File

@ -148,17 +148,17 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specversion 6.2.10
%define specversion 6.2.11
%define patchversion 6.2
%define pkgrelease 300
%define kversion 6
%define tarfile_release 6.2.10
%define tarfile_release 6.2.11
# This is needed to do merge window version magic
%define patchlevel 2
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.2.10
%define kabiversion 6.2.11
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3346,6 +3346,9 @@ fi
#
#
%changelog
* Thu Apr 13 2023 Augusto Caringi <acaringi@redhat.com> [6.2.11-0]
- Linux v6.2.11
* Thu Apr 06 2023 Augusto Caringi <acaringi@redhat.com> [6.2.10-0]
- fedora: arm: Enable DRM_PANEL_HIMAX_HX8394 (Peter Robinson)
- arm64: dts: rk3399-pinephone-pro: Add touchscreen support (Martijn Braam)

View File

@ -26,7 +26,6 @@
drivers/iommu/iommu.c | 22 +
drivers/pci/quirks.c | 24 +
drivers/usb/core/hub.c | 7 +
drivers/usb/host/xhci-pci.c | 7 +-
include/linux/efi.h | 22 +-
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -39,7 +38,7 @@
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
41 files changed, 1637 insertions(+), 181 deletions(-)
40 files changed, 1634 insertions(+), 177 deletions(-)
diff --git a/Documentation/devicetree/bindings/display/panel/himax,hx8394.yaml b/Documentation/devicetree/bindings/display/panel/himax,hx8394.yaml
new file mode 100644
@ -124,7 +123,7 @@ index 000000000000..1b2a1baa26f9
+
+...
diff --git a/Makefile b/Makefile
index 6ec0ec452e46..40a89b4c3682 100644
index 416490daa76a..f65904d89130 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1437,7 +1436,7 @@ index 84e7ba5314d3..efc96776f761 100644
data->xport.ops = &hid_rmi_ops;
diff --git a/drivers/hwtracing/coresight/coresight-etm4x-core.c b/drivers/hwtracing/coresight/coresight-etm4x-core.c
index 77bca6932f01..27f5455aef6c 100644
index a65b41017cec..f0ebfbba1f2f 100644
--- a/drivers/hwtracing/coresight/coresight-etm4x-core.c
+++ b/drivers/hwtracing/coresight/coresight-etm4x-core.c
@@ -9,6 +9,7 @@
@ -1448,7 +1447,7 @@ index 77bca6932f01..27f5455aef6c 100644
#include <linux/io.h>
#include <linux/err.h>
#include <linux/fs.h>
@@ -2216,6 +2217,16 @@ static const struct amba_id etm4_ids[] = {
@@ -2212,6 +2213,16 @@ static const struct amba_id etm4_ids[] = {
{},
};
@ -1465,7 +1464,7 @@ index 77bca6932f01..27f5455aef6c 100644
MODULE_DEVICE_TABLE(amba, etm4_ids);
static struct amba_driver etm4x_amba_driver = {
@@ -2249,6 +2260,11 @@ static int __init etm4x_init(void)
@@ -2245,6 +2256,11 @@ static int __init etm4x_init(void)
{
int ret;
@ -1477,7 +1476,7 @@ index 77bca6932f01..27f5455aef6c 100644
ret = etm4_pm_setup();
/* etm4_pm_setup() does its own cleanup - exit on error */
@@ -2275,6 +2291,9 @@ static int __init etm4x_init(void)
@@ -2271,6 +2287,9 @@ static int __init etm4x_init(void)
static void __exit etm4x_exit(void)
{
@ -1772,26 +1771,6 @@ index 97a0f8faea6e..d837548d2024 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/drivers/usb/host/xhci-pci.c b/drivers/usb/host/xhci-pci.c
index fb988e4ea924..6db07ca419c3 100644
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -771,12 +771,11 @@ static struct pci_driver xhci_pci_driver = {
/* suspend and resume implemented later */
.shutdown = usb_hcd_pci_shutdown,
- .driver = {
#ifdef CONFIG_PM
- .pm = &usb_hcd_pci_pm_ops,
-#endif
- .probe_type = PROBE_PREFER_ASYNCHRONOUS,
+ .driver = {
+ .pm = &usb_hcd_pci_pm_ops
},
+#endif
};
static int __init xhci_pci_init(void)
diff --git a/include/linux/efi.h b/include/linux/efi.h
index ac22f7ca195a..e680835ad387 100644
--- a/include/linux/efi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.2.10.tar.xz) = fe21468acfae30d18ae3bf9c104ab7896fd31683211a093159504064c21c3e40f5b0048c95e64cac78614c62040b40ca24fb666f1582217e6c24d11ded66101f
SHA512 (kernel-abi-stablelists-6.2.10.tar.bz2) = 9c5ef77a494cba38011b43ff07af2749940ba9f49915690192cbae674c20d2d914d66696a3f651b9602b7225ee6241c412ae9c3a53ee381d085df53058e911c6
SHA512 (kernel-kabi-dw-6.2.10.tar.bz2) = ca5ec107e56eafe2b8ba24e55894f5a873009d4701d5e4f9d897820feb22fd08699a7ff2abb1e81509ae0bbcf654033ce4fef8a1f464dbb8d0de4a224d0337ed
SHA512 (linux-6.2.11.tar.xz) = 282307954ae9555d9beb2f8d5d5abad5813064725311290e82082520998766cff7f993113c4f02fa34f5aafa9edc7985186a548bc1de24e54209989ce842af81
SHA512 (kernel-abi-stablelists-6.2.11.tar.bz2) = 19687f8a545865e906c1ef2a10636dc6d74db893ba47e9265cbcdf122540c691adc5f556d3d2299ce2f5fe48d0e7f710fe3d7535c87cb24282d1a6793dcf5663
SHA512 (kernel-kabi-dw-6.2.11.tar.bz2) = 7ffe7a54956c8723b997478027c55352592fb5ec3ccbba016d7b88e82583d29dfd2020936fe09e9809aa6a068cf2b898f77b5cc97e50471aa2a06a5972f30c89