Fixes for Tegra Jetson TX series, Initial support for NVIDIA Jetson Nano
This commit is contained in:
parent
70e042b78c
commit
509cc04d2b
2072
arm64-tegra-Add-NVIDIA-Jetson-Nano-Developer-Kit-support.patch
Normal file
2072
arm64-tegra-Add-NVIDIA-Jetson-Nano-Developer-Kit-support.patch
Normal file
File diff suppressed because it is too large
Load Diff
68
arm64-tegra-jetson-tx1-fixes.patch
Normal file
68
arm64-tegra-jetson-tx1-fixes.patch
Normal file
@ -0,0 +1,68 @@
|
||||
From 005e0b987019fff6013dff99f44d9f6ce68f08ad Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Sat, 23 Mar 2019 17:42:18 +0000
|
||||
Subject: [PATCH 1/3] arm64: tegra210: Jetson TX1: disable WP to make SD card
|
||||
work
|
||||
|
||||
There's some issue with Write Protect detection on the Jetson TX1
|
||||
so just apply a quirk to disable the check for the time being.
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
arch/arm64/boot/dts/nvidia/tegra210-p2597.dtsi | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/nvidia/tegra210-p2597.dtsi b/arch/arm64/boot/dts/nvidia/tegra210-p2597.dtsi
|
||||
index a96e6ee70c21..072788646cbf 100644
|
||||
--- a/arch/arm64/boot/dts/nvidia/tegra210-p2597.dtsi
|
||||
+++ b/arch/arm64/boot/dts/nvidia/tegra210-p2597.dtsi
|
||||
@@ -1456,6 +1456,7 @@
|
||||
sdhci@700b0000 {
|
||||
status = "okay";
|
||||
bus-width = <4>;
|
||||
+ disable-wp;
|
||||
|
||||
cd-gpios = <&gpio TEGRA_GPIO(Z, 1) GPIO_ACTIVE_LOW>;
|
||||
|
||||
--
|
||||
2.20.1
|
||||
|
||||
From aea4a7a551fd7342299d34f04a8b75f58644ac07 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Sat, 23 Mar 2019 17:45:10 +0000
|
||||
Subject: [PATCH 2/3] arm64: tegra210: Jetson TX1: disable display panel and
|
||||
associated backlight
|
||||
|
||||
The Jetson TX1 dev kit doesn't ship with a screen by default and if
|
||||
it's not there it appears to crash on boot so disable them both by
|
||||
default until we work out the problem.
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
arch/arm64/boot/dts/nvidia/tegra210-p2371-2180.dts | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/nvidia/tegra210-p2371-2180.dts b/arch/arm64/boot/dts/nvidia/tegra210-p2371-2180.dts
|
||||
index 37e3c46e753f..a16f24f1d5ff 100644
|
||||
--- a/arch/arm64/boot/dts/nvidia/tegra210-p2371-2180.dts
|
||||
+++ b/arch/arm64/boot/dts/nvidia/tegra210-p2371-2180.dts
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
host1x@50000000 {
|
||||
dsi@54300000 {
|
||||
- status = "okay";
|
||||
+ status = "disabled";
|
||||
|
||||
avdd-dsi-csi-supply = <&vdd_dsi_csi>;
|
||||
|
||||
@@ -54,6 +54,8 @@
|
||||
|
||||
i2c@7000c400 {
|
||||
backlight: backlight@2c {
|
||||
+ status = "disabled";
|
||||
+
|
||||
compatible = "ti,lp8557";
|
||||
reg = <0x2c>;
|
||||
|
||||
--
|
||||
2.20.1
|
10
kernel.spec
10
kernel.spec
@ -568,6 +568,12 @@ Patch312: arm64-rock960-enable-tsadc.patch
|
||||
|
||||
Patch339: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
|
||||
|
||||
# Tegra bits
|
||||
Patch340: arm64-tegra-jetson-tx1-fixes.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10858639/
|
||||
Patch341: arm64-tegra-Add-NVIDIA-Jetson-Nano-Developer-Kit-support.patch
|
||||
|
||||
# 400 - IBM (ppc/s390x) patches
|
||||
|
||||
# 500 - Temp fixes/CVEs etc
|
||||
@ -1855,6 +1861,10 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Sat Mar 23 2019 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Fixes for Tegra Jetson TX series
|
||||
- Initial support for NVIDIA Jetson Nano
|
||||
|
||||
* Fri Mar 22 2019 Jeremy Cline <jcline@redhat.com> - 5.1.0-0.rc1.git2.1
|
||||
- Linux v5.1-rc1-66-gfd1f297b794c
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user