Linux 2.6.36-rc1-git3
Drop x86-cpu-fix-regression-in-amd-errata-checking-code.patch, now merged.
This commit is contained in:
parent
a62b0aa064
commit
4b4acded4d
12
kernel.spec
12
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 4
|
%global baserelease 5
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -688,8 +688,6 @@ Patch12017: prevent-runtime-conntrack-changes.patch
|
|||||||
|
|
||||||
Patch12018: neuter_intel_microcode_load.patch
|
Patch12018: neuter_intel_microcode_load.patch
|
||||||
|
|
||||||
Patch12019: x86-cpu-fix-regression-in-amd-errata-checking-code.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||||
@ -1256,8 +1254,6 @@ ApplyPatch disable-i8042-check-on-apple-mac.patch
|
|||||||
|
|
||||||
ApplyPatch neuter_intel_microcode_load.patch
|
ApplyPatch neuter_intel_microcode_load.patch
|
||||||
|
|
||||||
ApplyPatch x86-cpu-fix-regression-in-amd-errata-checking-code.patch
|
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1865,6 +1861,10 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 20 2010 Chuck Ebbert <cebbert@redhat.com> - 2.6.36-0.5.rc1.git3
|
||||||
|
- Linux 2.6.36-rc1-git3
|
||||||
|
- Drop x86-cpu-fix-regression-in-amd-errata-checking-code.patch, now merged.
|
||||||
|
|
||||||
* Thu Aug 19 2010 Kyle McMartin <kmcmartin@redhat.com> - 2.6.36-0.4.rc1.git1
|
* Thu Aug 19 2010 Kyle McMartin <kmcmartin@redhat.com> - 2.6.36-0.4.rc1.git1
|
||||||
- Run oldnoconfig on the configs during make prep.
|
- Run oldnoconfig on the configs during make prep.
|
||||||
- Make the fix oldnoconfig patch a one liner.
|
- Make the fix oldnoconfig patch a one liner.
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
||||||
4f51963b5e076fb87ab32bda229a524f patch-2.6.36-rc1.bz2
|
4f51963b5e076fb87ab32bda229a524f patch-2.6.36-rc1.bz2
|
||||||
605f904e69fa5f67670505d8644ab47a patch-2.6.36-rc1-git1.bz2
|
e6b13a5770a0ee6bdd0c241e975420cd patch-2.6.36-rc1-git3.bz2
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From: Hans Rosenfeld <hans.rosenfeld@amd.com>
|
|
||||||
Date: Wed, 18 Aug 2010 14:19:50 +0000 (+0200)
|
|
||||||
Subject: x86, cpu: Fix regression in AMD errata checking code
|
|
||||||
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fmingo%2Flinux-2.6-x86.git;a=commitdiff_plain;h=07a7795ca2e6e66d00b184efb46bd0e23d90d3fe
|
|
||||||
|
|
||||||
x86, cpu: Fix regression in AMD errata checking code
|
|
||||||
|
|
||||||
A bug in the family-model-stepping matching code caused the presence of
|
|
||||||
errata to go undetected when OSVW was not used. This causes hangs on
|
|
||||||
some K8 systems because the E400 workaround is not enabled.
|
|
||||||
|
|
||||||
Signed-off-by: Hans Rosenfeld <hans.rosenfeld@amd.com>
|
|
||||||
LKML-Reference: <1282141190-930137-1-git-send-email-hans.rosenfeld@amd.com>
|
|
||||||
Signed-off-by: H. Peter Anvin <hpa@zytor.com>
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/arch/x86/kernel/cpu/amd.c b/arch/x86/kernel/cpu/amd.c
|
|
||||||
index 60a57b1..ba5f62f 100644
|
|
||||||
--- a/arch/x86/kernel/cpu/amd.c
|
|
||||||
+++ b/arch/x86/kernel/cpu/amd.c
|
|
||||||
@@ -669,7 +669,7 @@ bool cpu_has_amd_erratum(const int *erratum)
|
|
||||||
}
|
|
||||||
|
|
||||||
/* OSVW unavailable or ID unknown, match family-model-stepping range */
|
|
||||||
- ms = (cpu->x86_model << 8) | cpu->x86_mask;
|
|
||||||
+ ms = (cpu->x86_model << 4) | cpu->x86_mask;
|
|
||||||
while ((range = *erratum++))
|
|
||||||
if ((cpu->x86 == AMD_MODEL_RANGE_FAMILY(range)) &&
|
|
||||||
(ms >= AMD_MODEL_RANGE_START(range)) &&
|
|
Loading…
Reference in New Issue
Block a user