kernel-5.16-0.rc3.20211203git5f58da2befa5.26
* Fri Dec 03 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc3.20211203git5f58da2befa5.26] - redhat/configs: Add two new CONFIGs (Prarit Bhargava) - redhat/configs: Remove dead CONFIG files (Prarit Bhargava) - redhat/configs/evaluate_configs: Add find dead configs option (Prarit Bhargava) - Add more rebase notes for Fedora 5.16 (Justin M. Forbes) - Fedora: Feature: Retire wireless Extensions (Peter Robinson) - fedora: arm: some SoC enablement pieces (Peter Robinson) - fedora: arm: enable PCIE_ROCKCHIP_DW for rk35xx series (Peter Robinson) - fedora: enable RTW89 802.11 WiFi driver (Peter Robinson) - fedora: arm: Enable DRM_PANEL_EDP (Peter Robinson) - fedora: sound: enable new sound drivers (Peter Robinson) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
3d549bf473
commit
4b36b01cdc
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 25
|
||||
RHEL_RELEASE = 26
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
26
kernel.spec
26
kernel.spec
@ -85,7 +85,7 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc3.20211201git58e1100fdc59.25
|
||||
%global distro_build 0.rc3.20211203git5f58da2befa5.26
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -130,13 +130,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.16.0
|
||||
%define patchversion 5.16
|
||||
%define pkgrelease 0.rc3.20211201git58e1100fdc59.25
|
||||
%define pkgrelease 0.rc3.20211203git5f58da2befa5.26
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 16
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc3.20211201git58e1100fdc59.25%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc3.20211203git5f58da2befa5.26%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -687,7 +687,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.16-rc3-51-g58e1100fdc59.tar.xz
|
||||
Source0: linux-5.16-rc3-227-g5f58da2befa5.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1379,8 +1379,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.16-rc3-51-g58e1100fdc59 -c
|
||||
mv linux-5.16-rc3-51-g58e1100fdc59 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.16-rc3-227-g5f58da2befa5 -c
|
||||
mv linux-5.16-rc3-227-g5f58da2befa5 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2189,7 +2189,7 @@ InitBuildVars
|
||||
%global perf_build_extra_opts CORESIGHT=1
|
||||
%endif
|
||||
%global perf_make \
|
||||
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
||||
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
||||
%if %{with_perf}
|
||||
# perf
|
||||
# make sure check-headers.sh is executable
|
||||
@ -2977,6 +2977,18 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Dec 03 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc3.20211203git5f58da2befa5.26]
|
||||
- redhat/configs: Add two new CONFIGs (Prarit Bhargava)
|
||||
- redhat/configs: Remove dead CONFIG files (Prarit Bhargava)
|
||||
- redhat/configs/evaluate_configs: Add find dead configs option (Prarit Bhargava)
|
||||
- Add more rebase notes for Fedora 5.16 (Justin M. Forbes)
|
||||
- Fedora: Feature: Retire wireless Extensions (Peter Robinson)
|
||||
- fedora: arm: some SoC enablement pieces (Peter Robinson)
|
||||
- fedora: arm: enable PCIE_ROCKCHIP_DW for rk35xx series (Peter Robinson)
|
||||
- fedora: enable RTW89 802.11 WiFi driver (Peter Robinson)
|
||||
- fedora: arm: Enable DRM_PANEL_EDP (Peter Robinson)
|
||||
- fedora: sound: enable new sound drivers (Peter Robinson)
|
||||
|
||||
* Wed Dec 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc3.20211201git58e1100fdc59.25]
|
||||
- redhat/configs: unset KEXEC_SIG for s390x zfcpdump (Coiby Xu)
|
||||
- spec: Keep .BTF section in modules (Jiri Olsa)
|
||||
|
@ -619,7 +619,7 @@ index bbf7029e224b..cf7faa970dd6 100644
|
||||
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
|
||||
|
||||
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
|
||||
index deed355422f4..5199fb71a7e7 100644
|
||||
index c837d5416e0e..ded4c912067e 100644
|
||||
--- a/drivers/char/ipmi/ipmi_msghandler.c
|
||||
+++ b/drivers/char/ipmi/ipmi_msghandler.c
|
||||
@@ -35,6 +35,7 @@
|
||||
@ -630,7 +630,7 @@ index deed355422f4..5199fb71a7e7 100644
|
||||
#include <linux/delay.h>
|
||||
|
||||
#define IPMI_DRIVER_VERSION "39.2"
|
||||
@@ -5394,8 +5395,21 @@ static int __init ipmi_init_msghandler_mod(void)
|
||||
@@ -5417,8 +5418,21 @@ static int __init ipmi_init_msghandler_mod(void)
|
||||
{
|
||||
int rv;
|
||||
|
||||
@ -1520,7 +1520,7 @@ index 8b2adc56b92a..f0ad908048c6 100644
|
||||
|
||||
err_nl_init:
|
||||
diff --git a/drivers/net/wireguard/main.c b/drivers/net/wireguard/main.c
|
||||
index 75dbe77b0b4b..029ff8576f8e 100644
|
||||
index ee4da9ab8013..0f217997a764 100644
|
||||
--- a/drivers/net/wireguard/main.c
|
||||
+++ b/drivers/net/wireguard/main.c
|
||||
@@ -12,6 +12,7 @@
|
||||
@ -1531,7 +1531,7 @@ index 75dbe77b0b4b..029ff8576f8e 100644
|
||||
#include <linux/init.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/genetlink.h>
|
||||
@@ -21,6 +22,11 @@ static int __init mod_init(void)
|
||||
@@ -21,6 +22,11 @@ static int __init wg_mod_init(void)
|
||||
{
|
||||
int ret;
|
||||
|
||||
@ -1543,7 +1543,7 @@ index 75dbe77b0b4b..029ff8576f8e 100644
|
||||
ret = wg_allowedips_slab_init();
|
||||
if (ret < 0)
|
||||
goto err_allowedips;
|
||||
@@ -48,6 +54,7 @@ static int __init mod_init(void)
|
||||
@@ -48,6 +54,7 @@ static int __init wg_mod_init(void)
|
||||
pr_info("WireGuard " WIREGUARD_VERSION " loaded. See www.wireguard.com for information.\n");
|
||||
pr_info("Copyright (C) 2015-2019 Jason A. Donenfeld <Jason@zx2c4.com>. All Rights Reserved.\n");
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.16-rc3-51-g58e1100fdc59.tar.xz) = 13a4d0f39631f2ae3c3d09a7a736c865a6331b6cd60df42f68c9855cd8726292423bc751f6a6a088145f5d19acd9c6d60fe5fc7c3de2f626220135e0dee4c1d7
|
||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc3.20211201git58e1100fdc59.25.tar.bz2) = b10015629e59a85809864be0eef00a943c16609b57ec0fc9c9efc4cf0633e51de911dadd280fb094c1eff487878f101b7b74e63f8a7305640b6179388fbea502
|
||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc3.20211201git58e1100fdc59.25.tar.bz2) = b6bb5adb90fc17bab86e467e45ba120b0a77e4f6431334af7029b96969cfb8bcb6b9d35ebcd032bceedfba9e6cef297799ea28f2757ac8e48b8f56cf95fffc5e
|
||||
SHA512 (linux-5.16-rc3-227-g5f58da2befa5.tar.xz) = b4f99b10f1a4bfe276037f0f1487903adf31164e39380f0a10870b61c3ecc87b1b889a72ca49b2ba02bb61132193fe6b36e414b07c3e56d6feb3bcfbe10bef99
|
||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc3.20211203git5f58da2befa5.26.tar.bz2) = 34eb16a069b065d2c3c5f3c07be78b8ba190cb24effc108380452f858978d946e5263526217a7330091b328464f889638f643a1a31767dc8a6bf0fd3fbca6aa0
|
||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc3.20211203git5f58da2befa5.26.tar.bz2) = 68ced2b65f707fabf72fc96343fb02131a09bcb689370001b920e2abac3de7d260fb7e3f3b66ae029862d18e6e385379e3355d3eb3cbf7e968f50a06a32f7208
|
||||
|
Loading…
Reference in New Issue
Block a user