Add patch to fix 32-bit turbostat build with older glibc-headers

glibc-2.15 32-bit sigcontext.h pulls in asm/sigcontext.h.  Because turbostat
is using -I to point to the kernel source UAPI dir, we get an error about
linux/compiler.h not being found.  That's true, because the kernel doesn't
export linux/compiler.h and it's stripped out of the uapi sigcontext.h file
when we export it.  But that doesn't help us when turbostat is being stupid
and pointing at the pre-stripped UAPI headers.  Just what.

So just point it to the top level kernel include directory after it's already
searched everything else.
This commit is contained in:
Josh Boyer 2013-03-08 15:47:15 -05:00
parent f08161620a
commit 49decd0917
2 changed files with 19 additions and 1 deletions

View File

@ -761,6 +761,8 @@ Patch24101: fix-destroy_conntrack-GPF.patch
#rhbz 917353
Patch24102: backlight_revert.patch
Patch24103: turbostat-makefile.diff
# END OF PATCH DEFINITIONS
%endif
@ -1480,6 +1482,8 @@ ApplyPatch net-sctp-Validate-parameter-size-for-SCTP_GET_ASSOC_.patch
#rhbz 917353
ApplyPatch backlight_revert.patch -R
ApplyPatch turbostat-makefile.diff
# END OF PATCH APPLICATIONS
%endif
@ -2336,7 +2340,10 @@ fi
# '-' | |
# '-'
%changelog
* Fri Mar 08 2013 Justin M. Forbes <jforbes@redhat.com> - 3.8.2-105
* Fri Mar 08 2013 Josh Boyer <jwboyer@redhat.com> - 3.8.2-105
- Add patch to fix 32-bit turbostat build with older glibc-headers
* Fri Mar 08 2013 Justin M. Forbes <jforbes@redhat.com>
- Revert "write backlight harder" until better solution is found (rhbz 917353)
* Fri Mar 08 2013 Josh Boyer <jwboyer@redhat.com>

11
turbostat-makefile.diff Normal file
View File

@ -0,0 +1,11 @@
--- a/tools/power/x86/turbostat/Makefile 2013-03-08 15:42:39.274393369 -0500
+++ b/tools/power/x86/turbostat/Makefile 2013-03-08 15:41:59.162486862 -0500
@@ -5,7 +5,7 @@ DESTDIR :=
turbostat : turbostat.c
CFLAGS += -Wall
-CFLAGS += -I../../../../arch/x86/include/uapi/
+CFLAGS += -I../../../../arch/x86/include/uapi/ -idirafter ../../../../include/
%: %.c
@mkdir -p $(BUILD_OUTPUT)