kernel-5.15.10-0

* Fri Dec 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15.10-0]
- Changelog fixes for stable (Justin M. Forbes)
- platform/x86: thinkpad_acpi: Add lid_logo_dot to the list of safe LEDs (Hans de Goede)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-12-17 08:22:54 -06:00
parent e68c5cb010
commit 4882b85cc8
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 35 additions and 9 deletions

View File

@ -1,3 +1,6 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/0fa86a7082006675caec52bd8bfb003f3481b483
0fa86a7082006675caec52bd8bfb003f3481b483 platform/x86: thinkpad_acpi: Add lid_logo_dot to the list of safe LEDs
https://gitlab.com/cki-project/kernel-ark/-/commit/cc9dddca769975df12bb5dfe654486261a9add59
cc9dddca769975df12bb5dfe654486261a9add59 Revert "drm/i915: Implement Wa_1508744258"

View File

@ -128,7 +128,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.15
%define rpmversion 5.15.8
%define rpmversion 5.15.10
%define patchversion 5.15
%define pkgrelease 200
@ -682,7 +682,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.15.8.tar.xz
Source0: linux-5.15.10.tar.xz
Source1: Makefile.rhelver
@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.15.8 -c
mv linux-5.15.8 linux-%{KVERREL}
%setup -q -n kernel-5.15.10 -c
mv linux-5.15.10 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2972,6 +2972,10 @@ fi
#
#
%changelog
* Fri Dec 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15.10-0]
- Changelog fixes for stable (Justin M. Forbes)
- platform/x86: thinkpad_acpi: Add lid_logo_dot to the list of safe LEDs (Hans de Goede)
* Tue Dec 14 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15-0]
- Enable CONFIG_VFIO_NOIOMMU for Fedora (Justin M. Forbes)

View File

@ -32,6 +32,7 @@
drivers/nvme/host/multipath.c | 19 ++--
drivers/nvme/host/nvme.h | 4 +
drivers/pci/quirks.c | 24 ++++
drivers/platform/x86/thinkpad_acpi.c | 4 +-
drivers/usb/core/hub.c | 7 ++
include/linux/efi.h | 22 ++--
include/linux/lsm_hook_defs.h | 2 +
@ -46,7 +47,7 @@
security/lockdown/Kconfig | 13 +++
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
48 files changed, 750 insertions(+), 199 deletions(-)
49 files changed, 752 insertions(+), 201 deletions(-)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index 1396fd2d9031..4bc97128cee8 100644
@ -69,7 +70,7 @@ index 1396fd2d9031..4bc97128cee8 100644
This is normally done in pci_enable_device(),
so this option is a temporary workaround
diff --git a/Makefile b/Makefile
index 72344b214bba..efa8577eb3fa 100644
index d5e266291e5d..081570eb866b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1632,6 +1633,24 @@ index 208fa03acdda..88cfaa8ac3b3 100644
/*
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
* class code. Fix it.
diff --git a/drivers/platform/x86/thinkpad_acpi.c b/drivers/platform/x86/thinkpad_acpi.c
index 3dc055ce6e61..bb56640eb31f 100644
--- a/drivers/platform/x86/thinkpad_acpi.c
+++ b/drivers/platform/x86/thinkpad_acpi.c
@@ -5813,11 +5813,11 @@ static const char * const tpacpi_led_names[TPACPI_LED_NUMLEDS] = {
"tpacpi::standby",
"tpacpi::dock_status1",
"tpacpi::dock_status2",
- "tpacpi::unknown_led2",
+ "tpacpi::lid_logo_dot",
"tpacpi::unknown_led3",
"tpacpi::thinkvantage",
};
-#define TPACPI_SAFE_LEDS 0x1081U
+#define TPACPI_SAFE_LEDS 0x1481U
static inline bool tpacpi_is_led_restricted(const unsigned int led)
{
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index 00070a8a6507..e9e0ffa990cd 100644
--- a/drivers/usb/core/hub.c

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.15.8.tar.xz) = 94455b1edc647abd0a2832c6657a0b4ec7208ed5bfee2785f91cf66ae82c9b18c7285c5a17e33ea15919cdad06889c309e7fac3fb1c449cc1160723cca8fd0c3
SHA512 (kernel-abi-stablelists-5.15.8-200.tar.bz2) = 32141a4fa5132f43c65d7abee46b723a73f9ae29bac6f34cae71917c746ab58c8c135110625129801b536ce1f0eb67840e1bab04518f29158ff5b5f131467e21
SHA512 (kernel-kabi-dw-5.15.8-200.tar.bz2) = 699bd0cefd1df656eebba0f8d297fa4020e159c2d1e3c7cd7e570755ad1db4fc09bbaba504b4b440262e0f8490e41f1cc366d9abc034a230244556aa3beed89b
SHA512 (linux-5.15.10.tar.xz) = 335febcab7822bf9d6eff559f81f8e109fe42b5e566ab8d0c0ef61bc9110ae4c0a3429cf86f2ebbc8ada9eebf75b1b8f40837b5e86619a2e0a3fd69fab9f20c9
SHA512 (kernel-abi-stablelists-5.15.10-200.tar.bz2) = 08157142378a2d8592947ee735d2ed148d4b9f95f585c6e9ead328725f64f775f72e5f11b6941c6cd9e82fa72231e3f7752b16142acb2d35f9f9c85fce6493c8
SHA512 (kernel-kabi-dw-5.15.10-200.tar.bz2) = 13be582ade22eace39641908995e2479e1955b19e7d7cea8b15f39403771f07f9c2029d88ce703ac4b914604027539f2b410709127cd3fcb84bf83867ff7e6d6