Linux v3.16-rc3
- Enable USB rtsx drivers (rhbz 1114229) - Disable debugging options.
This commit is contained in:
parent
53684dde09
commit
44fb75f606
@ -147,6 +147,7 @@ CONFIG_MMC_CB710=m
|
||||
CONFIG_MMC_RICOH_MMC=y
|
||||
CONFIG_MMC_USHC=m
|
||||
CONFIG_MMC_REALTEK_PCI=m
|
||||
CONFIG_MMC_REALTEK_USB=m
|
||||
CONFIG_MMC_VUB300=m
|
||||
# CONFIG_MMC_SDHCI_PXAV2 is not set
|
||||
# CONFIG_MMC_SDHCI_PXAV3 is not set
|
||||
@ -1694,13 +1695,13 @@ CONFIG_B43_SDIO=y
|
||||
CONFIG_B43_BCMA=y
|
||||
# CONFIG_B43_BCMA_EXTRA is not set
|
||||
CONFIG_B43_BCMA_PIO=y
|
||||
CONFIG_B43_DEBUG=y
|
||||
# CONFIG_B43_DEBUG is not set
|
||||
CONFIG_B43_PHY_LP=y
|
||||
CONFIG_B43_PHY_N=y
|
||||
CONFIG_B43_PHY_HT=y
|
||||
# CONFIG_B43_FORCE_PIO is not set
|
||||
CONFIG_B43LEGACY=m
|
||||
CONFIG_B43LEGACY_DEBUG=y
|
||||
# CONFIG_B43LEGACY_DEBUG is not set
|
||||
CONFIG_B43LEGACY_DMA=y
|
||||
CONFIG_B43LEGACY_PIO=y
|
||||
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
|
||||
@ -3977,6 +3978,7 @@ CONFIG_MFD_VX855=m
|
||||
CONFIG_MFD_SM501=m
|
||||
CONFIG_MFD_SM501_GPIO=y
|
||||
CONFIG_MFD_RTSX_PCI=m
|
||||
CONFIG_MFD_RTSX_USB=m
|
||||
# CONFIG_MFD_TI_AM335X_TSCADC is not set
|
||||
CONFIG_MFD_VIPERBOARD=m
|
||||
# CONFIG_MFD_RETU is not set
|
||||
@ -4020,7 +4022,6 @@ CONFIG_MFD_VIPERBOARD=m
|
||||
# CONFIG_MFD_DA9063 is not set
|
||||
# CONFIG_MFD_LP3943 is not set
|
||||
# CONFIG_MFD_BCM590XX is not set
|
||||
# CONFIG_MFD_RTSX_USB is not set
|
||||
# CONFIG_MFD_TPS65218 is not set
|
||||
|
||||
|
||||
@ -4640,7 +4641,7 @@ CONFIG_PM_DEBUG=y
|
||||
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
|
||||
CONFIG_PM_TRACE=y
|
||||
CONFIG_PM_TRACE_RTC=y
|
||||
CONFIG_PM_TEST_SUSPEND=y
|
||||
# CONFIG_PM_TEST_SUSPEND is not set
|
||||
CONFIG_PM_RUNTIME=y
|
||||
# CONFIG_PM_OPP is not set
|
||||
# CONFIG_PM_AUTOSLEEP is not set
|
||||
@ -4898,6 +4899,7 @@ CONFIG_MEMSTICK_TIFM_MS=m
|
||||
CONFIG_MEMSTICK_JMICRON_38X=m
|
||||
CONFIG_MEMSTICK_R592=m
|
||||
CONFIG_MEMSTICK_REALTEK_PCI=m
|
||||
CONFIG_MEMSTICK_REALTEK_USB=m
|
||||
|
||||
CONFIG_ACCESSIBILITY=y
|
||||
CONFIG_A11Y_BRAILLE_CONSOLE=y
|
||||
|
118
config-nodebug
118
config-nodebug
@ -2,101 +2,101 @@ CONFIG_SND_VERBOSE_PRINTK=y
|
||||
CONFIG_SND_DEBUG=y
|
||||
CONFIG_SND_PCM_XRUN_DEBUG=y
|
||||
|
||||
CONFIG_DEBUG_ATOMIC_SLEEP=y
|
||||
# CONFIG_DEBUG_ATOMIC_SLEEP is not set
|
||||
|
||||
CONFIG_DEBUG_MUTEXES=y
|
||||
CONFIG_DEBUG_WW_MUTEX_SLOWPATH=y
|
||||
CONFIG_DEBUG_RT_MUTEXES=y
|
||||
CONFIG_DEBUG_LOCK_ALLOC=y
|
||||
CONFIG_LOCK_TORTURE_TEST=m
|
||||
CONFIG_PROVE_LOCKING=y
|
||||
CONFIG_DEBUG_SPINLOCK=y
|
||||
CONFIG_PROVE_RCU=y
|
||||
# CONFIG_DEBUG_MUTEXES is not set
|
||||
# CONFIG_DEBUG_WW_MUTEX_SLOWPATH is not set
|
||||
# CONFIG_DEBUG_RT_MUTEXES is not set
|
||||
# CONFIG_DEBUG_LOCK_ALLOC is not set
|
||||
# CONFIG_LOCK_TORTURE_TEST is not set
|
||||
# CONFIG_PROVE_LOCKING is not set
|
||||
# CONFIG_DEBUG_SPINLOCK is not set
|
||||
# CONFIG_PROVE_RCU is not set
|
||||
# CONFIG_PROVE_RCU_REPEATEDLY is not set
|
||||
CONFIG_DEBUG_PER_CPU_MAPS=y
|
||||
# CONFIG_DEBUG_PER_CPU_MAPS is not set
|
||||
CONFIG_CPUMASK_OFFSTACK=y
|
||||
|
||||
CONFIG_CPU_NOTIFIER_ERROR_INJECT=m
|
||||
# CONFIG_CPU_NOTIFIER_ERROR_INJECT is not set
|
||||
|
||||
CONFIG_FAULT_INJECTION=y
|
||||
CONFIG_FAILSLAB=y
|
||||
CONFIG_FAIL_PAGE_ALLOC=y
|
||||
CONFIG_FAIL_MAKE_REQUEST=y
|
||||
CONFIG_FAULT_INJECTION_DEBUG_FS=y
|
||||
CONFIG_FAULT_INJECTION_STACKTRACE_FILTER=y
|
||||
CONFIG_FAIL_IO_TIMEOUT=y
|
||||
CONFIG_FAIL_MMC_REQUEST=y
|
||||
# CONFIG_FAULT_INJECTION is not set
|
||||
# CONFIG_FAILSLAB is not set
|
||||
# CONFIG_FAIL_PAGE_ALLOC is not set
|
||||
# CONFIG_FAIL_MAKE_REQUEST is not set
|
||||
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set
|
||||
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set
|
||||
# CONFIG_FAIL_IO_TIMEOUT is not set
|
||||
# CONFIG_FAIL_MMC_REQUEST is not set
|
||||
|
||||
CONFIG_LOCK_STAT=y
|
||||
# CONFIG_LOCK_STAT is not set
|
||||
|
||||
CONFIG_DEBUG_STACK_USAGE=y
|
||||
# CONFIG_DEBUG_STACK_USAGE is not set
|
||||
|
||||
CONFIG_ACPI_DEBUG=y
|
||||
# CONFIG_ACPI_DEBUG is not set
|
||||
# CONFIG_ACPI_DEBUG_FUNC_TRACE is not set
|
||||
|
||||
CONFIG_DEBUG_SG=y
|
||||
CONFIG_DEBUG_PI_LIST=y
|
||||
# CONFIG_DEBUG_SG is not set
|
||||
# CONFIG_DEBUG_PI_LIST is not set
|
||||
|
||||
# CONFIG_DEBUG_PAGEALLOC is not set
|
||||
|
||||
CONFIG_DEBUG_WRITECOUNT=y
|
||||
CONFIG_DEBUG_OBJECTS=y
|
||||
# CONFIG_DEBUG_WRITECOUNT is not set
|
||||
# CONFIG_DEBUG_OBJECTS is not set
|
||||
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
|
||||
CONFIG_DEBUG_OBJECTS_FREE=y
|
||||
CONFIG_DEBUG_OBJECTS_TIMERS=y
|
||||
CONFIG_DEBUG_OBJECTS_RCU_HEAD=y
|
||||
# CONFIG_DEBUG_OBJECTS_FREE is not set
|
||||
# CONFIG_DEBUG_OBJECTS_TIMERS is not set
|
||||
# CONFIG_DEBUG_OBJECTS_RCU_HEAD is not set
|
||||
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
|
||||
|
||||
CONFIG_X86_PTDUMP=y
|
||||
CONFIG_EFI_PGT_DUMP=y
|
||||
# CONFIG_X86_PTDUMP is not set
|
||||
# CONFIG_EFI_PGT_DUMP is not set
|
||||
|
||||
CONFIG_CAN_DEBUG_DEVICES=y
|
||||
# CONFIG_CAN_DEBUG_DEVICES is not set
|
||||
|
||||
CONFIG_MODULE_FORCE_UNLOAD=y
|
||||
# CONFIG_MODULE_FORCE_UNLOAD is not set
|
||||
|
||||
CONFIG_SYSCTL_SYSCALL_CHECK=y
|
||||
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
|
||||
|
||||
CONFIG_DEBUG_NOTIFIERS=y
|
||||
# CONFIG_DEBUG_NOTIFIERS is not set
|
||||
|
||||
CONFIG_DMA_API_DEBUG=y
|
||||
# CONFIG_DMA_API_DEBUG is not set
|
||||
|
||||
CONFIG_MMIOTRACE=y
|
||||
# CONFIG_MMIOTRACE is not set
|
||||
|
||||
CONFIG_DEBUG_CREDENTIALS=y
|
||||
# CONFIG_DEBUG_CREDENTIALS is not set
|
||||
|
||||
# off in both production debug and nodebug builds,
|
||||
# on in rawhide nodebug builds
|
||||
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
|
||||
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
|
||||
|
||||
CONFIG_EXT4_DEBUG=y
|
||||
# CONFIG_EXT4_DEBUG is not set
|
||||
|
||||
# CONFIG_XFS_WARN is not set
|
||||
|
||||
CONFIG_DEBUG_PERF_USE_VMALLOC=y
|
||||
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set
|
||||
|
||||
CONFIG_JBD2_DEBUG=y
|
||||
# CONFIG_JBD2_DEBUG is not set
|
||||
|
||||
CONFIG_NFSD_FAULT_INJECTION=y
|
||||
# CONFIG_NFSD_FAULT_INJECTION is not set
|
||||
|
||||
CONFIG_DEBUG_BLK_CGROUP=y
|
||||
# CONFIG_DEBUG_BLK_CGROUP is not set
|
||||
|
||||
CONFIG_DRBD_FAULT_INJECTION=y
|
||||
# CONFIG_DRBD_FAULT_INJECTION is not set
|
||||
|
||||
CONFIG_ATH_DEBUG=y
|
||||
CONFIG_CARL9170_DEBUGFS=y
|
||||
CONFIG_IWLWIFI_DEVICE_TRACING=y
|
||||
# CONFIG_ATH_DEBUG is not set
|
||||
# CONFIG_CARL9170_DEBUGFS is not set
|
||||
# CONFIG_IWLWIFI_DEVICE_TRACING is not set
|
||||
|
||||
# CONFIG_RTLWIFI_DEBUG is not set
|
||||
|
||||
CONFIG_DEBUG_OBJECTS_WORK=y
|
||||
# CONFIG_DEBUG_OBJECTS_WORK is not set
|
||||
|
||||
CONFIG_DMADEVICES_DEBUG=y
|
||||
CONFIG_DMADEVICES_VDEBUG=y
|
||||
# CONFIG_DMADEVICES_DEBUG is not set
|
||||
# CONFIG_DMADEVICES_VDEBUG is not set
|
||||
|
||||
CONFIG_PM_ADVANCED_DEBUG=y
|
||||
|
||||
CONFIG_CEPH_LIB_PRETTYDEBUG=y
|
||||
CONFIG_QUOTA_DEBUG=y
|
||||
# CONFIG_CEPH_LIB_PRETTYDEBUG is not set
|
||||
# CONFIG_QUOTA_DEBUG is not set
|
||||
|
||||
CONFIG_PCI_DEFAULT_USE_CRS=y
|
||||
|
||||
@ -104,18 +104,18 @@ CONFIG_KGDB_KDB=y
|
||||
CONFIG_KDB_KEYBOARD=y
|
||||
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
|
||||
|
||||
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
||||
# CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER is not set
|
||||
# CONFIG_PERCPU_TEST is not set
|
||||
CONFIG_TEST_LIST_SORT=y
|
||||
# CONFIG_TEST_LIST_SORT is not set
|
||||
# CONFIG_TEST_STRING_HELPERS is not set
|
||||
|
||||
CONFIG_DETECT_HUNG_TASK=y
|
||||
# CONFIG_DETECT_HUNG_TASK is not set
|
||||
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
||||
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
||||
|
||||
CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
|
||||
# CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK is not set
|
||||
|
||||
CONFIG_DEBUG_KMEMLEAK=y
|
||||
# CONFIG_DEBUG_KMEMLEAK is not set
|
||||
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
|
||||
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
|
||||
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
||||
@ -126,7 +126,7 @@ CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
||||
|
||||
# CONFIG_SPI_DEBUG is not set
|
||||
|
||||
CONFIG_X86_DEBUG_STATIC_CPU_HAS=y
|
||||
# CONFIG_X86_DEBUG_STATIC_CPU_HAS is not set
|
||||
|
||||
# CONFIG_SCHEDSTATS is not set
|
||||
# CONFIG_LATENCYTOP is not set
|
||||
|
@ -334,7 +334,7 @@ CONFIG_SP5100_TCO=m
|
||||
|
||||
# CONFIG_MEMTEST is not set
|
||||
# CONFIG_DEBUG_TLBFLUSH is not set
|
||||
CONFIG_MAXSMP=y
|
||||
# CONFIG_MAXSMP is not set
|
||||
|
||||
|
||||
CONFIG_HP_ILO=m
|
||||
|
23
kernel.spec
23
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 4
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -130,7 +130,7 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||
# and 0 for rawhide (all kernels are debug kernels).
|
||||
# See also 'make debug' and 'make release'.
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
# Want to build a vanilla kernel build without any non-upstream patches?
|
||||
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
|
||||
@ -643,12 +643,6 @@ Patch25102: intel_pstate-Fix-setting-VID.patch
|
||||
Patch25103: intel_pstate-dont-touch-turbo-bit-if-turbo-disabled-or-unavailable.patch
|
||||
Patch25104: intel_pstate-Update-documentation-of-max-min_perf_pct-sysfs-files.patch
|
||||
|
||||
#rhbz 1110968
|
||||
Patch25105: x86_32-signal-Fix-vdso-rt_sigreturn.patch
|
||||
|
||||
#CVE-2014-4508 rhbz 1111590 1112073
|
||||
Patch25106: x86_32-entry-Do-syscall-exit-work-on-badsys.patch
|
||||
|
||||
Patch25109: revert-input-wacom-testing-result-shows-get_report-is-unnecessary.patch
|
||||
|
||||
#rhbz 1021036, submitted upstream
|
||||
@ -1373,12 +1367,6 @@ ApplyPatch intel_pstate-Fix-setting-VID.patch
|
||||
ApplyPatch intel_pstate-dont-touch-turbo-bit-if-turbo-disabled-or-unavailable.patch
|
||||
ApplyPatch intel_pstate-Update-documentation-of-max-min_perf_pct-sysfs-files.patch
|
||||
|
||||
#rhbz 1110968
|
||||
ApplyPatch x86_32-signal-Fix-vdso-rt_sigreturn.patch
|
||||
|
||||
#CVE-2014-4508 rhbz 1111590 1112073
|
||||
ApplyPatch x86_32-entry-Do-syscall-exit-work-on-badsys.patch
|
||||
|
||||
ApplyPatch revert-input-wacom-testing-result-shows-get_report-is-unnecessary.patch
|
||||
|
||||
#rhbz 1021036, submitted upstream
|
||||
@ -2263,6 +2251,11 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Jun 30 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.16.0-0.rc3.git0.1.1
|
||||
- Linux v3.16-rc3
|
||||
- Enable USB rtsx drivers (rhbz 1114229)
|
||||
- Disable debugging options.
|
||||
|
||||
* Fri Jun 27 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.16.0-0.rc2.git4.1
|
||||
- Linux v3.16-rc2-222-g3493860c76eb
|
||||
|
||||
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
||||
97ca1625bb40368dc41b9a7971549071 linux-3.15.tar.xz
|
||||
ef8f4db937f521a7e323ec589536ba25 perf-man-3.15.tar.gz
|
||||
77133c50724a5510c3d7a61703deccf5 patch-3.16-rc2.xz
|
||||
64c50e3a11b730bb947d1b39f7069d1c patch-3.16-rc2-git4.xz
|
||||
423d8cf28277a385276146c990d029e8 patch-3.16-rc3.xz
|
||||
|
@ -1,130 +0,0 @@
|
||||
Bugzilla: 1112073
|
||||
Upstream-status: Sent for 3.16 and CC'd to stable
|
||||
Delivered-To: jwboyer@gmail.com
|
||||
Received: by 10.76.6.212 with SMTP id d20csp139586oaa;
|
||||
Mon, 23 Jun 2014 14:28:15 -0700 (PDT)
|
||||
X-Received: by 10.68.222.196 with SMTP id qo4mr32453892pbc.14.1403558895116;
|
||||
Mon, 23 Jun 2014 14:28:15 -0700 (PDT)
|
||||
Return-Path: <stable-owner@vger.kernel.org>
|
||||
Received: from vger.kernel.org (vger.kernel.org. [209.132.180.67])
|
||||
by mx.google.com with ESMTP id bm3si23587434pad.232.2014.06.23.14.27.47
|
||||
for <multiple recipients>;
|
||||
Mon, 23 Jun 2014 14:28:15 -0700 (PDT)
|
||||
Received-SPF: none (google.com: stable-owner@vger.kernel.org does not designate permitted sender hosts) client-ip=209.132.180.67;
|
||||
Authentication-Results: mx.google.com;
|
||||
spf=neutral (google.com: stable-owner@vger.kernel.org does not designate permitted sender hosts) smtp.mail=stable-owner@vger.kernel.org
|
||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1752475AbaFWVWX (ORCPT <rfc822;tuffkidtt@gmail.com> + 73 others);
|
||||
Mon, 23 Jun 2014 17:22:23 -0400
|
||||
Received: from mail-pb0-f42.google.com ([209.85.160.42]:39692 "EHLO
|
||||
mail-pb0-f42.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org
|
||||
with ESMTP id S1752518AbaFWVWW (ORCPT
|
||||
<rfc822;stable@vger.kernel.org>); Mon, 23 Jun 2014 17:22:22 -0400
|
||||
Received: by mail-pb0-f42.google.com with SMTP id ma3so6319797pbc.15
|
||||
for <stable@vger.kernel.org>; Mon, 23 Jun 2014 14:22:21 -0700 (PDT)
|
||||
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
|
||||
d=1e100.net; s=20130820;
|
||||
h=x-gm-message-state:from:to:cc:subject:date:message-id:in-reply-to
|
||||
:references:mime-version:content-type:content-transfer-encoding;
|
||||
bh=7AW5eK5e3OhAcFYPrsffKoD56CbJdqfg9BcyF1JKfUE=;
|
||||
b=iLlWTJCuH9FlKTif4N6XtFZNvj8a/fbsjuP4kWWD/gmHHGEOWI6bh2Jm8X3vcN6GtV
|
||||
f7rqFO0SAMf197e66uME3pq8NzYFad4eRgJpBGON93P22+cPbqrsT9FZjMZqn2bJkEw4
|
||||
EDZZy2MFqm3Kx2m/5g76NLDV1tgafEnwbgL1vg6IxlbPi6J8inkXwKP3FdMoTcfRBO6p
|
||||
dIcI1cV7VDNf6zKaMj+XS/ZiSxqpArhwvZ6xnXRmLfgD+x/JsxEcg2pX03BXHTKO9QNm
|
||||
nixe+cuug0X0E5idHuiLJzV0Wf6IhYsvVz/FvjY16pggduecA2NgNU2e7txqb+IcTBZ/
|
||||
jBbA==
|
||||
X-Gm-Message-State: ALoCoQlblcwmTrVjpekrIOzidDrxwB18p5Rfd5SObiPQifpOQZmSFUKrxzV0kxCjcW/wVwxOzAG7
|
||||
X-Received: by 10.68.197.8 with SMTP id iq8mr32930210pbc.124.1403558541680;
|
||||
Mon, 23 Jun 2014 14:22:21 -0700 (PDT)
|
||||
Received: from localhost (50-76-60-73-ip-static.hfc.comcastbusiness.net. [50.76.60.73])
|
||||
by mx.google.com with ESMTPSA id fl6sm99195659pab.43.2014.06.23.14.22.19
|
||||
for <multiple recipients>
|
||||
(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
|
||||
Mon, 23 Jun 2014 14:22:20 -0700 (PDT)
|
||||
From: Andy Lutomirski <luto@amacapital.net>
|
||||
Cc: "H. Peter Anvin" <hpa@zytor.com>,
|
||||
Richard Weinberger <richard@nod.at>, X86 ML <x86@kernel.org>,
|
||||
Eric Paris <eparis@redhat.com>,
|
||||
Linux Kernel <linux-kernel@vger.kernel.org>,
|
||||
security@kernel.org, Steven Rostedt <rostedt@goodmis.org>,
|
||||
Borislav Petkov <bp@alien8.de>,
|
||||
=?UTF-8?q?Toralf=20F=C3=B6rster?= <toralf.foerster@gmx.de>,
|
||||
Andy Lutomirski <luto@amacapital.net>, stable@vger.kernel.org,
|
||||
Roland McGrath <roland@redhat.com>
|
||||
Subject: [PATCH] x86_32,entry: Do syscall exit work on badsys (CVE-2014-4508)
|
||||
Date: Mon, 23 Jun 2014 14:22:15 -0700
|
||||
Message-Id: <e09c499eade6fc321266dd6b54da7beb28d6991c.1403558229.git.luto@amacapital.net>
|
||||
X-Mailer: git-send-email 1.9.3
|
||||
In-Reply-To: <CA+5PVA70nFS8JZkL0-Q-1HjFHT5NA04275_M4WstjQMrpT+hrQ@mail.gmail.com>
|
||||
References: <CA+5PVA70nFS8JZkL0-Q-1HjFHT5NA04275_M4WstjQMrpT+hrQ@mail.gmail.com>
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
To: unlisted-recipients:; (no To-header on input)
|
||||
Sender: stable-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <stable.vger.kernel.org>
|
||||
X-Mailing-List: stable@vger.kernel.org
|
||||
|
||||
The bad syscall nr paths are their own incomprehensible route
|
||||
through the entry control flow. Rearrange them to work just like
|
||||
syscalls that return -ENOSYS.
|
||||
|
||||
This fixes an OOPS in the audit code when fast-path auditing is
|
||||
enabled and sysenter gets a bad syscall nr (CVE-2014-4508).
|
||||
|
||||
This has probably been broken since Linux 2.6.27:
|
||||
af0575bba0 i386 syscall audit fast-path
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Cc: Roland McGrath <roland@redhat.com>
|
||||
Reported-by: Toralf Förster <toralf.foerster@gmx.de>
|
||||
Signed-off-by: Andy Lutomirski <luto@amacapital.net>
|
||||
---
|
||||
|
||||
I realize that the syscall audit fast path and badsys code, on 32-bit
|
||||
x86 no less, is possibly one of the least fun things in the kernel to
|
||||
review, but this is still a real security bug and should get fixed :(
|
||||
|
||||
So I'm cc-ing a bunch of people and maybe someone will review it.
|
||||
|
||||
arch/x86/kernel/entry_32.S | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/x86/kernel/entry_32.S b/arch/x86/kernel/entry_32.S
|
||||
index a2a4f46..f4258a5 100644
|
||||
--- a/arch/x86/kernel/entry_32.S
|
||||
+++ b/arch/x86/kernel/entry_32.S
|
||||
@@ -431,9 +431,10 @@ sysenter_past_esp:
|
||||
jnz sysenter_audit
|
||||
sysenter_do_call:
|
||||
cmpl $(NR_syscalls), %eax
|
||||
- jae syscall_badsys
|
||||
+ jae sysenter_badsys
|
||||
call *sys_call_table(,%eax,4)
|
||||
movl %eax,PT_EAX(%esp)
|
||||
+sysenter_after_call:
|
||||
LOCKDEP_SYS_EXIT
|
||||
DISABLE_INTERRUPTS(CLBR_ANY)
|
||||
TRACE_IRQS_OFF
|
||||
@@ -688,7 +689,12 @@ END(syscall_fault)
|
||||
|
||||
syscall_badsys:
|
||||
movl $-ENOSYS,PT_EAX(%esp)
|
||||
- jmp resume_userspace
|
||||
+ jmp syscall_exit
|
||||
+END(syscall_badsys)
|
||||
+
|
||||
+sysenter_badsys:
|
||||
+ movl $-ENOSYS,PT_EAX(%esp)
|
||||
+ jmp sysenter_after_call
|
||||
END(syscall_badsys)
|
||||
CFI_ENDPROC
|
||||
/*
|
||||
--
|
||||
1.9.3
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe stable" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
@ -1,102 +0,0 @@
|
||||
Bugzilla: 1110968
|
||||
Upstream-status: Sent for 3.16
|
||||
Delivered-To: jwboyer@gmail.com
|
||||
Received: by 10.76.6.212 with SMTP id d20csp498917oaa;
|
||||
Sat, 21 Jun 2014 07:32:08 -0700 (PDT)
|
||||
X-Received: by 10.68.222.196 with SMTP id qo4mr13568182pbc.14.1403361127771;
|
||||
Sat, 21 Jun 2014 07:32:07 -0700 (PDT)
|
||||
Return-Path: <luto@amacapital.net>
|
||||
Received: from bastion.fedoraproject.org (bastion02.fedoraproject.org. [209.132.181.3])
|
||||
by mx.google.com with ESMTP id lc8si14177597pab.180.2014.06.21.07.32.07
|
||||
for <jwboyer@gmail.com>;
|
||||
Sat, 21 Jun 2014 07:32:07 -0700 (PDT)
|
||||
Received-SPF: softfail (google.com: domain of transitioning luto@amacapital.net does not designate 209.132.181.3 as permitted sender) client-ip=209.132.181.3;
|
||||
Authentication-Results: mx.google.com;
|
||||
spf=softfail (google.com: domain of transitioning luto@amacapital.net does not designate 209.132.181.3 as permitted sender) smtp.mail=luto@amacapital.net
|
||||
Received: by bastion02.phx2.fedoraproject.org (Postfix)
|
||||
id 168B1409CE; Sat, 21 Jun 2014 14:32:07 +0000 (UTC)
|
||||
Delivered-To: jwboyer@fedoraproject.org
|
||||
Received: from mx1.redhat.com (ext-mx13.extmail.prod.ext.phx2.redhat.com [10.5.110.18])
|
||||
by bastion02.phx2.fedoraproject.org (Postfix) with ESMTP id D0C2F409C7
|
||||
for <jwboyer@fedoraproject.org>; Sat, 21 Jun 2014 14:32:06 +0000 (UTC)
|
||||
Received: from mail-pd0-f176.google.com (mail-pd0-f176.google.com [209.85.192.176])
|
||||
by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id s5LEW4FM005994
|
||||
(version=TLSv1/SSLv3 cipher=RC4-SHA bits=128 verify=FAIL)
|
||||
for <jwboyer@fedoraproject.org>; Sat, 21 Jun 2014 10:32:05 -0400
|
||||
Received: by mail-pd0-f176.google.com with SMTP id ft15so3955970pdb.7
|
||||
for <jwboyer@fedoraproject.org>; Sat, 21 Jun 2014 07:32:04 -0700 (PDT)
|
||||
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
|
||||
d=1e100.net; s=20130820;
|
||||
h=x-gm-message-state:from:to:cc:subject:date:message-id:in-reply-to
|
||||
:references;
|
||||
bh=9ojFh7kYLbjyUNQqXEB1a+XYU5MXkJE3dfv8VGqmp7U=;
|
||||
b=R90lfJ9+LPLahfLiaskJdqINOIulosFA5kTRA6zFncXdehLXlO1/bgzCbVSBQp0Zda
|
||||
jH2JtoZFUe+cfg5kQTtnVhE+H5Z+J6zTGQy3vmlloZh5QOxVDtHZU85FKZWL4ME/teZD
|
||||
4dHDVOmlO9zXrhRKLs6jdxQnKCJNCovWf5DVPe51OuwKKCwm49VmLTHaYkCox+vsVaGk
|
||||
J5FG3Q7yxRpGwrhMvI3yWuhj5hxaAq+R+B7pk7xY1xrekBoah2W983/ZXUVYWcclOoi+
|
||||
pw4ntIfVczLCLffVR4UmV4/Tf4SU/pzUHAwKoDzVG8E1JP4oxtBquCPMfm19ZM0lwStV
|
||||
wgpw==
|
||||
X-Gm-Message-State: ALoCoQlE1XpTJdEnv/MtB0QmbA8XP2ta23AV4hVoUU4182Z6n5xs9NiTKRJfyIbepTPOiKzLFr/I
|
||||
X-Received: by 10.68.132.42 with SMTP id or10mr13559986pbb.80.1403361124560;
|
||||
Sat, 21 Jun 2014 07:32:04 -0700 (PDT)
|
||||
Received: from localhost (pool-108-13-237-90.lsanca.fios.verizon.net. [108.13.237.90])
|
||||
by mx.google.com with ESMTPSA id ak1sm18452139pbc.58.2014.06.21.07.32.02
|
||||
for <multiple recipients>
|
||||
(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
|
||||
Sat, 21 Jun 2014 07:32:03 -0700 (PDT)
|
||||
From: Andy Lutomirski <luto@amacapital.net>
|
||||
To: Josh Boyer <jwboyer@fedoraproject.org>, "H. Peter Anvin" <hpa@zytor.com>
|
||||
Cc: "Linux-Kernel@Vger. Kernel. Org" <linux-kernel@vger.kernel.org>,
|
||||
Andy Lutomirski <luto@amacapital.net>
|
||||
Subject: [PATCH] x86_32,signal: Fix vdso rt_sigreturn
|
||||
Date: Sat, 21 Jun 2014 07:31:55 -0700
|
||||
Message-Id: <1eb40ad923acde2e18357ef2832867432e70ac42.1403361010.git.luto@amacapital.net>
|
||||
X-Mailer: git-send-email 1.9.3
|
||||
In-Reply-To: <CA+5PVA61wwmnstiBdDemufGvXvSu4RL3WHds3NSstH-rVx7tYg@mail.gmail.com>
|
||||
References: <CA+5PVA61wwmnstiBdDemufGvXvSu4RL3WHds3NSstH-rVx7tYg@mail.gmail.com>
|
||||
X-RedHat-Spam-Score: -2.011 (BAYES_00,DCC_REPUT_13_19,RCVD_IN_DNSWL_NONE,SPF_PASS)
|
||||
X-Scanned-By: MIMEDefang 2.68 on 10.5.110.18
|
||||
|
||||
This commit:
|
||||
|
||||
commit 6f121e548f83674ab4920a4e60afb58d4f61b829
|
||||
Author: Andy Lutomirski <luto@amacapital.net>
|
||||
Date: Mon May 5 12:19:34 2014 -0700
|
||||
|
||||
x86, vdso: Reimplement vdso.so preparation in build-time C
|
||||
|
||||
Contained this obvious typo:
|
||||
|
||||
- restorer = VDSO32_SYMBOL(current->mm->context.vdso, rt_sigreturn);
|
||||
+ restorer = current->mm->context.vdso +
|
||||
+ selected_vdso32->sym___kernel_sigreturn;
|
||||
|
||||
Note the missing 'rt_' in the new code. Fix it.
|
||||
|
||||
Signed-off-by: Andy Lutomirski <luto@amacapital.net>
|
||||
---
|
||||
|
||||
Compile-tested only. I bet that someone will test it here far more quickly
|
||||
than I can figure out how to test it:
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1110968
|
||||
|
||||
arch/x86/kernel/signal.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/x86/kernel/signal.c b/arch/x86/kernel/signal.c
|
||||
index a0da58d..2851d63 100644
|
||||
--- a/arch/x86/kernel/signal.c
|
||||
+++ b/arch/x86/kernel/signal.c
|
||||
@@ -363,7 +363,7 @@ static int __setup_rt_frame(int sig, struct ksignal *ksig,
|
||||
|
||||
/* Set up to return from userspace. */
|
||||
restorer = current->mm->context.vdso +
|
||||
- selected_vdso32->sym___kernel_sigreturn;
|
||||
+ selected_vdso32->sym___kernel_rt_sigreturn;
|
||||
if (ksig->ka.sa.sa_flags & SA_RESTORER)
|
||||
restorer = ksig->ka.sa.sa_restorer;
|
||||
put_user_ex(restorer, &frame->pretcode);
|
||||
--
|
||||
1.9.3
|
||||
|
Loading…
Reference in New Issue
Block a user